Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 15/01/2013, à 17:35

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Si tu décides d'installer Ubuntu en mode Legacy, ça ne sert à rien de traiter le pb de dépendances : ça parle de grub-efi or c'est grub-pc qui est utilisé quand on installe Ubuntu en mode Legacy.
Quant à la partition /boot ("grub_bios"), il n'est pas indispensable qu'elle soit vers le début* du disque dur. Tu peux donc réduite légèrement la taille de ton disque C: depuis Windows 8 pour dégager de la place après cette partition (et non pas avant) juste ce qu'il faut pour cette partition "grub_bios". Ensuite, tu créeras cette partition avec Gparted depuis une session live de Ubuntu. Important à comprendre : après que tu auras créé cette partition, tu n'auras pas à t'en occuper pour l'installation de Ubuntu : l'installateur de Ubuntu sait ce qu'il a à faire avec cette partition. Toi tu auras juste à préciser que tu veux que le chargeur d'amorçage de Grub soit installé dans /dev/sda et l'installateur traduira cela par l'écriture dans cette partition "grub_bios". C'est transparent pour toi.

* je sais qu'il y a écrit "n'importe quel emplacement entièrement inclus dans les 100 premiers Go du disque" en bas de la doc GPT mais ça ne s'applique pas à ton Bios qui est très récent. Tu peux la mettre où tu veux cette partition "grub_bios".

Edit : tu peux dire merci à Dell de te fournir une daube pareille. C'est quand même rageant de devoir s'emmerder comme ça pour installer un dual-boot.

Dernière modification par malbo (Le 15/01/2013, à 17:51)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#27 Le 15/01/2013, à 18:14

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

C'est ce que je pense avoir essayé de faire, le problème, c'est que je m'y perds un peu maintenant vues le nombres de configuration que j'ai essayé. 
En gros j'ai fait un peu n'importe quoi, ce qui fait que plus rien ne marchait au final. Résultat, j'ai utilisé mon image clonezilla (merci encore!) pour tout recommencer. Néanmoins voici à peu près ce que j'ai essayé :

j'ai créé une partition non formatée après Windows de 2 mégas non formatée pour le bios_grub, puis une partition de 1 giga pour le /boot, une partition swap, puis une partition racine de 25 gigas, puis une partition /home avec le reste.
J'ai lancé Ubuntu installé depuis le BIOS sur le disque dur en mode legacy, et de là l'ai lancé le boot repair qui m'a donné ce résultat :

Le démarrage de l'ordinateur a été correctement réparé.

Écrivez sur un papier l'URL suivante :
http://paste.ubuntu.com/1533067/


Si vous avez toujours des problèmes de démarrage, indiquez cette URL à :
boot.repair@gmail.com ou sur votre forum favori.

Vous pouvez maintenant redémarrer votre ordinateur.
N'oubliez pas de régler votre BIOS pour qu'il amorce sur le fichier sda1/EFI/ubuntu/shimx64.efi !


Les fichiers de démarrage de [L'OS actuellement utilisé - Ubuntu-Secure-Remix 12.10 30nov2012] sont loin du début du disque. Votre BIOS pourrait ne pas les détecter. Vous voudrez peut-être re-essayer après avoir créé une partition /boot (EXT4, >200MB, en début de disque). Cela peut être réalisé via des outils tels que gParted. Puis sélectionnez cette partition via l'option [Partition /boot séparée :] de [Réparateur de démarrage]. (http://doc.ubuntu-fr.org/tutoriel/partition_boot)

je n'ai pas remarqué la ligne :

N'oubliez pas de régler votre BIOS pour qu'il amorce sur le fichier sda1/EFI/ubuntu/shimx64.efi !

Résultat : Ubuntu ne démarrait plus (en mode LEGACY si besoin de le préciser). J'ai donc lancé une session live, le boot repair et obtenu ce message :

Une erreur est survenue pendant la réparation.


Écrivez sur un papier l'URL suivante :
http://paste.ubuntu.com/1534262/


Si vous avez toujours des problèmes de démarrage, indiquez cette URL à :
boot.repair@gmail.com

Vous pouvez maintenant redémarrer votre ordinateur.
N'oubliez pas de régler votre BIOS pour qu'il amorce sur le disque sda (500GB) !


Les fichiers de démarrage de [L'OS actuellement utilisé - Ubuntu-Secure-Remix 12.10 30nov2012] sont loin du début du disque. Votre BIOS pourrait ne pas les détecter. Vous voudrez peut-être re-essayer après avoir créé une partition /boot (EXT4, >200MB, en début de disque). Cela peut être réalisé via des outils tels que gParted. Puis sélectionnez cette partition via l'option [Partition /boot séparée :] de [Réparateur de démarrage]. (http://doc.ubuntu-fr.org/tutoriel/partition_boot)

Et là, je ne me souviens pas de tout, mais en gros plus rien ne marchait, ni windows, ni ubuntu... etc

Bref, j'ai conscience d'avoir été imprudent et amateur, mais soyez indulgent, Avant de procéder à l'installation d'ubuntu, j'ai vraiment essayer de faire mes sauvegardes d'usine, impossible ! J'ai passer une après midi avec le service de Dell, via de multiples services pour qu'ils reconnaissent finalement le bug de leur logiciel "Dell recovery and Backup" sur windows 8 (avec comme consolation l'éventualité que les CDs d'installation soient prochainement disponibles). Si j'avais eu connaissance de Clonezilla avant.. Du coup, je me suis lancé, car j'ai besoin de Windows, mais d'un Windows stable, que je n'utilise que pour un logiciel professionnel. Du coup le dual boot Ubuntu/Windows et vital pour moi.

Hors ligne

#28 Le 15/01/2013, à 18:23

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Je me reprends, désolé, je perds mon calme...
Déjà merci encore Malbo !
Après pour répondre à ton message, il me semble qu'une partition /boot n'est pas suffisante, et qu'il faut aussi une petite partition non formatée grub_bios. Je crois que ce n'est pas la même chose.
http://doc.ubuntu-fr.org/tutoriel/parti … eur_ubuntu
Paragraphe 2.3 et 2.4 :

Partition EFI ou BIOS-boot (si disque GPT)

Si votre disque dur est partitionné en GPT, il faudra y créer soit une partition EFI, soit une partition BIOS-Boot. Il n'y a pas besoin de leur attribuer un point de montage, car l'installateur s'en charge automatiquement4). Voir cette page pour plus d'informations.
Partition boot (parfois nécessaire)

    Point de montage : /boot
    Utilité : Certains ordinateurs n'arrivent pas à lire les fichiers de démarrage s'ils sont situés trop loin (>100Go) du début du disque. Dans ce cas, il est généralement nécessaire de créer une partition /boot en début de disque5).
    Taille : 250Mo~1Go
    Type : Linux (généralement EXT4)

En tout cas j'ai bien eu des messages m'indiquant un problème du à la distance de la partition d'amorçage sur le disque dur GPT.

Je suis complètement perdu...

Hors ligne

#29 Le 15/01/2013, à 18:37

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Pour faire court, je suis entrain de tout remettre à zéro autant que possible, et essayer de faire les choses bien proprement.
À ce stade, je crois que le plus simple pour moi serait de trouver une solution pour pouvoir lancer une session en mode UEFI. Je ne suis pas le seul  possesseur de Dell dans ce cas (on est au moins 2 : http://askubuntu.com/questions/224040/ubuntu-12-10-64-bits-not-booting-on-a-dell-inspiron-15z-puissance-french-in-ue, néanmoins, il ne nous dit pas ce qui ce passe après son reboot...).

Hors ligne

#30 Le 15/01/2013, à 18:46

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

C'est ma faute là : je t'ai embrouillé parce que j'ai recopié bêtement dans le post #26 ce que tu avais écrit plus haut : en fait je ne voulait parler que de la partition "grub_bios" et je ne voulais pas du tout parler de la partition /boot qui ne sert qu'à foutre le bazar selon moi (je sais que la doc dit le contraire). Donc à mon avis, oui il faut une partition "grub_bios" mais non il ne faut pas de partition /boot. Les messages dont tu parles ( un problème du à la distance de la partition d'amorçage sur le disque dur GPT), ce sont des messages d'alerte de Boot-Repair et à mon avis, tu peux t'en foutre royalement.
Par contre, tu as fait très fort là :

============================= Boot Info Summary: ===============================

 => Grub Legacy0.97 is installed in the MBR of /dev/sda and looks at sector 
    466901488 of the same hard drive for the stage2 file.  A stage2 file is at 
    this location on /dev/sda.  Stage2 looks on partition #7 for 
    /grub/menu.lst..

Tu as tenté d'installer Grub Legacy pour lancer Ubuntu 12.10. Ce n'est pas bon mais pas bon du tout. Je ne sais même pas comment tu as pu réussir cette config monstrueuse.
On doit voir à cet emplacement :

============================= Boot Info Summary: ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda.....

C'est à dire le chargeur d'amorçage de grub-pc

D'autre part, je constate que tu utilises Boot-Repair sans le mettre à jour alors que la version de base livrée avec Ubuntu sécurisée est boguée. Voici ce que tu utilises (extrait de ton Boot-Info) :

ADDITIONAL INFORMATION :
=================== log of boot-repair 2013-01-15__14h22 ===================
boot-repair version : 3.195~ppa26~quantal
boot-sav version : 3.195~ppa26~quantal
glade2script version : 3.2.2~ppa45~quantal
boot-sav-extra version : 3.195~ppa26~quantal
boot-repair is executed in installed-session (Ubuntu-Secure-Remix 12.10 30nov2012, quantal, Ubuntu, x86_64)

Malheureusement, la version à jour est 3.197~ppa20~quantal comme tu peux voir là : https://launchpad.net/~yannubuntu/+arch … hive-extra
Comme solutions à ce dernier problème, je te suggère d'utiliser un liveCD de Ubuntu 12.10 réalisé depuis la version officielle de l'iso Ubuntu 12.10 : http://releases.ubuntu.com/releases/qua … -amd64.iso
Puis d'installer Boot-Repair depuis une session live de Ubuntu 12.10 sur ce liveCD. Là, tu auras forcément la version à jour de Boot-Repair (3.197~ppa20~quantal)

Dernière modification par malbo (Le 15/01/2013, à 19:12)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#31 Le 15/01/2013, à 18:50

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

oups...
j'ai fait un essai et coché l'option Grub-legacy dans le réparateur de démarrage, mais ce n'est qu'un essai parmi d'autres...

Hors ligne

#32 Le 15/01/2013, à 18:52

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Tu penses que ça vaut le coup que je tente à nouveau l'installation d'ubuntu en mode LEGACY ? mais cette fois-ci en faisant les choses proprement bien entendu...

Hors ligne

#33 Le 15/01/2013, à 19:02

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Alors voici mon plan après le post #30 de Malbo:
-démarrer une session live en mode legacy
- après la partition Windows créer une partition de 2 mégas non formatée pour le bios bios_grub
... une partition swap 9 Gi
.... une partition racine / 25 Gi
... une partition /home le reste
- installer ubuntu  "normalement" (ne va-t-il pas me demander une partition /boot ? )
- redémarrer et ne rien toucher si ce n'est les options dans le bios pour voir si je peux jongler entre windows et ubuntu via le bios.

Dernière modification par ipaul (Le 15/01/2013, à 19:03)

Hors ligne

#34 Le 15/01/2013, à 19:08

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

ipaul a écrit :

- installer ubuntu  "normalement" (ne va-t-il pas me demander une partition /boot ? )

Il faut choisir "Autre chose" à l'étape 3 et faire l'affectation manuelle des partitions avec l'aide de la doc : http://doc.ubuntu-fr.org/tutoriel/parti … eur_ubuntu

Attention : j'ai complété mon post #30 au sujet de Boot-Repair non à jour mais à priori, si tu t'y prends bien, tu n'as pas besoin d'utiliser Boot-repair.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#35 Le 15/01/2013, à 19:20

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Merci pour toutes ces précisions dont j'ai pris note ! Je me lance..

Hors ligne

#36 Le 15/01/2013, à 20:12

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

C'est bon !!!!!!! ça marche !!!
L'heure est aux remerciements. Bien sûr je ne remercie pas Dell et windows !
Je ne saurais comment remercier Malbo et à travers lui toute la "communauté". Je suis tellement impressionné par l'aide que vous donnez et les outils fabuleux que vous développez. Alors merci Malbo, merci à tous.
En fait la solution était très simple : ne rien faire ! Bon, après coup c'est un peu facile à dire... Ceci-dit, mes problèmes viennent du fait qu'après chaque installation je m'évertuais à lancer le réparateur de démarrage pour avoir le choix entre windows et ubuntu au démarrage. Cause perdue, puisque SUR MON DELL, les deux systèmes ne peuvent fonctionner sur le même mode (LEGACY/UEFI).
En installant normalement Ubuntu et surtout sans toucher au réparateur de démarrage, je suis en mesure de passer d'un OS à l'autre simplement en passant par le BIOS pour changer le mode de démarrage (LEGACY ou UEFI selon mes besoins).  En fait à chaque fois que je lancais le réparateur de démarrage je perdais l'accès à l'un de mes OS !
En conclusion, j'ai ce qu'il me faut ! même si il y a toujours un bug dans le lancement d'ubuntu sur mon ordinateur en mode UEFI.
Beaucoup de prise de tête, mais au moins je vais mourir moins bête..

Encore une fois, merci Malbo pour ta patience, ton temps, ton expertise....

Dernière modification par ipaul (Le 15/01/2013, à 20:22)

Hors ligne

#37 Le 15/01/2013, à 21:43

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

ipaul a écrit :

SUR MON DELL, les deux systèmes ne peuvent fonctionner sur le même mode (LEGACY/UEFI).

Heureusement que ce cas est assez rare parce que jusqu'ici j'ai toujours conseillé d'installer Ubuntu dans le même mode que Windows. Et je continuerai à dire que c'est ce qu'il faut faire.
Profite bien de Ubuntu parce que tu as souffert pour l'installer.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#38 Le 16/01/2013, à 08:26

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

ipaul,
Je souhaiterais ajouter une ligne pour ton modèle Inspiron 15z 5523 dans la liste des portables Dell. J'y donnerai un lien vers la présente discussion aussi je te prie de poster le Boot-Info actuel afin que les personnes intéressées puissent avoir un modèle d'installation. Merci d'avance.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#39 Le 22/01/2013, à 15:57

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

@Malbo
Avec du retard désolé (faut dire qu'avec le temps passé sur ma machine, j'avais beaucoup de choses à rattraper après !), Voici mon boot-info actuel  : http://paste.ubuntu.com/1559317/.
J'ai finalement opter pour Ubuntu 12.04 (puisque je n'ai pas besoin d'une version compatible avec le mode UEFI), mais ça marchait bien avec 12.10, néamoins, il fallait quelques manipulations supplémentaires pour le Wifi (Voir mon autre sujet pour le wifi avec la version 12.04:http://forum.ubuntu-fr.org/viewtopic.php?id=1152231).
C'est quand même une bonne machine (Dell inspiron 5523 15z Ultrabook), mais si en plus de Windows, Dell nous met des bâtons dans les roues, difficile de l'utiliser comme bon nous semble.
J'espère ne plus avoir de souci à poster ici. Merci encore pour ton aide Malbo.

Dernière modification par ipaul (Le 22/01/2013, à 15:58)

Hors ligne

#40 Le 22/01/2013, à 16:27

malbo

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Merci pour le retour.
j'ai ajouté une ligne pour le modèle "Inspiron 15Z 5523" : http://doc.ubuntu-fr.org/liste_portables_dell#inspiron


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#41 Le 22/01/2013, à 19:13

ipaul

Re : [Résolu] DELL Echec installation/live en mode UEFI- dual boot 12.10/W8

Super ! Du coup petite précision encore pour ceux qui arriveraient ici, la carte Ethernet de mon dell (Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] ) n'est pas non plus prise en charge par Ubuntu. Il y a des solutions sur le net, mais je ne les ai pas encore appliquées, me contentant d'une connexion Wifi pour le moment. Sans connexion internet ni par le wifi, ni par ethernet au début, c'est plus difficile de faire l'installation. Pour ma part, j'ai fait mon installation avec la connexion USB de ma freebox v5, ce qui m'a évité bien des tracas (supplémentaires)...

Hors ligne

Haut de page ↑