Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 24/05/2011, à 14:03

bmzoom

[Résolu ] Xsane et scanner lide 110

bonjour ,

TUTO :    http://doc.ubuntu-fr.org/scanner_canoscan_lide

Un blocage ici :

git clone git://git.debian.org/sane/sane-backends.git
Initialized empty Git repository in /home/bltherm/sane-backends/.git/
git.debian.org[0: 217.196.43.140]: errno=Connection refused
fatal: unable to connect a socket (Connection refused)

J'ai désinstallé simple scan qui peut entrer en conflit avec xsane

Une idée ????

Dernière modification par bmzoom (Le 24/05/2011, à 15:11)

Hors ligne

#2 Le 24/05/2011, à 14:17

anjack

Re : [Résolu ] Xsane et scanner lide 110

Bonjour,
Je suis sous natty et le lidle 110 a été reconnu directement dès son installation. Je tourne avec simple scan sans problème.
Sous 10.04 j'avais trouvé un tuto qui permettait d'installer le dépôt de sane et, par la console, installer le driver adéquat. Simple scan n'entrait pas en conflit avec XSane.

1. Ouvrez un terminal administrateur (root)
( Pour les débutants :
Sous ubuntu, il est dans Applications / Outils systèmes / Terminal administateur )
Cela va demander votre mot de passe administrateur.
Il est conseillé de mettre un fond de couleur avec Edition/Profils
pour ne pas confondre avec une console ordinaire )
- On commence par charger des librairies et xsane
( si c'est déjà fait, c'est pas un problème )
Tapez ou copiez chacune des lignes ci dessous dans la console root :
( Les habitués de Linux, font un triple clic pour sélectionner la ligne ici,
reviennent dans la console, se placent juste après le $
et pressent la touche du milieu pour coller)
apt-get install xsane xsane-common xsane-doc sane sane-utils
apt-get install libusb-dev
apt-get install build-essential
apt-get install libsane-dev
2. Laissez le terminal root ouvert, on va en avoir encore besoin.
3. Branchez le scanner usb.
4. Ouvrir une console normale ( Applications / Accessoires / Terminal )
- Taper (ou copiez collez juste après le $ ):
lsusb
Le scanner doit être visible dans la liste qui apparaît
( exemple : Bus 001 Device 004: ID 04a9:1904 Canon, Inc.)
sinon il y un problème usb ...
- Dans la même console, lancez :
sane-find-scanner
Cela doit trouver votre scanner, mais...
found USB scanner (vendor=0x04a9 [Canon], product=0x1904 [CanoScan], chip=GL847) at
libusb:001:005
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.
Si vous n'avez pas de "was probably detected", vous pouvez lancer : scanimage -L
Si ça marche, c'est gagné, sinon, on continue la méthode.
5. Laissez la console ouverte car on aura besoin des valeurs suivantes :
ici : - vendor=0x04a9 (pour canon) et
- product=0x1904 (pour lide 100)
6. Revenez dans la console administrateur (root) et lancez :
apt-get install git-core
git clone git://git.debian.org/sane/sane-backends.git
( Tout cela prend un peu de temps...)
puis :
cd ~/sane-backends
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
A la fin, on voit la liste des scanners qui seront supportés
- On installe :
make
make install
Cela prend un peu de temps...
S'il n'y a pas trop de messages d'erreur, tout est installé correctement.
- Il n'y a plus qu'à donner les dernières permissions :
gedit /lib/udev/rules.d/40-libsane.rules
- Copiez-collez les 2 lignes qui suivent à la fin du fichier :
# Canon CanoScan Lide 100
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1904", ENV{libsane_matched}="yes"
( si vous avez autre chose qu'un Canon Lide 100, mettre ici les valeurs que
sane-find-scanner vous a données dans la console laissée ouverte, sans les "0x" )
- Enregistrez. Fermez le fichier. Fermez l'éditeur gedit.
- Editez le dernier fichier :
gedit /etc/sane.d/genesys.conf
pour y ajouter les 2 lignes qui suivent. Copier-coller :
# Canon CanoScan Lide 100
usb 0x04a9 0x1904
( pareil, mettre ici les valeurs de sane-find-scanner, avec les "0x" cette fois )
- Enregistrez, fermez le fichier, fermez l'éditeur gedit.
C'est fini.
- Menu Applications, graphisme, programme d'acquisition xsane... ça marche !
- Si ça marche pas du premier coup, redémarrez.
jpt, août 2010, corrigé en octobre 2010.
Désolé je ne peux pas citer l'auteur de cette méthode car j'ai effacé URL, merci à lui quand même


MSI WIND u100 Kubuntu 14.04

Hors ligne

#3 Le 24/05/2011, à 14:58

bmzoom

Re : [Résolu ] Xsane et scanner lide 110

ok - utiliser une méthode , cela marche 1 fois sur 10  --- Il faut adapter au coup par coup :

6. Revenez dans la console administrateur (root) et lancez :
apt-get install git-core
git clone git://git.debian.org/sane/sane-backends.git  #  obsolète

Ce que  j'ai trouvé de mieux est ici :

http://anonscm.debian.org/git/sane/sane-backends.git/

git clone git://anonscm.debian.org/git/sane/sane-backends.git/  #  utilisé

Ensuite :

cd ~/sane-backends    # ok
make
make install   #  il y a des erreurs ici

Je vais redémarrer pour voir  .....   Yes , c'est reconnu smile

Dernière modification par bmzoom (Le 24/05/2011, à 15:10)

Hors ligne

#4 Le 24/01/2013, à 16:00

obelix1502

Re : [Résolu ] Xsane et scanner lide 110

Bonjour,

Je suis complètement débutant sue Ubuntu. J'ai la version 10.12 que j'ai installée hier à côté de Windows 7.
Ubuntu ne reconnaît pas du tout mon scanner canon Lide 110.
J'ai essayé de suivre ce tuto, mais dès la première ligne (après avoir ouvert un terminal - ctrl+alt+t- et en sudo avec mot de passe, je trouve pas Applications / Outils systèmes / Terminal administateur ), la réponse est que: xsane-doc est devenu obsolète.

Que puis-je faire?

Merci d'avance.

Hors ligne

#5 Le 24/01/2013, à 16:18

alca94

Re : [Résolu ] Xsane et scanner lide 110

@ obelix1502
vous pouvez regarder dans la doc
http://doc.ubuntu-fr.org/scanner_canoscan_lide

Hors ligne

#6 Le 24/01/2013, à 17:02

obelix1502

Re : [Résolu ] Xsane et scanner lide 110

@alca94

merci beaucoup, j'ai suivi le tuto, tout va bien jusqu'à ce que j'arrive à cette ligne:

bruno-ubuntu# git clone git://git.debian.org/sane/sane.backends.git
Cloning into 'sane.backends'...
fatal: protocol error: bad line length character: wagn

Là comme tu peux voir: erreur.

Que dois-je faire?

sinon au début du tuto, mon scanner est reconnu.

Merci.

Hors ligne

#7 Le 24/01/2013, à 17:11

bmzoom

Re : [Résolu ] Xsane et scanner lide 110

Voir plus haut , en 2011 , c'était bon pour moi ..

git clone git://anonscm.debian.org/git/sane/sane-backends.git/  #  utilisé

Hors ligne

#8 Le 24/01/2013, à 17:12

obelix1502

Re : [Résolu ] Xsane et scanner lide 110

Merci beaucoup, avec un peu de recherche, j'ai trouvé.

Très bon tuto, merci.

Hors ligne

Haut de page ↑