Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 23/01/2013, à 13:50

sanju-san

[Résolu] Problème avec wine depuis mise à jour.

Bonjour à tous,

Wine a toujours fonctionné à merveille sur mon ordinateur. Notamment pour jouer à Vice City où à divers jeux flash au format .swf que j'ouvrait avec un standalone windows de flash. Jusque-là aucun problème.
Mais depuis une certaine mise à jour (malheureusement, je ne me rappelle plus de quoi, ça semblait être une mise à jour d'un truc graphique sur l'ordi), wine fonctionne complètement de travers.

Il n'ouvre plus Vice City et affiche le fameux "Unhandled exception" alors qu'auparavant tout fonctionnait très bien (et je n'ai fait aucune modification au fichier du jeu ni au jeu lui-même).

Je croyais que cela ne s'appliquait que pour le jeu mais les fichiers flash que j'ouvrait avec le standalone connaissent aussi un dysfonctionnement : soit ils ne démarrent pas du tout, soit ça affiche "Le programme flashplayer_11_sa.exe a rencontré un problème sérieux et doit être fermé. Nous sommes désolés pour le désagrément subi." alors que, là aussi, aucune modification n'a été faite.

Malgré tout, il semble que les petits programmes .exe ou les .exe qui ne consomment aucune ressource graphique (genre programme d'installation ou petits jeux) semblent toujours fonctionner.

J'ai supprimé complètement wine via Synaptic et supprimé ~/.wine et toute la configuration pour une réinstallation complète, mais rien à faire, ça continue.

J'ai la version stable 1.4 de wine installée (la bêta 1.5 a été catastrophique, plus rien ne s'ouvrait, absolument rien !).
Aussi, je ne suis pas sur que cela soit dû à la mise à jour, mais c'est la seule chose qui a changé sur l'ordi avant que wine ne commence à dysfonctionner après un redémarrage (indirect).

Quelqu'un pourrait-il m'aider, s'il vous plaît ?


Merci d'avance.

Dernière modification par sanju-san (Le 27/01/2013, à 11:24)

Hors ligne

#2 Le 23/01/2013, à 17:07

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

"Bonjour docteur, j'ai mal"
"Oui où ça Monsieur ?"
"Je sais pas j'ai mal, soignez moi!"

Voila à quoi ressemble ton problème en gros ... on a juste pour nous aider, un message d'erreur qui est programme dépendant, et des plus communs, ainsi qu'une mise à jour mais tu sais plus laquelle. Autrement dit : On a rien.

Tu pourrais nous donner les retours console de wine lorsque le programme plante ? Nous donner ta version d'Ubuntu, ta version de wine ... bref des informations utiles quoi.

uname -v && wine --version

Dernière modification par shoot76 (Le 23/01/2013, à 17:08)


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#3 Le 24/01/2013, à 16:36

sanju-san

Re : [Résolu] Problème avec wine depuis mise à jour.

Merci d'avoir répondu.

Désolé d'avoir été si flou, je suis débutant. Avant tout, j'utilise Ubuntu 12.04.1 LTS. Edit : en version 32 bits !
Quand je tape la commande fournie, voici ce qui apparaît :

#55-Ubuntu SMP Wed Dec 5 18:04:39 UTC 2012
wine-1.4.1

Et en essayant d'ouvrir mes fichiers avec wine (en tapant wine dans le terminal et en indiquant après un espace l'emplacement du fichier .exe, corrigez-moi si ce n'est pas la chose à faire !) :

-Pour Vice City, rien. Le bureau virtuel s'ouvre normalement mais rien n'apparaît, en fait ça freeze complètement et je doit forcer l'arrêt.

-Pour le standalone de flash par contre il se passe quelque chose, je l'ouvre de la même façon que Vice City avec le terminal, dès qu'il s'exécute, j'essaye d'ouvrir un fichier .swf, et là quand ça affiche le message d'erreur :

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "AMD Radeon HD 6400M Series", version "1.4 (2.1 (4.2.11931 Compatibility Profile Context))").
wine: Unhandled page fault on write access to 0x7cf6f000 at address 0xb75b86af (thread 0009), starting debugger...
Unhandled exception: page fault on write access to 0x7cf6f000 in 32-bit code (0xb75b86af).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:b75b86af ESP:0032d53c EBP:0032d71c EFLAGS:00010206(  R- --  I   - -P- )
 EAX:7d7473bd EBX:b7627ff4 ECX:03275ca0 EDX:7cf6ef90
 ESI:7cea0e48 EDI:032d5f50
Stack dump:
0x0032d53c:  7d5c6ff4 7d59f551 7cf0edf0 7d6e719d
0x0032d54c:  032d5f40 7d710ff4 7d710ff4 0032d5f0
0x0032d55c:  00000001 7d648f54 00000001 0032d5f0
0x0032d56c:  0032d5f4 7d6e719d 00147078 7d56dff4
0x0032d57c:  00000001 00000000 7cea1580 7def9ff4
0x0032d58c:  7ce22ee8 7d5c6ff4 7cea0e48 7ce22ee8
Backtrace:
=>0 0xb75b86af in libc.so.6 (+0x1366af) (0x0032d71c)
  1 0x7d59f551 in libgl.so.1 (+0x2c550) (0x0032d71c)
  2 0x7d648f54 in wined3d (+0x58f53) (0x0032d71c)
  3 0x7d64ce8e in wined3d (+0x5ce8d) (0x0032dbbc)
  4 0x7d650983 in wined3d (+0x60982) (0x0032dbdc)
  5 0x7d6d5951 wined3d_create+0x60() in wined3d (0x0032dc1c)
  6 0x7d72bf17 Direct3DCreate9+0x66() in d3d9 (0x0032dc4c)
  7 0x00583bde in flashplayer_11_sa (+0x183bdd) (0x0032e0bc)
  8 0x0043f2f0 in flashplayer_11_sa (+0x3f2ef) (0x0032e100)
  9 0x0044083a in flashplayer_11_sa (+0x40839) (0x0032e148)
  10 0x00440972 in flashplayer_11_sa (+0x40971) (0x0032e174)
  11 0x0045391d in flashplayer_11_sa (+0x5391c) (0x0032e1ec)
  12 0x00438d6f in flashplayer_11_sa (+0x38d6e) (0x0032e4e4)
0xb75b86af: movntq	%mm7,0x70(%edx)
Modules:
Module	Address			Debug info	Name (131 modules)
PE	  400000-  d0e000	Export          flashplayer_11_sa
ELF	7a4a9000-7b800000	Deferred        libllvm-3.0.so.1
ELF	7b800000-7ba29000	Deferred        kernel32<elf>
  \-PE	7b810000-7ba29000	\               kernel32
ELF	7bc00000-7bcc3000	Deferred        ntdll<elf>
  \-PE	7bc10000-7bcc3000	\               ntdll
ELF	7bf00000-7bf04000	Deferred        <wine-loader>
ELF	7cfb8000-7cfbf000	Deferred        libffi.so.6
ELF	7cfbf000-7cfdd000	Deferred        libgcc_s.so.1
ELF	7d535000-7d542000	Deferred        libdrm.so.2
ELF	7d542000-7d55a000	Deferred        libxcb-glx.so.0
ELF	7d55a000-7d55d000	Deferred        libx11-xcb.so.1
ELF	7d55d000-7d573000	Deferred        libglapi.so.0
ELF	7d573000-7d5cc000	Dwarf           libgl.so.1
ELF	7d5e2000-7d716000	Dwarf           wined3d<elf>
  \-PE	7d5f0000-7d716000	\               wined3d
ELF	7d716000-7d74f000	Dwarf           d3d9<elf>
  \-PE	7d720000-7d74f000	\               d3d9
ELF	7d74f000-7d765000	Deferred        dwmapi<elf>
  \-PE	7d750000-7d765000	\               dwmapi
ELF	7d765000-7d77a000	Deferred        schannel<elf>
  \-PE	7d770000-7d77a000	\               schannel
ELF	7d7b5000-7d7b9000	Deferred        libxdamage.so.1
ELF	7d7b9000-7d7db000	Deferred        iphlpapi<elf>
  \-PE	7d7c0000-7d7db000	\               iphlpapi
ELF	7d7db000-7d806000	Deferred        netapi32<elf>
  \-PE	7d7e0000-7d806000	\               netapi32
ELF	7d806000-7d832000	Deferred        secur32<elf>
  \-PE	7d810000-7d832000	\               secur32
ELF	7d832000-7d856000	Deferred        mlang<elf>
  \-PE	7d840000-7d856000	\               mlang
ELF	7d856000-7d85f000	Deferred        librt.so.1
ELF	7d85f000-7d864000	Deferred        libgpg-error.so.0
ELF	7d864000-7d87c000	Deferred        libresolv.so.2
ELF	7d87c000-7d880000	Deferred        libkeyutils.so.1
ELF	7d880000-7d8c9000	Deferred        libdbus-1.so.3
ELF	7d8c9000-7d8db000	Deferred        libp11-kit.so.0
ELF	7d8db000-7d960000	Deferred        libgcrypt.so.11
ELF	7d960000-7d972000	Deferred        libtasn1.so.3
ELF	7d972000-7d97b000	Deferred        libkrb5support.so.0
ELF	7d97b000-7d9a3000	Deferred        libk5crypto.so.3
ELF	7d9a3000-7da72000	Deferred        libkrb5.so.3
ELF	7da72000-7da84000	Deferred        libavahi-client.so.3
ELF	7da84000-7db48000	Deferred        libgnutls.so.26
ELF	7db48000-7db86000	Deferred        libgssapi_krb5.so.2
ELF	7db86000-7dbd9000	Deferred        libcups.so.2
ELF	7dbdc000-7dbef000	Deferred        gnome-keyring-pkcs11.so
ELF	7dc1d000-7dc51000	Deferred        uxtheme<elf>
  \-PE	7dc20000-7dc51000	\               uxtheme
ELF	7dc51000-7dc57000	Deferred        libxfixes.so.3
ELF	7dc57000-7dc62000	Deferred        libxcursor.so.1
ELF	7dc63000-7dc68000	Deferred        libcom_err.so.2
ELF	7dc68000-7dc76000	Deferred        libavahi-common.so.3
ELF	7dcda000-7dd04000	Deferred        libexpat.so.1
ELF	7dd04000-7dd38000	Deferred        libfontconfig.so.1
ELF	7dd38000-7dd48000	Deferred        libxi.so.6
ELF	7dd48000-7dd4c000	Deferred        libxcomposite.so.1
ELF	7dd4c000-7dd55000	Deferred        libxrandr.so.2
ELF	7dd55000-7dd5f000	Deferred        libxrender.so.1
ELF	7dd5f000-7dd65000	Deferred        libxxf86vm.so.1
ELF	7dd65000-7dd87000	Deferred        imm32<elf>
  \-PE	7dd70000-7dd87000	\               imm32
ELF	7dd87000-7dd8e000	Deferred        libxdmcp.so.6
ELF	7dd8e000-7ddaf000	Deferred        libxcb.so.1
ELF	7ddaf000-7ddc9000	Deferred        libice.so.6
ELF	7ddc9000-7defd000	Deferred        libx11.so.6
ELF	7defd000-7df0f000	Deferred        libxext.so.6
ELF	7df0f000-7dfa3000	Deferred        winex11<elf>
  \-PE	7df20000-7dfa3000	\               winex11
ELF	7dfa3000-7e03d000	Deferred        libfreetype.so.6
ELF	7e03d000-7e05c000	Deferred        libtinfo.so.5
ELF	7e05c000-7e07e000	Deferred        libncurses.so.5
ELF	7e07e000-7e0c2000	Deferred        dsound<elf>
  \-PE	7e080000-7e0c2000	\               dsound
ELF	7e0c2000-7e0ea000	Deferred        msacm32<elf>
  \-PE	7e0d0000-7e0ea000	\               msacm32
ELF	7e0ea000-7e197000	Deferred        winmm<elf>
  \-PE	7e0f0000-7e197000	\               winmm
ELF	7e197000-7e21b000	Deferred        urlmon<elf>
  \-PE	7e1a0000-7e21b000	\               urlmon
ELF	7e21b000-7e2d5000	Deferred        crypt32<elf>
  \-PE	7e220000-7e2d5000	\               crypt32
ELF	7e2d5000-7e2fb000	Deferred        mpr<elf>
  \-PE	7e2e0000-7e2fb000	\               mpr
ELF	7e2fb000-7e311000	Deferred        libz.so.1
ELF	7e311000-7e380000	Deferred        wininet<elf>
  \-PE	7e320000-7e380000	\               wininet
ELF	7e380000-7e3b9000	Deferred        liblcms.so.1
ELF	7e3cf000-7e3ee000	Deferred        mscms<elf>
  \-PE	7e3e0000-7e3ee000	\               mscms
ELF	7e3ee000-7e420000	Deferred        ws2_32<elf>
  \-PE	7e400000-7e420000	\               ws2_32
ELF	7e420000-7e45a000	Deferred        winspool<elf>
  \-PE	7e430000-7e45a000	\               winspool
ELF	7e45a000-7e553000	Deferred        comctl32<elf>
  \-PE	7e460000-7e553000	\               comctl32
ELF	7e553000-7e5bd000	Deferred        shlwapi<elf>
  \-PE	7e560000-7e5bd000	\               shlwapi
ELF	7e5bd000-7e7d0000	Deferred        shell32<elf>
  \-PE	7e5d0000-7e7d0000	\               shell32
ELF	7e7d0000-7e8af000	Deferred        comdlg32<elf>
  \-PE	7e7e0000-7e8af000	\               comdlg32
ELF	7e8af000-7e925000	Deferred        rpcrt4<elf>
  \-PE	7e8c0000-7e925000	\               rpcrt4
ELF	7e925000-7e93e000	Deferred        version<elf>
  \-PE	7e930000-7e93e000	\               version
ELF	7e93e000-7e9fb000	Dwarf           gdi32<elf>
  \-PE	7e950000-7e9fb000	\               gdi32
ELF	7e9fb000-7eb3b000	Deferred        user32<elf>
  \-PE	7ea10000-7eb3b000	\               user32
ELF	7eb3b000-7eb9d000	Deferred        advapi32<elf>
  \-PE	7eb50000-7eb9d000	\               advapi32
ELF	7eb9d000-7eca5000	Deferred        ole32<elf>
  \-PE	7ebb0000-7eca5000	\               ole32
ELF	7eca5000-7ed97000	Deferred        oleaut32<elf>
  \-PE	7ecc0000-7ed97000	\               oleaut32
ELF	7ef97000-7efa4000	Deferred        libnss_files.so.2
ELF	7efa4000-7efbe000	Deferred        libnsl.so.1
ELF	7efbe000-7efea000	Deferred        libm.so.6
ELF	7efea000-7efee000	Deferred        libxinerama.so.1
ELF	7efee000-7eff4000	Deferred        libuuid.so.1
ELF	7eff4000-7f000000	Deferred        libnss_nis.so.2
ELF	b7473000-b747c000	Deferred        libnss_compat.so.2
ELF	b747d000-b7482000	Deferred        libdl.so.2
ELF	b7482000-b762c000	Dwarf           libc.so.6
ELF	b762d000-b7648000	Deferred        libpthread.so.0
ELF	b7649000-b764d000	Deferred        libxau.so.6
ELF	b764d000-b7656000	Deferred        libsm.so.6
ELF	b765e000-b77a0000	Dwarf           libwine.so.1
ELF	b77a2000-b77c4000	Deferred        ld-linux.so.2
ELF	b77c4000-b77c5000	Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) Z:\home\payet\TÚlÚchargements\flashplayer_11_sa.exe
	00000024    0
	00000023    0
	00000009    0 <==
0000000e services.exe
	0000001f    0
	0000001e    0
	00000018    0
	00000017    0
	00000015    0
	00000010    0
	0000000f    0
00000012 winedevice.exe
	0000001c    0
	00000019    0
	00000014    0
	00000013    0
0000001a plugplay.exe
	00000020    0
	0000001d    0
	0000001b    0
00000021 explorer.exe
	00000022    0

J'espère que c'est mieux. N'hésitez pas à corriger mes maladresses !

Dernière modification par sanju-san (Le 24/01/2013, à 16:38)

Hors ligne

#4 Le 24/01/2013, à 18:22

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

Tout d'abord merci pour ces retours,c'est déjà beaucoup plus clair.

Voici ce que je lis :

X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed

Soit wine a un soucis et il ne trouve pas tes drivers graphiques, soit, ils ne sont pas installés. Auquel cas, installe les avec l'outil fournit par Ubuntu pour le faire (un truc comme "Pilotes additionnels" de mémoire).

Tiens moi au courant.


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#5 Le 25/01/2013, à 16:25

sanju-san

Re : [Résolu] Problème avec wine depuis mise à jour.

Tiens c'est étrange, j'ai toujours utilisé les drivers catalyst propriétaires fournis ici en les installant en suivant ce tuto.

Les pilotes propriétaires du système ne m'ont jamais vraiment emballé (je les utilisais quand j'étais en 11.04, et même si c'était relativement complet, ça laissait parfois à désirer sur mon ordi) et je croyais que wine fonctionnait toujours très bien avec mes pilotes téléchargés.

Se pourrait-il qu'il ne détecte plus mes pilotes du jour au lendemain ?

Mon pilote téléchargé est la version 12.10-x86 de catalyst. Aussi, mes infos carte graphique et tout sont indiqués dans le message d'erreur.

Hors ligne

#6 Le 25/01/2013, à 21:32

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

C'est étrange car selon wine, tu n'en a pas... peux tu me donner le retour de ceci s'il te plait :

glxinfo | grep rendering

si ça te retourne une erreur "glxinfo introuvable, veuillez installer ..." fais le wink


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#7 Le 26/01/2013, à 10:41

sanju-san

Re : [Résolu] Problème avec wine depuis mise à jour.

Effectivement, j'ai eu à installer mesa-utils quand j'ai tapé la commande.

Ensuite, ça m'a retourné :

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

J'imagine que cela n'est pas bon. Que faire s'il vous plaît ?

Hors ligne

#8 Le 26/01/2013, à 11:55

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

Non en effet. Ton Direct Rendering (Rendu Direct) n'est pas activé, en gros ... tes pilotes graphiques ne fonctionnent pas.

Essaie de les installer simplement avec la méthode fournie par Ubuntu, tu auras peut être plus de chances.

http://doc.ubuntu-fr.org/acceleration_g … _graphique


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#9 Le 26/01/2013, à 13:22

sanju-san

Re : [Résolu] Problème avec wine depuis mise à jour.

D'accord. Mais, comme je l'ai précisé plus haut, j'ai des pilotes téléchargés qui sont installés.

Dois-je les désinstaller proprement avant de faire cette manipulation ?

Edit : J'ai essayé de désinstaller mes pilotes en faisant la commande "sudo sh /usr/share/ati/fglrx-uninstall.sh", mais c'est impossible ! Voici ce que ça me retourne :

One or more files have been altered since installation.
Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details.

Je vais donc voir le .log en question avec sudo nautilus et voici ce qui y est écrit :

*** AMD Catalyst(TM) Proprietary Driver Uninstall Log 2013-01-26 16:40:20 ***
File is missing from system /usr/bin/amdcccle.
One or more files have been altered since installation.
Uninstall will not be completed.

To force uninstall, removing all installed files without verification,
run /usr/share/ati/amd-uninstall.sh --force.

Forcing uninstall is not recommended and may cause system corruption.


Que faire ? Je ne veux pas mettre mon ordi en danger en forçant la désinstallation, mais je ne peux rien désinstaller.

Aussi, en cherchant un peu partout, j'ai trouvé cette commande qui est censée faire la même chose : "sudo apt-get remove fglrx*"
Voici ce que ça me retourne :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de fglrx-updates pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-driver-dev pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-amdcccle-updates pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-driver pour l'expression rationnelle « fglrx* »
Note : sélection de xfree86-driver-fglrx-dev pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-control pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-amdcccle pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-dev pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-modaliases pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-glx pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-kernel-source pour l'expression rationnelle « fglrx* »
Note : sélection de xorg-driver-fglrx pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-control-qt2 pour l'expression rationnelle « fglrx* »
Note : sélection de fglrx-updates-dev pour l'expression rationnelle « fglrx* »
Note : sélection de xorg-driver-fglrx-dev pour l'expression rationnelle « fglrx* »
Note : sélection de xfree86-driver-fglrx pour l'expression rationnelle « fglrx* »
Le paquet fglrx n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates-dev n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.2.0-34-generic libx264-116 linux-headers-3.2.0-34
  linux-headers-3.2.0-34-generic-pae libmusicbrainz4c2a libosmesa6 libvpx0
  libiso9660-7 libgrail1 libmatroska4
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 13 non mis à jour.

Le pilote est là. C'est sûr car ses fichiers sont toujours présents dans /usr/share/. Mais le système ne le reconnaît plus.
Si j'installe le pilote fourni par Ubuntu, tout sera corrompu car les deux pilotes s'entre-choqueront, non ?

Que faire ? Et comment ?

Dernière modification par sanju-san (Le 26/01/2013, à 14:48)

Hors ligne

#10 Le 27/01/2013, à 05:10

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

Tu as suivi l'installation des pilotes propriétaires fournit par AMD, ces pilotes sont mieux, dans le sens où ils sont à jour etc, mais nécessite une recompilation à chaque changement de noyau. Je pense que lors de ta mise à jour, tu as dû avoir un de ces changements de noyaux, et n'a pas recompilé le pilote, auquel cas, retrouve dans le tutoriel que tu as suivi, la partie traitant de ce que je viens de te dire.

Autre hypothèse/solution : Le log que tu affiche montre un fichier manquant, et te donne même la commande pour désinstaller ton pilote. Alors, une fois cette commande exécutée (si elle fonctionne), tu pourras les installer proprement par les paquets. Certes, les paquets ne sont pas la dernière version en date d'AMD, mais offrent l'avantage d'être stable, et mis à jour en même temps que ton Kernel, autrement dit, tu n'as rien à faire.

Alors par soucis de simplicité, et de stabilité, je te conseil de lancer la commande décrite par AMD :

/usr/share/ati/amd-uninstall.sh --force.

puis d'installer les pilotes fglrx comme je te l'ai dit plus haut.

Bon courage


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#11 Le 27/01/2013, à 11:24

sanju-san

Re : [Résolu] Problème avec wine depuis mise à jour.

J'avais très peur à l'idée d'exécuter cette commande. Quand je l'ai fais, chaque seconde d'attente était un vrai supplice.
Et puis, ça s'est terminé, et j'ai redémarré mon ordinateur comme indiqué à la fin de la commande.

Au redémarrage, j'ai fait comme tu l'as dit, j'ai installé le pilote fourni par Ubuntu, et une nouvelle fois, j'ai redémarré l'ordi.

C'est parfait, c'est comme avant maintenant ! Mes programmes wine fonctionnent, et le retour de "glxinfo | grep rendering" est :

direct rendering: Yes

Je tiens à te remercier très sincèrement d'avoir consacré de ton temps à m'aider, shoot76. Tu as été d'une grande aide. Grâce à toi, ce problème est [Résolu] !

Merci beaucoup !

Hors ligne

#12 Le 27/01/2013, à 12:21

shoot76

Re : [Résolu] Problème avec wine depuis mise à jour.

Content de voir autant de gratitude et que ton problème est résolu.
Sache que c'est l'esprit Linux, et surtout de ce forum. On aide les gens par passion, parce que Linux on aime ça, et qu'on veut que les gens l'utilisent dans de bonnes conditions.

Amuse toi bien smile


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

Haut de page ↑