Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 26/01/2013, à 12:41

poweriser360

[Résolu] Windows8 et Ubuntu

Bonjour,
Je souhaite installer ubuntu en cohabitation avec Windows8, mais je pense que celui-ci est installé en UEFI puisque j'obtiens cette ligne après avoir tapé bcdedit dans l’invite de commandes : 130126113340453647.png

Du coup j'ai regardé là Le démarrage EFI, j'ai tenté de suivre la première méthode mais je ne trouve pas le QuickBoost dans mon BIOS ni Intel Smart Response Technology . J'ai ensuite essayé la seconde méthode, mais le CD d'ubuntu (Ubuntu-Secure-Remix 64bits) ne démarre pas en mode EFI, et je n'ai pas trouvé d'options pour le faire dans le BIOS.

Merci de votre aide future wink

Dernière modification par poweriser360 (Le 03/02/2013, à 21:35)

Hors ligne

#2 Le 26/01/2013, à 12:51

malbo

Re : [Résolu] Windows8 et Ubuntu

C'est quoi le modèle (complet si possible) et le fabricant de ton PC ?
Pourrais-tu essayer ton liveCD de Ubuntu sur un autre PC (même un PC non-EFI, mais pas une antiquité quand même) pour être sûr au moins qu'il est fonctionnel ? Il faudra choisir "Essayer" pour seulement vérifier que tu peux bien faire une session live sur cet autre PC.

Edit : c'est Ubuntu 12.10 ou Ubuntu 12.04 ton liveCD ?

Dernière modification par malbo (Le 26/01/2013, à 12:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 26/01/2013, à 12:58

poweriser360

Re : [Résolu] Windows8 et Ubuntu

Salut,
Alors c'est un pc portable ASUS S56CM-XX038H, et le CD fonctionne bien sur ce PC (je peux l'essayer,etc) mais ne démarre en mode EFI  puisque j'arrive sur cet  écran.

Dernière modification par poweriser360 (Le 26/01/2013, à 12:59)

Hors ligne

#4 Le 26/01/2013, à 13:15

malbo

Re : [Résolu] Windows8 et Ubuntu

Oui, tu es bien démarré en mode Bios (Legacy).
C'est Ubuntu 12.10 ou Ubuntu 12.04 ?
Ton modèle ne se fabrique déjà plus si j'en crois ce post : http://www.forum-des-portables-asus.fr/ … post-69821
ça va vite l'obsolescence de nos jours...

Dernière modification par malbo (Le 26/01/2013, à 13:15)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 26/01/2013, à 14:08

poweriser360

Re : [Résolu] Windows8 et Ubuntu

c'est ubuntu-secure-remix-12.10-64bit !

Hors ligne

#6 Le 26/01/2013, à 15:01

malbo

Re : [Résolu] Windows8 et Ubuntu

Puisque tu as un Bios Aptio, peux-tu essayer de pratiquer comme expliqué ici : http://forum.ubuntu-fr.org/viewtopic.ph … #p12004841


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#7 Le 26/01/2013, à 19:29

poweriser360

Re : [Résolu] Windows8 et Ubuntu

J'ai fais les manipulations mais je n'arrive toujours pas sur l'écran grub mais j'ai des lignes sur l'écran en plus après le chargement d'ubuntu
mini_130126064124160130.jpg

Dernière modification par poweriser360 (Le 26/01/2013, à 19:40)

Hors ligne

#8 Le 27/01/2013, à 08:07

malbo

Re : [Résolu] Windows8 et Ubuntu

Je t'ai demandé dans le post #2 d'essayer ton liveCD dans un autre PC que le tien. Je renouvelle ma suggestion : rien ne dit que ton liveCD soit fonctionnel.
D'autre part, je te propose de réaliser une liveUSB (à la place du liveCD) en utilisant la procédure suivante qui s'appuie sur LiLi (elle a été rédigée pour la 12.04 mais elle est applicable aussi pour la 12.10) : http://forum.ubuntu-fr.org/viewtopic.ph … #p10730101
Tu pourras utiliser le fichier .iso de ubuntu-secure-remix-12.10-64bit pour réaliser la liveUSB avec LiLi

Dernière modification par malbo (Le 27/01/2013, à 08:11)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#9 Le 27/01/2013, à 12:58

poweriser360

Re : [Résolu] Windows8 et Ubuntu

J'ai essayé le CD sur un autre PC il fonctionne bien,
J'ai aussi crée la liveUSB, et je peut démarrer en mode UEFI ou "classique" dessus, quand je choisis le mode UEFI j'obtiens bien  l'écran avec GRUb smile
Je pense maintenant que je peux finir de suivre cette  doc ?!

Hors ligne

#10 Le 27/01/2013, à 13:11

malbo

Re : [Résolu] Windows8 et Ubuntu

poweriser360 a écrit :

Je pense maintenant que je peux finir de suivre cette  doc ?!

Non, je pense que ça vaut le coup de laisser "Secure Boot" sur Enabled parce que Ubuntu 12.10 est compatible "Secure Boot"


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#11 Le 27/01/2013, à 13:17

poweriser360

Re : [Résolu] Windows8 et Ubuntu

Ok je l'ai réactivé.

Hors ligne

#12 Le 02/02/2013, à 11:05

poweriser360

Re : [Résolu] Windows8 et Ubuntu

Suite à mon installation d'Ubuntu, j'ai eu quelques soucis avec le dualboot entre mes 2 OS que j' ai réglé avec boot-repair. J'ai l'impression que l'installation n'est pas "propre", il y a par exemple un choix du GRUB qui ne fonctionne pas .
Pouvez-vous jetez un œil au rapport de boot-repair ?

Dernière modification par poweriser360 (Le 02/02/2013, à 11:16)

Hors ligne

#13 Le 03/02/2013, à 07:59

malbo

Re : [Résolu] Windows8 et Ubuntu

Voici un extrait de ton Boot-Info :

### BEGIN /etc/grub.d/25_custom ###

menuentry "Windows UEFI bkpbootmgfw.efi" {
search --fs-uuid --no-floppy --set=root 1041-EBC4
chainloader (${root})/EFI/Microsoft/Boot/bkpbootmgfw.efi
}

menuentry "Windows Boot UEFI loader" {
search --fs-uuid --no-floppy --set=root 1041-EBC4
chainloader (${root})/EFI/Boot/bkpbootx64.efi
}
### END /etc/grub.d/25_custom ###

On y voit que tu as deux entrées qui ont été créées par Boot-Repair et qui permettent l'accès à Windows.
Elles apparaissent dans le Menu Grub comme ceci :

Windows UEFI bkpbootmgfw.efi
Windows Boot UEFI loader

Chacune de ces deux entrées pointe vers un chargeur d'amorçage qui lance Windows 8 de la même façon, si bien que tu peux utiliser indifféremment l'une ou l'autre.

Autre extrait de ton Boot-Info :

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Recovery Environment (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-9CE4C18AE4C166DC' {
	insmod part_gpt
	insmod ntfs
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9CE4C18AE4C166DC
	else
	  search --no-floppy --fs-uuid --set=root 9CE4C18AE4C166DC
	fi
	drivemap -s (hd0) ${root}
	chainloader +1
}
menuentry 'Windows 8 (loader) (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-chain-CA0EB4B00EB49743' {
	insmod part_gpt
	insmod ntfs
	set root='hd0,gpt4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  CA0EB4B00EB49743
	else
	  search --no-floppy --fs-uuid --set=root CA0EB4B00EB49743
	fi
	drivemap -s (hd0) ${root}
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

Ce sont des entrées créées d'origine par l'installateur de Ubuntu. Elles apparaissent dans le menu Grub au démarrage comme ceci :

Windows Recovery Environment (loader) (on /dev/sda2)
Windows 8 (loader) (on /dev/sda4)

Ces entrées sont non-fonctionnelles (elles ne permettent pas de démarrer Windows 8) à cause d'un bug de Grub (Bug #1024383). Je te conseille de laisser les choses en l'état, c'est à dire que ton menu Grub continuera à proposer ces deux entrées mais tu ne les utilises pas, c'est tout.

Edit : Pourrais-tu démarrer ton ordi sur Ubuntu puis passer cette commande dans un terminal :

mount

et poster le résultat obtenu. Motif : je voudrais vérifier que ta partition EFI est bien montée au démarrage.
Ce qui m'inquiète, c'est qu'on voit ça dans ton Boot-Info :

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda8        /                        ext4       (rw,errors=remount-ro)

Et on aurait dû voir ça (avec la ligne de montage de la partition EFI) :

 
================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda1        /boot/efi                vfat       (rw)
/dev/sda8        /                        ext4       (rw,errors=remount-ro)

Dernière modification par malbo (Le 03/02/2013, à 08:38)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#14 Le 03/02/2013, à 13:21

poweriser360

Re : [Résolu] Windows8 et Ubuntu

Merci pour toutes ces informations !
Voici le résultat de la commande mount:
13020312205760964.png

Merci pour ton aide wink

Hors ligne

#15 Le 03/02/2013, à 17:54

malbo

Re : [Résolu] Windows8 et Ubuntu

Dans ton post #14, on voit bien la ligne de montage de la partition EFI :

/dev/sda1 on /boot/efi type vfat (rw)

Donc c'est correct et toute ton installation est bonne.
Je te prie de modifier le titre de ton post #1 pour qu'il devienne :

[Résolu] Windows8 et Ubuntu

conformément aux indications de l'item 5.2 de ce lien : http://doc.ubuntu-fr.org/tutoriel/howto … _en_resolu


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#16 Le 03/02/2013, à 21:36

poweriser360

Re : [Résolu] Windows8 et Ubuntu

Super !
Encore merci pour ton aide wink

Hors ligne

Haut de page ↑