Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#1 Le 28/01/2013, à 00:27

henclav25

RESOLU Grub pas sur le bon disque

bonsoir
une enigme pour moi : j'ai 2 DD : quand j'installe avec le dvd d'origine Ubuntu 12.10 je lui précise bien : sur le DD 1, tout se passe bien, mais au re-démarrage il a mis le Grub sur l'autre DD ! donc pas de son,  pas d'image.
j'ai essayé 4 fois, et 4 fois même punition.
suis obligée de débrancher physiquement mon DD 2.
c'est normal ? ou j'ai fait ( ou pas fait ) quelque chose d'anormal ?
si il existe une solution ça m'eviterait d'ouvrir la caisse, débrancher etc...
merci
cordialement

Dernière modification par henclav25 (Le 13/11/2013, à 03:50)

Hors ligne

#2 Le 28/01/2013, à 00:45

salival

Re : RESOLU Grub pas sur le bon disque

Salut,
tu peux aussi tout simplement changer l'ordre de démarrage de tes disque durs dans le BIOS. Tu choisis en premier le disque sur lequel Ubuntu démarre et le tour est joué.


"Il ne faut jamais prendre les gens pour des cons, mais il ne faut pas oublier qu'ils le sont."  Les Inconnus

Hors ligne

#3 Le 28/01/2013, à 01:03

henclav25

Re : RESOLU Grub pas sur le bon disque

oui j'y ai pensé mais "master et slave" : je vais devoir changer les cavaliers ?

Hors ligne

#4 Le 28/01/2013, à 10:08

malbo

Re : RESOLU Grub pas sur le bon disque

henclav25 a écrit :

suis obligée de débrancher physiquement mon DD 2.

Le problème ne vient pas d'une mauvaise installation de Grub. Ce qui te pose problème, c'est que quand le disque DD2 est connecté, le démarrage se fait sur lui alors qu'il faudrait qu'il se fasse sur DD1. C'est un souci de ton ordi et de son Bios. Il est possible que le changement que tu évoques (changer les cavaliers) soit une solution : je t'encourage à l'essayer. Mais si ton Bios est une tête de lard et qu'il continue à démarrer obstinément sur DD2, il existe une solution qui est d'installer un chargeur d'amorçage de Grub dans le MBR du disque DD2. Ce n'est pas glorieux mais c'est pragmatique. Dans ce cas, si ton disque DD2 est vu comme sdb depuis ta session Ubuntu, il suffit de passer la commande suivante dans un terminal :

sudo grub-install /dev/sdb

Bien sûr, s'il est vu comme sda, tu remplaceras /dev/sdb par /dev/sda dans la commande
Cette dernière solution n'est même pas pérenne : en cas de mise à jour de Grub, seul le chargeur d'amorçage du MBR de DD1 sera mis à jour, le chargeur d'amorçage du MBR de DD2 sera inchangé. C'est pour dire que cette solution est à utiliser en dernier recours et qu'il faut privilégier les solutions qui peuvent te permettre de démarrer directement sur DD1 (changement des cavaliers, priorité du démarrage dans le Bios mise sur DD1, utilisation du Boot Menu s'il existe dans ton ordi)

Dernière modification par malbo (Le 28/01/2013, à 10:19)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 28/01/2013, à 14:13

jplemoine

Re : RESOLU Grub pas sur le bon disque

Je vais peut-être dire une ânerie mais si les 2 DD sont tous les 2 en maitres ou inversés (DD1 en esclave et DD2 en maitre), est-ce que
on ne pourrait pas avoir ce genre de comportement ?

Donc, perso, je vérifierais les cavaliers. Puis, dans le bios (il y a parfois (ou tout le temps ?) une option qui privilégie un disque).

Sauf erreur de ma part, la notion de maitre/esclave ne concerne que les disque IDE pas les SATA.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

En ligne

#6 Le 28/01/2013, à 15:40

malbo

Re : RESOLU Grub pas sur le bon disque

jplemoine a écrit :

J Puis, dans le bios (il y a parfois (ou tout le temps ?) une option qui privilégie un disque)

Oui, c'est la priorité de démarrage (notée "Boot Priority" dans le Bios). C'est peut-être seulement ça qui est nécessaire, tu as raison de le signaler.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

Haut de page ↑