Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/01/2013, à 00:27

Maisondouf

[résolu] Netboot + Live +iSCSI

Je viens de passer quelques temps à finaliser la mise en place (ou la remise en place) des serveur TFTP, NFS et iSCSI sur mon dédié local et tout fonctionne à merveille.

Donc, à cette heure, je suis en mesure de démarrer un PC via PXE sur un Live servi en NFS, de lui "coller" un disque iSCSI et d'installer le système dessus.

Mais une fois ce disque crée et rempli avec tout ce qu'il faut, je me penche vers une combinaison où un noyau intelligent accompagné du fs de base serait chargé en TFTP et qu'il serait assez costaud pour se coller lui même son disque iSCSI et continuer le boot.

Cela sous-entend évidement que ce beau vmlinuz et son initrd.lz soient tenus à jour en postinst à chaque modif puis transférés via smb, ftp ou autre au bon endroit pour le prochain démarrage.

Si quelqu'un a une idée sur une procédure à mettre en place, je suis tout ouie !!!

Dernière modification par Maisondouf (Le 29/01/2013, à 14:01)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#2 Le 29/01/2013, à 04:05

Maisondouf

Re : [résolu] Netboot + Live +iSCSI

Pour ceux que ça intéresse, ça prends forme....
J'ai une erreur de la part de iscsistart :

conn 0 login rejected

Un peu plus tôt, il y a un message de l'initiateur :

connection2:0 detected conn error (1020)

Si ça parle à quelqu'un....

Dans la longue ligne de paramètres qu'il faut passer au noyau, il y a deux variables 'iscsi_username' et 'iscsi_password' dans lesquelles je ne sais pas ce qu'il faut mettre.
Un utilisateur du serveur, du client ???


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 29/01/2013, à 14:01

Maisondouf

Re : [résolu] Netboot + Live +iSCSI

Le 'rejected' venait d'une histoire de syntaxe ... hmm
Donc le noyau arrive à connecter le disque et au fil du démarrage, tout se plante à cause de Network-Manager qui veut se ré-approprier eth0...
Il faut passer la carte en mode manuel dans etc/network/interfaces

iface eth0 inet manual

Et ça marche...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#4 Le 29/01/2013, à 14:43

Maisondouf

Re : [résolu] Netboot + Live +iSCSI

Enfin ça démarre, mais pas d'internet...
Il faut ajouter le route vers la passerelle à la main

sudo route add default gw asusrouter

Ensuite c'est bon...(d'ailleurs je vous écris ça depuis la machine en boot iscsi)
13c84daa3f084ef2a840b4ce2c609tt.jpg


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

Haut de page ↑