Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 07/12/2012, à 21:38

Chewbacca

[Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

Auto résolu

Bonjour.

J'ai effectué la migration de mon netbook sur kubuntu 12.10 (installation neuve, pas de dist-upgrade).

Pour faire reconnaitre ma clé 3G sur ubuntu 12.04, je rajoutais usbserial et option dans /etc/modules . Je pouvais ensuite configurer ma connexion à partir de network-manager.

Mais cette solution ne fonctionne pas sur 12.10. Y'a t'il un moyen de faire reconnaitre la clé par network manager?

PS: j'ai essayé avec Sakis3G, ça fonctionne, et ça réveille network-manager en même temps. Sakis3G fait quelquechose que network-manager ne fait pas.

PS 2 : Il s'agit visiblement du chargement du module option, je teste un modprobe option....
Ca ne marche pas

Suite de l'investigation. D'après dmesg, mon usb_modeswitch segfault.

dmesg | tail -n 30 a écrit :

[ 1115.160640] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[ 1115.168255] sd 5:0:0:0: Attached scsi generic sg1 type 0
[ 1116.821940] usb_modeswitch_[12179]: segfault at 8 ip 00007ff81a659101 sp 00007fffd8c58d58 error 4 in libc-2.15.so[7ff81a5d0000+1b5000]
[ 2132.892591] usb 1-1: USB disconnect, device number 7
[ 2139.872103] usb 1-1: new high-speed USB device number 8 using ehci_hcd
[ 2140.007514] usb 1-1: New USB device found, idVendor=1bbb, idProduct=f000
[ 2140.007529] usb 1-1: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[ 2140.007536] usb 1-1: Product: HSPA Data Card
[ 2140.007542] usb 1-1: Manufacturer: USBModem
[ 2140.007548] usb 1-1: SerialNumber: 1234567890ABCDEF
[ 2140.015687] scsi6 : usb-storage 1-1:1.0
[ 2141.015961] scsi 6:0:0:0: Direct-Access     ALCATEL  Mass Storage     2.31 PQ: 0 ANSI: 2
[ 2141.017048] scsi 6:0:0:1: CD-ROM            ALCATEL  Mass Storage     2.31 PQ: 0 ANSI: 2
[ 2141.024776] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 2141.025214] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 2141.027901] sr0: scsi-1 drive
[ 2141.028730] sr 6:0:0:1: Attached scsi CD-ROM sr0
[ 2141.029038] sr 6:0:0:1: Attached scsi generic sg2 type 5
[ 2141.552879] usb 1-1: USB disconnect, device number 8
[ 2141.920211] usb 1-1: new high-speed USB device number 9 using ehci_hcd
[ 2142.064634] usb 1-1: New USB device found, idVendor=1bbb, idProduct=0017
[ 2142.064650] usb 1-1: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[ 2142.064659] usb 1-1: Product: HSPA Data Card
[ 2142.064667] usb 1-1: Manufacturer: USBModem
[ 2142.064675] usb 1-1: SerialNumber: 1234567890ABCDEF
[ 2142.075544] scsi7 : usb-storage 1-1:1.4
[ 2143.074944] scsi 7:0:0:0: Direct-Access     ALCATEL  Mass Storage     2.31 PQ: 0 ANSI: 2
[ 2143.078843] sd 7:0:0:0: Attached scsi generic sg1 type 0
[ 2143.083062] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[ 2144.740320] usb_modeswitch_[19843]: segfault at 8 ip 00007f50cc3b5101 sp 00007fffe56a3308 error 4 in libc-2.15.so[7f50cc32c000+1b5000]

je vais tenter de le downgrader avec la version de precise

CA A MARCHÉ !!!

Au vu de mes dernières observations sur mon dmesg, j'ai donc téléchargé le paquet usb-modeswitch fourni avec precise
(à chercher sur http://packages.ubuntu.com ).
Une fois le paquet rapatrié, débranchez la clé si ce n'est pas déjà fait, ouvrez un terminal et mettez y ceci

Commande Terminal a écrit :

sudo dpkg -i usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb
version 64 bits pour moi, à adapter à votre installation

Validez, attendez.
Une fois fini, rebranchez votre clé et souriez smile

Dernière modification par Chewbacca (Le 08/12/2012, à 12:24)


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#2 Le 08/12/2012, à 08:39

michel_04

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

onjour,

Merci pour l'info.
Pour ceux qui feraient une recherche sur le forum des posts avec solution genre : "[Resolu] Clé 3G Alcatel" je pense qu'il serait mieux de mettre [Résolu] plutôt que [R] dans le titre, non ?

A+

Hors ligne

#3 Le 08/12/2012, à 12:24

Chewbacca

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

J'ai essayé, mais plus de place. Je change le titre pour en avoir un peu


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#4 Le 08/12/2012, à 17:36

lolane

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

bonjour


pourriez vous m'indiquer comment et quels réglages as-tu fais pour installer LA clé 3G sous ubuntu 12.04 ! je ne sais pas comment m'y prendre!!!! sachant que je ne suis pas très douée en informatique c'est la premiere fois que j'utilise ubuntu.
Merci d'avance

Hors ligne

#5 Le 12/12/2012, à 20:12

Chewbacca

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

Sur ubuntu 12.04 :

démarrer le terminal.

Dans le terminal, marquer : sudo gedit /etc/modules

A la fin du fichier, ajouter:

usbserial
option

Sauvegarder, et redémarrer.


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#6 Le 02/02/2013, à 16:24

Eichkätzele

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

Même problème sous Ubuntu 12.10 avec Alcatel X500D. Je télécharge par câble l'usb-modeswitch de Precise, j'ouvre avec Ubuntu Software Center : Error ; A later version is already installed. Impossible d'installer, la manip par terminal ne fonctionnant pas non plus.

dpkg: error processing usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb

Hors ligne

#7 Le 02/02/2013, à 19:54

Eichkätzele

Re : [Résolu]Clé 3G Alcatel OT X230L non fonctionnelle sur Kubuntu 12.10

Nouvel essai après transfert du fichier et en le copiant dans le terminal :

Eichkätzele@Eichkätzele-ENLE11BZ:~$ sudo dpkg -i file:///home/Eichkätzele/usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb
[sudo] password for Eichkätzele:
dpkg: error processing file:///home/Eichkätzele/usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb (--install):
cannot access archive: No such file or directory
Errors were encoutered while processing:
file:///home/Eichkätzele/usb-modeswitch_1.2.3+repack0-1ubuntu2_amd64.deb

donc à peu près la même chose.

Pourriez-vous m'aider, s'il vous plaît? Par exemple en m'indiquant un emplacement où le fichier pourrait se comporter comme un paquetage Ubuntu normal?

Au fait, j'ai désinstallé l'usb-modeswitch de 12.10 ; maintenant, quand j'ouvre l'usb-modeswitch de 12.04 avec Ubuntu Software Center, l'icône "Install" s'affiche mais je ne peux pas cliquer dessus, à mon avis parce que je ne peux pas signaler que je "trust the origin".

Merci pour votre aide!
Eichkätzele

Hors ligne

Haut de page ↑