Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/02/2013, à 10:34

__fabrice

Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Bonjour,

J'ai, depuis quelques jours, un soucis avec CURL. J'ai cette erreur :

curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)

Cela m'empeche de faire pas mal de chose (comme installer un package avec sublimetext2, par exemple smile ...)

J'ai essayé pas mal de manip comme :

php -i | grep curl

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/curl.so' - /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4) in Unknown on line 0
/etc/php5/cli/conf.d/curl.ini,

ou

apt-file search libssl.so.1.0.0
E: The cache is empty. You need to run 'apt-file update' first.

et du coup :

 apt-file update
...
...
curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
Download of http://ppa.launchpad.net/yannubuntu/os-uninstaller/ubuntu/dists/precise/Contents-i386.gz failed
Command exited with code 1

J'ai essaye de ré-installer:

sudo apt-get install libssl1.0.0
sudo apt-get install php5-curl

Ensute, dans les libs :

ls /lib/i386-linux-gnu/libssl*

/lib/i386-linux-gnu/libssl.so.0.9.8  /lib/i386-linux-gnu/libssl.so.1.0.0

et avec...

dpkg -L libssl1.0.0

...j'ai bien les packages (/usr/lib/i386-linux-gnu/openssl-1.0.0)

En fesant çà, même erreur :

sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /usr/lib/libssl.so.1.0.0

Pas d'erreur lorsque je redémarre apache.

Une idée ?

Merci à tout

Dernière modification par __fabrice (Le 04/02/2013, à 10:35)

Hors ligne

#2 Le 04/02/2013, à 14:59

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

"1.0.0" est pas pareil que "1.0.1".
CURL a dû évoluer plus vite que ubuntu
Mais il existe une version 1.0.1, dans le paquet "libssl-dev"

sudo apt-get install libssl-dev

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 04/02/2013, à 16:32

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Bonjour,

Je sais çà, j'ai déjà la libssl-dev, cela ne change rien ... sad

Merci
Fabrice

Hors ligne

#4 Le 04/02/2013, à 16:37

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Tentes un lien bidon..

sudo ln -s /usr/lib/libssl.so.1.0.0 /usr/lib/libssl.so.1.0.1

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 04/02/2013, à 16:50

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

déjà fait aussi wink, et non, çà change pas sad

Hors ligne

#6 Le 04/02/2013, à 17:07

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

T'as quelle version de Ubuntu ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 04/02/2013, à 17:13

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Linux version 3.2.0-37-generic-pae (buildd@roseapple) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #58-Ubuntu SMP Thu Jan 24 15:51:02 UTC 2013

Ubuntu 12.04.2 LTS

Hors ligne

#8 Le 04/02/2013, à 17:42

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Bizarre parce que ma libcurl3 standard 12.04 (7.22.0-3ubuntu4) ne nécessite que libssl 1.0.0.
T'as pas eu un mélange ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#9 Le 05/02/2013, à 14:11

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Je pense que oui. Il y a dù avoir un soucis avec les libs. Il faudrait que je vire toutes les libssl ?, et que je réinstalle ?

Fab.

Hors ligne

#10 Le 05/02/2013, à 14:21

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Non pas ta libsssl, c'est la bonne.
Ton curl est bien celui du dépôt ou t'en as mis un plus récent ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#11 Le 05/02/2013, à 14:31

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Pour le CURL , j'en sais rien, mais je pense que c'est plus la bonne version du dépot. Je l'ai résintallé, mais çà change rien.
Y'a une autre manip à faire pour çà ?

Fabrice

Dernière modification par __fabrice (Le 05/02/2013, à 14:31)

Hors ligne

#12 Le 05/02/2013, à 14:52

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Essayes de voir ce que veut réellement ta lib curl.

dpkg -l libcurl3

tu auras la version, moi j'ai "7.22.0-3ubuntu4"

ldd  /usr/lib/x86_64-linux-gnu/libcurl.so.3

Tu cherche la ligne de libssl et tu auras la version de libssl  qu'elle demande


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#13 Le 05/02/2013, à 14:55

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

J'ai çà :

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                          Version                      Description
+++-============================-============================-========================================================================
ii  libcurl3                     7.22.0-3ubuntu4              Multi-protocol file transfer library (OpenSSL)

Hors ligne

#14 Le 05/02/2013, à 15:26

compte supprimé

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Je ne suis pas un pro de php, mais je pense que la lib ssl a un probleme de versioning ...tu peut pas forcer curl à utiliser la version 1.0.0 ? au cas ou un précisant le cypher ...

Si ça peut aider LOL, ce n'est pas une parole d'évangile ...

#15 Le 05/02/2013, à 15:39

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Et la 2ème commande ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#16 Le 05/02/2013, à 15:47

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

ldd  /usr/lib/x86_64-linux-gnu/libcurl.so.3
ldd: /usr/lib/x86_64-linux-gnu/libcurl.so.3: Aucun fichier ou dossier de ce type

Je n'ai pas de dossier x86_64-linux-gnu

Hors ligne

#17 Le 05/02/2013, à 15:48

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

J'ai çà à la place :

ldd  /usr/lib/i386-linux-gnu/libcurl.so.3
/usr/lib/i386-linux-gnu/libcurl.so.3: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.3)
	linux-gate.so.1 =>  (0xb7728000)
	libidn.so.11 => /usr/lib/i386-linux-gnu/libidn.so.11 (0xb7679000)
	liblber-2.4.so.2 => /usr/lib/i386-linux-gnu/liblber-2.4.so.2 (0xb766a000)
	libldap_r-2.4.so.2 => /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2 (0xb7617000)
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb760e000)
	libgssapi_krb5.so.2 => /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2 (0xb75d0000)
	libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb7583000)
	libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb73df000)
	librtmp.so.0 => /usr/lib/i386-linux-gnu/librtmp.so.0 (0xb73c4000)
	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb73ae000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb7204000)
	libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb71ec000)
	libsasl2.so.2 => /usr/lib/i386-linux-gnu/libsasl2.so.2 (0xb71d0000)
	libgssapi.so.3 => /usr/lib/i386-linux-gnu/libgssapi.so.3 (0xb7192000)
	libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb70ce000)
	libgcrypt.so.11 => /lib/i386-linux-gnu/libgcrypt.so.11 (0xb7049000)
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb702e000)
	libkrb5.so.3 => /usr/lib/i386-linux-gnu/libkrb5.so.3 (0xb6f5f000)
	libk5crypto.so.3 => /usr/lib/i386-linux-gnu/libk5crypto.so.3 (0xb6f36000)
	libcom_err.so.2 => /lib/i386-linux-gnu/libcom_err.so.2 (0xb6f31000)
	libkrb5support.so.0 => /usr/lib/i386-linux-gnu/libkrb5support.so.0 (0xb6f28000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6f23000)
	/lib/ld-linux.so.2 (0xb7729000)
	libheimntlm.so.0 => /usr/lib/i386-linux-gnu/libheimntlm.so.0 (0xb6f1b000)
	libkrb5.so.26 => /usr/lib/i386-linux-gnu/libkrb5.so.26 (0xb6e97000)
	libasn1.so.8 => /usr/lib/i386-linux-gnu/libasn1.so.8 (0xb6df2000)
	libhcrypto.so.4 => /usr/lib/i386-linux-gnu/libhcrypto.so.4 (0xb6dbd000)
	libroken.so.18 => /usr/lib/i386-linux-gnu/libroken.so.18 (0xb6da7000)
	libtasn1.so.3 => /usr/lib/i386-linux-gnu/libtasn1.so.3 (0xb6d95000)
	libp11-kit.so.0 => /usr/lib/i386-linux-gnu/libp11-kit.so.0 (0xb6d82000)
	libgpg-error.so.0 => /lib/i386-linux-gnu/libgpg-error.so.0 (0xb6d7d000)
	libkeyutils.so.1 => /lib/i386-linux-gnu/libkeyutils.so.1 (0xb6d79000)
	libwind.so.0 => /usr/lib/i386-linux-gnu/libwind.so.0 (0xb6d50000)
	libheimbase.so.1 => /usr/lib/i386-linux-gnu/libheimbase.so.1 (0xb6d41000)
	libhx509.so.5 => /usr/lib/i386-linux-gnu/libhx509.so.5 (0xb6cf9000)
	libsqlite3.so.0 => /usr/lib/i386-linux-gnu/libsqlite3.so.0 (0xb6c54000)
	libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xb6c23000)

Hors ligne

#18 Le 05/02/2013, à 15:50

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

ldd  /usr/lib/i386-linux-gnu/libcurl
libcurl.a                libcurl-gnutls.so.4      libcurl.la               libcurl-nss.so.4         libcurl.so               libcurl.so.4
libcurl-gnutls.so.3      libcurl-gnutls.so.4.2.0  libcurl-nss.so.3         libcurl-nss.so.4.2.0     libcurl.so.3             libcurl.so.4.2.0

Hors ligne

#19 Le 05/02/2013, à 16:38

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

la même chose avec la 4:

ldd  /usr/lib/i386-linux-gnu/libcurl.so.4

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#20 Le 05/02/2013, à 16:42

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

ldd  /usr/lib/i386-linux-gnu/libcurl.so.4
/usr/lib/i386-linux-gnu/libcurl.so.4: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
	linux-gate.so.1 =>  (0xb776e000)
	libidn.so.11 => /usr/lib/i386-linux-gnu/libidn.so.11 (0xb76bf000)
	liblber-2.4.so.2 => /usr/lib/i386-linux-gnu/liblber-2.4.so.2 (0xb76b0000)
	libldap_r-2.4.so.2 => /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2 (0xb765d000)
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb7654000)
	libgssapi_krb5.so.2 => /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2 (0xb7616000)
	libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb75c9000)
	libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb7425000)
	librtmp.so.0 => /usr/lib/i386-linux-gnu/librtmp.so.0 (0xb740a000)
	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb73f4000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb724a000)
	libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb7232000)
	libsasl2.so.2 => /usr/lib/i386-linux-gnu/libsasl2.so.2 (0xb7216000)
	libgssapi.so.3 => /usr/lib/i386-linux-gnu/libgssapi.so.3 (0xb71d8000)
	libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb7114000)
	libgcrypt.so.11 => /lib/i386-linux-gnu/libgcrypt.so.11 (0xb708f000)
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb7074000)
	libkrb5.so.3 => /usr/lib/i386-linux-gnu/libkrb5.so.3 (0xb6fa5000)
	libk5crypto.so.3 => /usr/lib/i386-linux-gnu/libk5crypto.so.3 (0xb6f7c000)
	libcom_err.so.2 => /lib/i386-linux-gnu/libcom_err.so.2 (0xb6f77000)
	libkrb5support.so.0 => /usr/lib/i386-linux-gnu/libkrb5support.so.0 (0xb6f6e000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6f69000)
	/lib/ld-linux.so.2 (0xb776f000)
	libheimntlm.so.0 => /usr/lib/i386-linux-gnu/libheimntlm.so.0 (0xb6f61000)
	libkrb5.so.26 => /usr/lib/i386-linux-gnu/libkrb5.so.26 (0xb6edd000)
	libasn1.so.8 => /usr/lib/i386-linux-gnu/libasn1.so.8 (0xb6e38000)
	libhcrypto.so.4 => /usr/lib/i386-linux-gnu/libhcrypto.so.4 (0xb6e03000)
	libroken.so.18 => /usr/lib/i386-linux-gnu/libroken.so.18 (0xb6ded000)
	libtasn1.so.3 => /usr/lib/i386-linux-gnu/libtasn1.so.3 (0xb6ddb000)
	libp11-kit.so.0 => /usr/lib/i386-linux-gnu/libp11-kit.so.0 (0xb6dc8000)
	libgpg-error.so.0 => /lib/i386-linux-gnu/libgpg-error.so.0 (0xb6dc3000)
	libkeyutils.so.1 => /lib/i386-linux-gnu/libkeyutils.so.1 (0xb6dbf000)
	libwind.so.0 => /usr/lib/i386-linux-gnu/libwind.so.0 (0xb6d96000)
	libheimbase.so.1 => /usr/lib/i386-linux-gnu/libheimbase.so.1 (0xb6d87000)
	libhx509.so.5 => /usr/lib/i386-linux-gnu/libhx509.so.5 (0xb6d3f000)
	libsqlite3.so.0 => /usr/lib/i386-linux-gnu/libsqlite3.so.0 (0xb6c9a000)
	libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xb6c69000)

PS : Merci de passer autant de temps smile

Hors ligne

#21 Le 05/02/2013, à 17:15

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Bizarre c'est toujours la même version 1.0.0 qu'elle réclame.

libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb75c9000)

On va revenir au début pour essayer de trouver la cause de ce message:

Unable to load dynamic library '/usr/lib/php5/20090626+lfs/curl.so'

pour ça il me faut deux infos:

ls -l /usr/lib/php5/20090626+lfs/curl.so
cat  /etc/php5/cli/conf.d/curl.ini

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#22 Le 05/02/2013, à 17:42

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Voilà :

ls -l /usr/lib/php5/20090626+lfs/curl.so
-rw-r--r-- 1 root root 71172 janv. 19 00:50 /usr/lib/php5/20090626+lfs/curl.so
cat  /etc/php5/cli/conf.d/curl.ini
; configuration for php CURL module
extension=curl.so
curl -V
curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
apt-cache policy curl
curl:
  Installé : 7.22.0-3ubuntu4
  Candidat : 7.22.0-3ubuntu4
 Table de version :
 *** 7.22.0-3ubuntu4 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     7.21.6-3ubuntu3.2 0
         -1 http://security.ubuntu.com/ubuntu/ oneiric-security/main i386 Packages

Dernière modification par __fabrice (Le 05/02/2013, à 17:45)

Hors ligne

#23 Le 05/02/2013, à 20:45

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Je sèche ....


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#24 Le 06/02/2013, à 08:41

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Moi aussi sad...

Je peux pas désinstaller CURL et la libssl et tout réinstaller après ?. Y'a une manip de précise à faire ?
Merci
Fab

Hors ligne

#25 Le 06/02/2013, à 11:31

compte supprimé

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Je suis pas un pro , mais ça confirmerais ma pensée que c'est un problème de versioning et qu'il y a des symboles pourris dans libssl ... tu es sous quel distrib??(edit:quelle question ...) Tiens une discution intéressante : discussion sur irc à ce sujet même si elle date ...
En gros , essaye de changer de version ... désolé de ne pas avoir de solution toute prête à te proposer, j'essaye juste avec mes modestes compétences de faire avancer la résolution du problème.Si un pro comme Maisondouf ou autre  peu passer dans le coin ...

nb:je peut me tromper ...

Dernière modification par sogyam (Le 06/02/2013, à 20:39)

Haut de page ↑