Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 04/02/2013, à 18:32

gael10

configurer le wifi avec antenne TPlink tlwn722n (résolu)

Bonjour à tous, j'ai fait le grand pas et j'installe xubuntu 12.04 sur un vieux portable (DELL latitude D505).
Tout à l'air de fonctionner, notamment la connexion par câble Ethernet reconnue et établie automatiquement.
Voila le problème :
Je branche ma clé USB wifi TPlink TLWN722N, mais en l'absence de câble ethernet, aucune connexion. Il semble pourtant que xubuntu reconnaisse la clé, car dans le menu connexion (en haut à droite de l'écran), il est écrit "ATHEROS 2 réseau sans fil désactivé par un commutateur matériel". Or cette clé ne possède pas de bouton et elle fonctionne sous XPpro (je suis en dual boot).
Je précise enfin que j'ai désactivé le wifi originel de l'ordinateur car il provoquait un blue screen of death sous XP, à ne surtout pas réactiver donc !
Je cherche une solution depuis deux jours mais je craque, j'espère ne pas avoir manqué un post ou solution sur google.
Merci d'avance, bonne soirée.

Dernière modification par gael10 (Le 05/02/2013, à 02:28)

Hors ligne

#2 Le 04/02/2013, à 18:38

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

salut
post le resultat des commandes(a taper dans le terminal)

lsusb
lsmod
iwconfig
ifconfig
nm-tool

Hors ligne

#3 Le 04/02/2013, à 19:31

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

Salut chibbata
Voila ce que tu m'as demandé, c'est pas très lisible mais je vois pas comment mettre sur fond noir...
D'après ce que je comprends le matériel est détecté mais j'avoue que tout ça est nouveau pour moi.
Merci de ta réponse rapide.
PS:je précise que dans mes essais pour faire marcher tout ça j'ai configuré manuellement une "connexion sans fil 1" avec le gestionnaire de connexions de xubuntu (SSID, adresse mac et clé WEP)
_

gael@gael-Latitude-D505:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
_

gael@gael-Latitude-D505:~$ lsmod
Module                  Size  Used by
arc4                   12473  2
joydev                 17393  0
ath9k_htc              90811  0
snd_intel8x0           33455  3
snd_ac97_codec        110213  1 snd_intel8x0
ac97_bus               12642  1 snd_ac97_codec
snd_pcm                80916  2 snd_intel8x0,snd_ac97_codec
rfcomm                 38139  4
mac80211              436493  1 ath9k_htc
bnep                   17830  2
bluetooth             158479  10 rfcomm,bnep
ppdev                  12849  0
snd_seq_midi           13132  0
snd_rawmidi            25424  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
dell_laptop            17767  0
snd_seq                51592  2 snd_seq_midi,snd_seq_midi_event
dcdbas                 14098  1 dell_laptop
pcmcia                 39826  0
snd_timer              28931  2 snd_pcm,snd_seq
psmouse                96718  0
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    62218  13 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ath9k_common           13781  1 ath9k_htc
ath9k_hw              391591  2 ath9k_htc,ath9k_common
soundcore              14635  1 snd
ath                    19387  3 ath9k_htc,ath9k_common,ath9k_hw
snd_page_alloc         14115  2 snd_intel8x0,snd_pcm
ipw2200               146210  0
libipw                 46732  1 ipw2200
serio_raw              13027  0
cfg80211              178877  5 ath9k_htc,mac80211,ath,ipw2200,libipw
i915                  419326  2
yenta_socket           27428  0
parport_pc             32114  1
pcmcia_rsrc            18367  1 yenta_socket
pcmcia_core            21511  3 pcmcia,yenta_socket,pcmcia_rsrc
lib80211               14040  2 ipw2200,libipw
mac_hid                13077  0
drm_kms_helper         45466  1 i915
drm                   197641  3 i915,drm_kms_helper
i2c_algo_bit           13199  1 i915
shpchp                 32325  0
video                  19068  1 i915
lp                     17455  0
parport                40930  3 ppdev,parport_pc,lp
firewire_ohci          40180  0
firewire_core          56940  1 firewire_ohci
e100                   36289  0
crc_itu_t              12627  1 firewire_core
_

gael@gael-Latitude-D505:~$ iwconfig
lo        no wireless extensions.

eth1      IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
eth0      no wireless extensions.
_

gael@gael-Latitude-D505:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0f:1f:c7:7f:47 
          inet adr:192.168.1.31  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::20f:1fff:fec7:7f47/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:4897 erreurs:0 :0 overruns:0 frame:0
          TX packets:3324 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:5052761 (5.0 MB) Octets transmis:474375 (474.3 KB)

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:180 erreurs:0 :0 overruns:0 frame:0
          TX packets:180 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:17186 (17.1 KB) Octets transmis:17186 (17.1 KB)
_

gael@gael-Latitude-D505:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k_htc
  State:             unavailable
  Default:           no
  HW Address:        64:70:02:26:80:4B

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points


- Device: eth0  [Connexion filaire 1] ------------------------------------------
  Type:              Wired
  Driver:            e100
  State:             connected
  Default:           yes
  HW Address:        00:0F:1F:C7:7F:47

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.31
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ipw2200
  State:             unavailable
  Default:           no
  HW Address:        00:0E:35:64:74:88

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

Hors ligne

#4 Le 04/02/2013, à 19:43

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

sudo rmmod ipw2200 
sudo rmmod ath9k_htc
sudo modprobe ath9k_htc

si le wifi fonctionne,il reste une manip afin de blacklister le driver wifi interne

Hors ligne

#5 Le 04/02/2013, à 20:00

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

Génial ! ça marche après déconnexion du cable ethernet. Et ça à même l'air de très bien marcher.
C'est incroyable de pouvoir dépanner les gens à distance et qui plus est rapidement !
Si tu pense que "blacklister" la carte wifi interne est important, je suis preneur.
Merci beaucoup pour ta rapidité chef.

Hors ligne

#6 Le 04/02/2013, à 20:03

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

gksudo mousepad /etc/modprobe.d/blacklist.conf

ajoutes a la fin du fichier qui vient de s'ouvrie une ligne:
blacklist ipw2200

enregistres et quittes mousepad

redemarres le pc pour tester

Dernière modification par chibbata (Le 04/02/2013, à 20:03)

Hors ligne

#7 Le 04/02/2013, à 20:10

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

Rien ne s'ouvre quand je tape cette commande :

gael@gael-Latitude-D505:~$ gksudo mousepad /etc/modprobe.d/blacklist.conf
gael@gael-Latitude-D505:~$ gksudo mousepad /etc/modprobe.d/blacklist.conf
gael@gael-Latitude-D505:~$

Hors ligne

#8 Le 04/02/2013, à 20:14

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

mousepad est un editeur de texte de xubuntu
sinon essayes comme ça

sudo -s
echo "blacklist ipw2200" >> /etc/modprobe.d/blacklist.conf
exit

Dernière modification par chibbata (Le 04/02/2013, à 20:14)

Hors ligne

#9 Le 04/02/2013, à 20:17

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

Rien ne se passe mais j'imagine que là on ne passe pas par l'ouverture d'un traitement de texte ?

gael@gael-Latitude-D505:~$ sudo -s
root@gael-Latitude-D505:~# echo "blacklist ipw2200" >> /etc/modprobe.d/blacklist.conf
root@gael-Latitude-D505:~#

Hors ligne

#10 Le 04/02/2013, à 20:19

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

Désolé j'avais oublié la dernière étape en tout cas je ne vois rien :

gael@gael-Latitude-D505:~$ sudo -s
root@gael-Latitude-D505:~# echo "blacklist ipw2200" >> /etc/modprobe.d/blacklist.conf
root@gael-Latitude-D505:~# exit
exit

Hors ligne

#11 Le 04/02/2013, à 20:22

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

redemarres le pc pour verifier que le wifi est present au demarrage

Hors ligne

#12 Le 04/02/2013, à 20:29

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

ça marche ! merci encore pour ton aide précieuse, je vais pouvoir explorer xubuntu !
Bonne soirée
Gael

Hors ligne

#13 Le 04/02/2013, à 20:31

chibbata

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

edites ton 1er post et met resolu dans le titre
bonne soirée a toi

Hors ligne

#14 Le 05/02/2013, à 02:29

gael10

Re : configurer le wifi avec antenne TPlink tlwn722n (résolu)

c'est fait, j'espère que ça aidera d'autres débutants, bonne soirée chef.

Hors ligne

  • Accueil
  • » Forum
  • » WiFi
  • » configurer le wifi avec antenne TPlink tlwn722n (résolu)

Haut de page ↑