Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 05/02/2013, à 19:44

clement.analogue

Mauvais PATH dans gnome terminal

Bonjour,

Je viens d installer Ubuntu depuis une iso alternate (pour lvm). La variable $PATH n est pas correcte dans gnome terminal.

$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/games

Pas de soucis avec les tty ou j ai bien /usr/local/sbin, /usr/sbin et /sbin.

Des idees pour avoir le PATH correct ?
Merci d avance smile

Infos complementaires :

$ cat .bashrc 
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi
$ cat .profile 
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#2 Le 05/02/2013, à 22:38

J5012

Re : Mauvais PATH dans gnome terminal

pourquoi penses-tu ne pas avoir le bon path ? quelle est l'erreur ?

a ma connaissance il n'y a pas d'iso alternate specifique pour l'install en lvm, juste une serie d'etapes a effectuer sans s'emmeler les pinceaux ... si tu es reste en serveur sans continuer les autres etapes d'install du desktop, il est normal d'avoir un path "incomplet"

Hors ligne

#3 Le 05/02/2013, à 22:45

clement.analogue

Re : Mauvais PATH dans gnome terminal

Il manque /sbin, /usr/local/sbin et /usr/sbin pour avoir le $PATH par défaut, celui qui est bien pratique et qui se trouve dans /etc/environment.


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#4 Le 05/02/2013, à 22:51

J5012

Re : Mauvais PATH dans gnome terminal

as-tu installe un environnement desktop ?

Hors ligne

#5 Le 05/02/2013, à 22:52

clement.analogue

Re : Mauvais PATH dans gnome terminal

j'ai commencé par gnome-shell, ensuite, j'ai essayé le meta paquet ubuntu-desktop, mais ça ne change rien.


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#6 Le 05/02/2013, à 22:55

J5012

Re : Mauvais PATH dans gnome terminal

et gnome-shell fonctionne sans erreur ?

ex chez moi : je suis en u12.04 64b unity-2d , mon path ne contient pas la meme chose que mon etc/environment pour la bonne raison que certains chemins ne sont utiles que dans la console et pas dans l'environnement graphique.

ces chemins y ont ete installes a la suite d'installation de paquets precedents

Dernière modification par J5012 (Le 05/02/2013, à 22:59)

Hors ligne

#7 Le 05/02/2013, à 22:59

clement.analogue

Re : Mauvais PATH dans gnome terminal

Le network-manager m'affiche "unmanage" lorsque je branche un cable ethernet. Il faut que je fasse des trucs sur tty (comme apt-get upadte) pour avoir accès à internet en graphique (forcément avec ifconfig et ifup accessible qu'en root).

Ce qui me fait percuter que finalement, ça n'a pas l'air lié à gnome terminal mais à la session, non ?


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#8 Le 05/02/2013, à 23:03

J5012

Re : Mauvais PATH dans gnome terminal

c'est plutot lie au fait qu'il y a une config manuelle de la carte reseau, et que celle-ci entre en conflit avec la gestion network manager

Hors ligne

#9 Le 05/02/2013, à 23:09

clement.analogue

Re : Mauvais PATH dans gnome terminal

Étrange car je n'ai pas encore touché à networks interface (je passe en IP publique demain).


Association Ubuntu-Lyon : Organisation d'événements autour d'Ubuntu sur Lyon.

Venez discuter philosophie, exposez vos textes et réflexions, ...
Forum Analogue : Philosophie, sciences, art, actualité, etc.

Hors ligne

#10 Le 06/02/2013, à 15:07

gigiair

Re : Mauvais PATH dans gnome terminal

clement.analogue a écrit :

Il manque /sbin, /usr/local/sbin et /usr/sbin pour avoir le $PATH par défaut, celui qui est bien pratique et qui se trouve dans /etc/environment.

Ils ne manquent pas.
C'est normal que ces répertoires ne soient pas dans le $PATH  d'un $USER, car les programmes qu'ils contiennent n'ont pas à être lancés par un utilisateur ordinaire. Par contre, ils sont dans le $PATH de root.


--
JJR.

Hors ligne

Haut de page ↑