Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#101 Le 20/01/2013, à 11:39

PPdM

Re : Installation simple de Gimp 2.8

Je n'ai pas testé la version 14, je crois que les petit bug de la 12.10 sont réglés maintenant, si tu a envisagé de migrer, effectivement autant le faire.
Mais je serais curieux de comprendre ce qu'il c'est passé, d’après ce que tu dis, il semble que la désinstallation de Gimp 2.6 ait foiré.
Quand tu désinstalle prend l'habitude de faire suive par

sudo apt-get autoremove --purge

pour nettoyer les éventuels résidus, c'est rapide et ça peut éviter ce genre de souci, bien que cela soit peu courant que ça arrive.

Dernière modification par pierguiard (Le 20/01/2013, à 14:00)

Hors ligne

#102 Le 20/01/2013, à 12:16

Andreu

Re : Installation simple de Gimp 2.8

pierguiard a écrit :

Je n'ai pas testé la version 14, je crois que les petit bug de la 15.10 sont réglé maintenant, si tu envisagé de migré effectivement autant le faire.
Mai je serais curieux de comprendre ce qu'il c'est passé, d’après ce que tu dis il semble que la désinstallation de Gimp 2.6 ait foirée.
Quand tu désinstalle prend l'habitude de faire suive par

sudo apt-get autoremove --purge

pour nettoyer les éventuels résidus, c'est rapide et ça peut éviter ce genre de souci, bien que cela soit peu courant que ça arrive.

Bien noté ta suggestion.

Tu veux sans doute dire la 12.10 (tu as écrit 15.10).

Je vais attendre encore 3 ou 4 jours pour migrer, j'ai plein de choses à faire entre deux. Ça te laisse le temps de la réflexion.

Bien cordialement. Et bonne journée

Michel

Hors ligne

#103 Le 20/01/2013, à 23:31

Andreu

Re : Installation simple de Gimp 2.8

Pour pierguiard :

Bonsoir,

Bon, c'est fait ! j'ai installé LinuxMint Nadia (14) Cinnamon. Je ne pouvais plus attendre, le problème des fenêtres fantômes s'aggravait.

Maintenant, je pense que les difficultés rencontrées pour installer Gimp 2.8 venaient d'autre part que de ce que tu cherchais. Plus cela allait, plus des paquets manquaient et des icones disparaissaient. C'est le système qui était certainement abîmé.

Gimp est bien présent en version 2.8. Je n'ai plus qu'à ...

Je te remercie pour ton aide infatigable et compétente. Pendant ce fil j'ai appris un certain nombre de choses, particulièrement l'histoire des "codes", que je ne pratiquais pas auparavant.

J'ai également apprécié ta pugnacité. Malgré les problèmes à répétition.

Merci encore de tout cœur.

Michel

Hors ligne

#104 Le 06/02/2013, à 10:48

Lomic

Re : Installation simple de Gimp 2.8

ALLELUIAAAAAAAAAAAA purée j'en pouvais plus de ce multi-fenêtrage à la noix où il fallait recliquer dans la fenêtre de l'image pour que le menu présent dans le bandeau donne accès aux commandes non dispo sur les boites d'outils ou de calques!!!! j'en avais des boutons!

dommage que la version Gimp accessible depuis la logithèque soit toujours la 2.6

Hors ligne

#105 Le 06/02/2013, à 12:24

Andreu

Re : Installation simple de Gimp 2.8

Lomic a écrit :

dommage que la version Gimp accessible depuis la logithèque soit toujours la 2.6

Bonjour,

Là, tu m'étonnes ! dans la version 14 de LinuxMint c'est bien GIMP 2.8 qui est présent, comme je l'ai constaté.

Hors ligne

#106 Le 06/02/2013, à 19:45

Lomic

Re : Installation simple de Gimp 2.8

Andreu a écrit :

Là, tu m'étonnes ! dans la version 14 de LinuxMint c'est bien GIMP 2.8 qui est présent, comme je l'ai constaté.

si je passe par la logithèque il me sort que la 2.6

Hors ligne

#107 Le 07/02/2013, à 04:57

Gemnoc

Re : Installation simple de Gimp 2.8

Linux Mint 14 est basée sur Ubuntu 12.10. Donc, elle dispose des dépôts de cette dernière, qui offre Gimp 2.8.

Gimp 2.8 n'a été publié qu'après la sortie d'Ubuntu 12.04, c'est pourquoi dans ses dépôts c'est toujours la version 2.6.

Dernière modification par Gemnoc (Le 07/02/2013, à 04:58)


Pensez à consulter la documentation ! :-)

Hors ligne

#108 Le 07/02/2013, à 08:01

Lomic

Re : Installation simple de Gimp 2.8

ok, je suis en 12.04, voilà pourquoi wink

Hors ligne

#109 Le 10/02/2013, à 18:45

sideritis

Re : Installation simple de Gimp 2.8

Bonjour,
Merci pour la méthode. Mais avec GIMP 2.8 , maintenant, UFRAW est inutilisable car GIMP ne peut pas ouvrir les fichiers temp que UFRAW génère. Il dit "L'ouverture de « /tmp/DSC_0224.NEF_KS3ESW.ufraw » a échoué : Impossible d'ouvrir « /tmp/DSC_0224.NEF_KS3ESW.ufraw » en lecture : Raison inconnue" (Mon fichier d'origine s'appelle DSC_0224.NEF).
Si vous aviez un truc....
merci !
cordialement

Hors ligne

#110 Le 11/02/2013, à 13:55

jbyvosges

Re : Installation simple de Gimp 2.8

Quelle idée de passer du temps à faire d'un bon logiciel un logiciel moins bon !
Le nouveau Gimp (2.8.2) ne m'apporte que des déconvenues.
Un exemple : insérer un texte devient une galère; le texte est à moitié caché par un espèce de popup incrusté qui ne fonctionne pas  et qu'on ne peut pas déplacer. On ne peut plus déplacer le texte : il faut changer d'outil !

Des bouts de fenêtres se mettent à se 'dés ancrer' sans que je sache pourquoi et je n'ai rien trouvé dans l'aide à ce sujet ...
Je crois que je vais revenir à la 2.6 !


hp Pavilion ELite 020fr - Intel® Core™ i7 860 - 12Go RAM - Ubuntu 16.04 (et 16.10 sur un portable)
Mes sites : http://www.jbyorchid.fr
http://www.dolman.fr
http://www.sfola.fr

Hors ligne

#111 Le 03/05/2013, à 14:40

BigBug

Re : Installation simple de Gimp 2.8

JD13 a écrit :

Bonjour
Je suis équipé d'Ubuntu 10.04.
J'ai suivi le tuto de Plumachau, effacé ma version 2.6.8 de Gimp et tenté d'installer la nouvelle version en ligne de commande. Malheureusement, tout cela a tout bonnement réinstallé la version 2.6.8!!!
Comment faire pour installer la nouvelle version de Gimp?
D'avance, merci pour votre aide.

Tu as raison on ne change pas une équipe qui gagne, de plus si a chaque nouvelle distribution il faut changer de PC ça va devenir comme Windows !

Donc j'ai installé a partir d'un tutoriel qui est ici : nouzytux.com

C'est un petit compilation mais ça fonctionne très bien !

Pour la version 12.04 la procédure de Plumachau est très bien .... pas de soucis.... du velours...


Croire en quelque chose et ne pas le vivre, c'est malhonnête.
[Gandhi]

Hors ligne

#112 Le 15/04/2014, à 21:03

olivier0233

Re : Installation simple de Gimp 2.8

Bonsoir
Je suis équipé de ubuntu12.04 depuis peu de temps  et ai suivi à la lettre le tutoriel de Plumachau. L'installation de gimp 2.8.10 s'est faite sans aucun problème. Il est vrai que je n'avais pas d'ancienne version à écraser.
Le logiciel fonctionne très bien pour les premières  fonctionnalités testées, notamment la transformation par cage que je n'avais pas sur ma version de Gimp sous windows
Un grand merci donc.

Hors ligne

#113 Le 26/07/2017, à 11:03

patrick L

Re : Installation simple de Gimp 2.8

bonjour à vous tous.   

suite  à une panne sur la dernière version 2.9.5  je veux revenir à la version 2.8.22 derniere version stable.

donc  j'ai fait la commande pour effacer la version de developpement
la commande  ppa-purge  attends très longtemps

"Updating packages lists"

donc j'ai lancé  la commande

sudo add-apt-repository -r ppa:otto-kesselgulasch/gimp-edge

et là les problemes, 

$ sudo apt-get update
Atteint:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Atteint:2 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial InRelease                                                                                      
Atteint:3 http://mirrors.ircam.fr/pub/ubuntu/archive xenial InRelease                                                                                               
Ign:4 http://mint-mirror.gwendallebihan.net/packages sarah InRelease                                                                                                             
Atteint:5 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                                   
Atteint:6 http://ppa.launchpad.net/atareao/atareao/ubuntu xenial InRelease                                                                     
Atteint:7 http://mint-mirror.gwendallebihan.net/packages sarah Release                                                                          
Atteint:8 http://ppa.launchpad.net/dhor/myway/ubuntu xenial InRelease                                                                           
Atteint:9 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-updates InRelease                    
Atteint:10 http://ppa.launchpad.net/freecad-community/ppa/ubuntu xenial InRelease               
Atteint:11 http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial InRelease               
Atteint:12 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-backports InRelease                 
Atteint:14 http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial InRelease
Atteint:15 http://ppa.launchpad.net/jtaylor/keepass/ubuntu xenial InRelease
Atteint:16 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial InRelease
Atteint:17 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease
Atteint:18 http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu xenial InRelease
Atteint:19 http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu xenial InRelease
Atteint:20 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial InRelease
Atteint:21 https://pkg.tox.chat/debian nightly InRelease        
Lecture des listes de paquets... Fait
patrick@patrick-win7:~$ 

ensuite

$ sudo apt-get remove gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libwebpdemux2 libwebpmux2
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  gimp
0 mis à jour, 0 nouvellement installés, 1 à enlever et 17 non mis à jour.
Après cette opération, 15,3 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 258326 fichiers et répertoires déjà installés.)
Suppression de gimp (2.9.5~133-0x2~ppa~82e34fb) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...

et je réinstalle gimp  et là le probleme  !!!

patrick@patrick-win7:~$ sudo apt-get install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libgimp2.0 (<= 2.8.16-z) mais 2.9.5~133-0x2~ppa~82e34fb devra être installé
        Dépend: gimp-data (<= 2.8.16-z) mais 2.9.5~133-0x2~ppa~82e34fb devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
patrick@patrick-win7:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
Vous êtes sur le point d'ajouter le PPA suivant :
 This PPA is for Ubuntu >=14.04 and Linux Mint >=17

Installing: 
open a terminal and type:
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

Removing:
open a terminal and type:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp 

Many thanks to David Tschumperlé for his masterpiece called G'MIC. 
http://gmic.eu/
Look for the gmic packages!

We should not forget the Gimp crew!
http://www.gimp.org/

And many, many thanks to http://siduction.org. They helped me on my first steps making the Gimp packages.

I promise as long as I live this PPA will never die and the most recent packages will for ever be. ;-)

Regards

Otto Meier

If you had a really problem: 
Skype: thorsten.stettin
G+: https://plus.google.com/u/0/117581776478455814502/posts
FB: https://www.facebook.com/otto06217

Some stats:

https://kesselgulasch.org/ppastats/gimp/

 Plus d'informations : https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp
Appuyez sur Entrée pour continuer ou Ctrl+C pour annuler

Executing: /tmp/tmp.bDYTaVYhuy/gpg.1.sh --keyserver
hkp://keyserver.ubuntu.com:80
--recv-keys
614C4B38
gpg: demande de la clef 614C4B38 sur le serveur hkp keyserver.ubuntu.com
gpg: clef 614C4B38 : « Launchpad otto06217 » n'est pas modifiée
gpg: Quantité totale traitée : 1
gpg:              non modifiées : 1

et la commande d'installation de gimp indique le meme message

patrick@patrick-win7:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
[sudo] Mot de passe de patrick : 
Impossible d'ajouter le PPA : '"Error reading https://launchpad.net/api/1.0/~otto-kesselgulasch/+archive/gimp: (6, 'Could not resolve host: launchpad.net')"'.
patrick@patrick-win7:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
Vous êtes sur le point d'ajouter le PPA suivant :
 This PPA is for Ubuntu >=14.04 and Linux Mint >=17

Installing: 
open a terminal and type:
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

Removing:
open a terminal and type:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp 

Many thanks to David Tschumperlé for his masterpiece called G'MIC. 
http://gmic.eu/
Look for the gmic packages!

We should not forget the Gimp crew!
http://www.gimp.org/

And many, many thanks to http://siduction.org. They helped me on my first steps making the Gimp packages.

I promise as long as I live this PPA will never die and the most recent packages will for ever be. ;-)

Regards

Otto Meier

If you had a really problem: 
Skype: thorsten.stettin
G+: https://plus.google.com/u/0/117581776478455814502/posts
FB: https://www.facebook.com/otto06217

Some stats:

https://kesselgulasch.org/ppastats/gimp/

 Plus d'informations : https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp
Appuyez sur Entrée pour continuer ou Ctrl+C pour annuler

Executing: /tmp/tmp.LfJYDmTKYA/gpg.1.sh --keyserver
hkp://keyserver.ubuntu.com:80
--recv-keys
614C4B38
gpg: demande de la clef 614C4B38 sur le serveur hkp keyserver.ubuntu.com
gpg: clef 614C4B38 : « Launchpad otto06217 » n'est pas modifiée
gpg: Quantité totale traitée : 1
gpg:              non modifiées : 1
patrick@patrick-win7:~$ sudo apt update
Atteint:1 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial InRelease
Ign:2 http://mint-mirror.gwendallebihan.net/packages sarah InRelease           
Atteint:3 http://archive.canonical.com/ubuntu xenial InRelease                 
Atteint:4 http://mirrors.ircam.fr/pub/ubuntu/archive xenial InRelease          
Atteint:5 http://ppa.launchpad.net/atareao/atareao/ubuntu xenial InRelease     
Atteint:6 http://mint-mirror.gwendallebihan.net/packages sarah Release         
Réception de:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:9 http://ppa.launchpad.net/dhor/myway/ubuntu xenial InRelease [17,5 kB]
Atteint:10 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-updates InRelease 
Atteint:11 http://ppa.launchpad.net/freecad-community/ppa/ubuntu xenial InRelease
Atteint:12 http://mirrors.ircam.fr/pub/ubuntu/archive xenial-backports InRelease
Atteint:13 http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial InRelease
Atteint:14 http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial InRelease
Atteint:15 http://ppa.launchpad.net/jtaylor/keepass/ubuntu xenial InRelease
Atteint:16 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial InRelease
Atteint:17 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease
Atteint:18 https://pkg.tox.chat/debian nightly InRelease        
Atteint:19 http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu xenial InRelease
Atteint:20 http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu xenial InRelease
Atteint:21 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial InRelease
Réception de:22 http://ppa.launchpad.net/dhor/myway/ubuntu xenial/main Sources [16,2 kB]
136 ko réceptionnés en 5s (25,2 ko/s)                           
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
17 packages can be upgraded. Run 'apt list --upgradable' to see them.
patrick@patrick-win7:~$ sudo apt install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libgimp2.0 (<= 2.8.22-z) mais 2.9.5~133-0x2~ppa~82e34fb devra être installé
        Dépend: gimp-data (<= 2.8.22-z) mais 2.9.5~133-0x2~ppa~82e34fb devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
patrick@patrick-win7:~$ 

Dernière modification par patrick L (Le 26/07/2017, à 14:20)

Hors ligne

#114 Le 26/07/2017, à 12:41

k3c

Re : Installation simple de Gimp 2.8

Moi j'installerais docker, puis je suivrais

https://hub.docker.com/r/jarfil/gimp-git/

après tout, faire

docker run -it --rm -e DISPLAY=$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix jarfil/gimp-git

même si la première fois, ça va télécharger l'image docker, ensuite ça sera instantané !

reste à trouver la version de Gimp que tu veux en image docker, ou à la construire soi-même

Dernière modification par k3c (Le 26/07/2017, à 13:55)


Archlinux sur Xiaomi Air 13

Hors ligne

#115 Le 26/07/2017, à 14:19

patrick L

Re : Installation simple de Gimp 2.8

merci  de votre réponse.    Sinon j'ai chargé synaptic  qui m'a affiché un paquet de version 2.9 et j'avais supprimé le ppa de 2.9 donc j'ai eu idée de remettre le ppa gimp-edge   et le ppa gimp pour la version 2.8.   

alors j'ai voulu desinstaller gimp dans synaptic et j'ai eu le message d'erreur et j'ai réinstallé gimp avec les deux ppa actifs...    alors ca m'a viré les paquets de la version précécente et ca m'a mis la version 2.8 qui est moins bien que la 2.9 mais elle marche sans se fermer à la validation de chaque commande du menu couleur.  Le message etait stack mashing

et ensuite j'ai supprimé le ppa gimp-edge.  ca a l'air de marcher.

Dernière modification par patrick L (Le 26/07/2017, à 14:27)

Hors ligne

#116 Le 26/07/2017, à 15:34

Roschan

Re : Installation simple de Gimp 2.8

Mais arrêtez de jouer avec les PPA sans raison neutral surtout si vous les tirez d'une discussion datant de 2012 hmm si le GIMP des dépôts ne convient pas pour une raison de stabilité, ce n'est certainement pas en forçant l'ajout de versions antérieures via des PPA que la stabilité de quoi que ce soit va s'améliorer.
Pareil, pas la peine de s'alourdir avec des docker alors que des formats comme .appimage existent exprès pour ça

Hors ligne

#117 Le 27/07/2017, à 16:23

BigBug

Re : Installation simple de Gimp 2.8

patrick L a écrit :

bonjour à vous tous.   

suite  à une panne sur la dernière version 2.9.5  je veux revenir à la version 2.8.22 dernière version stable.

Personnellement je suis sous Ubuntu 16.04 LTS 64 bits et je tourne avec la version 2.8.16 qui est dans les dépôts, je ne vois pas l'intérêt de changer dans la mesure où tout fonctionne bien, surtout que la version 2.8.22 est en tar.bz. Mais chacun son truc, ... voici un line il y a le choix ! Gimp Download
Moi j'ai bien désinstallé Libreoffice parce que j'ai l'habitude d'OpenOffice, je n'ai pas eu de problème !
J'ai fait

 sudo apt-get autoremove libreoffice*

ensuite

dpkg --configure a 

J'ai lancé un petit script qui appelle l'autre,en fait il y en a deux, que je me suis fait histoire de tout vérifier. puis j'ai installer ma version d' OpenOffice, pas de problème même pas avec la virguler sur le pavé numérique !
Pour ceux qui voudraient les codes faites-le moi savoir ...
Donc un petit

 sudo apt-get autoremove gimp* 

ne peu pas faire plus de mal !
Tout ça pour dire que autoremove c'est pas fait pour les windoziens ! LOL


Croire en quelque chose et ne pas le vivre, c'est malhonnête.
[Gandhi]

Hors ligne