Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 03/09/2012, à 11:33

nuwanda03

[Résolu] Installation gnome-shell-extensions-user-theme impossible

Bonjour à tous,

Longtemps sur Ubuntu, j'avais préféré tourner sur Debian pour m'éviter Unity. Finalement me revoilà ! Mais il reste encore beaucoup de lacunes à mon goût, surtout en terme de personnalisation (à force de vouloir rendre simple, c'en devient compliqué !).

Bref, pour modifier Unity gnome-tweak-tool semblait l'outil adapté, auquel il faut ajouter le paquet gnome-shell-extensions et ses dépendances (gnome-shell-extensions-common notamment). Maintenant pour installer un thème personnalisé, il faut le paquet gnome-shell-extensions-user-theme, et c'est justement celui-ci qui me pose problème :

~$ sudo apt-get install gnome-shell-extensions-user-theme 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 gnome-shell-extensions-user-theme : Dépend: gnome-shell-extensions-common mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Si j'essaie de résoudre les dépendances avec aptitude, il me propose un peu n'importe quoi, donc ce n'est pas la solution non plus. J'ai bien sûr ppa:webupd8team/gnome3 dans mes dépots !

Si vous avez quelques idées à ce sujet !

Merci à tous.

Dernière modification par nuwanda03 (Le 03/09/2012, à 18:19)

Hors ligne

#2 Le 03/09/2012, à 12:45

winux12

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

essaie une installation par le site https://extensions.gnome.org/extension/19/user-themes/


La LIBERTE n'a pas de prix ...Ubuntu 12.04 - Gnome-Shell - Asus K52F-SSD 240Go-8Go Ram
TuxLibre - ARU2L
Adhérent à l'APRIL
1 Photo - 1 Jour

Hors ligne

#3 Le 03/09/2012, à 13:13

nuwanda03

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

'lut winux,

Je suis déjà tombé sur cette page dans mes recherches (logique me direz vous !), mais impossible de trouver le switch (et je ne suis pas le seul dans ce cas), et pourtant je suis bien sur Firefox (15.0).

Hors ligne

#4 Le 03/09/2012, à 13:41

nuwanda03

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

~$ sudo apt-get build-dep gnome-shell-extensions-user-theme 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Choix de « gnome-shell-extensions » comme paquet source à la place de « gnome-shell-extensions-user-theme »
Les NOUVEAUX paquets suivants seront installés :
  autoconf automake autotools-dev build-essential cdbs debhelper dh-apparmor
  dh-translations dpkg-dev g++ g++-4.6 gettext gir1.2-gnomedesktop-3.0
  gnome-pkg-tools gsettings-desktop-schemas-dev html2text intltool
  intltool-debian libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev
  libdpkg-perl libexpat1-dev libfontconfig1-dev libfreetype6-dev
  libgdk-pixbuf2.0-dev libglib2.0-dev libgnome-desktop-3-dev libgtk-3-dev
  libgtop2-dev libice-dev libpango1.0-dev libpcre3-dev libpcrecpp0
  libpixman-1-dev libpng12-dev libpthread-stubs0 libpthread-stubs0-dev
  libsm-dev libstdc++6-4.6-dev libx11-dev libxau-dev libxcb-render0-dev
  libxcb-shm0-dev libxcb1-dev libxcomposite-dev libxcursor-dev libxdamage-dev
  libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev
  libxml-parser-perl libxml2-utils libxrandr-dev libxrender-dev m4 po-debconf
  python-scour x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
  x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev
  x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
0 mis à jour, 74 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 25,8 Mo dans les archives.
Après cette opération, 95,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? 

Ça se tente ? Ce qui m'étonne c'est qu'il ne le propose pas quand je demande l'installation...

Verdict : Rien n'a changé. Même message d'erreur...

Hors ligne

#5 Le 03/09/2012, à 17:14

Major Grubert

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

C'est un bazar courant MAIS si depuis le site Gnome tu ne vois pas le bouton pour activer l'extension, c'est que tu ne dois pas être avec Gnome Shell mais avec Gnome fallback.
Ensuite le bazar vient de la version de Gnome et de la version de l'extension User-theme.
Déjà le paquet gnome-shell-extension-user-theme correspond à la version Gnome 3.2, de même que gnome-shell-extension-commo,.
Depuis Gnome 3.4 toutes les extensions officielles (dont User-theme) sont regroupées dans un seul paquet : gnome-shell-extensions.
Celui-ci n'est pas dispo dans les dépôts Ubuntu, il faut passer par un dépôt supplémentaire : webupd8.
Cf cette page pour plus d'explications.


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.10
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Ubuntu 14.04 (32b)

Hors ligne

#6 Le 03/09/2012, à 18:18

nuwanda03

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

Waw, là ça m'éclaire !

Donc gnome-shell-extensions est censé suffire pour importer de nouveaux thèmes; je comprends mieux pourquoi l'on trouve énormément de conflits avec d'autres extensions quand on regarde les propriétés du paquets sur Synaptic.

Je vire gnome-session-fallback pour ne garder que gnome-shell et la compagnie... Youhou, ça marche ! [je ne sais pas pourquoi mais les polices sont immondes, faut que je revois ça]

Merci de vos conseils, sujet résolu :]

Hors ligne

#7 Le 03/09/2012, à 23:20

Major Grubert

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

De rien, bonne continuation sur Gnome Shell.


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.10
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Ubuntu 14.04 (32b)

Hors ligne

#8 Le 07/02/2013, à 22:27

xavier123412

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

Bonsoir,

Ben chez moi ça ne fonctionne pas ! sad

Dans gnome tweak tool l'onglet shell thème n'est pas accessible. Pourtant j'ai bien installé gnome-shell-extensions en passant par le depot webupd8.

Si vous avez une idée !

merci

Hors ligne

#9 Le 08/02/2013, à 07:28

Major Grubert

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

Le dépôt webupd8 des extensions n'est plus mis à jour depuis que tout est disponible dans les dépôts Ubuntu (depuis gnome 3.6).
Il faut désinstaller toutes les extensions en provenance de ce dépôt et installer leurs équivalentes depuis le site gnome (ou bien installer le paquet des extensions présent dans les dépôts Ubuntu mais ça en installe une 15aine à la fois dont certaines pourraient ne pas vous être utiles).


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.10
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Ubuntu 14.04 (32b)

Hors ligne

#10 Le 09/02/2013, à 12:38

xavier123412

Re : [Résolu] Installation gnome-shell-extensions-user-theme impossible

Merci smile

tout fonctionne !

Hors ligne

  • Accueil
  • » Forum
  • » Gnome3
  • » [Résolu] Installation gnome-shell-extensions-user-theme impossible

Haut de page ↑