Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 16/02/2013, à 00:27

Tinmar69

Son saccadé lorsque le CPU est sollicité

Bonjour,

J'ai un souci avec le son de mon PC sur Ubuntu: il est saccadé voire haché dès que le PC est sollicité (lecture de video, visualisation d'une photo, parfois même déplacement rapide de la souris...)
C'est un PC portable ASUS A7C, avec chipset Realtek HDA (High Definition Audio) ALC882. J'ai installé les drivers "à la main" comme indiqué ici: http://forum.ubuntu-fr.org/viewtopic.php?id=1121131) Le problème apparaît lorsque j'écoute de la musique avec Rythmbox, mais aussi une video en ligne.

Quelqu'un a une idée d'où peut venir ce son saccadé, et comment l'éviter? C'est assez gênant pour écouter de la musique en faisant autre chose.... Je suis motivé pour tester des solutions mais ne sais pas trop par où commencer.

(NB:j'ai trouvé d'autres fils qui traitent du problème, mais qui semblaient plutôt liés à Adobe Flash Player. Dans mon cas le son est saccadé dès que le CPU est sollicité)

D'avance merci pour votre aide

Tinmar69

Dernière modification par Tinmar69 (Le 16/02/2013, à 00:55)

Hors ligne

#2 Le 16/02/2013, à 04:58

Hibou57

Re : Son saccadé lorsque le CPU est sollicité

Bonsoir Tinmar,

Tout d’abord je dirais qu’il est normal que lorsque la machine doit assumer une charge de travail importante, il est normal que les tâches individuelles perdent de la fluidité. Il ne faut donc pas que tu y vois un dysfonctionnement à proprement parler, le comportement que tu observe est normal dans les circonstances que tu décris.

Mais il y a peut‑être une solution a essayer, et un suggestion à faire.

La solution a essayer, et d’ajouter ton compte au groupe audio, si ce n’est pas déjà fait. Pour vérifier si ton compte appartient à ce groupe, tu peux lancer la commande suivante depuis un terminal :

fgrep -ie 'audio' /etc/group

Si ton identifiant de connexion à ton compte apparait, c’est que tu en fais déjà partie. S’il n’apparait pas, tu peux l’ajouter au groupe audio, en appliquant la commande suivante, en remplaçant « ton‑login » par ton identifiant de connexion :

sudo adduser ton‑login audio

Remarque : sudo te demandera ton mot de passe, c’est normal, car la commande adduser, fait partie des commandes d’administration.

La suggestion maintenant. Comme dit plus haut, le comportement que tu observes est normal, et si la solution plus haut ne résous rien, la chose qui peut t’être conseillé, et de ne pas utiliser trop d’applications en même temps, ou parmi ces applications, d’en choisir d’autres remplissant les mêmes fonctions, mais qui sont moins gourmandes en mémoire et en processeur. C’est bêta, mais c’est utile à rappeler.

Bon courage pour la suite

Dernière modification par Hibou57 (Le 16/02/2013, à 05:02)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#3 Le 16/02/2013, à 12:56

Tinmar69

Re : Son saccadé lorsque le CPU est sollicité

Hibou,

D'abord merci pour ton aide ! je n'étais pas dans le groupe audio, c'est maintenant chose faite, malheureusment sans résultat: le son craque toujours.

Ce qui m'ennuie c'est que:
1/ je n'ai pas ce pb avec Windows :-(
2/ ça se produit même qd je ne fais pas grand chose: je démarre l'ordi, je lance Rythmbox avec un peu de musique, et j'ouvre la visionneuse d'images, et la musique se met à craquer.... ça ne devrait pas être trop gourmand en mémoire et processeur quand même non? J'ai fait un top, résultat:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                  
 2604 martin    20   0  132m  50m  31m S   72  2.5   0:06.67 eog                      
 1115 root      20   0  232m  82m  50m R   26  4.1   1:44.09 Xorg                     
 1731 martin    20   0 98112  21m  11m S    8  1.1   0:17.45 unity-panel-ser          
 1730 martin    20   0 63168 5692 3492 S    8  0.3   0:05.18 hud-service              
 2078 martin    20   0  401m  90m  48m S    6  4.5   0:24.94 rhythmbox                
 1610 martin    20   0  215m  66m  32m S    4  3.3   0:27.69 compiz                   
 1335 martin    20   0  6836 3096  644 S    3  0.2   0:02.95 dbus-daemon              
 2003 martin    20   0 54396 5684 4204 R    3  0.3   0:01.10 zeitgeist-datah          
  752 root      20   0  6376 1996  648 S    1  0.1   0:03.89 mount.ntfs               
 1714 martin    20   0 71856  11m 7684 S    1  0.6   0:01.57 bamfdaemon               
 1645 martin     9 -11  169m 6248 4580 S    1  0.3   0:06.86 pulseaudio               
 1813 martin    20   0 45140  11m 8640 S    1  0.6   0:00.84 gtk-window-deco          
 2452 martin    20   0 88504  16m  11m S    1  0.8   0:01.19 gnome-terminal           
 1439 martin    20   0  183m  21m  16m S    1  1.1   0:01.52 gnome-settings-          
 2569 root      20   0     0    0    0 S    1  0.0   0:00.70 kworker/0:2              
  110 root      20   0     0    0    0 R    0  0.0   0:01.10 kworker/1:2              
  801 syslog    20   0 31064 1524 1072 S    0  0.1   0:00.16 rsyslogd                 
 1622 martin    20   0  181m  35m  22m S    0  1.8   0:08.89 nautilus                 
 1628 martin    20   0  3712  796  664 S    0  0.0   0:00.31 syndaemon                
 1647 rtkit     21   1 21332 1256 1068 S    0  0.1   0:00.01 rtkit-daemon             
 1685 martin    20   0 27064  10m 3080 S    0  0.5   0:00.80 python                   
 1695 martin    20   0  9244 3248 2720 S    0  0.2   0:00.11 gvfsd-trash           

Je suis preneur d'autres pistes de solutions...

Par avance merci
Tinmar69

Hors ligne

#4 Le 22/02/2013, à 10:25

Tinmar69

Re : Son saccadé lorsque le CPU est sollicité

Quelqu'un a une idée ???

Hors ligne

#5 Le 22/02/2013, à 11:41

compte supprimé

Re : Son saccadé lorsque le CPU est sollicité

Salut,

Tu peux déjà essayer de désactiver pulseaudio pour voir si ça vient de là. Arrête rhythmbox et dans un terminal :

pulseaudio --kill

Si ça le fait toujours tu peux réactiver pulseaudio :

pulseaudio -D

D'après http://doc.ubuntu-fr.org/audio_intel_hda tu peux ajouter à  /etc/modprobe.d/alsa-base.conf (sudo gedit /etc/modprobe.d/alsa-base.conf) :

options snd-hda-intel model=asus-a7m

#6 Le 22/02/2013, à 14:46

Tinmar69

Re : Son saccadé lorsque le CPU est sollicité

Merci alduc1.
Alors:

pulseaudio --kill

ne donne pas d'amélioration. Et je ne peux pas le réactiver:

pulseaudio -D
E: [pulseaudio] main.c: Échec lors du démarrage du démon.

Pour le fichier de configuration d'alsa, je l'avais fait déjà (voir mon précédent post http://forum.ubuntu-fr.org/viewtopic.php?id=1121131)

Pas d'autre idée ?

Hors ligne

#7 Le 22/02/2013, à 17:03

compte supprimé

Re : Son saccadé lorsque le CPU est sollicité

#8 Le 05/03/2013, à 22:55

Tinmar69

Re : Son saccadé lorsque le CPU est sollicité

Bon, je rentre de vacances, je vais me replonger dans mon problème de son saccadé :-/

Je viens de tenter ce qui est indiqué dans cette doc (§4.3), à savoir rajouter "tsched=0"  dans le fichier /etc/pulse/default.pa dans la ligne:

load-module module-udev-detect tsched=0

Mais rien à faire, c'est toujours aussi saccadé dès qu'il y a un peu d'activité CPU (mouvements de souris rapides, ouverture d'une photo avec la visionneuse...)

un autre truc qui me tarabiscote, c'est que je ne parviens pas à relancer pulseaudio après pulseaudio -k:

~$ pulseaudio -D
E: [pulseaudio] main.c: Échec lors du démarrage du démon.

Je me demande si le serveur de son est installé correctement sur mon ordi, mais comment faire pour le savoir?

Tinmar69

Dernière modification par Tinmar69 (Le 06/03/2013, à 22:43)

Hors ligne

Haut de page ↑