Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 04/05/2009, à 19:35

faco

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Bonjour,

Sous kubuntu 9.04, j'ai réussi à résoudre ce même problème de manière graphique (sans passer par la modification directe du xorg.conf ):
Menu >> configuration du système >> Région & langues >> Disposition du clavier.

Dans l'onglet disposition:
Activer les dispositions de clavier

Ma disposition active contenait "oss" dans la colonne "variante". J'ai supprimé ma disposition puis je l'ai re-ajoutée (en choisissant français dans la colonne de gauche) sans mettre de variante.

(Pour info, la commande concernant ma variante est devenue "setxkbmap -model pc104 -layout fr -variant ")

Bon courage ^^

Hors ligne

#27 Le 17/05/2009, à 14:43

FP

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Salut a tous!

Merci à toi  Faco, ca fait quelque heure que je recherche à activer correctement l'espace dans codeblock!!!
Ca fonctionne un peu.

mais quel est maintenant le raccourci pour le code completion sous codeblocks.

#28 Le 19/06/2009, à 16:12

Hamson

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Bonjour !,
Je suis sous Linux depuis peu (Ubuntu 9.04), et j'ai donc téléchargé Code::Blocks comme IDE,
Et j'ai le même problème, l'espace sert a l'autocomplétion,
J'ai lu le topic mais... mon menu de Code::Blocks ne contient pas le menu système
FILE | EDIT | VIEW | SEARCH | PROJECT | BUILD | DEBUG | WXSMITH | TOOLS | PLUGINGS | SETTINGS | HELP
Quelqu'un pourrait m'aider svp ?

PS : je n'ai pas vu le forum pour se présenter, alors que j'en ai l'habitude, donc j'ai posté tout de suite ici, excusez moi si il faut se présenter et indiquez moi le forum servant a cet effet svp

Merci, ++

Hamson.

Dernière modification par Hamson (Le 19/06/2009, à 16:13)


Si la liberté est le résultat de la guerre
Il n'y aura jamais de liberté
Car l'homme fera toujours la guerre...

Hors ligne

#29 Le 19/06/2009, à 20:49

valAa

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Salut, et bienvenue sur le forum.
Le menu système dont il est question ici est celui de ton bureau, en haut à gauche.

Dernière modification par valAa (Le 19/06/2009, à 20:49)

Hors ligne

#30 Le 20/06/2009, à 09:33

Hamson

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Ha !!!!!!!!!
Ok !
J'avais pas compris comme ça moi ^^
Merci beaucoup smile (pour le bienvenue aussi ^^)
(edit : ça y est ça marche smile)
edit2 : J'ai encore un problème avec code::blocks, je code une petite page que je compile et lance pour tester des paramètres, donc je clicke sur le bouton (build and go) mais il n'y a rien qui s'ouvre, donc je vais dans le dossier, aucun fichier executable, pourriez-vous m'aider svp ? (si il faut mettre mon message dans un nouveau topic je le ferais)
++

Hamson.

Dernière modification par Hamson (Le 20/06/2009, à 11:01)


Si la liberté est le résultat de la guerre
Il n'y aura jamais de liberté
Car l'homme fera toujours la guerre...

Hors ligne

#31 Le 12/07/2009, à 15:07

Micool

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Bonjour,

Sous kubuntu 9.04, j'ai réussi à résoudre ce même problème de manière graphique (sans passer par la modification directe du xorg.conf ):
Menu >> configuration du système >> Région & langues >> Disposition du clavier.

Dans l'onglet disposition:
Activer les dispositions de clavier

Ma disposition active contenait "oss" dans la colonne "variante". J'ai supprimé ma disposition puis je l'ai re-ajoutée (en choisissant français dans la colonne de gauche) sans mettre de variante.

(Pour info, la commande concernant ma variante est devenue "setxkbmap -model pc104 -layout fr -variant ")

Bon courage ^^

Ceci a fonctionné pour moi aussi smile
Grand merci à Faco !

#32 Le 18/07/2009, à 16:16

BuBu07

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Pandark a écrit:

    Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
    Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).

+1
Merci à Pandark.

#33 Le 05/08/2009, à 16:04

Çelebi

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Jonass a écrit :

J'avais le même problème, en fait pas besoin de commenter cette ligne.

Allez dans Système>Préférence>Clavier>Agencement.
Là vous avez sûrement "France Autre", remplacez le par France (par défaut).
Chez moi ça à réglé le problème wink

Idem ça a suffit pour régler le socis.
Merci Jonass : )

Çe


Çelebi

Hors ligne

#34 Le 21/08/2009, à 11:02

Skadi

Re : [Résolu]Problème de barre d'espace sous Code Blocks

faco a écrit :

(Pour info, la commande concernant ma variante est devenue "setxkbmap -model pc104 -layout fr -variant ")

Sur #! Crunchbang (donc ubuntu+openbox), c'est "setxkbmap -model pc104 -layout fr" qu'il faut faire.

Merci pour le coup de main en tout cas.:)


Confortablement installée dans la sécurité d'un soyeux cocon d'ennui…

Hors ligne

#35 Le 17/08/2012, à 01:25

fluccini

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Encore + simple -->

Désactivation du plugin Code Completion:
Plugins → Manage Plugins puis sélectionnez Code Completion et cliquez sur le bouton Disable

Cordialement smile


Si vous ne réussissez pas du premier coup, appelez ça version 1.0  ;)
http://www.foxtrot-security.fr  --> La Sécurité Informatique pour tous, du Geek, de la Musique, de l'Actualité et bien + encore… ;)

Hors ligne

#36 Le 19/02/2013, à 13:43

D13

Re : [Résolu]Problème de barre d'espace sous Code Blocks

j'ai eu ce soucis avec SPE sur ubuntu 12.04 (precise), le problème a été résolut de manière graphique :
fenêtre paramètre système / agencement du clavier / option.../ Utiliser la barre d'espacement pour insérer une espace insécable, ensuite sélectionner "L'espace habituelle quelque-soit le niveau".

Une fois l'option cocher, en démarrant spe le problème été résolut.

Hors ligne

Haut de page ↑