Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 21/02/2013, à 00:03

kr2sis

des clones parfaits

salut,
l'informatique se joue de moi ou alors je suis une bille !

mon serveur est dans le salon et ce pc dans une piece.
dans mon serveur, il y a un petit repertoire ou figure un stockage de données que j'actualise constamment.
ce repertoire, je l'avais mis en "liaison" avec Samba par le biais d'une création de dossiers eux meme dans un repertoire nommé XY.
on a donc un dossier XY dans le serveur à un certain niveau et le clone de ce dossier dans un repertoire accessible avec le CIFS
or, aujourd'hui celui du CIFS est vide et celui du serveur contient les données que je lui ai fourni jusqu'à présent
non pas que je manque d'idées, mais la peur de faire l'irréversible et de saccager 2/3 semaines de boulots sur mon serveur me fait vous demander comment je peux faire pour avoir ces deux dossiers (qui n'en font qu'un au final) soit reliés et que chaque entrée ou sortie de données soit identique sur les deux
je suis sûr que je me prends la tête pour pas grand chose mais je taffe comme un malade sur ce serveur et mes idées se mélangent
mais en gros une mis a jour sur un dossier fait une mis a jour sur l'autre...

merci à vous

Hors ligne

#2 Le 21/02/2013, à 14:40

Maisondouf

Re : des clones parfaits

C'est qui qui les clone ?
Si tu as physiquement 2 répertoires séparés sur le serveur, 1 accessible localement et l'autre via samba (cifs), il faut quelqu'un pour assurer le clonage.
Si tu n'as en fait qu'un seul répertoire physique accessible localement et via samba, c'est ton partage samba qui tombe à coté et te montre un répertoire vide.

Je ne comprends pas trop ton organisation....


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 21/02/2013, à 14:59

kr2sis

Re : des clones parfaits

alors, salut
donc, le dossier A est : /media/raid5/medias
je voudrais accéder a ce dossier via le CIFS mais windows ne trouve pas l'acces
pourtant le path de smb.conf est sur /media/raid5/medias
je ne comprends pas ce probleme

mon fichier sb.conf (un peu épuré)

[global]
         workgroup = WORKGROUP

         path=/media/raid5/medias
         browseable=yes
         writeable=yes
         valid users = kri2sis
         admin users = kri2sis
         create mask = 0775
         directory mask = 0775
         force user = kri2sis
         force group = kri2sis

 workgroup=MONDOMAINE
      netbios name=SERVEURSMB
      server string=Serveur

security = SHARE
      domain logons = yes
      username map = /etc/samba/smbusers
encrypt passwords = yes
      smb passwd file = /etc/samba/smbpasswd

unix password sync = no
passwd program = /usr/bin/passwd %u
local master = yes
        os level = 33
        domain master = yes


logon script = script.bat
        logon path = \\%L\Profiles\%U
        logon drive = p:
        logon home = \\%L\%U\Profile
wins support = no
        wins server = 10.0.0.2
        wins proxy = yes
        dns proxy = no

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        interfaces = 10.0.0.1/32

%U : Nom de l'utilisateur
%G : Groupe de l'utilisateur
%h : Nom du serveur Samba
%m : Nom NetBIOS du client Samba
%L : Nom NetBIOS du serveur Samba
%M : Le nom internet du client
%a : Type de la machine cliente
%I : IP de la machine cliente
%i : IP local de la machine cliente
%T : Date et heure courante
%D :Nom de domaine
%I : IP de la machine cliente

Dernière modification par kr2sis (Le 21/02/2013, à 15:02)

Hors ligne

#4 Le 21/02/2013, à 19:40

Maisondouf

Re : des clones parfaits

Tu n'as pas crée de partage du tout...
Ton path est dans la section [global] du smb.conf, il n'a aucune utilitée.
Il faut déclarer un partage en dehors de la section globale avec la syntaxe normale:

[MediaShare]
#	valid users=@"administrators",@"windows",@"everyone"
#	valid users=@"root"
	comment=Répertoire de partage des Médias
	path=/media/raid5/medias
#	writeable = yes
	browseable = yes
	read only=yes
#	write list=@"administrators"
	write list=root,toto,tata, tutu

Avec ça ce répertoire sera accessible en smb à //serveur/MediaShare


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 22/02/2013, à 16:50

kr2sis

Re : des clones parfaits

bon et bien je vous remercie pour avoir répondu c'est éjà tres sympa.:)
pour ce qui est du partage, en effet mon fichier smb.conf était tout pourri (merci le net et ses sites faciles)
donc en cherchant a droite et a gauche et en réunissant les comms et expériences, mon puzzle m'a conduit simplement au fait que ma config était mal faite (je le savais mais je ne savais pas ou) et bien ARTOUT !
quel naze je suis donc tout est rentré dans l'ordregrace a un petit effort de reflexion et j'ai enfin bougé le point de montage de mon raid pour le mettre a un niveau en accord avec les repertoires de sites et "pather" samba... donc le souci est réglé
merci a vous

Hors ligne

Haut de page ↑