Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 22/02/2013, à 10:38

Mobidique

[RESOLU] Lecture DVD avec VLC : CPU à 100%

Bonjour,

La machine contient un P4 2.66, 1GO de RAM une carte vidéo ATI HD4650 avec 512 MO. Le système est une voyager (xubuntu) 12.04 amd 64. Je peux lire un DVD, c'est pas le problème, mais ce n'est pas fluide, ça accroche. J'ai constaté que mon CPU est à 100%, coté RAM ça va par contre je suis loin des 1GO, je dois avoir moins de 512 MO d'utilisé, mais le CPU est quasiment tout le temps à 100%. J'ai regardé dans les préférences de VLC, j'ai coché l'utilisation du GPU quand c'était possible. Mais je n'ai touché à rien d'autre. Si je me met en fenêtré pas trop grand ça passe. Mais dès que je suis en fenêtré pleine page ou carrément en plein écran ça fatigue. Totem ouvre le DVD par défaut, on a essayé avec mais c'est pire que VLC.

Une soluce de réglage pour que ça accroche pas ? De la RAM en plus arrangerait le truc ?

Merci d'avance.
@+

Dernière modification par Mobidique (Le 23/02/2013, à 23:10)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#2 Le 22/02/2013, à 10:45

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Salut,

Quel pilote graphique as-tu installés? Donne le fglrxinfo.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 22/02/2013, à 11:10

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

C'est le pilote propriétaire.
Je me demande s'il n'y a pas quelque chose du coté du son ... c'est un chipset intégré AC'97 1981a (Dell dimension 4550). J'ai déjà relevé un pb d'utilisation excessive du CPU => ici <=, je réalise cela maintenant et je n'ai pas pensé hier soir à regardé la liste des tâches en cours ...

Je me demandais aussi si en mesure d'urgence une copie sur le DD arrangerait pas le coup ... Mais le pb est (peut être) du coté utilisation CPU, c'est pas en limitant le transfert dans les tubes que ça changera. Ou alors en bridant la qualité ... Je n'ai jamais fait ça si kkun peut me mettre sur la voie d'un job comme ça (ok ça fait une seconde requête, c'est mal, désolé).

Merci d'avance
@+

EDIT
Ho ... Outre le caractère libre ou proprio du pilote tu aurais peut être voulu la version ? Je ne sais pas, le PC est chez moi et là tout de suite, pas moi smile.

Dernière modification par Mobidique (Le 22/02/2013, à 11:11)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#4 Le 22/02/2013, à 11:16

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Donne le retour de fglrxinfo. Coche accéleration gpu dans vlc>lectures et codecs puis relance vlc et essaye pour voir si le %tage cpu a diminué.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#5 Le 22/02/2013, à 11:22

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

oki je fais ça ce soir
merci de l'aide.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#6 Le 22/02/2013, à 11:25

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Ca roule, de rien.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#7 Le 22/02/2013, à 20:01

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Voilà pour ça :

fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 3650 AGP
OpenGL version string: 3.3.11627 Compatibility Profile Context

Je reviens plus tard avec d'autres infos.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#8 Le 22/02/2013, à 22:19

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%


Voilà le coupable.
C'est pas évident à voir sur la vidéo (faut se mettre en plein écran quand même et jouer avec la pause) et pour cause : essayer de faire une capture vidéo d'une lecture vidéo qui occupe la presque totalité du proc ne se fait pas sans mal ...
Or donc, au début VLC fait 1/4 de l'écran à la louche et Pulseaudio prend 20 à 30%. Après réduction, Pulse prend 7%. Finalement après maximisation de la fenêtre, Pulse prend 39% affiché dans la vidéo mais in the real world cela a dépassé 50%.

J'ai vu dans la doc que je pouvais virer pulse mais bon ... j'ai l'impression que c'est quand même un morceau important dans ubuntu.

Dernière modification par Mobidique (Le 22/02/2013, à 22:21)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#9 Le 23/02/2013, à 08:45

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

C'est donc cet oignon de pulse qui merde et pas vlc... Essaye de changer la sortie son de vlc et de la mettre sur alsa pour voir si c'est mieux.

Perso, ça fait des années que j'ai viré pulse qui ne sert strictement à rien du tout, si ce n'est à emmerder le monde! D'ailleurs, je ne comprends pourquoi cette crotte est installée d'office alors qu'alsa par défaut à travers dmix, joue aussi plusieurs sons en même temps, pulse n'est qu'une surcouche d'alsa.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#10 Le 23/02/2013, à 16:48

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

J'ai déjà essayé de spécifier alsa à la place de pulse mais en fait pulse est le point de sortie du système, to sink, comme l'eau dans évier qui part forcément par la bonde, le son sort forcément par pulse même si on spécifie alsa, c'est bien de l'alsa mais via pulse. La seule soluce c'est virer pulse.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#11 Le 23/02/2013, à 20:31

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

C'est fait et le fil passe en résolu.

J'ai suivi le tuto suivant :
http://le-marocain-dailleurs.blogspot.f … audio.html
pour virer pulseaudio. En résumé :

sudo apt-get purge pulseaudio  
sudo apt-get purge pavucontrol
sudo apt-get install xfce4-mixer

la dernière installe un greffon pour les tableaux de bord xfce4 là il faut d'une part identifier le volume controlé par le greffon et on peut lancer alsa-mixer qui lui permet de choisir/identifier le périphérie que de sortie audio. Faut tâtonner : sur mon portable c'est le volume génral, sur le pc c'est PCM ... enfin bon c'est pas grave.

Bonne nouvelle sinon : le tuto ci-dessous donne des raccourcis clavier à mettre en place pour avoir les touches multimédia active, ben pas besoin. J'avais désactivé xfce4-volumed parce que ça merdait complètement avec pulseaudio, et bin en le remettant, mirac' ! les touches multimédia remarchent sans raccourci particulier et j'ai de nouveau les notifications que j'avais perdu précédemment. Par contre, pas d'equalizer alsa, j'ai jamais été content du son sur mon portable, l'eq pulse arrangeait bien le coup, j'ai trouvé un eq pour alsa mais pas pris le temps de l'installer. Autre pb : j'ai pris le pli rhythmbox avec ubuntu 10.04, je ne vois pas pourquoi changer. Mais du coup il n'est pas accessible depuis le greffon son de la barre comme avant, par contre à la fermeture par la croix de la fenêtre il reste actif mais inaccessible par où que ce soit, il faut le relancer (via synapsre par exemple) pour le retrouver. Ca c'est en XFCE4.10, dans la version précédente de XFCE le greffon permettait de donner la commande à lancer sur un click gauche sur le greffon, du coup en mettant rhythmbox, on se trouve avec un fonctionnement similaire.

Bref ... Totem est toujours à la ramasse, par contre VLC s'en tire beaucoup mieux. Plus de processus audio à occuper le proc. Du coup VLC peut prendre ses aises avec des perf tout à fait honorables sur cette petite machine (le petit pc, pas le portab'). Contrariété : en plein écran VLC occupe 50% du proc et le second processus derrière c'est le gestionnaire des tâches à ~10%, le reste affiche du 0% mais tout ces 0% remplissent l'activité du proc qui affiche une charge à 100%. Y a peut être du ménage à faire ou optimiser un peu cette affaire ...

@+

Dernière modification par Mobidique (Le 24/02/2013, à 16:08)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#12 Le 25/02/2013, à 13:27

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Ben voilà... Pulse viré et c'est tout de suite moins épais! Pour optimiser le tout et faire le ménage, je te laisse regarder la doc.
Tu peux aussi installer xvba-va-driver qui va faire passer l'accélération par le GPU et soulager le CPU, comme décrit dans cette doc au point 4.:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Une fois en place, il faut dans vlc>lectures&codecs activer l'accélération GPU (tout en haut) et le relancer dans un terminal: vlc -vv et lancer une video et dans les logs vlc du terminal il y a une phrase en GRAS qui dit vaapi enabled, un truck du genre.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#13 Le 26/02/2013, à 12:21

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Dément.

Tu mets le driver propriétaire et on te dit

Video hardware acceleration with the Linux AMD driver is not as full featured as other OEMs, but there is some that can be enabled.

C'est quoi Video hardware acceleration ? Juste la lecture video ou bien on parle bien de l'affichage graphique en général par le GPU ?

Je vais tester cela partout
Merci bien.

@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#14 Le 26/02/2013, à 14:55

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Ben: Video hardware acceleration = l'accélération matériel en bon françois... pour ce qui peut être configuré pour l'utiliser, dont justement, vlc.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#15 Le 27/02/2013, à 14:55

chinois02

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Autre piste possible de l'occupation à 100% du processeur:
http://forum.ubuntu-fr.org/viewtopic.php?id=1193151
mon processeur n'est maintenant qu'à 60% lorsque j'utilise VLC sur la configuration ci dessus.

Dernière modification par chinois02 (Le 27/02/2013, à 14:57)

Hors ligne

#16 Le 27/02/2013, à 16:06

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Mazette.

J'essaierais.
Merci !
@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#17 Le 28/02/2013, à 10:28

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

J'ai essayé.

Je rentre, j'allume, je me log, je vire le compositeur, je lance vlc et ma vidéo. Oki c'est mieux. Je regarde les tâches : c'est quoi ce pulseaudio à 10% ? Je l'ai viré le 23/02 ...

C'est possible que pulseaudio s'installe tout seul à l'occasion d'une mise à jour ?

J'active le compositeur pendant cette lecture : pulseaudio passe premier processus bouffeur de proc à 40% et on retombe dans le bégaiement de lecture vidéo. Je ferme VLC, je supprime à nouveau pulseaudio, j'ouvre vlc, je spécifie explicitement dans VLC que la sortie audio c'est alsa (nanmého!) sans doute est-ce que je referme et réouvre VLC, je vire le compositeur, je lance ma vidéo : proc à 10-20%, VLC ultra majoritaire les autres aux miettes, diffusion nickelle. J'active le compositeur : proc à 100%, pas de changements flagrants pour VLC et personne d'autre bouffant du proc explicitement ...

=> y a un truc entre le compositeur et pulseaudio.
=> y a un truc avec le compositeur : manifestement des effets sont pris en compte par le proc au lieu du GPU.

Ce soir j'y retourne, je fais la manip de faucon50 pour activer l'acceleration hardware pas prise en compte par le driver proprio.

Merci
@+

Dernière modification par Mobidique (Le 28/02/2013, à 12:00)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#18 Le 28/02/2013, à 11:13

chinois02

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Je vais tester pour voir cette histoire de pulseaudio...
Sur mon vieux PC, l'inactivation du compositeur a réglé le problème mais je suis curieux.
bon, ce n'est pas évident pulseaudio ne semble pas être le souci sur ma machine il reste à 8% d'utilisation processeur...
mais, le plus curieux, c'est que la remise en route du compositeur change à la marge l'utilisation du processeur. maintenant je passe de 55 à 65% environ de charge processeur et ma vidéo reste fluide ...
mon souci est réglé mais je ne sais pas pourquoi!

Dernière modification par chinois02 (Le 28/02/2013, à 12:31)

Hors ligne

#19 Le 28/02/2013, à 20:08

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Wé.

Dla merde.
J'ai fait la manip du xvba-va-driver, j'ai activé les service gnome mais pas mieux. Y a vraiment que virer le compositeur qui améliore drastiquement les perf. Actuellement avec VLC en plein écran, le gestionnaire des taches et firefox je suis à moins de 50% d'utilisation du proc. Et VLC à ~20%.

C't'une misère ..

Je jette l'éponge.

Merci
@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#20 Le 01/03/2013, à 09:48

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Mobidique a écrit :

C'est possible que pulseaudio s'installe tout seul à l'occasion d'une mise à jour ?

Probablement dû au paquet buntu-desktop qui est installé.

J'ai fais quelques tests avec/sans compositeur sur des .mkv, sur mon système ça ne change rien, par contre, avec/sans l'accélération cochée dans Lecture/Codecs c'est du simple au double (CPU à 25-30% pour du .mkv avec l'accélération).

@ Mobidique: Dans vlc: vidéo>sortie, tu as bien mis Xvideo (XKB)? Car c'est celle qu'il faut utiliser.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#21 Le 01/03/2013, à 10:06

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Nan.
Je fais ça ce soir.
Merci
@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#22 Le 01/03/2013, à 20:32

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Fait.

J'ai essayé d'autre sortie, je suis allé sur la page de la documentation ici même à la page vlc, des options d'optimisations sont évoquées, certaines déjà mise en œuvre, d'autres conduisant à une forte dégradation (e.g. sauter des trames).

Pas mieux, dès que le compositeur est activé, le cpu passe à 100% sans proc clairement identifié, vlc prend plus de cpu passage de 25% à 40%, les perf sont moins bonnes.

La carte est une ATI Radeon HD 3650 AGP et j'ai lu que la prise en charge de ces chipsets est lentement abandonné par ati, j'ai lu des chose sur une incompatibilité entre noyau et ces chipset, bref, je subodore kkchose comme ça. En attendant, pas de compositeur mais ça marche bien.

Merci
@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#23 Le 02/03/2013, à 10:59

fcn50

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Mobidique a écrit :

La carte est une ATI Radeon HD 3650 AGP et j'ai lu que la prise en charge de ces chipsets est lentement abandonné par ati

C'est exact, au même titre que la série HD 4xxx et tu dois installer le catalyst legacy pour ta carte qui est en fait le catalyst 12.4 mais qui bénéficie des mise à jours de sécurité. Je te laisse chercher où trouver ce legacy pour l'installer. La sortie à utiliser dans vlc est Xvideo.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#24 Le 02/03/2013, à 14:02

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Pfiou ...

J'ai fait une recherche sur le net mais c'est confus, ça part dans tous les sens, on retrouve des choses de manière récurente. J'aime bien

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

mais sur un forum un gars dit que l'on a pas besoin d'un nouveau ppa. Avec le system profiler and benchmark, j'ai trouvé que mon noyau est le 3.2.038, la version de X est 1.11.3 et fglrxinfo me dit :

display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 4650
OpenGL version string: 3.3.11627 Compatibility Profile Context

Mais ça c'est sur mon portable sur lequel tout marche bien, mais comme la tour du fils et le portable sont tous les deux sur voyager, l'un en x86 l'autre en amd64, j'imagine que les noyaux, X et version de fglrx sont identiques.

Autre truc qui me chagrine : dans la confusion, j'ai lu kkchose du genre "à chaque nouvelle version du noyau il faut updater (réinstaller) le pilote". C'est le cas ? Ca me parait chiant, je veux dire plus chiant que désactiver le compositeur.

Là tout de suite je lève le pied sur le sujet, je reprendrais dans 8 jours au moins, mais je veux bien quelques précisions voire une mise sur les rails.

Merci beaucoup d'avance
@+

Dernière modification par Mobidique (Le 09/03/2013, à 13:08)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

#25 Le 12/03/2013, à 13:48

Mobidique

Re : [RESOLU] Lecture DVD avec VLC : CPU à 100%

Ceci devrait faire l'affaire :
http://forum.ubuntu-fr.org/viewtopic.php?id=1194711
Soit les legacy 13.1 plutôt que les 12.4.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

En ligne

Haut de page ↑