Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/02/2013, à 18:37

GGhiles

problème serveur lamp (erreur 403) [resolu]

Bonjour,


J'avais une erreur 403 récurrente, et donc j'ai modifié le fichier apache2.conf selon les indications sur le site, et voila ou j'en suis :
Je n'arrive pas à démarrer mon serveur lamp:

 ghiles@ghiles-TravelMate-5744:~$ sudo service apache2 start
[sudo] password for ghiles: 
 * Starting web server apache2                                                  
apache2: Syntax error on line 177 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/httpd.conf: No such file or directory
Action 'start' failed.
The Apache error log may have more information.

voici la ligne 177 qui provoque l'erreur:

 Include /etc/apache2/httpd.conf 

Aussi, lorsque j'essaye d'accéder à mon localhost, j'obtiens ceci:
La connexion a échoué
Firefox ne peut établir de connexion avec le serveur à l'adresse localhost.

Avez-vous une idée pour régler ce problème? Comment puis-je récupérer le fichier httpd.conf ?

Dernière modification par GGhiles (Le 23/02/2013, à 14:02)

Hors ligne

#2 Le 21/02/2013, à 20:10

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

Tant que tu auras ce message : "Action 'start' failed.", c'est que Apache ne se lance pas donc oublie firefox...
Est ce que "/etc/apache2/httpd.conf" existe et si oui qu'est qu'il y a dedans

ls -l /etc/apache2/httpd.conf
cat /etc/apache2/httpd.conf

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 21/02/2013, à 22:05

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

non je n'ai pas ce fichier ...

 ls: impossible d'accéder à /etc/apache2/httpd.conf: Aucun fichier ou dossier de ce type 

Hors ligne

#4 Le 21/02/2013, à 22:12

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

C'est un fichier qui est en général vide, il ne sert que pour des configurations locales.
Son absence empêche Apache de démarrer, il faut en créer un même vide.

sudo touch /etc/apache2/httpd.conf

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 21/02/2013, à 22:36

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

Maisondouf a écrit :

C'est un fichier qui est en général vide, il ne sert que pour des configurations locales.
Son absence empêche Apache de démarrer, il faut en créer un même vide.

sudo touch /etc/apache2/httpd.conf

super merci, une fois ceci fait j'en arrive la:

 ghiles@ghiles-TravelMate-5744:~$ sudo service apache2 start
 * Starting web server apache2    
 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

une idée?

Hors ligne

#6 Le 21/02/2013, à 22:54

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

Oui...C'est juste un Warning, apache démarre quand même.
Tu édites le fichier incriminé et tu mets un nom de serveur dedans...

gksu gedit /etc/apache2/httpd.conf

et tu mets dedans une ligne :

ServerName monserveur.local.lan

Ou quelque chose en correspondance avec ta config réseau.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 21/02/2013, à 22:56

rescue

Re : problème serveur lamp (erreur 403) [resolu]

Bonsoir,

Il faut aller voir dans cat /etc/hosts et mets un # devant la ligne ou il y aura le nom de ton PC:

cat /etc/hosts
127.0.0.1	localhost
#127.0.0.1	nom du PC

Redémarre apache
@+

Hors ligne

#8 Le 21/02/2013, à 23:17

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

hum juste pour être sur, voila le contenu de mon hosts:

 
127.0.0.1	localhost ghiles-TravelMate-5744

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Je le change comment?

Hors ligne

#9 Le 22/02/2013, à 08:49

rescue

Re : problème serveur lamp (erreur 403) [resolu]

Re,

127.0.0.1	localhost
#127.0.0.1 ghiles-TravelMate-5744

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Chez moi j'avais 2 lignes la deuxième je ne l'ai pas supprimé j'ai juste mis un # devant.
@+

Hors ligne

#10 Le 22/02/2013, à 11:54

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

rescue a écrit :

Re,

127.0.0.1	localhost
#127.0.0.1 ghiles-TravelMate-5744

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Chez moi j'avais 2 lignes la deuxième je ne l'ai pas supprimé j'ai juste mis un # devant.
@+


j'obtiens toujours un warning, différent du premier:

 
waiting apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.71 for ServerName

edit:
en fait j'ai trouvé la solution pour enlever le warning sur le site:

On doit éditer le fichier /etc/apache2/httpd.conf
Par défaut ce fichier est vide, il faut donc ajouter la ligne suivante:
ServerName localhost



Toutefois, j'obtiens toujours lorsque j'essaie d'accéder à mon localhost une erreur 403:
Forbidden
You don't have permission to access / on this server.
Apache/2.2.22 (Ubuntu) Server at localhost Port 80


Voici une partie, de mon fichier apache2.conf, il me semble que je devrais ajouter une ligne du style: allow from xxx.xxx.xxx ...

# Restriction de la racine du serveur
<Directory />
  Order Deny,Allow
  Deny from all
  Options None
  AllowOverride None
</Directory>

Si quelqu'un peut m'éclairer ...

Dernière modification par GGhiles (Le 22/02/2013, à 15:27)

Hors ligne

#11 Le 22/02/2013, à 15:32

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

GGhiles a écrit :

edit:
en fait j'ai trouvé la solution pour enlever le warning sur le site:

On doit éditer le fichier /etc/apache2/httpd.conf
Par défaut ce fichier est vide, il faut donc ajouter la ligne suivante:
ServerName localhost

Chose expliquée au post #6


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#12 Le 22/02/2013, à 15:41

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

Maisondouf a écrit :
GGhiles a écrit :

edit:
en fait j'ai trouvé la solution pour enlever le warning sur le site:

On doit éditer le fichier /etc/apache2/httpd.conf
Par défaut ce fichier est vide, il faut donc ajouter la ligne suivante:
ServerName localhost

Chose expliquée au post #6


ah! merci j'avais zappé neutral ... malheureusement j'ai toujours une erreur 403

Hors ligne

#13 Le 22/02/2013, à 17:05

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

Ben oui je comprends bien, mais là tu es parti dans une configuration perso qui n'est plus trop standard.
Normalement on ne touche jamais au fichier /etc/apache2/apache2.conf...
Toutes les déclarations de sites se font dans des fichiers qui sont dans sites-available qu'on active ou pas avec des liens symboliques dans sites-enabled.
Même principe pour les modules d'apache...
Et au fait, lamp n'est pas un serveur, c'est un kit logiciel qui installe des serveurs (Linux Apache Mysql PHP)

En version de base, apache est installé et fonctionnel de suite.
Son répertoire serveur est /var/www et il faut qu'il y ait au moins un fichier 'index.html' dedans sinon il y a une erreur 403


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#14 Le 22/02/2013, à 17:22

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

Maisondouf a écrit :

En version de base, apache est installé et fonctionnel de suite.

Mais oui mon capitaine tongue
Non sans rire, j'ai du modifié le fichier pour autoriser l’exécution des scripts cgi ...
En attendant mon fichier index.html est bien dans mon répertoire /var/www/ et l'erreur 403 subsiste ...

voici par ailleurs les autorisations du dossier:

ghiles@ghiles-TravelMate-5744:/var/www$ ls -l
total 4
-rwx---r-x 1 ghiles ghiles 398 janv. 28 20:35 index.html
lrwxrwxrwx 1 root   root    23 janv. 31 12:13 private -> /media/www-dev/private/
lrwxrwxrwx 1 root   root    22 janv. 31 12:13 public -> /media/www-dev/public/

Dernière modification par GGhiles (Le 22/02/2013, à 18:18)

Hors ligne

#15 Le 22/02/2013, à 18:39

Maisondouf

Re : problème serveur lamp (erreur 403) [resolu]

C'est bien ce que je disais, ce n'est pas une installation standard.
Si ça avait été le cas, tu n'aurais pas eu le besoin de modifier quoi que ce soit puisque les cgi sont activés par défaut.
Le fichier "/etc/apache2/sites-available/default" contient tout ce qu'il faut pour fonctionner.

<VirtualHost *:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /var/www
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog ${APACHE_LOG_DIR}/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Maintenant si tu veux faire du spécifique avec une 'DocumentRoot' à ta sauce, il faut dépatouiller tout ça tout seul ou donner plus d'infos.

A ce que je vois, il y a deux répertoires private et public qui peut-être doivent correspondre chacun à un host spécifique, donc dans ce cas ton fichier index.html ne sert à rien à cet endroit.
D'autre part, l'accès aux répertoires réels se fait par des liens symboliques et il faut l'autoriser dans la config.
Mais comme tu as l'air bien sur de toi, je vais te laisser le soin de régler cela : http://httpd.apache.org/docs/2.2/fr/


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#16 Le 22/02/2013, à 22:25

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

Maisondouf a écrit :

C'est bien ce que je disais, ce n'est pas une installation standard.
Si ça avait été le cas, tu n'aurais pas eu le besoin de modifier quoi que ce soit puisque les cgi sont activés par défaut.
Le fichier "/etc/apache2/sites-available/default" contient tout ce qu'il faut pour fonctionner.

<VirtualHost *:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /var/www
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog ${APACHE_LOG_DIR}/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Maintenant si tu veux faire du spécifique avec une 'DocumentRoot' à ta sauce, il faut dépatouiller tout ça tout seul ou donner plus d'infos.

A ce que je vois, il y a deux répertoires private et public qui peut-être doivent correspondre chacun à un host spécifique, donc dans ce cas ton fichier index.html ne sert à rien à cet endroit.
D'autre part, l'accès aux répertoires réels se fait par des liens symboliques et il faut l'autoriser dans la config.
Mais comme tu as l'air bien sur de toi, je vais te laisser le soin de régler cela : http://httpd.apache.org/docs/2.2/fr/

Je te remercie beaucoup pour ton aide et ton temps, ton dernier commentaire m'a beaucoup aidé.
Cependant je ne comprend pas ton attitude. Faire une blague ne veut pas dire être sur de soi, et je te ferais remarquer que si je demande de l'aide sur un forum c'est justement parce je ne le suis pas. Et merci pour ce lien presque aussi utile que celui-la : https://www.google.fr/.

Hors ligne

#17 Le 23/02/2013, à 14:05

GGhiles

Re : problème serveur lamp (erreur 403) [resolu]

Ah comme vous pouvez le voir j'ai résolu mon problème!

Cependant comme j'avais fait pas mal de conneries au préalable, ça va être dur d'expliquer ma démarche. Mais grossomerdo, j'ai crée un lien symbolique vers mon home/user/repertoire_en_question grâce à la ligne de commande:

 ln -s /home/ghiles/repertoire_en_question/ 

puis 2 ou 3 chmod et c'est réglé

Hors ligne

Haut de page ↑