Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 21/02/2013, à 23:28

Aegyptos

[En cours] Installation Dual Boot W7 : OS non reconnu

Bonjour,

Pour des besoins pro j'ai besoin d'installer Ubuntu, mais je dois également garder une session window, j'ai donc cherché à installer ubuntu, mais j'ai rencontrer quelques soucis. J'ai cherché à droite et à gauche des réponses, mais je n'y arrive toujours pas, peut être qu'il y a un détail qui m'échappe et j'espère que l'un d'entre vous le verra !
Je vais vous expliquer se que j'ai fait :

Ma machine :
OS : Windows seven 64bits
Processeur : Intel i5-2310 @ 2.90GHz 2.90GHz
Ram : 4*2Go DDR4 (10600)
Carte Mère : P8H67 rev3.0
Carte Graphique : Asus GTX560 (je ne sais pas si utile, mais on a notre ordi Debian down à cause de la CG en ce moment au boulot)



Dans un premier temps, j'ai essayé d'installer Ubuntu 64bits (12.10, puis 12.04 LTS) (1.1), mais j'ai rencontré une erreur, j'ai donc essayé avec Ubuntu Secure Remix 64bits (1.2) mais j'ai eu la même erreur :
J'ai installé Ubuntu sur une clé USB avec Lili en suivant ce guide (2)
Lorsque j'ai boot, j'ai démarer avec "essayer ubuntu sans l'installer"
Lorsque je lance l'installer, à l'étape où il devrait alors me proposer d'installer ubuntu à coté de seven, il ne détecte pas d'OS et j'ai cette même fenêtre (3) (tiré d'un post sur un forum, la personne a eu la même erreur, sans solution (4))
edit : mon screen : http://i.imgur.com/OJcEOGd.jpg
Dans l'option "autre chose", je vois seulement mes disques comme s'ils n'avaient pas été partitionnées (http://i.imgur.com/g5jptTo.jpg)



J'ai donc lancé un gparted, et là j'ai cette erreur :

[i]root@ubuntu:~# gparted
======================
libparted : 2.3
======================
/dev/sda contains GPT signatures, indicating that it has a GPT table.  However, it does not have a valid fake msdos partition table, as it should. 
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. 
Or perhaps you deleted the GPT table, and are now using an msdos partition table.  Is this a GPT partition table?

/dev/sdb contains GPT signatures, indicating that it has a GPT table.  However, it does not have a valid fake msdos partition table, as it should. 
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. 
Or perhaps you deleted the GPT table, and are now using an msdos partition table.  Is this a GPT partition table?[/i]

et cette fenêtre apparaît *erf erreur sur le screen, j'eddit rapidement, mais même fenêtre que dans le post (1)*
Si je répond Oui, ou Non, j'ai pas tout à fait le même résultat :
http://i.imgur.com/0QV6FaO.jpg
http://i.imgur.com/uxv8Vt8.jpg
par contre, qu'est ce qu'une partition GPT concrètement ? Je ne connaissais pas.

Je lance ensuite un sudo fdisk -l

[i]WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.[/i]


[i]Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcb8efc4f[/i]

[i]   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *      206848   204802047   102297600    7  HPFS/NTFS/exFAT
/dev/sda2       204802048   625137663   210167808    7  HPFS/NTFS/exFAT[/i]

[i]WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.[/i]


[i]Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2e9ad30a[/i]

[i]   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   921602047   460800000    7  HPFS/NTFS/exFAT[/i]

[i]WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk doesn't support GPT. Use GNU Parted.[/i]


[i]Disk /dev/sdc: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xfa10c418[/i]

[i]   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1              63   488392064   244196001    7  HPFS/NTFS/exFAT[/i]

[i]Disk /dev/sdd: 4023 MB, 4023386112 bytes
128 heads, 60 sectors/track, 1023 cylinders, total 7858176 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18[/i]

[i]   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *       11352     7858175     3923412    b  W95 FAT32
root@ubuntu:~#[/i] 

Il me reconnait donc mes différents disques et partitions :

sda est mon disque physique 1 (2 partitions)
sda1 est ma première partition avec mon Seven (100Go)
sda2 est une seconde partition de data (200Go) espace que j'ai libéré pour que ubuntu s'y installe
il reste 100Mo non alloué

sdb est mon disque physique 2 (1 partition)
sdb1 est une partition data (400Go)
il reste ~600Go non alloué

sdc est mon disque externe (1 partition)

sdd est ma clé usb live pour boot ubuntu

Cependant, quand je lance l'OS_uninstall de Ubuntu Secure Remix, il me propose bien de désinstaller Seven qu'il reconnait...
http://i.imgur.com/U8bxqyu.jpg


N'étant pas abbatu par si peu, j'essaie de passer par wubi (5) !
Mais que neni ! Au boot, avant de me proposer Windows ou ubuntu, il me met un message d'erreur :

[i]fichier : \ubuntu\winboot\wubildr.mbr
statut: 0xC0000001
Infos : Impossible de charger l'entrée sélectionnée car l'application est absente ou endommagée[/i]

J'ai essayé depuis le disque C partition windows et depuis mon autre disque phsyque  "Data", même erreur. Que se soit avec la version 64bits ou 32bit (lancé depuis la commande windows wubi --32bits)

Bon, Ubuntu ne même pas, mais je ne me décourage pas, et essaie VirtualBox (6) (solution temporaire mais bon)
Et bah non, il me dit que l'application nécessite une version AMD64, et qu'il n'y a qu'un processeur i686. Or je tourne sur seven 64bits sans soucis!
Peut être que je n'avais qu'une version 32bits de virtualbox qui ne gere pas l'installation d'un OS 64 mais bon, je ne me suis pas acharné sur cette solution de bricolage? J'ai besoin d'une installation solide...

Bref
-help svp !


Lien dont je me suis aidé
(1.1) http://www.ubuntu.com/download/desktop
(1.2) http://doc.ubuntu-fr.org/ubuntu_secure_remix
(2) http://doc.ubuntu-fr.org/live_usb
(3) http://img4.hostingpics.net/pics/643006DSC4407.jpg
(4) http://www.siteduzero.com/forum/sujet/l … tion-43995
(5) http://doc.ubuntu-fr.org/wubi
(6) http://doc.ubuntu-fr.org/virtualbox
(7) http://askubuntu.com/questions/169530/t … installing
(8) http://lehollandaisvolant.net/tuto/dualboot/
(9) http://forum.ubuntu-fr.org/viewtopic.php?id=1011441


edit : rajout de mes screens

Dernière modification par Aegyptos (Le 22/02/2013, à 10:56)

Hors ligne

#2 Le 22/02/2013, à 01:09

TGM

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Bonsoir,
A priori, si c'est comme pour W8, ton Seven serait installé en mode UEFI. A vérifier dans ton Bios. En mode de boot, tu devrais avoir soit UEFI soit Legacy.
Dans le cas de l'UEFI, il y a 3 partitions avant le disque C, une de restauration, une appelée EFI et une appelée Microsoft Reserved quelque chose.
Tu peux aussi essayer avec Testdisk pour voir ce qu'il te propose comme partitions.
L'intérêt de GPT est de pouvoir adresser un nombre "illimité" de partitions de type "primaire" et de dépasser la taille fatidique de n To par partitions (12to je crois)


Nemo me impune lacessit

Hors ligne

#3 Le 22/02/2013, à 01:57

Aegyptos

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Bonsoir,

En effet, dans mon BIOS, mon boot seven est en mode UEFI, est-ce que celà peut avoir une influence sur mon installation ubuntu ? Par contre, en vérifiant ceci, une nouvelle question ce pose : pourquoi mon boot windows s'appelle "ubuntu" dans mon bios, mais lance bel est bien mon windows...


J'ai lancé testdisk depuis windows, je n'ai pas réussi à l'installer depuis le ubuntu libe de la clé (mais j'imagine que c'est normal) et voilà le résultat :
(j'ai laissé tourné moins de 5min, dans le tuto il est dit qu'il faudrait le laisser tourner des heures mais j'ai trouvé déjà 3 partitions)
http://i.imgur.com/S6RPnuh.jpg
J'y ai également rajouté la vision de windows quant à la gestion de mes partitions.

Par contre, je n'ai pas trop compris se que je dois chercher avec testdisk. Il a repéré 3 partitions (3 anciennes) mais elles n’existent plus (si j'ai suivis), du coup, quelle(s) influence(nt) pourrait elle(s) avoir ?


Je vais lire les posts à propos de W8, peut être que j'y trouverai une réponse.
Merci


edit : donc après avoir lu les différents tuto & posts : ma version ubuntu est également en boot UEFI dans mon gestionnaire boot du bios, du coup il ne devrait pas y avoir de soucis, si ?

Dernière modification par Aegyptos (Le 23/02/2013, à 00:53)

Hors ligne

#4 Le 23/02/2013, à 13:29

Aegyptos

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

J'ai encore essayé quelques manip sans succès...

Mon installation W7 est toute fraiche (2 semaines), je peux me permettre d'en refaire une toute belle si besoin, comment est-ce que je peux éviter les soucis que je rencontre actuellement ?
Sinon, est-ce que si j'installe linux et W7 sur deux disque physiquement différent, il me proposera un dualboot ? Ou est-ce qu'il y aura conflit au boot ? Dernière solution, serait d'installer W7 et Ubuntu sur deux disques et d'en débrancher 1 quand je veux boot sur l'autre , mon externe ferait alors office de partage entre les deux. Mais cette solution ne m'enchante pas... Déjà ce n'est pas très pratique, puis avoir ma partition OS et ma partition Data sur le même disque physique ne me donne pas envie!


Dernière solution, abandonné linux et passer sur la version windows de mon programme, mais version loin d'être terminé, sans outils graphiques (pas supra pratique pour du traitement d'image, mais faisable)


En espérant que l'un d'entre vous ai la solution !
J'ai déjà trouvé pas mal de poste avec mon problème, sans jamais y trouver de solution!

merci

Hors ligne

#5 Le 23/02/2013, à 15:04

squall35

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Salut,
J'ai un probleme qui semble similaire au tien. En ce qui concerne ton ideed installer les deux os sur deux disque physique differente je pense que c'est le mieu et le plus simple, tu n'aura pas besoin d'en debrancher un pour acceder a tel ou tel os. Via ton bios il te suffit de mettre le disque contenant ton l'os dont tu te servira le plus au dessus dans la hierarchie des device checker au moment du bootv(genre harddrive1 contenant ubuntu en num 1 et harddrive2 contenant w7 en num2). Dans cas ou tu veux changer d'os , au boot tu tape F11 (selon ta carte mere cela peut varier) "select boot device" et tu selectionne le bon ...

Hors ligne

#6 Le 23/02/2013, à 15:37

renyeu

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Bonjour,
Dans ton bios (accès via F2  ou suppr) désactives l'option Secure boot (disabled)
Redémarre ta machine en bootant sur ton lecteur CD/DVD (dans lequel tu as inséré au préalable Ubuntu Secure Remix 12.10) et tentes d'installer Linux.
En cas de souci, n'hésites pas à utiliser l'outil de réparation BootRepair que contient ton CD.
Tu peux trouver ICI une aide précieuse pour réussir ton installation.
Bon courage
Cdlt
Renyeu

Hors ligne

#7 Le 23/02/2013, à 15:38

antony21

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Hello,

gpt , efi

Dans le lien de la doc de l'efi, tu peux voir qu'il faut utiliser l'iso de la version internationale et pas l'édition francophone car elle est buggée pour l'efi, donc qu'as tu téléchargé?

++

Hors ligne

#8 Le 23/02/2013, à 15:44

malbo

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Aegyptos,
Pour moi, ce que tu as posté plus haut :

/dev/sda contains GPT signatures, indicating that it has a GPT table.  However, it does not have a valid fake msdos partition table, as it should. 
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. 
Or perhaps you deleted the GPT table, and are now using an msdos partition table.  Is this a GPT partition table?

/dev/sdb contains GPT signatures, indicating that it has a GPT table.  However, it does not have a valid fake msdos partition table, as it should. 
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. 
Or perhaps you deleted the GPT table, and are now using an msdos partition table.  Is this a GPT partition table?

Montre que tu as deux tables de partition (une GPT et une MSDOS) sur le disque sda et la même chose sur le disque sdb. C'est la merdouille et c'est ça qui bloque. Le mieux serait de déconnecter le disque sdb (pour éviter de faire des conneries dessus) et ne s'occuper que du disque sda : supprimer toutes les partitions du disque sda (tout ce qu'il y a actuellement dessus sera évidemment perdu) et créer une nouvelle table de partition MSDOS puis une seule partition NTFS de 100 Go au début du disque dur (le reste du disque restant non alloué pour l'instant) et installer Windows 7 dans cette unique partition (il s'installera en mode Bios, c'est à dire en mode classique, non-EFI). Ensuite, installer Ubuntu en mode BIOS en cohabitation avec Windows 7 sur ce même disque sda. Pour installer en mode Bios, il faut que le liveCD d'installation (ou la liveUSB d'installation) de Ubuntu soit démarré en mode Bios : voir doc
Après cela, tu vérifies que le dual-boot fonctionne bien, et si c'est la cas, tu peux reconnecter ton disque sdb.

En résumé, je te propose de faire une installation toute propre de Win7 en mode Bios (non-EFI) sur disque sda partitionné en MSDOS et de faire une installation de Ubuntu également en mode BIOS (non-EFI).

Dernière modification par malbo (Le 23/02/2013, à 16:00)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#9 Le 23/02/2013, à 16:15

Aegyptos

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

@ Renyeu : J'essaie de ce pas de désactiver le secureboot

@ antony21 : Je suis déjà sur la version ubuntu international UEFI

@ malbo ; J'essaie les autres proposition avant de me relancer dans un formatage de W7  (long à faire toute les sauvergarde) mais si je n'y arrive toujours pas, je test.

Hors ligne

#10 Le 23/02/2013, à 17:02

malbo

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Aegyptos a écrit :

J'essaie les autres proposition avant de me relancer dans un formatage de W7  (long à faire toute les sauvergarde) mais si je n'y arrive toujours pas, je test.

Je ne comprends pas l'argument  : je ne te parle pas de ton disque sdb, je te parle du disque sda qui n'est pas ton disque de données mais ton disque dédié aux OS si j'ai bien compris. Alors pourquoi aurais-tu des sauvegardes à faire sur ce disque sda ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#11 Le 04/03/2013, à 10:12

ikewdu

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Bjr,

Le problème identique a été solutionné dans la discussion suivante: voilà la situation initiale:

http://www.commentcamarche.net/forum/af … -ubuntu#23

http://i50.tinypic.com/wiszgy.png
http://i48.tinypic.com/72al8g.png

Pour faire court, il reste des traces de gpt dans le disque. On peut faire un nettoyage avec gdisk. Il suffit de l'installer sur le live-cd. On sauve son mbr (au cas où), puis on lance la commande (en root):

gdisk /dev/sda  (à adapter selon sa situation perso).

Au menu, on choisit 1 (ou 2, c'est sans conséquence).

Found valid MBR and GPT. Which do you want to use?
1 - MBR
2 - GPT
3 - Create blank GPT

Dans la liste des options, on choisit : x extra functionality (experts only)
Puis nouvelle liste d'options, on choisit : z zap (destroy) GPT data structures and exit
On accepte par y de nettoyer les traces de gpt : About to wipe out GPT on /dev/sda. Proceed? (Y/N): Y
On refuse de vider le mbr: Blank out MBR? (Y/N): N

On laisse faire et on constate que son Ws démarre toujours et que maintenant, les partitions sont reconnues par Ubuntu.

Dernière modification par ikewdu (Le 04/03/2013, à 10:17)

Hors ligne

#12 Le 05/03/2013, à 14:29

squall35

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

bonjour,

ikewdu a écrit :

gdisk /dev/sda  (à adapter selon sa situation perso).

Au menu, on choisit 1 (ou 2, c'est sans conséquence).

Found valid MBR and GPT. Which do you want to use?
1 - MBR
2 - GPT
3 - Create blank GPT

Dans la liste des options, on choisit : x extra functionality (experts only)
Puis nouvelle liste d'options, on choisit : z zap (destroy) GPT data structures and exit
On accepte par y de nettoyer les traces de gpt : About to wipe out GPT on /dev/sda. Proceed? (Y/N): Y
On refuse de vider le mbr: Blank out MBR? (Y/N): N

J'ai le même problème d'installation dualboot, mais en mode traditionnel (non uefi), pense tu que cela résoudra également mon problème?
Merci d'avance (et désolé de m’incruster smile )

Hors ligne

#13 Le 08/03/2013, à 09:01

ikewdu

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Bjr,

Il serait surprenant que le disque dur contienne des traces de gpt, mais tu ne risques rien à essayer. gdisk te diras s'il en trouve, avant d'effectuer quoi que ce soit.

Hors ligne

#14 Le 08/03/2013, à 10:59

squall35

Re : [En cours] Installation Dual Boot W7 : OS non reconnu

Merci mais finalement j'ai utilisé Fixpart et le problème est résolue.

Hors ligne

Haut de page ↑