Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 25/02/2013, à 17:07

tonimalt

libasound_module_pcm_equal.so introuvable ! (alsa equal vlc .asoundrc)

Bonjour,
j'ai désinstallé pulseaudio, installé volti et alsaequal. j'ai configuré alsa de la manière suivante :

$ cat .asoundrc
defaults.pcm.rate_converter "samplerate_medium"
defaults.pcm.card 1
defaults.pcm.device 0

### define equalizers -- BEGIN --

# -- 1 equalized digital output --

pcm.denon {
	# FLOAT_LE is the only format alsaequal understand (need to plug equal)
	type equal
	#controls ".alsaequal.denon.bin.libasound"
	controls ".alsaequal.denon.bin.mbeq"
	#slave.pcm "plug:front:1"
	slave.pcm "plug:dmix"

	# use mbeq
	library "/usr/lib/ladspa/mbeq_1197.so"
	module "mbeq"
}

ctl.denon {
	type equal;
	#controls ".alsaequal.denon.bin.libasound"
	controls ".alsaequal.denon.bin.mbeq"

	# use mbeq
	library "/usr/lib/ladspa/mbeq_1197.so"
	module "mbeq"
}


# -- 2 equalized headphone --

pcm.audiotechnica {
	# FLOAT_LE is the only format alsaequal understand (need to plug equal)
	type equal;
	controls ".alsaequal.audiotechnica.bin"
	slave.pcm "plug:dmix"
	#slave.pcm "plug:front:1"

	# use mbeq
	library "/usr/lib/ladspa/mbeq_1197.so"
	module "mbeq"
}

ctl.audiotechnica {
	type equal
	controls ".alsaequal.audiotechnica.bin"

	# use mbeq
	library "/usr/lib/ladspa/mbeq_1197.so"
	module "mbeq"
}

### define equalizers -- END --


pcm.equaldigital {
	type plug
	slave.pcm "denon"
}

pcm.equalheadphone {
	type plug
	slave.pcm "audiotechnica"
}


#pcm.!default "plug:dmix"
pcm.!default pcm.equalheadphone

ainsi mplayer, flashplayer, totem ouvrent le alsa default device. Mais ce n'est pas le cas de vlc et rhythmbox !

$ vlc -vvv fichier.mp4
...
ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_equal.so
[0x7fe8bc000958] alsa audio output error: cannot open ALSA device "default": Aucun périphérique ou adresse
...

pourtant les paths sont bien renseignés dans ld.so.conf.d

$ ldconfig -p | grep equal
	libasound_module_pcm_equal.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_equal.so
	libasound_module_ctl_equal.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_ctl_equal.so

le comble du comble c'est qu'il est possible de lancer vlc avec la lib en question en preload et là tout fonctionne :

$ LD_PRELOAD="/usr/lib/x86_64-linux-gnu/libasound.so.2:/usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_equal.so" vlc

je ne comprends pas ! quelqu'un aurait-il une explication ?
merci d'avance.

Hors ligne