Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 27/02/2013, à 18:18

bjacquem

[RÉSOLU] Hyperliens pas cliquables dans Okular

Bonjour à tous,

Désolé si le sujet est déjà traité, mais je n'ai pas trouvé de réponse à mon problème (ni ici, ni ailleurs)...

Je suis sous Kubuntu, et j'utilise donc Okular pour visualiser mes PDF, PS et autres. Or depuis quelques temps (en fait, depuis 12.10) , plus moyen de cliquer sur les hyperliens des PDF. Ou plutôt, le clic sur ces hyperliens ne donne plus aucun résultat... J'ai cherché dans la config de Okular (avec pour l'instant pour seul résultat que les hyperliens sont encadrés à l'affichage), mais pas moyen de résoudre mon problème.

Pourtant, ces liens sont bel et bien cliquables dans le PDF : soit href dans LaTeX, soit  hyperlien transformé dans LibreOffice, et tous fonctionnent (se lancent dans un navigateur ou éventuellement dans un client mail si c'est un mailto:) dès lors que j'ouvre ces documents dans un AdobeReader (pardon...).

Mais je souhaiterais ne passer que par Okular pour les PDF et les PS, voire les DVI... Quelqu'un aurait une idée (autre que ne plus utiliser Okular, évidemment !) ?

D'avance merci pour vos conseils éclairés !

bjacquem

Dernière modification par bjacquem (Le 28/02/2013, à 16:22)

Hors ligne

#2 Le 27/02/2013, à 20:18

jajaX

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

salut

il faut pas appuyer sur la touche "control" ou "maj" avant de cliquer ?

pas tester.


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#3 Le 27/02/2013, à 22:26

bjacquem

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

Non, c'est dans les logiciels de traitement de texte qu'on doit faire ça. Ici, j'ai essayé également, mais ça ne fonctionne pas. Et contrairement à ce qu'il y avait avant la dernière version de Kubuntu, le pointeur de la souris ne se transforme même plus en « petite main » quand on passe au dessus de l'hyperlien. J'en suis à me demander si la fonctionnalité n'a pas été purement et simplement supprimée / oubliée (mais ça m'étonnerait tout de même).
Merci quand même d'avoir essayé !

Hors ligne

#4 Le 28/02/2013, à 02:00

jajaX

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

ok, bizarre.

sinon, je cite l'aide d'Okular :

Certains documents possèdent des liens. Dans ce cas, cliquer sur l'un d'eux affichera la page ciblée par ce lien dans l'aire d'affichage. Si le lien est une page web ou tout autre document, le programme par défaut de KDE gérant ce format de fichier sera appelé. Par exemple, cliquer sur un lien pointant vers « http://fr.kde.org » ouvrira cette page web dans le navigateur par défaut de KDE.

il y a sûrement un bug alors...


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#5 Le 28/02/2013, à 16:21

bjacquem

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

Bonjour à tous,

Vous allez me lancer des cailloux... Il n'y a pas de bug, pas de problème de configuration, pas de souci au niveau de l'application, simplement un souci au niveau de l'utilisateur de l'application : moi... Pour qu'un lien soit cliquable dans Okular, il ne faut pas que l'outil de sélection de texte soit activé (sinon il essaie de sélectionner le texte du lien) : il faut passer par l'outil de navigation (ce qui est logique, mais que je n'avais pas vu : avec la version précédente, on repassait en navigation à chaque démarrage de Okular). Bref, le problème est résolu, et moi je cours me cacher...
Merci à tous et spécialement à jajaX, et désolé...

Hors ligne

#6 Le 01/03/2013, à 01:40

jajaX

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

salut,

t'as pas à être désolé !! au contraire, ça m'a appris un truc.

un grand merci plutôt wink


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#7 Le 05/09/2013, à 13:59

samR

Re : [RÉSOLU] Hyperliens pas cliquables dans Okular

ah merci!!! Ça fait des jours que j'avais le même problème!!! smile

Hors ligne

  • Accueil
  • » Forum
  • » KDE
  • » [RÉSOLU] Hyperliens pas cliquables dans Okular

Haut de page ↑