Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#26 Le 06/02/2013, à 11:55

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Ubuntu 12.04.2 LTS

Hors ligne

#27 Le 06/02/2013, à 14:38

Maisondouf

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

__fabrice a écrit :

Je peux pas désinstaller CURL et la libssl et tout réinstaller après ?

On peut tenter....
Il faut virer curl et php5-curl car libssl a trop de dépendance.

sudo apt-get remove --purge curl php5-curl libssl-dev
sudo apt-get clean
sudo apt-get autoremove --purge
sudo apt-get install --reinstall libssl1.0.0
sudo apt-get install curl php5-curl

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#28 Le 07/02/2013, à 09:36

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Salut,
J'ai fait çà, et cela ne répare pas le problème sad. De plus, pourquoi cela supprimé beaucoup de lib... ? :

sudo apt-get remove --purge curl php5-curl libssl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  php-fpdf libjs-jquery-ui php-mail-mime libgnutlsxx27 ckeditor libtasn1-3-dev libkadm5clnt-mit8 libgpg-error-dev librtmp-dev comerr-dev
  libgcrypt11-dev libphp-adodb libregexp-assemble-perl libkrb5-dev libapt-pkg-perl libldap2-dev libphp-pclzip libgssrpc4 libgnutls-dev
  krb5-multidev libp11-kit-dev libgnutls-openssl27 libkadm5srv-mit8 php5-geoip libkdb5-6 liblist-moreutils-perl libnusoap-php libidn11-dev
  libconfig-file-perl php-mail-mimedecode

et

sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  ckeditor* comerr-dev* krb5-multidev* libapt-pkg-perl* libconfig-file-perl* libgcrypt11-dev* libgnutls-dev* libgnutls-openssl27*
  libgnutlsxx27* libgpg-error-dev* libgssrpc4* libidn11-dev* libjs-jquery-ui* libkadm5clnt-mit8* libkadm5srv-mit8* libkdb5-6* libkrb5-dev*
  libldap2-dev* liblist-moreutils-perl* libnusoap-php* libp11-kit-dev* libphp-adodb* libphp-pclzip* libregexp-assemble-perl* librtmp-dev*
  libssl-doc* libtasn1-3-dev* php-fpdf* php-mail-mime* php-mail-mimedecode* php5-geoip* shtool*

Y'a pas un problème là ?
Fabrice

Hors ligne

#29 Le 21/02/2013, à 13:29

Mooty

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Bonjour,

Je me permet de t'apporter la solution, après avoir vu que personne sur le web n'y était arrivé (SuperUser/ServerFault aussi ...).
Elle est toute simple, tu installes la nouvelle version de libssl :
http://packages.ubuntu.com/precise/amd6 … 0/download
Derrière tu fais un wget sur l'adresse de téléchargement, puis un dpkg sur le fichier téléchargé.

Voila smile

Hors ligne

#30 Le 21/02/2013, à 15:10

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Salut,

Merci pour ta solution, mais j'avais déjà essayé. Lorsque je fais çà, la logithèque Ubuntu s'ouvre (évidemment smile ), et j'ai ce message d'erreur :

casse le paquet existant "libssl-dev" à cause de sa dépendance libssl1.0.0 (=1.0.0e-23ubuntu4.6)

Mais si je passe effectivement par :

sudo wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.1-4ubuntu5.3_i386.deb

et

sudo dpkg -i libssl1.0.0_1.0.1-4ubuntu5.3_i386.deb

çà marche smile... étonnant, mais çà marche... merci smile

Fabrice

Hors ligne

#31 Le 21/02/2013, à 15:54

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Sauf que... sauf que smile, la libssl-dev est maintenant en erreur  sad :

vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.

Les paquets suivants contiennent des dépendances non satisfaites :

 libssl-dev : Dépend: libssl1.0.0 (= 1.0.0e-2ubuntu4.7) mais 1.0.1-4ubuntu5.3 est installé

On peut enlever la libssl-dev ??, je crois pas. Ou l'as ré installer/linker sur la 1.0.1, ici  ? :

sudo apt-get install libssl-dev=1.0.1-4ubuntu5

Fab

Dernière modification par __fabrice (Le 21/02/2013, à 15:59)

Hors ligne

#32 Le 01/03/2013, à 11:46

__fabrice

Re : Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1

Pas de réponse sur le soucis de la libssl-dev maintenant ? smile

Merci
F.

Hors ligne

Haut de page ↑