Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/03/2013, à 11:16

Foromus

Configuration clavier[Résolu]

Bonjour,

Voulant configurer la touche Ver Maj, je me suis mis en recherche.
Et je n'ai rien trouvé... (qui solutionne mon problème...)
D'abord, je n'avais rien dans les menus qui me donne l'accès à la configuration clavier. Puis j'ai trouvé quelque chose dans les paramètres, et j'ai une fenêtre qui me donne des possibilités de configuration.
Je me souviens - ce devait être une version antérieure à la 12.04 - que j'avais tout un tas de possibilités, en particulier pour configurer Ver Maj, même si ça n'a jamais vraiment bien fonctionné. Je n'arrive plus à retrouver cette liste (avec cases à cocher), si je regarde le menu "Système", il n'y a pas le sous-menu adéquat. En regardant la configuration des menus, justement, l'option des préférences n'apparaît pas non plus (comme proposé dans les résultats de ma recherche).
Par ailleurs, j'ai voulu, dans les "Avancé" de "Clavier", mettre une autre option que "Par défaut", et là, je me suis retrouvé avec des frappes qui ne correspondaient plus aux touches, bien qu'étant toujours avec clavier français de France ! Gros problème pour entrer le mot de passe ! Fort heureusement, j'ai remis sur "Par défaut", et après redémarrage, j'ai retrouvé mon clavier originel : Ouf...
Cela est assez dangereux, et je pose la question : peut-on mettre le clavier directement "Français par défaut" lors du démarrage de la machine, dans le panneau du mot de passe justement ?
Ensuite, comment accéder au réglage Ver Maj ?
( Je sais, ça fait deux questions à la fois, mais la chose est liée ).

Merci de votre aide.

Dernière modification par Foromus (Le 24/03/2013, à 10:09)


Assemblé perso - AMD Athlon LE 1640 _ Ram 2 G - Xubuntu 12.04(Precise) _ Xfce 4.8

Hors ligne

#2 Le 04/03/2013, à 14:36

Slystone

Re : Configuration clavier[Résolu]

Salut !

Pour la touche verr maj ne sais pas, je vais regarder. Pour remettre le clavier par défaut, ce n'est pas possible dans la fenêtre du mot de passe il me semble. Mais en ligne de commande tu as une commande très pratique : 'setxkbmap'. Si tu veux le fr oss : 'setxkbmap fr oss'.
++


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

Hors ligne

#3 Le 22/03/2013, à 14:43

The Uploader

Re : Configuration clavier[Résolu]

Foromus a écrit :

Bonjour,

Voulant configurer la touche Ver Maj, je me suis mis en recherche.
Et je n'ai rien trouvé... (qui solutionne mon problème...)
D'abord, je n'avais rien dans les menus qui me donne l'accès à la configuration clavier. Puis j'ai trouvé quelque chose dans les paramètres, et j'ai une fenêtre qui me donne des possibilités de configuration.
Je me souviens - ce devait être une version antérieure à la 12.04 - que j'avais tout un tas de possibilités, en particulier pour configurer Ver Maj, même si ça n'a jamais vraiment bien fonctionné. Je n'arrive plus à retrouver cette liste (avec cases à cocher), si je regarde le menu "Système", il n'y a pas le sous-menu adéquat. En regardant la configuration des menus, justement, l'option des préférences n'apparaît pas non plus (comme proposé dans les résultats de ma recherche).
Par ailleurs, j'ai voulu, dans les "Avancé" de "Clavier", mettre une autre option que "Par défaut", et là, je me suis retrouvé avec des frappes qui ne correspondaient plus aux touches, bien qu'étant toujours avec clavier français de France ! Gros problème pour entrer le mot de passe ! Fort heureusement, j'ai remis sur "Par défaut", et après redémarrage, j'ai retrouvé mon clavier originel : Ouf...
Cela est assez dangereux, et je pose la question : peut-on mettre le clavier directement "Français par défaut" lors du démarrage de la machine, dans le panneau du mot de passe justement ?
Ensuite, comment accéder au réglage Ver Maj ?
( Je sais, ça fait deux questions à la fois, mais la chose est liée ).

Merci de votre aide.

Salut

Sous Xfce, il y a bien de quoi sélectionner la disposition, la variante, et le modèle du clavier dans le gestionnaire de paramètres => Clavier => Disposition.
Le plus souvent ce sera "PC générique 105 touches (intl)" pour le modèle, "Français" pour la disposition, et "Français (variante)" pour la variante.

Il n'y a pas d'interface dans Xfce pour régler le comportement de la touche Verr. Maj, mais tu peux le régler tout de même en modifiant le fichier /usr/share/X11/xorg.conf.d/10-evdev.conf.

Lance ceci à partir du terminal Xfce :

gksu leafpad /usr/share/X11/xorg.conf.d/10-evdev.conf

Dans la section contenant la ligne suivante :

Identifier "evdev keyboard catchall"

Rajouter sur une nouvelle ligne en dessous :

        Option  "XkbOptions" "caps:shiftlock"

Ce qui devrait donner quelque chose comme :

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        Option  "XkbOptions" "caps:shiftlock"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Enregistre les modifications, et au prochain redémarrage tu devrais avoir la touche Verr. Maj. qui se désactive quand tu appuie sur la touche Maj (comportement "machine à écrire").

Foromus a écrit :

Cela est assez dangereux, et je pose la question : peut-on mettre le clavier directement "Français par défaut" lors du démarrage de la machine

Normalement une Xubuntu dont le bon clavier a été sélectionné lors de l'installation n'a pas besoin d'être réglé pour avoir la bonne disposition dès le démarrage. Mais pour ça il te suffit de rajouter les lignes suivantes (toujours dans la même section dans le même fichier) :

        Option "XKbLayout" "fr"
        Option "XKbVariant" "oss"
        Option "XKbModel" "pc105"

En effet, les réglages que tu peux faire dans le gestionnaire de paramètres Xfce ne modifient pas les paramètres par défaut.

Dernière modification par The Uploader (Le 22/03/2013, à 14:50)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/Xfce sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#4 Le 24/03/2013, à 09:59

Foromus

Re : Configuration clavier[Résolu]

Bonjour,

Merci beaucoup pour cette réponse très détaillée.
Mon souvenir de la configuration de la touche Maj devait dater du temps où j'étais sous Ubuntu Gnome. Or, je suis passé sous Xubuntu car je ne supportais pas Unity...

Bien que très explicites, les commandes ici proposées m'impressionnent un peu, en ce sens que je n'aime pas trop intervenir sur les fichiers système. Pour la raison simple que si ça se passe mal, je crains d'être obligé de tout réinstaller, je n'ai pas assez de maîtrise pour remettre en ordre un système qui démarre complètement de travers, d'où une prudence - probablement exagérée - de ma part !

Cela dit, je garde sous le coude la formule. En y réfléchissant bien,  je pourrais, à la rigueur, tenter la manœuvre sur mon portable, il ne me sert que de back-up, je n'aurais pas trop de risques. Or donc, et si à un prochain moment, un éclair de témérité venait à traverser mon cerveau déjà bien usé par les ans, il est possible que je tente le coup !..

En tous les cas, merci encore pour les renseignements, j'apprécie la qualité du forum et je suis très reconnaissant aux personnes qui donnent de leur temps pour aider les néophytes de mon genre !

Je passe donc en [Résolu]


Assemblé perso - AMD Athlon LE 1640 _ Ram 2 G - Xubuntu 12.04(Precise) _ Xfce 4.8

Hors ligne

Haut de page ↑