Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 05/03/2013, à 09:49

Morgiver

[jQuery]Problème avec la fonction load()

Salut,

Je suis certains que ce n'est pas grand chose, mais je n'arrive pas à trouver de solution, j'imagine que je dois totalement passé à coté de quelque chose que je ne vois pas.

Je charge un fichier avec la fonction load() comme ceci :

$('a[class="load"]').on('click', function() {
		var href = $(this).attr('href');
		$('#corpsWorkflow').load(href);
		return false;
	});

Rien de très compliqué, avec un fichier ".html" basique, ça fonctionne parfaitement.

Mais seulement voilà, si j'ai l'audace de vouloir charger un fichier ".php", tout le contenu du fichier est passé en commentaire html comme ceci :

<!--?php


echo 'Session test avant modification : '.$_SESSION['test'];

$_SESSION['test']++;

echo 'Session test après modification : '.$_SESSION['test'];

?-->

Je comprendrais qu'il me tape une erreur à cause des test sur les sessions, mais je comprend pas pourquoi il me passe tout en commentaire hmm

Si quelqu'un à une réponse et/ou une explication, n'hésitez pas smile

Merci d'avance,

Morgiver

EDIT :

Autant pour moi, apparemment c'est un problème lié au serveur local que j'utilise pour faire des test.

Dernière modification par Morgiver (Le 05/03/2013, à 10:11)

Hors ligne

Haut de page ↑