Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/02/2013, à 02:09

Gedeon84

Retrouver configuration de mes écrans au lancement de Lubuntu

Bonsoir!!  Actuellement je teste LUBUNTU sur mon portable. Mais j'ai un problème que je n'arrive pas à résoudre. J'ai branché un moniteur Acer en VGA sur l'ordi (21 pouces) pour des raisons de confort visuel. Lorsque je lance lubuntu, je me retrouve de fait avec deux écrans "clones" en résolution 1440 X 900. Je veux donc éteindre l'écran d'origine, celui de mon Dell 17 pouces. Pour cela j'utilise l'outil  graphique de configuration d'écran LXRANDR. Je fais mes réglages, je me retrouve avec une résolution 1920 X 1080. Normal pour ce type de moniteur, sauf que l'écran est partagé en 4 bizarrement (4 rectangles inégaux, fonds d'écran divisé) comme une petite mosaïque ! Je suis contraint alors de passer par divers réglages ( Préférences,  zoom puis recliquer dans étirer écran, alors qu'il l'était d'origine ) pour me retrouver enfin avec une image correcte. Mais le plus ennuyeux (et je reste poli), c'est au re-démarrage (ou lancement) de LUBUNTU. Bien que j'ai sauvegardé mes réglages d'écran dans /etc/xdg/lxsession/lubuntu/autostart  (grâce à un script avec ARANDR, puis sauvegardé), je me retrouve sans cesse avec mes deux écrans allumés et en résolution identique!!! Tout est à refaire! Que me conseillez-vous? Pour vous aider, voici mon "lubuntu /autostart." Où est l'erreur? Merci de votre aide.

@xcompmgr
@xrandr --output VGA-0 --mode 1920x1080 --pos 0x0 --rotate normal --output LVDS --off --output HDMI-0 --off
@lxpanel --profile Lubuntu
@xscreensaver -no-splash
@xfce4-power-manager
@pcmanfm --desktop --profile lubuntu
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

Hors ligne

#2 Le 02/03/2013, à 01:53

Gedeon84

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Bon, il semblerait que personne ne puisse apporter de solution, (malgré de nombreuses lectures) Aucune réponse! Je vais essayer de vous mettre sur une piste: comme j'utilise Cubuntu, je crains bien que deux gestionnaires de bureau (ou de fenêtres) entrent en conflit au lancement de LUBUNTU: celui de gnome et celui de LUBUNTU (car j'ai cru m'apercevoir que les fonds d'écran distincts se superposaient et entraient en conflit, entraînant des bugs (images sectionnées, instable, panneau LXDE en mode transparent laissant entrevoir le fonds d'écran de GNOME/CINNAMON etc...)  Est-ce que la solution ne consisterait pas à "mettre en sommeil" au démarrage: "pcmanfm --desktop --profile lubuntu" ? Peut-être je me trompe, mais si vous avez un avis, je suis preneur !
PS: je voudrais bien joindre une image d'écran mais je ne sais pas m'y prendre !

Hors ligne

#3 Le 04/03/2013, à 20:25

chobbes

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Bonjour,

normalement, tu n'as pas à ajouter la ligne @xrandr --output VGA-0 --mode 1920x1080 --pos 0x0 --rotate normal --output LVDS --off --output HDMI-0 --off dans le fichier autostart si tu fais tes réglages avec LXRandR.
LXRandR est lancé au démarrage et son fichier .desktop est situé dans ton home à cet endroit : ~/.config/autostart.

Ce que je te conseillerais, ce serait de supprimer la ligne concernant xrandr dans le fichier /etc/xdg/lxsession/Lubuntu/autostart et de vérifier ton fichier ~/.config/autostart/lxrandr-autostart.desktop. A la ligne exec, tu as la commande qui s’exécute au démarrage, adapte là en fonction de ce que tu souhaites comme options (recopie simplement celle que tu avais mise dans le fichier /etc/xdg/lxsession/Lubuntu/autostart, si elle est correcte bien sûr...).

Concernant un possible conflit avec Gnome, j'ai un doute puisque LXRandR ne se lance qu'avec Lubuntu (c'est la ligne "OnlyShowIn=LXDE" dans le fichier ~/.config/autostart/lxrandr-autostart.desktop qui me permet d'affirmer cela). Cela dit, je ne connais pas Gnome et j'ignore quel logiciel utilise-t-il pour le réglage des écrans (grandr?) donc je ne peux t'assurer à 100% que ce dernier n'interfère pas sur ta session Lubuntu.

Tiens nous au courant...

Dernière modification par chobbes (Le 04/03/2013, à 20:29)

Hors ligne

#4 Le 09/03/2013, à 01:38

Gedeon84

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Bonsoir ! smile
Merci de la réponse. Effectivement supprimer la ligne "@xrandr--output...." n'empêche nullement LUBUNTU de démarrer avec la config des écrans désirée (écran portable éteint, moniteur externe en 1920X1080) grâce à LXRANDR. Malgré tout, il subsiste un conflit entre l'application de lubuntu qui gère mes fonds d'écran et celui de gnome: Wallch-(logiciel permettant la rotation d'images car j'utilise cette appli pas encore fonctionnelle sur LXDE-)  Au bout de quelques minutes, bizarrement, les wallpapers utilisés sur mes sessions gnome  "prennent le dessus" sur ceux choisis pour Lxde/Lubuntu (les cachent en fait) ...Dans ce cas, quand je clique sur "préférences du bureau" dans la fenêtre "wallpapers" apparait l'indication "aucun" ! . Pour échapper à ce kaléidoscope gênant, je voudrais dans ce cas mettre hors d'usage le gestionnaire qui affiche, qui gère les wallpapers de Lubuntu ou à la rigueur mentionner de façon permanente "aucun" dans "préférences du bureau...." Mais je ne sais comment faire! pouvez vous m'aider ??? Merci !:rolleyes:

Hors ligne

#5 Le 09/03/2013, à 11:15

chobbes

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

J'imagine que Wallch est lancé au démarrage.
Dans ce cas, il faut lui dire de ne pas démarrer lors d'une session LXDE.
Dans ton home, tu dois avoir le .desktop de Wallch, à cet endroit : ~\.config\autostart\WallchOnBoot.desktop. Ouvre le dans leafpad et ajoute cette ligne en bas :

NotShowIn=LXDE

Enregistre et redémarre une session pour voir.

Dernière modification par chobbes (Le 09/03/2013, à 11:16)

Hors ligne

#6 Le 10/03/2013, à 01:51

Gedeon84

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Bonsoir!
Oui , on avance à grands pas vers une solution. Grâce à ton idée d'ajouter  une ligne à la fin du script de lancement de l'appli Wallch au démarrage, je suis débarrassé du problème de changement de fonds d'écran en vigueur sur gnome -ubuntu ! Je me retrouve enfin avec mes 4 bureaux Lubuntu et leur fonds d'écran spécifiques. C'est presque parfait, car au démarrage, j'aperçois encore sur ma barre des taches transparente en arrière fond ainsi que sur mon conky  un extrait du fonds d'écran gnome....et surtout, l 'écran demeure divisé en 4 parties inégales au démarrage à chaque fois.Bizarre et frustrant ! Rien de grave cependant car en cliquant sur "préférences du bureau", puis en variant le mode d'affichage (voir + haut) je retombe sur mes pattes, mais bon, j'aimerais comprendre !! Comment connaitre le nom de mon gestionnaire de fonds d'écran gnome au démarrage et comment lui aussi le désactiver sur LXDE ? En tout cas merci pour ces idées qui vont dans le bon sens!!;)

Hors ligne

#7 Le 13/03/2013, à 19:38

chobbes

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Lorsque j'avais un moniteur connecté à mon netbook, je me rappelle qu'au démarrage, l'écran était également divisé en plusieurs parties avant de revenir très rapidement en plein écran.
Je ne sais pas trop d'où vient le souci chez toi. Peut-être faudrait-il retarder le lancement de la commande lors de l'ouverture de session.
Dans ton fichier ~/.config/autostart/lxrandr-autostart.desktop, à la ligne exec mets l'expression sleep 5 && au début, ce qui donnera :

sleep 5 && xrandr --output VGA-0 --mode 1920x1080 --pos 0x0 --rotate normal --output LVDS --off --output HDMI-0 --off

Redémarre une session pour voir.
Mais je ne suis pas certain que cela fonctionne. Es-tu bien sûr de l'exactitude de la commande?

Hors ligne

#8 Le 20/05/2014, à 19:58

Scavenger

Re : Retrouver configuration de mes écrans au lancement de Lubuntu

Un petit up pour apporter ma pierre à l'édifice. Ayant le même problème avec une machine de bureau connectée à 2 écrans, il me fallait reconfigurer à chaque redémarrage la disposition des écrans, j'utilisais pour cela ARandR.

Malheureusement, le fait de mettre un script Shell dans le répertoire ~/.config/autostart/ n'a pas fonctionné, du moins sur ma toute récente installation Lubuntu 14.04. J'ai donc copié la commande fournie par le système d'enregistrement d'ARandR directement dans l'outil Default application for LXsession (onglet Autostart, rubrique "Manual autostarted applications"), disponible dans le menu Préférences.

Et ça marche.

Merci pour m'avoir mis sur la piste, en espérant que cela puisse aider d'autres personnes.


Pour l'innovation par le libre

Acer Aspire M1610 - Intel Core2 Duo - Ubuntu 13.10 64bits
ASUS EeePC 1215B - AMD C-50 - Lubuntu 13.10 32bits

Hors ligne

  • Accueil
  • » Forum
  • » LXDE
  • » Retrouver configuration de mes écrans au lancement de Lubuntu

Haut de page ↑