Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#26 Le 12/03/2013, à 22:09

moko138

Re : problème home en lecture seul

derzhou a écrit :

J'ai changé de cable et même de port sata, vérifier mes branchements.

Très bien.

derzhou a écrit :

Une question ? prefail m'indique qu'un futur panne me pend au nez, n'est ce pas ?

Théoriquement oui ; en pratique, nous sommes nombreux à faire tourner des disques affichant "prefail" depuis plusieurs années
Il faut avoir sous les yeux le rapport de smartctl et les bonnes pages de la doc de smartctl pour y voir clair. Je vais essayer de te retrouver un bon lien en français.

derzhou a écrit :

fglrx n'est pas installer sur mon Ubuntu. un doute , fglrx est bien le driver propriétaire de AMD ?
Toujours selon synaptic, ubuntu-drivers-common et xserver-xorg-video-radeon sont installés.

fglrx est un des pilotes propriétaires de AMD-ATI.
 
- Gparted en session live.
- As-tu essayé de démarrer sur un ancien noyau ?
- As-tu essayé de démarrer en mode "dépannage" ?

Hors ligne

#27 Le 12/03/2013, à 22:44

derzhou

Re : problème home en lecture seul

Que veux tu que je teste avec Gparted, c'est une appli pour manipuler les partitions, je n'ai rien trouver d'intéressant.


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

#28 Le 12/03/2013, à 23:27

moko138

Re : problème home en lecture seul

Sans rien modifier, Gparted est capable de signaler certains problèmes sur la partition sélectionnée.

Hors ligne

#29 Le 13/03/2013, à 23:26

derzhou

Re : problème home en lecture seul

moko138 a écrit :

Gparted en session live.

Gparted ne m'a rien signalé

moko138 a écrit :

As-tu essayé de démarrer sur un ancien noyau ?

changer de noyau est du domaine de l'inconnu pour moi, mais je vais me renseigner sur le web.

je suis aller sur le site ubuntu, qu'elle noyau me conseille-tu ?
3.2.0.38.46: amd64
3.8.0.12.26: amd64
puisque le Linux version 3.5.0-25-generic (ma version) n'est pas stable.


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

#30 Le 14/03/2013, à 05:21

moko138

Re : problème home en lecture seul

STOP !
  Je ne t"ai pas dit de de télécharger un noyau (ou "kernel") !
Mais de démarrer avec un qui a fait ses preuves sur ton pc et qui est déjà dans ton grub !
http://doc.ubuntu-fr.org/grub-pc dit :
  "Depuis Ubuntu Lucid / 10.04, le menu de GRUB ne s'affiche pas au démarrage d'un PC mono-système. Il suffit de laisser la touche Majuscule (shift) enfoncée avant le chargement de GRUB pour afficher son menu."

  Redémarre ton pc en tapotant dès le début la touche Majuscule, jusqu'à obtenir sur fond noir une liste ressemblant à ceci :

Démarrer sur kernel 3.5.0-25
Démarrer sur kernel 3.5.0-25 recovery (ou dépannage)
Démarrer sur kernel 3.5.0-17
Démarrer sur kernel 3.5.0-17 recovery
MemTest

  Puisque le démarrage auto (1ère ligne) te donne du souci, sélectionne une des lignes suivantes (en te déplaçant avec les flèches, puis en validant avec Entrée).

Dans ton premier message, tu dis que le pb est arrivé d'un coup. Il est donc logique d'envisager, entre autres, un pb lié à une mise à jour du noyau.

  En mode normal, ça marche ou ça ne marche pas. Si ça marche, tu es fixé.

  En mode recovery, tu seras d'abord sans interface graphique. Note ou photographie les messages d'erreur. Puis, si tu arrives à derzhou@pc $, tape

startx

pour lancer l'interface graphique, ou redemarre.
Qu'un connaisseur de cette phase intervienne serait apprécié, merci !

Hors ligne

#31 Le 14/03/2013, à 19:30

derzhou

Re : problème home en lecture seul

OUPS !!! big_smile
Heureusement, je n'ai eu le temps de rien faire, j'ai frôlée la belle boulette.
Donc il faut que je sélectionne un autre Kernel dans le menu Grub.

Très bien dès que j'ai du temps libre je met cela en pratique.


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

#32 Le 16/03/2013, à 17:01

derzhou

Re : problème home en lecture seul

Me revoilà, pour faire un bilan.

Je teste actuellement et depuis 2 jours environ le kernel 3.5.0-17, pour l'instant pas d'erreur "DD en écriture seulement" à signaler, mais je tiens à tester encore car le problème est très aléatoire sur la périodicité.
Mais tous n'est pas résolu.
Au démarrage aujourd'hui sur le kernel 3.5.0-17, toujours en appuyant sur la touche SHIFT, après la sélection dans le GRUB, le système n'est pas monté avec le message d'erreur suivant.

/dev/sda1 contient un système de fichiers comportant des erreurs
/dev/sda1 : des i-neouds qui faisaient partie d'une liste chaînée d'orphelins corrompue ont été repérés.
/dev/sda1 : inconsistance inattendue ; exécutez fsck manuellement (i.E. sans options -a ou -p)
montall : fsck / [327] terminé avec le statut 4
montall : le système de fichiers comporte de erreurs :/

J'ai fait un fsck et tous est rentrés dans l'ordre.

Concernant mon clavier "Logitech Illuminated Keyboard" parfois non reconnu, j'ai lu sur des forums que je n'était pas le seul.
Une parade (provisoire) consiste à débrancher et rebrancher le port USB lorsque le problème a lieu et le clavier fonctionne.

voila c'est tout pour l'instant, je suis encore loin du système fiable et stable, mais c'est l'occasion d'apprendre de nouveau truc.
En tous cas merci pour ton suivi smile


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

#33 Le 16/03/2013, à 17:52

moko138

Re : problème home en lecture seul

Coincidence : je viens de traiter un pb similaire chez moi. Dans mon cas (Ubuntu 10.04), je savais que le HD était vieux ET que je venais de faire une boulette (lancer en mode graphique une application avec sudo au lieu de gksudo).

Tu ne dis pas de quelle manière tu as lancé fsck. Or ce serait intéressant !

1) J'ai d'abord modifié /etc/default/rcS

gksudo gedit /etc/default/rcS
# Changer si besoin la ligne fsckfix en
FSCKFIX=yes # (au lieu de "no")

  Ensuite, conformément à la page de doc
http://doc.ubuntu-fr.org/verification_de_fichiers
  qui m'a été fort utile :
Merci à Roger64 ! Et à ceux qui, comme Ungars, m'avaient mis sur la voie !
  j'ai lancé fsck comme suit :
2) Forcer la vérification prochaine de certains systèmes de fichiers
(déterminés par le dernier chiffre de chaque ligne dans fstab, cf. §3 de la doc, lignes vérifiées en conséquence juste avant, avec gksudo) :

sudo touch /forcefsck

3) suivi de

sudo reboot

  4) Après redémarrage, lire /var/log/boot.log et éventuellement en faire une copie datée à fins d'examen et de comparaison, puisque le fichier est réinitialisé à chaque démarrage.

Dernière modification par moko138 (Le 19/06/2013, à 10:53)

Hors ligne

#34 Le 17/03/2013, à 16:35

derzhou

Re : problème home en lecture seul

J'ai lancé fsck avec le cd live, puisque le disque doit être démonter, en faite je n'en connaissais pas d'autres méthodes.
Je vais tester cette procédure.

Je vais également pérenniser le démarrage par défaut avec le kernel 3.5.0-17, plus de problème de DD en lecture seul (cool big_smile )


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

#35 Le 17/03/2013, à 18:39

moko138

Re : problème home en lecture seul

fsck, oui mais avais-tu mis l'option -f (pour "forcer") ? Et lu la doc :
http://doc.ubuntu-fr.org/fsck

  Parce que sans -f, la première fois que je m'en suis servi, j'ai cru que tout était nickel, alors que le retour signifiait seulement que le contrôle serait fait n démarrages plus tard...

Hors ligne

#36 Le 30/03/2013, à 22:31

derzhou

Re : problème home en lecture seul

Me revoilà je reviens aux nouvelles.
En faite changer de kernel n'a pas résolu mon problème, j'ai fini par acheter un nouveau DD et là nickel plus aucun problème.:D
Mon DD était bien la cause de mes soucis.

Avec un peu de recul, il a été difficile de localiser le problème (pourtant on m'a bien aider dans ce forum) , le problème de lecture seul du DD, s'est installé vraiment très progressivement et aléatoirement, si bien que je ne suspectais pas mon DD, mais "moko138" tu m'a mis sur la bonne voie, avec le rapport de smartctl qui m'indiquais quelques "prefail".

Encore merci et à +


ubuntu 13.04 amd 64
processeur : AMD Phenom(tm) II X2 555 Processor × 2
mémoire : 7 gio

Hors ligne

Haut de page ↑