Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/03/2013, à 21:34

kinimode

Ardour/Jack ne veut pas démarrer [RESOLU]

Bonjour,

j'essaye de travailler en MAO en utilisant Pure Data, Hydrogen et Ardour, mais si tout marche très bien dans l'ensemble, au lancement de Ardour, au moment de lancer le moteur audio, après avoir paramétrer la session, j'ai un message d'erreur qui empêche la session de se créer disant:
Adour n'a pas pu lancer Jack:
1) Vous avez demandé des paramètres audio qui ne sont pas pris en charge.
2) JACK est lancé depuis un autre utilisateur.
Veuillez étudier ces possibilités et peut-être essayer d'autres paramètres.
J'ai tenter d'autre paramètres, mais je m'y connais assez peu dans le domaine (pour l'instant!), et ne sait pas quoi faire (évidemment Jack est installé).

J'ai lancer qjackctl (l'interface graphique de jack) pour voir si le problème ne venait pas de là. Il y'a bien des lignes rouge flamboyantes qui s'affiche dans la boite de messages:
BUS : impossible de démarrer le serveur JACK.
et:
Impossible de connecter le serveur JACK comme client.
- L'opération a échoué.
- Incapable de se connecter au serveur.
Veuillez consulter la fenêtre des messages pour plus d'informations.
(22:07:08.320 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type)

Merci de votre aide!
je tourne sur ubuntu 12.10, laptop eeepc 1011PX (du léger).

Dernière modification par kinimode (Le 14/05/2013, à 12:42)

Hors ligne

#2 Le 09/03/2013, à 11:02

kinimode

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

up!

Hors ligne

#3 Le 09/03/2013, à 11:17

Flo_

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Salut smile

Il vaut mieux d'abord lancer Jack puis Ardour, sinon Ardour lancera tout seul Jack et pas forcément avec les bons paramètres.

Donne le résultat de la commande :

cat .jackdrc

Tu utilises une carte son interne ?

Quelques liens pour t'aider pour Jack :
La page sur LinuxMAO http://linuxmao.org/tikiwiki/tiki-index.php?page=Jack
Le tutoriel de démarrage : http://linuxmao.org/tikiwiki/tiki-index … +lancement

Flo

Hors ligne

#4 Le 09/03/2013, à 13:37

kinimode

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Merci de t'intéresser à mon problème!
voici la réponse à la commande proposée:
/usr/bin/jackd -p 128 -R -P 60 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0
J'avais déjà essayer de lancer jackd avant ardour, mais sans plus de succès.
En fait il me semble que le problème vienne de jackd lui même. J'ai pas mal traîné sur tes liens et chercher des post similaires, sans véritables succès... soit ils se sont résolus par miracle, soit il ne correspondent pas vraiment à ma configuration.
Alors le problème de Jackd, après configuration, reste le même, voici l'ensemble de la ligne de messages:
13:14:16.505 Baie de brassage désactivée.
13:14:16.508 Réinitialisation des statistiques.
13:14:16.625 Changement des connexions ALSA.
13:14:16.673 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
13:14:16.700 Changement du graphique des connexions ALSA.
13:14:19.837 DBUS : impossible de démarrer le serveur JACK. Désolé
Sat Mar  9 13:14:19 2013: Starting jack server...
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
Sat Mar  9 13:14:19 2013: JACK server starting in realtime mode with priority 70
Sat Mar  9 13:14:19 2013: [1m[31mERROR: Cannot lock down 82274202 byte memory area (Cannot allocate memory)[0m
Sat Mar  9 13:14:19 2013: control device hw:0
Sat Mar  9 13:14:19 2013: control device hw:0
Sat Mar  9 13:14:19 2013: [1m[31mERROR: Failed to acquire device name : Audio0 error : Method "RequestRelease" with signature "i" on interface "org.freedesktop.ReserveDevice1" doesn't exist
[0m
Sat Mar  9 13:14:19 2013: [1m[31mERROR: Audio device hw:0 cannot be acquired...[0m
Sat Mar  9 13:14:19 2013: [1m[31mERROR: Cannot initialize driver[0m
Sat Mar  9 13:14:19 2013: [1m[31mERROR: JackServer::Open failed with -1[0m
Sat Mar  9 13:14:19 2013: [1m[31mERROR: Failed to open server[0m
Sat Mar  9 13:14:21 2013: Saving settings to "/home/kortouchka/.config/jack/conf.xml" ...
13:14:25.311 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started

Hors ligne

#5 Le 09/03/2013, à 19:34

kinimode

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

up! please...

Hors ligne

#6 Le 11/03/2013, à 21:14

kinimode

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Up! personne n'a eu ce problème? J'ai tenté des alternative à Ardour, mais rien ne l'égale...

Hors ligne

#7 Le 12/03/2013, à 21:51

Flo_

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Désolé ça fait un peu de temps que je n'ai pas utilisé jack, je ne me souviens plus de la config..
Par contre je peux te rediriger vers le forum de LinuxMAO qui est peut-être plus adapté à ce genre de problèmes :

http://linuxmao.org/tikiwiki/tiki-forums.php

Flo

Hors ligne

#8 Le 13/03/2013, à 07:51

allany

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Deux choses :
- as-tu bien configuré ton PAM ?
- bonne idée que de suivre le conseil de Flo et de surfer sur linuxmao.org...

Sinon, tu as aussi cette bonne lecture comme préalable à l'utilisation de Jack qui est le point névralgique de la MAO/Linux, en effet.

A+

Hors ligne

#9 Le 13/03/2013, à 09:33

strokkur

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Ici c'est intéressant aussi

http://doc.ubuntu-fr.org/jackd

Es-tu bien dans le groupe audio ? (cf paragraphe 2.1)

Adour n'a pas pu lancer Jack:
1) Vous avez demandé des paramètres audio qui ne sont pas pris en charge.
2) JACK est lancé depuis un autre utilisateur.

C'est ce message qui me fait penser à ça

Hors ligne

#10 Le 13/03/2013, à 15:42

allany

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

... et, pour finir, tu as aussi l'option, lorsque tu utilises Jack, de désactiver Pulseaudio qui, lui, n'est pas super adéquat en usage MAO.
J'avais fait un petit tuto là-dessus.
A+

Hors ligne

#11 Le 18/03/2013, à 11:45

Dim83

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Tu as décoché "activer l'interface Dbus" dans setup/divers ?


C'est fou ce que ça me contrarie d'être contrarié comme ça. Si je ne craignais pas de m'offrir en spectacle, je crois bien que j'irais jusqu'à manifester un soupçon de mauvaise humeur. Achille Talon

Hors ligne

#12 Le 23/04/2013, à 17:46

yoann54

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

J'ai le même problème sur mon ordinateur et j'utilise aussi la carte son interne. J'ai tenté tango et ubuntu studio mais j'ai la même erreur sur les deux...
BUS : impossible de démarrer le serveur JACK.
et:
Impossible de connecter le serveur JACK comme client.
- L'opération a échoué.
- Incapable de se connecter au serveur.

faut t'il forcément supprimer pulseaudio ? j'ai bien essayé mais rien n'y fait.

@kinimode : as tu trouvé une solution ?

je vais essayer d'approfondir sur linuxmao et je reviens poster si j'ai du neuf !

Edit: Bizarrement quand je lance ardour et puis après jack cela marche très bien.....donc ben je vais faire comme ça !

Dernière modification par yoann54 (Le 24/04/2013, à 03:15)


Je suis saoul saoul sous sous ton balcon........

Hors ligne

#13 Le 24/04/2013, à 07:53

allany

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Ouaip !
Pulse ne fait pas vraiment bon ménage avec Jack.
Tu trouveras ici un tuto expliquant comment désactiver/réactiver Pulse en fonction de la présence/absence de Jack.
A+

Hors ligne

#14 Le 27/04/2013, à 13:05

Dim83

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

je plussoie ma réponse : vérifiez bien que "activer l'interface Dbus" dans setup/divers est bien décochée, sans ça, ça marche pas.

Sinon inutile de supprimer quoi que ce soit, en revanche tu peux demander à Jack d'exécuter un script au lancement qui ferme Pulse, et un script à l'extinction qui le relance.
Dim


C'est fou ce que ça me contrarie d'être contrarié comme ça. Si je ne craignais pas de m'offrir en spectacle, je crois bien que j'irais jusqu'à manifester un soupçon de mauvaise humeur. Achille Talon

Hors ligne

#15 Le 28/04/2013, à 03:52

yoann54

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Merci pour le tuto @allany ça fonctionne bien comme cela !!  merci


Je suis saoul saoul sous sous ton balcon........

Hors ligne

#16 Le 14/05/2013, à 12:38

kinimode

Re : Ardour/Jack ne veut pas démarrer [RESOLU]

Bonjour,

désolé pour mon absence, j'étais en concours, soit plus trop de temps pour ces choses là!! Mais du coup j'ai fait la mise à niveau pour ubuntu 13.04 et depuis aucun soucis avec jack et ardour! (Peut être un des rare avantage de cette mise à niveau).
Par contre un nouveau post s'impose, Pure Data fait planter gentiment ma session ubuntu après quelques minutes d'utilisation des plus banales... Très agaçant...
Merci de votre aide, j'ai appris pas mal de choses! je marque le pb résolu du coup.
a bientôt

Hors ligne

Haut de page ↑