Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 18/03/2013, à 16:43

Raphael bodin

Bug au démarage

Bonjour a tous,
tous d'abord c'est la première fois que je m'inscrit sur un forum donc je ne sais pas trop ou poster j'espère que c'est ici..
j'ai un problème au démarage de linux dans grub quand je clique sur le démarage normal un écran noir s'affiche et j'entends le bruit de linux quand on doit s'identifier.
pour réussir a rentrer dans linux je doit passer par le mode généric et cliquer sur poursuivre vers le demarage normal..
Des idée?

Pour info:
J'ai une carte graphique hd 3000
mon installation est sur dd externe
mon ordi a 4gb de ram
c'est le tout dernier linux avec unity
et au démarage des foi je voit des flash ou autre ensuite c'est nickel merci a vous de m'aidez svpp

Hors ligne

#2 Le 18/03/2013, à 19:52

lepetitnouveau

Re : Bug au démarage

Bonsoir,

Tu es bien au bon endroit puisqu'il s'agit probablement d'un problème de carte graphique.
Dans le Grub, le premier choix te conduit à un écran noir alors que le mode generic (c'est pas plutôt le mode de dépannage ? ) ça marche pas trop mal.
Cela s'explique par le fait que les options de démarrage ne sont pas les mêmes. C'est probablement l'option "    gfxmode $linux_gfx_mode" qui fait foiré le démarrage.

Lorsque tu es sur GRUB, positionne toi sur une ligne et fais e, cela affiche quelques lignes que tu peux modifier pour le démarrage en cours, cela n'est pas sauvegardé.

Fais un test en masquant la ligne gfxmode $linux_gfx_mode par un # en début de ligne (ou en le remplaçant par GRUB_GFXMODE=640x480) dans la 1ère ligne de GRUB.
L'option nomodeset peut aussi résoudre le problème.
Lorsque tu trouves une solution satisfaisante, tu peux utiliser Boot-Repair ou Grub Customizer pour mettre cela dans le système en dur et pouvoir booter sans souci.

Voir §3.3 de http://doc.ubuntu-fr.org/grub-pc

Je ne connais pas suffisamment pour te dire précisément quoi changer mais la solution est certainement par là.

Ci-dessous un extrait de mon fichier /boot/grub/grub.cfg qui fait apparaitre le code associé aux 2 premières lignes de mon GRUB.

....
export linux_gfx_mode
if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
menuentry 'Ubuntu, avec Linux 3.2.0-39-generic' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos5)'
	search --no-floppy --fs-uuid --set=root 9aff8d32-c899-cd01-8043-8d32c899cd01
	linux	/boot/vmlinuz-3.2.0-39-generic root=UUID=9aff8d32-c899-cd01-8043-8d32c899cd01 ro   quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.2.0-39-generic
}
menuentry 'Ubuntu, avec Linux 3.2.0-39-generic (mode de dépannage)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos5)'
	search --no-floppy --fs-uuid --set=root 9aff8d32-c899-cd01-8043-8d32c899cd01
	echo	'Chargement de Linux 3.2.0-39-generic…'
	linux	/boot/vmlinuz-3.2.0-39-generic root=UUID=9aff8d32-c899-cd01-8043-8d32c899cd01 ro recovery nomodeset 
	echo	'Chargement du disque mémoire initial…'
	initrd	/boot/initrd.img-3.2.0-39-generic
}
...

Asus EeePC 1011PX - Intel Atom N570 - 1Go Ram - Dual Boot Lubuntu 14.04- Windows 7

Hors ligne

#3 Le 18/03/2013, à 20:43

Raphael bodin

Re : Bug au démarage

Merci a toi pour cette réponse,
J'ai essayer ce que tu ma dis effectivement sa marche mais que si j'appuie sur ctrl+alt+f3 ( enfin je croit )
Ta une idée pour que j'évite de tapper sa a chaque démarage?

Dernière modification par Raphael bodin (Le 18/03/2013, à 20:48)

Hors ligne

#4 Le 18/03/2013, à 20:49

lepetitnouveau

Re : Bug au démarage

ctrl+alt+f12, tu as trouvé cela tout seul ou c'est le système qui te le demande ?
Qu'est ce que c'est sensé faire ?

Quelles modifs as tu faites ?


Asus EeePC 1011PX - Intel Atom N570 - 1Go Ram - Dual Boot Lubuntu 14.04- Windows 7

Hors ligne

#5 Le 18/03/2013, à 21:34

Raphael bodin

Re : Bug au démarage

Désolé je voulais dire ctrl+alt+f3 oui j'ai trouver sa tous seul car sa représente sur mon clavier la touche luminosité et j'avais vue sur un autre sujet du fofo qu'un mec avait besoin de faire sa pour démarrer son ubuntu.
j'ai fais les 2 modif que tu ma écrite ci dessus et cela fonctionne ( en meme temps ).

Hors ligne

Haut de page ↑