Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/03/2013, à 10:56

benjaminlaurent

Lancement de minidlna

Bonjour,

Je pense pas que mon problème soit compliqué, mais je ne sais plus quoi faire et en cherchant sur le net je n'ai pas trouvé grand chose.
Hier soir j'ai installé minidlna pour tester son fonctionnement avec mon decodeur neufbox (ancienne version car depuis le passage à la nouvelle interface le mediacenter ne fonctionne plus).
J'ai un netbook samsung N145 avec ubuntu 12.04 dessus.

J'ai suivi la doc suivante, en réalisant l'installation à partir de la logithèque rien à signaler d'anormal sur cette phase.
Ensuite j'ai modifié le fichier de configuration.
- port=49200
- network_interface=wlan0 (j'ai essayé de le configurer aussi comme ceci pour qu'il s'adapte suivant que je suis en wifi ou avec un câble eth0,wlan0 mais ça n'avait pas l'air de fonctionner et ne sachant pas j'ai préféré revenir à un cas simple on verra plus tard pour complexifier)
- media_dir=V,/home/monuser/videos
- friendly_name=My DLNA Server
- db_dir=/var/cache/minidlna

J'ai ensuite relancé le serveur

sudo /etc/init.d/minidlna restart

je me suis pris une erreur liée au fait que minidlna n'existait pas sous /var/cache/ j'ai donc fait un

sudo mkdir /var/cache/minidlna

j'ai relancé

sudo /etc/init.d/minidlna restart

j'ai pris un message relatif à eth0 j'ai donc modifié le fichier de configuration pour ne laissé que

network_interface=wlan0

j'ai relancé plusieurs fois

sudo /etc/init.d/minidlna restart

vérifié le status

sudo /etc/init.d/minidlna status
minidlna is NOT running

et à un moment donné j'ai eu un "minidlna is running" (j'en suis sûr j'ai vérifié avec la mémoire tampon du terminal xterm)

J'ai ensuite vu qu'il fallait configurer le firewall j'ai donc installé gufw comme indiqué dans la doc et paramétré la règle

sudo ufw allow from 192.168.1.0/24 to any port 49200

.
j'ai relancé

sudo /etc/init.d/minidlna restart

vérifié le status

sudo /etc/init.d/minidlna status
minidlna is NOT running

.
"NOT running"... à nouveau oui mais NOT Running à cause de quoi ? Pas à cause du FW c'est pas logique ?
Comment puis-je investiguer sur ce qui ne fonctionne pas ?
Pouvez-vous m'aider ?

Hors ligne

#2 Le 20/03/2013, à 11:28

titi89

Re : Lancement de minidlna

bonjour,
home/nomuser/Videos

nomuser = ton nom ubuntu le nom de ton dossier personnel
Videos ton dossier Vidéos vérifie  "l'accens"

sinon lance la commande:

sudo service minidlna force-reload

recharge la base de données et relance minidlna ou le lance
essaye déjà cela
@+

Hors ligne

#3 Le 20/03/2013, à 11:33

grandtoubab

Re : Lancement de minidlna

bonjour
Tu peux lancer minidlna avec l'option -d tu en sauras plus
http://manpages.ubuntu.com/manpages/pre … lna.1.html

Quel utilisiteur as u défini dans la configuration, j'ai mis root pour ne pas avoir de problème d'accès aux dossiers
http://forum.ubuntu-fr.org/viewtopic.ph … #p11967371


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

#4 Le 20/03/2013, à 14:42

benjaminlaurent

Re : Lancement de minidlna

titi89 a écrit :

Videos ton dossier Vidéos vérifie  "l'accens"

sinon lance la commande:

sudo service minidlna force-reload

@+

pour l'accent j'avais senti le coup venir, initialement le répertoire Vidéos s'écrit avec un accent à l'install d'ubuntu... je l'ai renommé sans accent donc pas de souci de ce côté là.
pour la commande j'essaye ce soir.

grandtoubab a écrit :

bonjour
Tu peux lancer minidlna avec l'option -d tu en sauras plus
http://manpages.ubuntu.com/manpages/pre … lna.1.html

Quel utilisiteur as u défini dans la configuration, j'ai mis root pour ne pas avoir de problème d'accès aux dossiers
http://forum.ubuntu-fr.org/viewtopic.ph … #p11967371

Je découvre qu'on peut aussi lancer minidlna avec cette commande (sans -R ça peut aller plus vite si c'est juste pour du débug)

sudo minidlna -f /etc/minidlna.conf -R

si j'ajoute -d comme tu le proposes j'arrive au même résultat ?

sudo minidlna -d -f /etc/minidlna.conf -R

Sinon dans ma configuration j'ai rien défini en suivant la doc on ne te parles pas du fichier /etc/default/minidlna.
Sinon y déclarer root c'est pas un peu violent ? hmm

Hors ligne

#5 Le 20/03/2013, à 15:04

grandtoubab

Re : Lancement de minidlna

benjaminlaurent a écrit :

Je découvre qu'on peut aussi lancer minidlna avec cette commande (sans -R ça peut aller plus vite si c'est juste pour du débug)

sudo minidlna -f /etc/minidlna.conf -R

si j'ajoute -d comme tu le proposes j'arrive au même résultat ?

sudo minidlna -d -f /etc/minidlna.conf -R

Sinon dans ma configuration j'ai rien défini en suivant la doc on ne te parles pas du fichier /etc/default/minidlna.
Sinon y déclarer root c'est pas un peu violent ? hmm

Y a t-il des erreurs dans le fichiers log?
Il est parfois intéressant de lire dans Synaptic quels sont les fichiers utilisés par un paquet lol
Mes fichiers media sont sur un disque externe usb monter automatiquement par la fstab et c'est ce que j'ai trouvé de plus simple pour que minidlna puisse constituer sa base de données à partir de /media/..... plutôt que de bidouiller les droits d'accès aux répertoires pour autoriser minidlna.
Je ne vois pas ou est le problème d'utiliser root


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

#6 Le 22/03/2013, à 08:53

benjaminlaurent

Re : Lancement de minidlna

Bon,
Comme je n'avais pas beaucoup de temps à y consacrer, j'ai rien changé et je me suis juste contenté de redémarrer le netbook.
Une fois démarré

sudo /etc/init.d/minidlna status
minidlna is NOT running

Jusque là rien de changé.
Ensuite j'ai fais un petit:

sudo /etc/init.d/minidlna stop

au cas où. La commande est passée sans gueuler !
Et ensuite dans une logique de droit au but j'ai balancé un:

sudo minidlna -d -f /etc/minidlna.conf -R

là faut savoir lire la matrice car ça défile très vite mais on dirait bien qu'il n'y avait pas de problème et qu'il scannait tout le répertoire de médias !
Puis plus rien ne s'ajoutait à l'écran.
Je me suis dirigé vers la télé et j'ai pu utiliser le médiacenter neufbox interface évolution.

Que faut-il en penser ? Résolu ?

Rq: ma TV en mode plein écran le bas de la vidéo est légèrement tronquée (la deuxième ligne de sous-titre est coupée en deux mais c'est peut-être déjà le cas quand on la regarde sur un PC)
Bon pour l'instant je fais mumuse avec ubuntu pour me familiariser avec minidlna mais mon but est de l'installer sur mon NAS MyBookWorld (blue ring) avec Ipkg comme je l'avais fait précédemment avec l'ancien médiacenter de la neufbox. Euh en cherchant deux seconde Ipkg ça n’existe plus ?

Hors ligne

#7 Le 22/03/2013, à 09:14

benjaminlaurent

Re : Lancement de minidlna

Bon,
Comme je n'avais pas beaucoup de temps à y consacrer, j'ai rien changé et je me suis juste contenté de redémarrer le netbook.
Une fois démarré

sudo /etc/init.d/minidlna status
minidlna is NOT running

Jusque là rien de changé.
Ensuite j'ai fais un petit:

sudo /etc/init.d/minidlna stop

au cas où. La commande est passée sans gueuler !
Et ensuite dans une logique de droit au but j'ai balancé un:

sudo minidlna -d -f /etc/minidlna.conf -R

là faut savoir lire la matrice car ça défile très vite mais on dirait bien qu'il n'y avait pas de problème et qu'il scannait tout le répertoire de médias !
Puis plus rien ne s'ajoutait à l'écran.
Je me suis dirigé vers la télé et j'ai pu utiliser le médiacenter neufbox interface évolution.

Que faut-il en penser ? Résolu ?

Rq: ma TV en mode plein écran le bas de la vidéo est légèrement tronqué (la deuxième ligne de sous-titre est coupée en deux mais c'est peut-être déjà le cas quand on la regarde sur un PC)
Bon pour l'instant je fais mumuse avec ubuntu pour me familiariser avec minidlna mais mon but est de l'installer sur mon NAS MyBookWorld (blue ring) avec Ipkg comme je l'avais fait précédemment avec l'ancien médiacenter de la neufbox. Euh en cherchant deux seconde Ipkg ça n’existe plus ?

Hors ligne

#8 Le 22/03/2013, à 09:39

grandtoubab

Re : Lancement de minidlna

benjaminlaurent a écrit :

Bon,
Comme je n'avais pas beaucoup de temps à y consacrer, j'ai rien changé et je me suis juste contenté de redémarrer le netbook.
Une fois démarré

sudo /etc/init.d/minidlna status
minidlna is NOT running

?

Salut
Au risque de répéter si tu veux que minidlna démarre automatiquement il faut démasquer le daemon dans /etc/default/minidlna
http://forum.ubuntu-fr.org/viewtopic.ph … #p11967371

@ubuntu-desktop:~$ ps -edf | grep minidlna
root      1515     1  0 Mar21 ?        00:00:01 /usr/bin/minidlna -f /etc/minidlna.conf -P /var/run/minidlna/minidlna.pid

Dernière modification par grandtoubab (Le 22/03/2013, à 09:59)


Linux tout seul sur le disque dur  Acer Aspire T650 :=))
RAM: 1,7 Gio, CPU: Intel® Pentium(R) 4 CPU 3.06GHz × 2. Carte graphique Gallium 0.4 on ATI RC410 (Radeon Xpress200)
Partition 1: Debian Jessie & Gnome Version 3.12, Kernel  3.16.3-031603-generic
Partition 2: Ubuntu Trusty 14.04 & Unity

Hors ligne

Haut de page ↑