Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 22/03/2013, à 16:18

grod

[Resolu]#1045 Connexion au serveur MySQL non permise

Bonjour,

Comme le sujet le dit, #1045 Connexion au serveur MySQL non permise.... mais en root ça marche..?!
Je viens d'installer apache2, subversion, et mysql, phpmyadmin sur mon ubuntu 12.10 32bits (serveur dédié virtualisé chez ovh), super tout marche.

Petit problème : j'accède sans soucis à mysql via phpmyadmin en root depuis un autre ordi, mais si j'utilise un autre utilisateur que je viens de créer, là non. j'ai l'erreur 1045.
j'ai demandé au serveur de me lister la table user, elle n'existe pas. Bizar non? Est ce que ça viendrait de là?

select host , user from user;
ERROR 1146 (42S02): Table 'papdb.user' doesn't exist

une idée? merci

Dernière modification par grod (Le 22/03/2013, à 19:02)

Hors ligne

#2 Le 22/03/2013, à 17:40

Kooothor

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

ta requête SQL comme tu l'as écrite ici est fausse.


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

En ligne

#3 Le 22/03/2013, à 18:10

grod

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

merci Kooothor pour ta réponse laconique!
non ma requête n'est pas fausse... mais je n'avais pas sélectionné la bonne base (enfin je pense). ici j'ai fait un

use mysql;
select host, user from user;
+-------------+------------------+
| host        | user             |
+-------------+------------------+
| %           | chrys0l1d        |
| %           | papdbusr         |
| %           | usrpapdb         |
| 127.0.0.1   | root             |
| ::1         | root             |
| localhost   |                  |
| localhost   | debian-sys-maint |
| localhost   | root             |
| pap-vm |                  |
| pap-vm | root             |
+-------------+------------------+

Donc je reposte : j'ai bien mes utilisateurs (les trois premiers de la liste) : impossible de se connecter à la base avec ces users avec la commande 

mysql -u usrpapdb -p

Faut il faire un grant ou une autre déclaration?
Merci en tout cas

Hors ligne

#4 Le 22/03/2013, à 18:41

tiramiseb

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

Faut il faire un grant ou une autre déclaration?

Bah oui, si tu ne fais pas de GRANT sur tes utilisateurs ils n'auront aucun droit. Il faut leur donner le droit d'accéder à la base de donnée à laquelle tu veux qu'ils accèdent...

(et ce n'est probablement pas la base "mysql", qui est plutôt sensible)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 22/03/2013, à 18:53

grod

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

ok ça marche,
merci
voila le pb :
j'avais écris

grant all privileges on ma_base to 'nom_utilisateur'@'%' identified by 'mot_de_passe' WITH GRANT OPTION;
grant all privileges on ma_base to 'nom_utilisateur'@'localhost' identified by 'mot_de_passe' WITH GRANT OPTION;

au lieu de

grant all privileges on ma_base.* to 'nom_utilisateur'@'%' identified by 'mot_de_passe' WITH GRANT OPTION;
grant all privileges on ma_base.* to 'nom_utilisateur'@'localhost' identified by 'mot_de_passe' WITH GRANT OPTION;

merci

Hors ligne

#6 Le 22/03/2013, à 18:55

tiramiseb

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

'WITH GRANT OPTION' tu es sûr ? Ça donne à cet utilisateur le droit de donner des droits aux autres...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 22/03/2013, à 18:59

grod

Re : [Resolu]#1045 Connexion au serveur MySQL non permise

Tu as raison! Maintenant que ça marche je vais pouvoir affiner tout ça.

Hors ligne

Haut de page ↑