Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/11/2005, à 21:01

Cyme

[résolu]pb install drivers nvidia

Malgré de nombreuses recherches et autant d'essais infructueux, je n'ai toujours pas réussi à installer les drivers nvidia (les 7174 car j'ai une Geforce 2 qui n'est plus reconnue par les pilotes plus récents).
J'ai testé la méthode par synaptic avec les drivers legacy(ça a pas marché), puis la méthode manuelle trouvée dans ce forum. L'installation s'est lancée mais a planté. Si quelqu'un a une solution pour moi, je  suis preneur car je commence à desespérer. Voici ce que dit le fichier nvidia-installer.log
.
option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : false
  no questions            : false
  silent                  : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  force tls               : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : /usr/X11R6
  OpenGL install prefix   : /usr
  compat32 install prefix : (not specified)
  installer install prefix: /usr
  utility install prefix  : /usr
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : /usr/src/linux-headers-2.6.12-9
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
-> Using the kernel source path '/usr/src/linux-headers-2.6.12-9' as specified
   by the '--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/linux-headers-2.6.12-9'
-> Performing CC test with CC="gcc-3.4".
-> Performing rivafb check.
-> Cleaning kernel module build directory.
   executing: 'cd ./usr/src/nv; make clean'...
   rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
   agp.o os-interface.o os-registry.o nvidia.mod.o
   rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
   rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
   rm -f -rf .tmp_versions
-> Building kernel module:
   executing: 'cd ./usr/src/nv; make module SYSSRC=/usr/src/linux-headers-2.6.1
   2-9 SYSOUT=/usr/src/linux-headers-2.6.12-9'...
   
   NVIDIA: calling KBUILD...
   make CC=gcc-3.4  KBUILD_VERBOSE=1 -C /usr/src/linux-headers-2.6.12-9 SUBDIRS
   =/tmp/selfgz8714/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src/nv modules
   /bin/sh: /usr/src/linux-headers-2.6.12-9/scripts/gcc-version.sh: Aucun fichi
   er ou répertoire de ce type
   mkdir -p /tmp/selfgz8714/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src/nv/.tmp_vers
   ions
   
     WARNING: Symbol version dump /usr/src/linux-headers-2.6.12-9/Module.symver
   s
              is missing; modules will have no dependencies and modversions.
   
   make -f scripts/Makefile.build obj=/tmp/selfgz8714/NVIDIA-Linux-x86-1.0-7174
   -pkg1/usr/src/nv
   make[3]: scripts/Makefile.build: Aucun fichier ou répertoire de ce type
   make[3]: *** Pas de règle pour fabriquer la cible « scripts/Makefile.build
   ». Arrêt.
   make[2]: *** [_module_/tmp/selfgz8714/NVIDIA-Linux-x86-1.0-7174-pkg1/usr/src
   /nv] Erreur 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Erreur 1
   make: *** [module] Erreur 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Dernière modification par Cyme (Le 20/11/2005, à 21:03)

Hors ligne

#2 Le 17/11/2005, à 02:15

sylware

Re : [résolu]pb install drivers nvidia

As-tu bien installer le paquet "build essential" dans synaptic?

Hors ligne

#3 Le 17/11/2005, à 09:51

Cyme

Re : [résolu]pb install drivers nvidia

Il me semble que oui. Je vérifierai ce soir chez moi car je ne suis pas devant mon ordi. Mais comme j'ai suivi le tuto (en anglais) trouvé sur ce site, je crois que c'était indiqué donc ce doit être fait.

Hors ligne

#4 Le 17/11/2005, à 10:26

michel2652

Re : [résolu]pb install drivers nvidia

tu as le driver nVidia dans synaptic,
Installe les sources de ton kernel linux-headers-2.6.12-9, puis nvidia-glx nvidia-kernel-common nvidia-settings

sudo nvidia-config-glx enable

A+

Dernière modification par michel2652 (Le 17/11/2005, à 10:28)

#5 Le 17/11/2005, à 13:41

Cyme

Re : [résolu]pb install drivers nvidia

Hélas, j'ai déjà tenté cette méthode. Comme indiqué dans mon premier message, je suis obligé d'installer les drivers 7174 car j'ai une carte Geforce 2 qui n'est plus gérée par les derniers drivers fournis par défaut par Ubuntu.
Il y a bien les drivers nommés legacy mais leur install par synaptic a planté malgré  l'ajout de tous les paquets legacy que j'ai trouvés et la modif de xorg.conf. Actuellement, c'est l'install manuelle qui plante. Elle se lance bien avec la commande sudo sh NVIDIA... mais j'ai le message Unable to build the NVIDIA kernel module (les détails sont dans mon premier post).

Hors ligne

#6 Le 17/11/2005, à 15:13

FCDI

Re : [résolu]pb install drivers nvidia

je ne suis plus dans le meme cas que toi mais comme les drivers sous ubuntu ne sont pas a jour j'avais proceder avec cette methode

http://lea-linux.org/cached/index/Trucs:Installation_des_drivers_Nvidia_6xxx_10.1_Community_%27kernel_2.6.8.1-xx-mdk%29.html#

a tester donc

Hors ligne

#7 Le 17/11/2005, à 18:24

Cyme

Re : [résolu]pb install drivers nvidia

merci pour ta réponse FCDI. Je teste dès que je peux et je te tiens au courant.
Pour sylware, les paquets build essential sont bien installés!

Hors ligne

#8 Le 17/11/2005, à 20:48

Cyme

Re : [résolu]pb install drivers nvidia

ça y est, j'ai testé la méthode donnée par ton lien et... ça marche pas.
Au fait est-il normal que j'ai la version 686 de linux-image installée (en même temps que la version 386) alors que j'ai un proc AMD. La commande uname -r me renvoie : 2.6.12-9-686. Est-ce que c'est ça qui peut faire foirer l'install? J'ai essayé de desinstaller ce paquet mais synaptic refuse...(désolé si mes questions sont cons, mais je n'y connais pas grand chose)

Hors ligne

#9 Le 17/11/2005, à 21:10

michel2652

Re : [résolu]pb install drivers nvidia

Si tu as un AMD, il te faut soit le kernel 386, soit le K7: image +headers+restricted ---> remonter a la réponse n°4

#10 Le 17/11/2005, à 21:57

Cyme

Re : [résolu]pb install drivers nvidia

Merci à toi michel2652. L'installation des paquets pour AMD K7 m'a permis d'installer ces foutus drivers 7174 avec modif du fichier xorg.conf. Bizarrement, le logo NVIDIA ne s'affiche pas au démarrage mais cela semble fonctionner. Dernière question et j'arrête de t'embêter. Est-ce qu'une mise à jour automatique par synaptic modifiera le paquet kernel-common (j'ai du installer manuellement celui correspondant aux drivers 7174) et risque de planter mes drivers car le paquet dans synaptic est la version pour les drivers 7667?

Hors ligne

#11 Le 18/11/2005, à 09:34

michel2652

Re : [résolu]pb install drivers nvidia

Hum, si ça semble fonctionner et que tu n'as pas le logo nVidia au démarrage ( à moins que dans ton xorg.conf tu es une option No Logo) j'ai un doute....:(

As tu modifier la ligne driver "nvidia" dans ton xorg.conf ("nv" par défaut)

Lance glxgears pour voir les fps:

glxgears -iacknowledgethatthistoolisnotabenchmark

A+

#12 Le 18/11/2005, à 09:54

Cyme

Re : [résolu]pb install drivers nvidia

J'essaierai ça ce soir. J'ai bien remplacé nv par nvidia dans xorg.conf mais je n'ai pas rajouté l'option no logo! En tout cas, merci encore pour ton aide et à ce soir pour le résultat...

Hors ligne

#13 Le 18/11/2005, à 10:14

michel2652

Re : [résolu]pb install drivers nvidia

OK; je lirai ça Dimanche soir, WE prolongé de 3 jours (Merci Mr RTT) là :
http://www.hotel-port-helene.fr/hotel-a … yeres.jpg?
smile

A+

#14 Le 18/11/2005, à 20:16

Cyme

Re : [résolu]pb install drivers nvidia

voilà le résultat de glxgears :

7967 frames in 5.0 seconds = 1593.258 FPS
8791 frames in 5.0 seconds = 1758.109 FPS
8844 frames in 5.0 seconds = 1768.696 FPS
8850 frames in 5.0 seconds = 1769.911 FPS
8681 frames in 5.0 seconds = 1736.079 FPS

Alors est-ce OK?

Et as-tu la réponse à ma question sur la mise à jour automatique?

Merci d'avance et bon week-end.

Hors ligne

#15 Le 20/11/2005, à 20:27

michel2652

Re : [résolu]pb install drivers nvidia

Bonsoir,
Le résultat de glxgears me semble correct, moi j'ai :

~$ glxgears -iacknowledgethatthistoolisnotabenchmark
5390 frames in 5.0 seconds = 1077.866 FPS
5936 frames in 5.0 seconds = 1187.019 FPS
5914 frames in 5.0 seconds = 1182.056 FPS
5854 frames in 5.0 seconds = 1170.297 FPS
5928 frames in 5.0 seconds = 1185.592 FPS
5976 frames in 5.0 seconds = 1195.197 FPS

pour le "nvidia-kernel-common" je ne peux te répondre, mais lorsque tu fais tes mises à jour, tu peux ke décocher...

A+

#16 Le 20/11/2005, à 21:01

Cyme

Re : [résolu]pb install drivers nvidia

C'est quand même bizarre que ce logo ne soit pas présent au démarrage... Quoi qu'il en soit les drivers sont installés, je vais donc pouvoir editer mon post pour indiquer Résolu. Merci encore pour ton aide.

Hors ligne

#17 Le 20/11/2005, à 21:56

janno59

Re : [résolu]pb install drivers nvidia

michel2652 a écrit :

Hum, si ça semble fonctionner et que tu n'as pas le logo nVidia au démarrage ( à moins que dans ton xorg.conf tu es une option No Logo) j'ai un doute....:(

As tu modifier la ligne driver "nvidia" dans ton xorg.conf ("nv" par défaut)

Lance glxgears pour voir les fps:

glxgears -iacknowledgethatthistoolisnotabenchmark

A+

ya plus simple comme commande que glxgears -iacknowledgethatthistoolisnotabenchmark

glxgears -printfps

jean

Hors ligne

Haut de page ↑