Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/03/2013, à 00:15

Raptor039

Petit souci d'usage lors d'un transfert via USB

Bonsoir à toute la communauté !

Je viens vous voir car je rencontre un petit souci sous Ubuntu depuis que je l'utilise (version 10.10) et je n'ai jamais pris le temps de m'en occuper mais là j'ai 5 minutes à tuer alors pourquoi pas les utiliser à bon escient afin de rendre le système encore plus conviviale big_smile

En fait le souci est que lorsque je copie un fichier sur une clé USB (que ça soit de l'USB 3 ou 2), la barre de progression se remplit en moins de 10 secondes (on pourrait faire croire que GNU/Linux c'est géniale parce que les contrôleurs USB sont OC tongue) mais au bout de ces 10 secondes la barre de progression stagne genre à 99% jusqu'à que la copie en question se termine (sans lenteur notable selon moi, on va dire que c'est comme si la barre de progression avait progresser normalement justement). Je précise que le je rencontre ce problème sur mes 3 PC qu'ils soient portable ou fixe avec des ports USB 2 et ou USB 3 (idem pour les clés USB).

Vous allez me dire que ce n'est pas un souci très grave et c'est le cas. Mais je me suis permis de poster afin de trouver peut être une solution de quelqu'un ayant rencontrer le souci afin de, pourquoi pas, tenter de solutionner tout ça big_smile. En effet il serait plus commode de savoir ou en est notre transfert (en 2013 en tout cas ^^) au lieu d'attendre bêtement qu'il se finisse sans jamais savoir ou ça en est.

Voilà ma fois si quelqu'un a une idée à proposer, c'est avec joie que je me ferai plaisir de tester ça !

Bonne soirée à vous.

Amicalement, Raptor.

Hors ligne

#2 Le 26/03/2013, à 08:25

J5012

Re : Petit souci d'usage lors d'un transfert via USB

c'est l'habituel avec les memoires usb pas chers : le micro-controleur fourni avec n'est pas tres performant en vitesse d'ecriture ... quand la barre de progression se remplit tres vite, c'est l'action cache linux → cache micro-controleur mais apres linux il attend le signal de fin d'ecriture du micro-controleur pour fermer la fenetre de copie ...

Hors ligne

#3 Le 26/03/2013, à 11:08

Raptor039

Re : Petit souci d'usage lors d'un transfert via USB

Merci beaucoup pour ta réponse J5012.

Pourtant, je rencontre le souci avec une clé USB3 Patriot SuperSonic (qui d'après ce que j'ai pu en lire est loin d'être une clé USB bas de gamme) et avec mon disque dur externe 2.5" Western Digital.

Es tu donc sur que cela provienne des supports USB que j'utilise ?

Et une autre question, pourquoi ce phénomène ne se produit il pas sous Windows ?

Merci encore pour vos réponses !

Amicalement, Raptor.

Dernière modification par Raptor039 (Le 26/03/2013, à 11:08)

Hors ligne

#4 Le 26/03/2013, à 11:53

jibe

Re : Petit souci d'usage lors d'un transfert via USB

Salut,

Je ne vais pas trop me mouiller sur un sujet que je connais assez mal. Mais je pense pouvoir attirer l'attention sur quelques points.

Raptor039 a écrit :

une clé USB3 Patriot SuperSonic (qui d'après ce que j'ai pu en lire est loin d'être une clé USB bas de gamme)

Tu as lu ça où ? Sur le site du vendeur qui dit ça uniquement pour justifier son prix en te faisant croire qu'il est très avantageux, ou sur un site sérieux et fiable qui n'a aucun intérêt à raconter des salades ? Le fait que des dizaines de vendeurs racontent à peu près la même chose et soient repris par des centaines de gens divers (que je ne traiterai pas de moutons pour rester politiquement correct tongue ) qui n'ont pas pris le temps de vérifier ne rend pas l'info plus véridique !

Raptor039 a écrit :

avec mon disque dur externe 2.5" Western Digital

Je n'utilise jamais ce genre de produit qui ne peut qu'attirer des ennuis. Ce n'est pas une question de marque ni même de qualité de fabrication, c'est une question de conception : un truc alimenté via la connectique USB qui est une des plus mal conçues et qui est limitée en intensité ne peut pas être fiable. Je n'utilise et ne conseille que des disques externes alimentés par une source séparée.

Raptor039 a écrit :

Et une autre question, pourquoi ce phénomène ne se produit il pas sous Windows ?

Windows et Linux, inévitablement, gèrent tout ça de manière différente. Que ce soit la taille des caches, la manière de les utiliser, peut-être même la manière de communiquer avec les supports ou la manière de calculer et d'afficher la progression, tout est différent. Il est donc normal que l'affichage ne soit pas identique !

Après, on peut troller longuement sur les avantages et inconvénients de chacun des choix, de chacune des méthodes. Personnellement, je n'attache que peu d'importance à l'affichage mais j'apprécie de pouvoir utiliser des supports de presque n'importe quel filesystem, ce que ne permet pas Windows. L'affichage n'est qu'un élément de confort - pas négligeable, certes, mais pas vital - alors que pouvoir utiliser n'importe quel filesystem est une question de liberté (surtout quand je dois payer pour qu'elle soit restreinte !).


Il y a deux manières de paraitre supérieur : en montrant sa valeur ou en dévalorisant les autres.

Hors ligne

#5 Le 26/03/2013, à 12:40

Raptor039

Re : Petit souci d'usage lors d'un transfert via USB

Merci pour ta réponse constructive, je vais essayer de me défendre ^^

- Pour ce qui est de la clé USB : voici un test que j'ai lu qui m'a fait l'acheter (j'hésitais avec une Corsaire). Je pense que le site est assez sérieux, étant informaticien, je me fit souvent à lui pour ce qui est des nouveautés.

- Pour ce qui est de mon disque dur, je me suis mal exprimé, c'est la marque du DD en lui même qui est WD, j'ai acheté le boitier à part (Icy Box) et monter le DD dedans, de plus je dispose d'une connectique double USB, 1 Data/Alim et 1 Alim seule (condition sinequanon selon moi pour les raisons que tu cite Jibe big_smile), donc il n'est pas limité par les 500mA d'un seul port USB.

- Je comprend bien que Windows et GNU/Linux fonctionnent pas du tout de la même manière. Et je ne troll pas Linux ou Windows, je trouve que ce sont deux familles de système d'exploitation très fonctionnelles, en tout cas j'aime utiliser les deux avec leurs avantages et leurs inconvénient c'est indéniable big_smile

Jibe a écrit :

Après, on peut troller longuement sur les avantages et inconvénients de chacun des choix, de chacune des méthodes.

Je ne pense pas que le problème que je cite soit un choix, je penserais plus à une mauvaise manière de gérer la barre de progression de la part de l'OS vis à vis des opérations qu'il effectue sur le périphérique.

Merci encore pour le temps que tu as pris pour me répondre.

Pour conclure, on peut dire que, pardonnez moi si je me trompe, que ce petit souci d'affichage n'en est pas un ? Est ce que toi Jibe et toi J5012 (ou d'autre smile) rencontrez aussi ce phénomène ?

Amicalement, Raptor.

Dernière modification par Raptor039 (Le 26/03/2013, à 12:51)

Hors ligne

#6 Le 27/03/2013, à 19:50

J5012

Re : Petit souci d'usage lors d'un transfert via USB

Raptor039 a écrit :

Merci beaucoup pour ta réponse J5012.

Pourtant, je rencontre le souci avec une clé USB3 Patriot SuperSonic (qui d'après ce que j'ai pu en lire est loin d'être une clé USB bas de gamme) et avec mon disque dur externe 2.5" Western Digital.

Es tu donc sur que cela provienne des supports USB que j'utilise ?

Et une autre question, pourquoi ce phénomène ne se produit il pas sous Windows ?

Merci encore pour vos réponses !

Amicalement, Raptor.

le probleme ne vient pas du support usb ni de la gestion des pilotes (linux/windows) , quand je parle de micro-controleurs, il s'agit des microprocesseurs embarques sur la microcarte usb :
- dans une cle usb, tu as l'emballage ou boitier, puis dedans une micro-carte de l'ordre de qqs cm, dessus un micro-controleur qui ecrit et lit la memoire flash (fournie dans une puce a part, eh oui tout cela sur qqs cm) qui est de meme taille que celle labellisee sur le boitier de la cle usb.

c'est ce micro-controleur qui est "fautif" :
- avec linux et la facon dont ubuntu a de gerer la copie actuellement, c'est de faire confiance au peripherique donc au micro-controleur ...
- avec w il n'y a pas une telle "confiance", et la barre de progression est synchronisee sur l'etat d'ecriture du micro-controleur ...
- cette facon de gerer est propre a ubuntu qui fait "confiance" pour se porter sur d'autres taches plus importantes; je suis certain qu'avec arch par ex ca peut etre different ... je crois me souvenir que ce comportement lambinatoire sur ubuntu est apparu avec les nouvelles cles usb 4go pas cheres et la nouvelle interface unity ...

Hors ligne

#7 Le 28/03/2013, à 13:49

Raptor039

Re : Petit souci d'usage lors d'un transfert via USB

Merci encore pour ta réponse J5012.

J'avais compris pour ce qui est du micro-contrôleur. En revanche tu viens de me donner enfin la raison de ce souci et je t'en remercie.
Et si je puis me permettre, en effet c'est que depuis Unity que je rencontre ce souci, sous Maverick, je n'avais pas du tout ce soucis.

Je pense que j'ai la réponse à ma question en tout cas.

Merci à vous pour le temps que vous avez pu prendre pour me répondre.

Amicalement, Raptor.

Hors ligne

Haut de page ↑