Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#51 Le 24/03/2013, à 20:30

jil1

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour,

Cela fait des jours et des jours que je bataille pour essayer de faire fonctionner Vpnautoconnect. En vain.

Dès que je l'installe (sans même le faire fonctionner! et bien sûr, lorsque je le lance également), mes VPN se déconnectent et se reconnectent sans arrêt à intervalles de quelques secondes.
J'ai pourtant suivi à la lettre les tutos que j'ai pu trouver.

Tout redevient normal lorsque je le désinstalle.

J'ai essayé Vpnautoconnect 2.0.5, 2.1, 2.2 sur les disributions Mint 13, Xubuntu 12.04 et 12.10, Ubuntu 12.04.

Pourriez-vous m'aider SVP ? Y a-t-il une manipulation particulière à faire ?


P.S : je débute sous Linux

Hors ligne

#52 Le 25/03/2013, à 15:07

ljere

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

si je ne me trompe pas pour que ça fonctionne tu dois avoir un fichier config de ce type la

#VPNAutoconnect Config

[global]
FollowReconnectParent=yes
reconnectAfterDisconnectManual=no
HostToPing=google.fr
AddrToPingIfDNSDown=198.41.0.4,192.33.4.12
scriptEvenement=
ReconnectAfterTime=4000
listAppJail=logiciel-de-telechargement;/usr/bin/firefox;

[mon vpn]
connectionSupport=eth0

donne le retour de

cat ~/.vpnautoconnect/config

Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#53 Le 26/03/2013, à 17:07

jil1

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Salut

J'avais pas vu ta réponse. Donc, entre temps, j'ai désinstallé cette version et l'ai remplacée par la 2.0.4 nounity.
Je n'ai plus le déconnexions/reconnexions intempestives mais je ne sais pas si le logiciel fonctionne. En effet, j'ai fait des essais, dont un avec Transmssion. J'ai décoché volontairement "connecter automatiquement" dans la config du VPN pour voir si tout se coupait, résultat : ça continue à télécharger alors que je coupe le VPN. Et je peux continuer à surfer avec firefox alors que je ne devrais pas pouvoir.

Je te mets quand-même le résultat de la commande que tu voulais (je précise que j'ai enlevé Transmission de la liste des programmes à surveiller depuis mon dernier essai) :

#VPNAutoconnect Config

[global]
FollowReconnectParent=yes
reconnectAfterDisconnectManual=no
HostToPing=google.fr
AddrToPingIfDNSDown=198.41.0.4,192.33.4.12
scriptEvenement=
TimeoutBeforeSwitch=15
listAppJail=/usr/bin/firefox;

[++++++]
connectionSupport=Connexion filaire 1
listAppJailActivated=/usr/bin/firefox;

Dernière modification par jil1 (Le 26/03/2013, à 17:10)

Hors ligne

#54 Le 26/03/2013, à 19:20

ljere

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

tu as coché activé firefox d’après cette ligne

listAppJailActivated=/usr/bin/firefox;

décoche cette case et recommence tes essais
si j'ai bien compris cette option permet d'utiliser firefox par exemple alors que le vpn a sauté


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#55 Le 27/03/2013, à 19:13

jil1

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

tu as coché activé firefox d’après cette ligne

Exact. Mais j'ai aussi essayé avec cette case décochée : même résultat.

si j'ai bien compris cette option permet d'utiliser firefox par exemple alors que le vpn a sauté

Moi, j'avais compris qu'en cochant cette case, l'application avait le droit de se connecter au VPN, et par contre, plus le droit d'utiliser une quelconque autre connexion si le VPN tombait.

Bref, c'est pas clair pour moi...

Hors ligne

#56 Le 27/03/2013, à 19:26

ljere

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

je te rassure ça ne l'est pas plus pour moi


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#57 Le 27/03/2013, à 20:43

jil1

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Ceci dit, j'avoue que je préfèrerais régler ufw/gufw pour qu'il empêche tout trafic lorsque le VPN tombe, mais je n'ai pas assez de connaissances pour cela. J'ai par exemple essayé la commande "sudo ufw deny out on eth0", que j'ai croisée au cours de mes recherches, mais cela n'a eu absolument aucun effet (ça aurait été trop facile... tongue)

Hors ligne

#58 Le 27/03/2013, à 21:21

ljere

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

au lieu d'essayer des commandes aux hasard je te conseille

man ufw

Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#59 Le 28/03/2013, à 19:01

jil1

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Je parlais plutôt d'un manque de connaissances en réseaux. Le pare-feu n'est ensuite qu'un outil destiné à traduire ces connaissances.

Mais je suppose que des conseils là-dessus doivent faire l'objet de l'ouverture d'un autre fil...?

Hors ligne

#60 Le 28/03/2013, à 19:03

ljere

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

exactement wink


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#61 Le 30/03/2013, à 15:32

jean-luc5629

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour;
Merci à mastergb pour son pare-feu vpn; Sans doute que ce post va paraître déplacé ici, vu que le sujet essentiel traite de vpnautoconnect, soft que je n'utilise pas vu que je suis en no-graphic
J'ai par contre parcouru l'ancien fil, et la suite dans celui ci, plutôt à la recherche d'infos sur le firewall de mastergb, car ayant installé un petit serveur (vsftpd+rtorrent+rutorrent+apache+amule+openvpn...) sur une cubieboard (comme une raspberry pi mais avec connexion sata et 1Go de ram : http://www.exp-tech.de/Mainboards/Cubie … oard.html); j'ai fait un petit script vérifiant toutes les minutes openvpn et j'ai couvert le tout par le fameux firewall de mastergb; je ne suis pas un as du réseau, mais force de tests et de lecture j'arrive néanmoins à me débrouiller, et ça à l'air de fonctionner, testé rutorrent avec http://checkmytorrentip.com/ : tout est ok.
Mais je n'envoie pas ce post pour dire seulement que tout va bien, j'ai un petit problème sur lequel je bute, car ayant une ip dynamique j'utilise no-ip qui convertit l'ip externe attribuée par mon fai en :(xyz.myftp.biz ou xyz.serveftp.com ou xyz.sytes.net), j'ai donc installé le soft de no-ip et rentré le port 8245 demandé dans le firewall (sans doute pas parfaitement ...) lors de la config de no-ip j'ai bien précisé interface eth0 mais l'ip externe détectée par no-ip correspond à l'ip externe de mon vpn et non celle de mon fai, ce qui pose problèmes pour l'update en cas de changement d'ip.
Voici mon pare-feu :

#!/bin/sh
interfaceWWW="eth0"
interfaceVPN="tun0"
localIP="192.168.10.140"
network="192.168.10.0/24"
vpnPort1="443"
sshport="29561"
torrentPorts="23951,28306,28308,28311"
ftpportstart="40110"
ftpportend="40210"
serverport="80,443,8245"

# Rappel IPTables .
#
#           /----------\         /-------\         /-----------\
# IN--->---< PREROUTING >--->---< FORWARD >--->---< POSTROUTING >--->--OUT
#           \----------/         \-------/         \-----------/
#              \                                            /
#               \                                          /
#             /-----\         /-------------\         /------\
#            < INPUT >--->---< LOCAL PROCESS >--->---< OUTPUT >
#             \-----/         \-------------/         \------/

 start() {
# Dans cette partie, on met en place le firewall
#vidage des chaines
iptables -F INPUT
iptables -F OUTPUT
iptables -F FORWARD
iptables -Z INPUT
iptables -Z OUTPUT
iptables -Z FORWARD

#destruction des chaines personnelles
#stratégies par défaut

iptables -P INPUT DROP
iptables -P OUTPUT DROP
iptables -P FORWARD DROP

# boucle locale 

iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT 

#on accepte tout le réseau local :)
iptables -A INPUT -s $network -j ACCEPT
iptables -A OUTPUT -d $network -j ACCEPT
iptables -A FORWARD -s $network -j ACCEPT 

#on autorise toutes les connexions déjà etablies

iptables -A OUTPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

# ICMP
iptables -A OUTPUT -p icmp -o $interfaceWWW -j ACCEPT


#on autorise les connexions sortantes vers le VPN sur interfaceWWW pour initialiser les connexions VPN
iptables -A OUTPUT -p TCP --dport $vpnPort1 -m state --state NEW -o $interfaceWWW -j ACCEPT

#on accepte tous les débits sur le port 80...443 https... venant d'internet (serveur APACHE)
iptables -A INPUT -p TCP -m multiport --dports $serverport -m state --state NEW  -i $interfaceWWW -j ACCEPT
iptables -A INPUT -p UDP -m multiport --dports $serverport -m state --state NEW  -i $interfaceWWW -j ACCEPT

#VSFTPD
iptables -A INPUT -p TCP -m multiport --dports $ftpportstart:$ftpportend -m state --state NEW  -i $interfaceWWW -j ACCEPT
iptables -A INPUT -p UDP -m multiport --dports $ftpportstart:$ftpportend -m state --state NEW  -i $interfaceWWW -j ACCEPT


## SSH
iptables -A OUTPUT -p TCP --dport $sshport -m state --state NEW -o $interfaceWWW -j ACCEPT

### P2P
iptables -A INPUT -p TCP -m multiport --dports $torrentPorts -m state --state NEW -i $interfaceVPN -j ACCEPT


#on autorise les connexions sortantes sur le VPN
iptables -A OUTPUT -m state --state NEW -o $interfaceVPN -j ACCEPT

#on autorise les connexions sortantes vers le 25 sur interfaceWWW
iptables -A OUTPUT -p TCP --dport 25 -m state --state NEW -o $interfaceWWW -j ACCEPT

#on autorise les DNS sortantes pour initialiser la connexion : port 53
iptables -A OUTPUT -p UDP --dport 53 -m state --state NEW -o $interfaceWWW -j ACCEPT

echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter
echo 0 > /proc/sys/net/ipv4/conf/$interfaceWWW/rp_filter
ip rule add fwmark 0x1 table connection

#on fait passer les connections SMTP et no-ip sur la connection internet standard
iptables -t mangle -A OUTPUT -p tcp -m multiport --dports 25,8245 -j MARK --set-mark 0x1
iptables -t nat -A POSTROUTING -o $interfaceWWW -p tcp -m multiport --dports 25,8245 -j SNAT --to $localIP


}
 

 
 stop() {

     iptables -P INPUT ACCEPT
     iptables -P FORWARD ACCEPT
     iptables -P OUTPUT ACCEPT
     iptables -F
 }
  
 case "$1" in
  start)
         start
         ;;
  stop)
         stop
         ;;
 restart)
         stop && start
         ;;
 *)
         echo "Usage $0 {start|stop|restart}"
         exit 1
 esac
  
 exit 0

Dernière modification par jean-luc5629 (Le 30/03/2013, à 15:34)

Hors ligne

#62 Le 30/03/2013, à 17:00

jean-luc5629

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

J'ai omis de rajouter :
-Je configure no-ip sur l'interface eth0:

root@cubie:~# /usr/local/bin/noip2 -C

Auto configuration for Linux client of no-ip.com.

Multiple network devices have been detected.

Please select the Internet interface from this list.

By typing the number associated with it.
0       eth0
1       tun0
0

Et dans le fichier no-ip2.conf, c'est bien eth0 qui est validé
Je lance no-ip puis affiche des infos...

root@cubie:~# /usr/local/bin/noip2 -S
1 noip2 process active.

Process 27804, started as noip2, (version 2.1.9)
Using configuration from /usr/local/etc/no-ip2.conf
Last IP Address set 83.149.126.77
Account xxxxx@yyyyy.net
configured for:
        host  xyz.myftp.biz
        host  xyz.serveftp.com
        host  xyz.sytes.net
Executing username=xyz..... upon successful update.
Updating every 30 minutes via /dev/eth0

Le problème c'est que 83.149.126.77 est l'ip externe du VPN et non celle de mon FAI qui est nécessaire pour la MAJ ne no-ip
Extrait du readme de no-ip:

COMMENT UTILISER LE CLIENT SANS LIRE LE RESTE DU TEXTE

Operation usuelle?
/usr/local/bin/noip2 -C       configure un client
/usr/local/bin/noip2          Lance un client
/usr/local/bin/noip2 -S       affiche des infos sur les clients lances
/usr/local/bin/noip2 -D pid   change l'etat de debug pour le client pid
/usr/local/bin/noip2 -K pid   termine le client pid

Si vous etes derriere un parefeu, vous devrez avoir besoin d'autoriser le port
8245 (TCP) dans les deux directions.

Et bien sur si je coupe mon vpn no-ip fonctionne et donne bien l'ip de mon fai.

Merci d'avance pour votre aide.

Dernière modification par jean-luc5629 (Le 30/03/2013, à 19:14)

Hors ligne

#63 Le 11/04/2013, à 09:17

mastergb

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bon je vois que le thread a bougé entre temps. Je suis sur un énorme projet qui me prend tout mon temps.
jean-luc5629> tes règles me paraisse bonnes mais il manque un détails important.
Le règles routings
As tu completé le fichier /etc/iproute2/rt_tables

As tu completé le fichier /etc/network/if-up.d/vpn ?

Pour une reponse rapide envoyez moi un petit PM même pour dire "Eh je viens de poster HELP ME"
Je recois un mail et je viendrai vous répondre aussitot wink

jil1> n'essaie pas de faire marcher apparmor depuis la nouvelle version il ya d'énorme restriction qui vont me pousser a retirer la fonctionnalité hmm

Dernière modification par mastergb (Le 11/04/2013, à 09:20)

Hors ligne

#64 Le 11/04/2013, à 09:42

jean-luc5629

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour & merci mastergb;
Voici les fichiers que j'avais omis de joindre :

#/etc/iproute2/rt_tables

#
# reserved values
#
255	local
254	main
253	default
0	unspec
#
# local
#
#1	inr.ruhep
1     connection


#/etc/network/if-up.d/parefeu

#!/bin/sh
#
set -e
if [ "$IFACE" = eth0 ]; then

/sbin/ip route add 192.168.10.0/24 dev eth0 src 192.168.10.140 table connection
/sbin/ip route add default via 192.168.10.254 table connection
/sbin/ip rule add from 192.168.1.140 table connection

fi


#/etc/network/if-down.d/parefeu

#!/bin/sh
#
set -e
if [ "$IFACE" = eth0 ]; then

/sbin/ip route del 192.168.10.0/24 dev eth0 src 192.168.10.140 table connection
/sbin/ip route del default via 192.168.10.254 table connection
/sbin/ip rule del from 192.168.10.140 table connection

fi

A++++

Hors ligne

#65 Le 11/04/2013, à 18:51

jean-luc5629

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Re;
J'ai modifié ces lignes :

iptables -t mangle -A OUTPUT -p tcp -m multiport --dports 25,80,8245 -j MARK --set-mark 0x1
iptables -t nat -A POSTROUTING -o $interfaceWWW -p tcp -m multiport --dports 25,80,8245 -j SNAT --to $localIP

pour y rajouter le port 80, pour pouvoir utiliser inadyn au lieu du soft de no-ip; mais résultat toujours négatif, inadyn va chercher mon ip externe chez : checkip.dyndns.org.
et si je fais en ligne de commande : wget http://checkip.dyndns.org -O - -o /dev/null | cut -d : -f 2 | cut -d \< -f 1
c'est l'ip netherland du vpn qui ressort en réponse.
Donc le port 80 passe via le vpn ....
A++++

Hors ligne

#66 Le 17/04/2013, à 13:43

Ansuz

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour,

Sous 12.10 et la v2.2, ça devrait fonctionner.
Est-ce que le VPN fonctionne ? Est-ce que ton adresse IP change lorsqu'il est activé ?

La partie [global] semble correcte, mais dans [openvpn] tu devrais avoir une interface de connexion, pas ton nom d'utilisateur, du style connexion support = auto eth0 ou = auto eth1 par exemple.

Lorsque tu déconnectes le VPN, la connexion ne devrait plus être active si tu as bien configuré ton parefeu.
http://forum.ubuntu-fr.org/viewtopic.ph … 7#p3492097 (post #78 et la suite...)

Sinon, n'hésites pas à envoyer un mail à mastergb en cas de difficultés... wink


"Tout ce qui est impossible, reste à accomplir" Jules Verne

Hors ligne

#67 Le 29/04/2013, à 19:09

Ansuz

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour à tous,

Quelqu'un a-t-il testé le couple Ubuntu 13.04 et vpnautoconnect 2.2 ?
Est-ce que l'ensemble fonctionne sans souci particulier ?

Au plaisir de vous lire.


"Tout ce qui est impossible, reste à accomplir" Jules Verne

Hors ligne

#68 Le 29/04/2013, à 20:40

lynn

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Salut Ansuz,

Vpnautoconnect 2.2 fonctionne sans soucis avec Ubuntu 13.04. ( Et ce, depuis la version instable d'Ubuntu 13.04 smile )


lynn

Linux est la solution ! Au fait, c'est quoi ton problème ?
Ubuntu 14.04 64 bits

Hors ligne

#69 Le 01/05/2013, à 09:29

Ansuz

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Salut Lynn,

Oui, après migration, je confirme que vpnautoconnect fonctionne parfaitement sous 13.04. wink


"Tout ce qui est impossible, reste à accomplir" Jules Verne

Hors ligne

#70 Le 29/05/2013, à 10:14

pascal.bzh

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour!

vpnautoconnect ne marche pas du tout chez moi sous ubuntu 13.4, malgrés les meme manip, meme config que sous les versions ubuntu précédentes ou vpnautoconnect fonctionnait trés bien.

voila!

Hors ligne

#71 Le 29/05/2013, à 10:51

Ansuz

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Salut pascal.bzh,

Marche pas du tout sous 13.04, Peux-tu détailler davantage ? (malgré les mêmes manip ???)
Si je comprends bien, tu avais vpnautoconnect installé sur une version antérieure d'ubuntu qui fonctionnait, et maintenant ce n'est plus le cas sous 13.04.
Logiquement, tu n'as aucune manipulation à effectuer, chez-moi ça à fonctionné de suite, sans aucune autre forme de procès.


"Tout ce qui est impossible, reste à accomplir" Jules Verne

Hors ligne

#72 Le 29/05/2013, à 11:57

pascal.bzh

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

bonjour Ansuz!

1) je suis chez ipjetable pour le vpn, configuration de mon vpn pas de probleme en manuel il marche tres bien.

2) installation de vpnautoconnect 2.2 sans souci adresse ip du vpn afffiché 188.121...etc
adresse MAC invisible ok
interface ppp0 (ok)

préferences de vpn autoconnect

onglet général : suivre le parent et reconnecter (coché ok)
                          reconnecter auto après deconnection manuelle (coché ok)
                          ip si DNS echoué 198.41.0.4,192.33.4.12
                          reconnect after (ms):  4000
                          scrip d'évenement (aucun)

options apparmor (rien pour l'instant)

troisieme onglet du vpn : connection parente (eth0) 00:23:AE:1C...etc
                                        connection vpn ipjetable (ok)

programme autorisé (aucun pour l'instant)

pour résumer la chose, si pour les test vpn connecté + vpnautoconnect lancé je débrance mon cable ethernet puis le rebranche , vpnautoconnect ne ce re-connect pas (ce qui fonctionnait pourtant tres bien sous ubuntu 12.04 et 12.10 avant.

quand je vais dans l'apparmor ou ce trouve l onglet général  connection 00:23:AE:1C...etc (eth0)
- se connecter automatiquement à ce réseau si disponible (coché)
-tous les utilisateur peuvent se connecter à ce réseau (décoché)
-se connecter automatiquement au vpn lorsque cette connexion et utilisée (coché) et juste en dessous ipjetable est affiché donc vu par l'apparmor

est il possible que les processus de connections ne ce déclenche pas dans le bonne ordre c est a dire qu'un process. essaye de demarrer le vpn avant la connection réseau?

je suis un utilisateur depuis un peu moins d un ans de ubuntu (trés satisfait)et je ne suis pas tres famillié avec les lignes de codes mais j'arrive a peut prés à les copier

Cordialement

Pascal

Hors ligne

#73 Le 19/10/2013, à 13:20

Ansuz

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour à tous,

Depuis hier, suite à la migration 13.04 vers 13.10, petit souci avec vpnautoconnect : (2.2.Oubuntu6)
Au démarrage, icône vpnautoconnect présente dans le systray, mais le vpn ne démarre plus automatiquement.
Je n'ai pourtant rien changé à mes réglages précédents, donc je suis contraint de le démarrer le vpn manuellement.

Fait étrange également, je ne trouve plus l'option "connecter automatiquement". Je me souviens de celle-ci, mais plus moyen de mettre la main dessus...
Désolé, quelqu'un pourrait-il me rappeler où se trouvait cette coche ?

J'ai essayé de désinstaller vpnautoconnect, puis de le réinstaller. Après reboot, aucun changement, je dois connecter le vpn manuellement.


"Tout ce qui est impossible, reste à accomplir" Jules Verne

Hors ligne

#74 Le 19/10/2013, à 13:36

lynn

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bonjour Ansuz,

Je croyais que ça venait de chez moi mais apparemment non... Des spécifications techniques ont certainement changé dans la version 13.10.

Attendons que mastergb passe par ici et nous éclaire sur ce dysfonctionnement. tongue


lynn

Linux est la solution ! Au fait, c'est quoi ton problème ?
Ubuntu 14.04 64 bits

Hors ligne

#75 Le 20/10/2013, à 01:20

lynn

Re : Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!)

Bon, j'ai désinstallé complètement vpnautoconnect et j'utilise la fonction vpn de network-manager.mini_131020010408410444.png

Mais ça ne fonctionne pas au démarrage... nm-applet m'affiche : "aucune connexion" Il faut redémarrer network-manager à la main ou bien utiliser nmcli.
Dans un script, j'ai mis ça :

#!/bin/bash
IFACE=eth0

nmcli con down id $IFACE
  sleep 2
nmcli con up id $IFACE

exit 0

et j'ai mis un lanceur dans "applications au démarrage".
mini_131020011215557768.png

Alors bien sûr, ça ne reconnecte pas le vpn en cas de coupure, ce n'est pas très joli mais au moins ça se lance tout seul au démarrage du pc. En attendant mieux tongue


lynn

Linux est la solution ! Au fait, c'est quoi ton problème ?
Ubuntu 14.04 64 bits

Hors ligne

Haut de page ↑