Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 23/03/2013, à 14:00

gisclace

Problème Samba (ou pas !!!)

Bonjour à tous,
J'ai un petit soucis que je n'arrive pas à résoudre, je viens de réinstaller un Ubuntu serveur, y ai mis tout mon bazar et ai configuré un partage Samba.

Sous Windows, et Xbmc, pas de soucis j'arrive à me connecter aux dossiers partagés par contre avec mon ubuntu j'ai le bon vieux message d'erreur suivant :

Impossible de monter l'emplacement
L'obtention de la liste des partages du serveur a échoué

Voila en gros mon installation :
ubuntu serveur : fichier Samba (commande testparm -s) :

[serveur]
	force user = nobody
	read only = No
	create mask = 0777
	force create mode = 0777
	directory mask = 0777
	force directory mode = 0777
	guest ok = Yes
	sync always = Yes
	locking = No
	delete readonly = Yes

Celui-ci à été généré par webmin, et voici celui que j'ai fait à la mano :

[samba-partage]
	comment = Données du serveur
	path = /home/bip
	read only = No
	guest ok = Yes
	hosts allow = 192.168.1.

Les deux sont accessible. (hormis par ubuntu hein )

Sur mon ubuntu :
Dans explorer le réseau j'ai : mon nas (ok en accès), openelec (raspberry avec xbmc, ok en accès), ma box (sfr, ok en accès) et réseau windows

Dans réseau windows, j'ai WORKGROUP qui contient tout les systèmes enregistrés dans le partage WORKGROUP (y compris mon partage samba Ubuntu serveur)

Je pense donc que cela ne vient pas de l'ubuntu serveur mais plutôt de l'ubuntu, mais rien à faire...

Merci d'avance si quelqu'un à une idée.

Hors ligne

#2 Le 25/03/2013, à 10:32

remi82

Re : Problème Samba (ou pas !!!)

Bonjour gisclace,

Sur ton poste client ubuntu, as-tu bien smbfs (cifs) et smbclient d'installé ?


www.aidememoire.info
Forum qui me sert d'aide mémoire. Mais autant partager

Hors ligne

#3 Le 25/03/2013, à 14:58

gisclace

Re : Problème Samba (ou pas !!!)

Bonjour remi82

Oui ces outils sont bien installés et fonctionnel

Hors ligne

#4 Le 25/03/2013, à 15:17

remi82

Re : Problème Samba (ou pas !!!)

As-tu essayer de les monter via le terminal ?

mount -t cifs -o username=ton_nom_utilisateur //ip_du_serveur/nom_du_partage /mnt

Ne met pas l'option -o si tu n'as pas de nom d'utilisateur sur tes partages.


www.aidememoire.info
Forum qui me sert d'aide mémoire. Mais autant partager

Hors ligne

#5 Le 25/03/2013, à 15:31

gisclace

Re : Problème Samba (ou pas !!!)

Oui j'ai essayé, j’obtiens un message d'erreur :

Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Hors ligne

#6 Le 25/03/2013, à 16:19

remi82

Re : Problème Samba (ou pas !!!)

Est-ce que ça fonctionne avec nautilus ? (avec l'interface graphique)


www.aidememoire.info
Forum qui me sert d'aide mémoire. Mais autant partager

Hors ligne

#7 Le 25/03/2013, à 16:58

gisclace

Re : Problème Samba (ou pas !!!)

Non ça ne fonctionne pas, je le vois mais ne peux l'ouvrir, j'ai le message d'erreur suivant :

Impossible de monter l'emplacement
L'obtention de la liste des partages du serveur a échoué

Hors ligne

#8 Le 25/03/2013, à 18:22

toutafai

Re : Problème Samba (ou pas !!!)

Bonsoir,

en ouvrant les ports se sera peut etre mieux ! Voir ici


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#9 Le 25/03/2013, à 18:33

gisclace

Re : Problème Samba (ou pas !!!)

J'y avais pensé... et ai donc rajouter les règles pour les ports en questions et ai même désactivé ufw pou vérifier si cela ne venait pas de là, mais non.

Hors ligne

#10 Le 25/03/2013, à 20:32

toutafai

Re : Problème Samba (ou pas !!!)

désactivé ufw ne sert à rien, y a toujours iptables (et netfilter) qui sont la....

retour de

sudo ufw status
smbtree

Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#11 Le 26/03/2013, à 02:03

gisclace

Re : Problème Samba (ou pas !!!)

Alors, pour :

sudo ufw status
État : actif

Vers                       Action      Depuis
----                       ------      ------
445                        ALLOW       Anywhere
139                        ALLOW       Anywhere
138                        ALLOW       Anywhere
137                        ALLOW       Anywhere
135                        ALLOW       Anywhere
445                        ALLOW       Anywhere (v6)
139                        ALLOW       Anywhere (v6)
138                        ALLOW       Anywhere (v6)
137                        ALLOW       Anywhere (v6)
135                        ALLOW       Anywhere (v6)

Par contre, smbtree de demande un mot de passe....étrange étant donné que j'ai testé tous les mots de passe que je peux avoir et qu'aucun ne semble marcher (cad, j'en tape un, et rien ne se passe)

Je précise que le mot de passe demandé n'est pas le root

bip@bip-ubuntu:~$ smbtree
Enter bip's password: 
bip@bip-ubuntu:~$ 

Edit :
Pour smbtree, j'ai rajouter les arguments -N et -b, ce qui me sort :

WORKGROUP
	\\STB01          		Neufbox
		\\STB01\IPC$           	IPC Service (Neufbox)
		\\STB01\PLAYLIST       	
		\\STB01\PERIPHERIQUES  	
		\\STB01\DISQUE_INTERNE 	
	\\OPENELEC       		OpenELEC
		\\OPENELEC\IPC$           	IPC Service (OpenELEC)
		\\OPENELEC\Logfiles       	
		\\OPENELEC\Media          	
		\\OPENELEC\Screenshots    	
		\\OPENELEC\Userdata       	
		\\OPENELEC\Configfiles    	
		\\OPENELEC\Emulators      	
		\\OPENELEC\Pictures       	
		\\OPENELEC\Downloads      	
		\\OPENELEC\Recordings     	
		\\OPENELEC\TV Shows       	
		\\OPENELEC\Music          	
		\\OPENELEC\Videos         	
		\\OPENELEC\Update         	
	\\BIP-UBUNTU     		bip-ubuntu server (Samba, Ubuntu)
		\\BIP-UBUNTU\Photosmart-C4400-series	HP Photosmart C4400 series
		\\BIP-UBUNTU\HP             	HP Photosmart c4400 nas
		\\BIP-UBUNTU\PDF            	PDF
		\\BIP-UBUNTU\HP-Photosmart-C4400-series	HP Photosmart C4400 series
		\\BIP-UBUNTU\IPC$           	IPC Service (bip-ubuntu server (Samba, Ubuntu))
		\\BIP-UBUNTU\print$         	Printer Drivers
	\\BIP-SERV       		bip-serv server (Samba, Ubuntu)
	\\BIP            		nas
		\\BIP\lp             	USB Printer
		\\BIP\IPC$           	IPC Service (nas)         	
		\\BIP\Volume_1       	
		\\BIP\videos         	
		\\BIP\tool           	
		\\BIP\musique        	
		\\BIP\photos

Quelques détails en plus :

    \\STB01                --> ça c'est la box     
    \\OPENELEC        --> ça c'est le raspebery avec xbmc           
    \\BIP-UBUNTU      --> ça c'est mon ubuntu avec lequel je n'arrive pas à me connécter
    \\BIP-SERV           --> ça c'est l'ubuntu serveur
    \\BIP                      --> ça c'est un nas

C'est dans BIP-SERV que je devrais trouver mon dossier de partage.

Dernière modification par gisclace (Le 26/03/2013, à 02:12)

Hors ligne

#12 Le 26/03/2013, à 20:07

toutafai

Re : Problème Samba (ou pas !!!)

tu peux aussi ouvrir le port 53 (qui aide pour la résolution de nom). il faut aussi ouvrir ces meme ports sur tous les pc de faisant partie de ton reseau local.

Donc si je comprend bien, c'est BIP-UBUNTU qui n'arrive pas à "voir les partages", c'est bien cela ?
Si oui, question :

es-ce que BIP-UBUNTU arrive à pinguer BIP-SERV ?
d'apres le retour de smbtree, il n'y a aucun partage sur BIP-SERV (ce que je trouve etonnant, vu que tu me dit que les autres pc voient les partage), donc :
donne ces retours :

cat /etc/samba/smb.conf #a faire sur BIP-SERV
cat /etc/samba/smb.conf #a faire sur BIP-UBUNTU

PS :
1/ a mon avis ton smb.conf de ton BIP-SERV n'est pas ok
2/ voila ce que j'ai comme smb.conf (je suis en samba 3.6.3)

[global]

	wide links = yes
	unix extensions = no
	workgroup = workgroup
	server string = %h server (Samba, Ubuntu)
	dns proxy = no
	log file = /var/log/samba/log.%m
	max log size = 1000
	syslog = 0
	security = share
	obey pam restrictions = yes
	invalid users = root
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
#======================= Share Definitions =======================
[printers]
	comment = All Printers
	browseable = no
	path = /tmp
	printable = yes
;	public = no
;	writable = No
	create mode = 0700
[jim-partage]
	path = /home/jim/partage
;	available = yes
;	browseable = yes
	guest ok = yes
	writeable = yes
	force user = jim
	comment = partage sur jim

[jim-public]
	path = /home/jim/public
;	available = yes
;	browseable = yes
	guest ok = yes
;	writeable = No
	force user = jim
	comment = public sur jim


[data]
	path = /media/data
	guest ok = yes
	writeable = yes
	force user = jim
	comment = partage sur data

Dernière modification par toutafai (Le 26/03/2013, à 20:07)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#13 Le 26/03/2013, à 20:56

gisclace

Re : Problème Samba (ou pas !!!)

Alors, j'ai ouvert le port 23, toujours pareille.

Oui c'est bien bip-Ubuntu qui ne voit pas le partage (il voit bien bip-serv mais pas les dossiers partagés)
C'est bizarre, sous ubuntu je peux pinger 192.168.1.33, par contre ça ne passe pas en pinguant bip-serv (alors que sous Windows ça marche avec les deux)

Pour le retour de :

cat /etc/samba/smb.conf

(je t'épargne les commentés et invalidés et met un lien pastebin si jamais tu as besoin du tout
Sous bip-ubuntu :

#======================= Global Settings =======================

[global]
   workgroup = WORKGROUP
   server string = %h server (Samba, Ubuntu)
   wins support = yes
   dns proxy = no
#### Networking ####
#### Debugging/Accounting ####
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
####### Authentication #######
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
########## Domains ###########
########## Printing ##########
############ Misc ############
   usershare allow guests = yes
#======================= Share Definitions =======================
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

Pastebin : http://pastebin.com/7pp7xw6i

Sous bip-serv :

#======================= Global Settings =======================
[global]
	log file = /var/log/samba/log.%m
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
	obey pam restrictions = yes
	socket options = TCP_NODELAY
	map to guest = bad user
	encrypt passwords = true
	passdb backend = tdbsam
	passwd program = /usr/bin/passwd %u
	dns proxy = no
	netbios name = bip-serv
	server string = %h server (Samba, Ubuntu)
	path = /home/bip/hd
	default = global
	unix password sync = yes
	workgroup = WORKGROUP
	os level = 20
	syslog = 0
	security = share
	usershare allow guests = yes
	panic action = /usr/share/samba/panic-action %d
	max log size = 1000
	pam password change = yes

## Browsing/Identification ###
#### Networking ####
#### Debugging/Accounting ####
####### Authentication #######
########## Domains ###########
########## Printing ##########
############ Misc ############

#======================= Share Definitions =======================
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
[serveur]
	writeable = yes
	locking = no
	delete readonly = yes
	force directory mode = 777
	sync always = yes
	force create mode = 777
	force user = nobody
	public = yes
	create mode = 777
	directory mode = 777
[samba-partage]
	locking = no
	writeable = yes
	delete readonly = yes
	path = /home/bip
	force directory mode = 777
	force create mode = 777
	comment = Données du serveur
	create mode = 777
	security = share
	public = yes
	directory mode = 777
[bip-serv]
	path = /home/bip/volume_1
;	available = yes
;	browseable = yes
	guest ok = yes
;	writeable = No
	force user = bip
	comment = public sur bip-ubuntu

Pastebin : http://pastebin.com/5R0syhFz

Notes que j'ai rajouté un dossier en partage en reprenant ton le schéma de ton conf, il est visible sur tous les posts hors bip-ubuntu.

Merci de ton aide

Hors ligne

#14 Le 26/03/2013, à 21:43

toutafai

Re : Problème Samba (ou pas !!!)

Ce n'est pas le port 23, mais le port 53 à ouvrir....
Il y a plein de truc inutile (voir bloquant) dans ton smb.conf...ex "wins support = yes", "netbios name=..."...le path qui n'as rien a faire dans la section global, le path qui n'est pas définit pas la section [partage].... bref, je te conseille de purger tout cela, et de refaire un smb.conf propre (sur le BIP-SERVER et sur BIP-UBUNTU) en t'appuyant sur mon exemple....

Ps : 1/ n'oublie pas de relancer samba pour que les modifications soient prise en compte avec un

sudo smbd restart

2/ un reboot des pc serveur et ubuntu (apres les modifications) peut aussi ne pas etre inutile (comme cela on est sur que tout est pris en compte)

Dernière modification par toutafai (Le 26/03/2013, à 21:45)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#15 Le 27/03/2013, à 11:39

gisclace

Re : Problème Samba (ou pas !!!)

Bon là je pète un câble (au sens propre je viens de péter un ethernet....)

J'ai remis à zéro les deux samba (sur bip-serv et sur bip-ubuntu) en prenant exemple sur ton smb.conf

Toujours pareille.

j'ai démarré un live ubuntu, et direct ça à marché, donc je dois avoir un truc d'installé qui bloque le tout...

La je ne vois pas trop où regarder...

ps : j'avais bien ouvert le 53 et non le 23

Edit :

Bon, je viens de tester (je me suis dit pourquoi pas essayer au cas ou) de monter le dossier via le terminal en utilisant mount.cifs et ça marche (je rappelle que ça ne marchait pas avant)
Par contre toujours impossible via nautilus...

Dernière modification par gisclace (Le 27/03/2013, à 11:45)

Hors ligne

#16 Le 27/03/2013, à 13:52

gisclace

Re : Problème Samba (ou pas !!!)

Bon, j'ai un autre soucis....mon ubuntu doit être vérolé par un trucs la....

Quand je monte mon dossier à la main, j'y ai accès mais ne peux pas modifier.

J'ai vérifié et c'est root qui est le proprio, j'ai voulu changer le propriétaire, mais ça ne veut pas.....

J'ai essayé par le terminale et en graphique (sudo nautilus) et aucune de ces deux méthodes de fonctionne.

Quand je navigue en SU pas de soucis dans le dossier de partage, je peux éditer ce que je veux.

Une idée ?


ps : le dossier et visualisable et éditable depuis d'autres posts donc ça ne doit pas venir de la conf du partage

Dernière modification par gisclace (Le 27/03/2013, à 13:53)

Hors ligne

Haut de page ↑