Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 12/03/2005, à 15:44

Funto

Monter un DD externe au démarrage

Bjr smile

Alors mon pb aujourd'hui, c'est que je possède 2 partitions formatées en FAT32 sur un disque dur externe branché en USB.
Je peux très bien les monter moi-même lorsque j'en ai besoin avec une ligne du genre :

root@home:/home/funto # mount /dev/sda1 /mnt/f -t vfat -o uid=funto

Je me suis donc dis que j'allais rajouter cette entrée à /etc/fstab pour que le DD soit monté au démarrage.

Seulement le pb c'est qu'apparemment au moment de démarrer, mo nDD n'est pas encore reconnu.
Problème...

Comment donc est-ce que je peux faire pour que mes 2 partitions (sda1 et sda5) soient montées au démarrage?

Merci d'avance wink

Hors ligne

#2 Le 13/03/2005, à 13:43

Funto

Re : Monter un DD externe au démarrage

arf apparemment personne ne sait...
Dommage sad

Merci qd même...

Hors ligne

#3 Le 13/03/2005, à 13:57

coffee

Re : Monter un DD externe au démarrage

faire en sorte que le montage des partitions USB soit monté par hotplug?


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#4 Le 13/03/2005, à 14:02

Olivier

Re : Monter un DD externe au démarrage

Cela m'étonne que fstab ne fonctionne pas pour monter ton DD externe, mais alors comme alternative dibouilleuse, je te propose de te faire un petit script de ta commande mount que tu lances au démarrage automatiquement... Ca marchera, comme ça qd tu démarres, il monte automatiquement...


Et Jean tua Madeleine. Ce fut à peu près vers cette époque que Madeleine perdit l'habitude de tromper Jean.  - A. Allais

Hors ligne

#5 Le 13/03/2005, à 14:22

coffee

Re : Monter un DD externe au démarrage

Le souci est que fstab monte les disques comme / /boot /home /usr ... tous les disques et ensuite hotplug peut lire ses fichiers et donc savoir comment crée les devices USB (donc au moment du premier fstab, les fichiers /dev/sdax n'existent pas)


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#6 Le 14/03/2005, à 21:05

Funto

Re : Monter un DD externe au démarrage

Je rajouterai aussi que j'avais tenté de créer un script comme ça :

sudo -s
mount /dev/sda1 /mnt/f -t vfat -o uid=funto

Quand je fais clic droit -> Lancer dans un terminal, le terminal s'ouvre, me demande mon mot de passe, puis je retombe sous root mais ma partition n'est quand même pas montée :'(

A part ça, même dans le cas où ça marcherait, pour exécuter un script au démarrage je fais comment?

Ah ouais aussi, est-ce que c'est normal que mes accès à mes partitions FAT32 sur mon DD USB soit aussi lents? Parce que là ça rame grave :'(

Hors ligne

#7 Le 14/03/2005, à 21:58

coffee

Re : Monter un DD externe au démarrage

ton script decryopté:

sudo -s

on devient root

mount /dev/sda1 /mnt/f -t vfat -o uid=funto

on monte /dev/sda1

bon la le souci, c'est un problème de thread (part pas en courant, tu vas comprendre)
Ton script instancie une demande d'espace pour s'executer, celui execute son contenu et lance ton sudo -s, tu rentres ton mdp et crée un shell root, à la fin de l'execution du shell root, il executera la commande mount. Hors ton script crée un espace terminal que tu vois pas... donc tu peux pas l'arreter, donc le mount n'est pas executer


root:                 / ---- (il devrait se passer des trucs mais non donc on attent donc script en attente )                 
                        /                                                                                                                                                                     
                      /                                                                                                                                                                         
user --- sudo -s                                                                                                                                                                   mount qui ne s'executera jamais


Pour que ça marche, il faut faire un

gksudo mount /dev/sda1 /mnt/f -t vfat -o uid=funto

Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#8 Le 15/03/2005, à 21:01

Funto

Re : Monter un DD externe au démarrage

Je dois avouer que j'ai du mal à comprendre...
sudo -s me crée un autre thread, appartement à root, mais mount n'est pas exécuté? Je comprends pas pourquoi...ce nouveau thread ne devrait-il pas l'exécuter en tant que root??

Par ailleurs, j'ai essayé avec gksudo mais, pour le script suivant :

#!/bin/sh
gksudo mount /dev/sda1 /mnt/f -t vfat -o uid=funto
gksudo mount /dev/sda5 /mnt/g -t vfat -o uid=funto

J'obtiens ceci :

funto@home:~/Desktop $ ./Monter
gksudo: option invalide -- o
GKsu version 1.2.0

Usage: gksudo [-u <user>] [-k] [-l] <command>

  --user <user>, -u <user>
    Calls <command> as the specified user
  --message <message>, -m <message>
    Replaces the standard message shown to ask for
    password for the argument passed to the option
  --title <title>, -t <title>
    Replaces the default title with the argument
  --icon <icon>, -i <icon>
    Replaces the default window icon with the argument
  --print-pass, -p
    Asks gksu to print the password to stdout, just
    like ssh-askpass. Useful to use in scripts with
    programs that accept receiving the passowrd on
    stdin.
  --disable-grab, -g
    Disables the "locking" of the keyboard, mouse,
    and focus done by the program when asking for
    password
  --ssh-fwd, -s
    Strip the host part of the $DISPLAY variable, so that
    GKSu will work on SSH X11 Forwarding.

  --login, -l
    Makes this a login shell. Beware this may cause
    problems with the Xauthority magic. Run xhost
    to allow the target user to open windows on your
    display!
  --preserve-env, -k
    Preserve the current environments, does not set $HOME
    nor $PATH, for example.

(2 fois car j'essaie de monter 2 partitions)

Hors ligne

#9 Le 15/03/2005, à 21:23

coffee

Re : Monter un DD externe au démarrage

#!/bin/sh
gksudo -t vfat -o uid=funto mount /dev/sda1 /mnt/f
gksudo -t vfat -o uid=funto mount /dev/sda5 /mnt/g

les options avant
le termes thread n'est peut etre pas bon, il instancie une session root et à la fin de cette session qui n'apparait pas de façon visible à l'écran) il lancera les commandes après

remplaçons ton sudo -s par une autre commande, par exemple un programme graphique comme firefox par exemple, ton script lance firefox, attend la fin d'execution de firefox et lancera ensuite le mount


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#10 Le 16/03/2005, à 20:41

Funto

Re : Monter un DD externe au démarrage

Mouais ok je vois mieux ce que tu veux dire...
Je trouve quand même ça curieux malgré tout, quand je fais un sudo -s sur ma console, normalement, qd le prog a fini de s'exécuter (ce qui est le cas dès que j'ai entré mon mdp) je suis tjs root...

Quant au code que tu viens de me passer, il ne fonctionne pas, ce qui en soi est logique : les -t vfat et -o uid=funto sont des arguments de mount, pas de gksudo, donc logiquement ils doivent se placer après le mount, pas avant...
Du coup j'ai toujours les mêmes erreurs:(

Hors ligne

#11 Le 17/03/2005, à 04:46

coffee

Re : Monter un DD externe au démarrage

oui je suis allé bcp trop vite en copier coller

gksudomount  -t vfat -o uid=funto  /dev/sda1 /mnt/f

sudo ne se termine pas quand tu as tapé ton mdp, il se termine lorsque tu as fini ta session root


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#12 Le 17/03/2005, à 21:01

Funto

Re : Monter un DD externe au démarrage

Comme tu peux le voir 3 msg plus haut, j'ai déjà testé cette solution et ça ne donne rien...

Hors ligne

#13 Le 17/03/2005, à 23:07

coffee

Re : Monter un DD externe au démarrage

J'ai du mal avec les copier coller moi
gksudo mount  -t vfat -o uid=1000  /dev/sda1 /mnt/f

Regarde la position des options, ça joue peut etre dans le mount., uid est un nombre.


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#14 Le 19/03/2005, à 14:02

Funto

Re : Monter un DD externe au démarrage

Oui bah j'avais rajouté l'espace entre gksudo et mount bien sûr (je sais qd même ce que je fais lol), mais comme je te l'ai dit dans le msg qui précède le dernier que tu viens de poster, j'avais déjà testé...

Hors ligne

#15 Le 21/03/2005, à 23:10

LiRYc

Re : Monter un DD externe au démarrage

mm pour faire dans le meme style :

gnome-sudo mount /dev/sda1 /mnt/removable

ou alors pkoi ne pas faire un script que tu place dans rc.d et que tu lances au level 5 ?

c'est pas une bonne idee ?

pour ton probleme de vitesse .... je ne sais pas ton port USB est bien reconu en USB2 ?

smile@plucH

Hors ligne

#16 Le 22/03/2005, à 20:37

Funto

Re : Monter un DD externe au démarrage

Ouais pr la vitesse, apparemment le HUB est reconnu en USB 1.1 (ce qui est peut-être le cas dans la réalité...), tandis que l'interface du DD est reconnue en USB 2...
J'essaierai de bidouiller les branchements ^^

Après, pour gnome-sudo, même combat qu'avec gksudo; d'ailleurs gnome-sudo est un fichier texte dont le contenu est :

#!/bin/sh

/usr/bin/gksudo "$@"

Ca veut tout dire ^^

J'ai essayé en virant l'option "-o" de mount, et là curieusement gksudo semble fonctionner...mais même pour root, la partition ne se monte quand même pas !!

Quant à ton rc.d et ton level 5...c'est quoi?:rolleyes:

Hors ligne

#17 Le 22/03/2005, à 23:26

LiRYc

Re : Monter un DD externe au démarrage

voici la liste des runlevels :

      0 — Arrêt
      1 — Mode texte mono-utilisateur
      2 — Non utilisé
      3 — Mode texte multi-utilisateurs complet
      4 — Non utilisé
      5 — Mode graphique multi-utilisateurs complet
      6 — Redémarrage

tu peux lire par ici :http://www.debian-fr.org/article.php?page=viewarticle&article=4 .
ceci dit je n'ai jamais essayer de monter un disque par la .. roll

mais de toutes facon lire un peut ne fait jamais de mal sous nux wink
@plucH

Hors ligne

#18 Le 24/03/2005, à 19:06

Funto

Re : Monter un DD externe au démarrage

Ouais je vois merci smile

Bon pr le pb du disque je réessaierai plus tard, ces temps-ci j'ai la flemme...

Merci à tous wink

Hors ligne

Haut de page ↑