Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 30/03/2013, à 12:50

goyou

desactiver eth0 avec ifconfig en permanence pour limiter consommation

Bonjour,

Récemment j'ai installé powertop pour surveiller la consommation de mon système.
En le lançant je me suis rendu compte que ma carte ethernet consomme 19 watts, soit bien plus que le reste du système, en plus ça fait chauffer mon pc méchamment. Et le plus marrant c'est que je ne me sers même pas de cette carte, j'utilise le wifi.

Avec lspci, le nom de mon controleur ethernet :
Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe (rev 10)

Donc je fais

sudo ifconfig eth0 down

mais je dois le faire a chaque fois que je redemarre.

J'ai cherché mais pas trouvé, il doit bien y avoir un fichier qui permet de sélectionner les périphériques à activer au démarrage.

Paramétrer un script qui désactive la carte à chaque ouverture de session ne me semble pas très propre du point de vue système.

--
(Pour info, dans mon fichier /etc/default/grub j'ai mis la ligne suivante :

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux pcie_aspm=force"

Pour activer l'aspm, cela à effectivement réduit ma consommation système.
)

Hors ligne

#2 Le 30/03/2013, à 12:57

fcn50

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Salut,

la commande c'est sudo ifdown eth0. Pour désactiver constamment eth0, poste ton /etc/network/interfaces.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 30/03/2013, à 13:07

BrunoGey

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Bonjour,

sinon, regardes dans ton bios, il doit y avoir une option pour désactiver/réactiver, l'éthernet, le wifi, le buetooth....

cdt

bruno

En ligne

#4 Le 30/03/2013, à 13:14

goyou

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

/etc/network/interfaces :

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

la commande sudo ifdown eth0 me répond :
ifdown: interface eth0 not configured

Hors ligne

#5 Le 30/03/2013, à 13:19

fcn50

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Tu es sous quelle version buntu, tu utilises network manager? Rajoute ceci en dessus de ce qu'il contient déjà avec une ligne d'espacement:

auto wlan0
iface wlan0 inet dhcp

Puis tu fais sudo ifdown wlan0 et sudo ifup wlan0 et poste le résultat.

Dernière modification par faucon50 (Le 30/03/2013, à 13:23)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#6 Le 30/03/2013, à 13:24

goyou

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Je suis sous Ubuntu 12.10 avex xfce + compiz
J'utilise NetworkManager (NetworkManager --version me donne 0.9.6.0)

Hors ligne

#7 Le 30/03/2013, à 13:42

fcn50

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Ok fais la manip de #5.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#8 Le 30/03/2013, à 13:47

goyou

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

En fait je n'ai pas de wlan0.

j'ai un eth0 que je veux désactiver,
eth1 c'est le wifi,
et un l0 qui est en 127.0.0.1, je ne sais pas a quoi ça sert

J'avais un wlan0 avant, c'était une clé usb wifi que je n'utilise plus maintenant.

Hors ligne

#9 Le 30/03/2013, à 14:01

goyou

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

Je crois comprendre, il faut mettre eth0 en option auto dans /etc/network/interfaces pour pouvoir le désactiver avec ifdown plutot que ifconfig.
C'est quoi iface et inet ?
Mais n'y a t'il pas plutot une OPTION=disabled à mettre dans le fichier ?

Hors ligne

#10 Le 30/03/2013, à 17:15

fcn50

Re : desactiver eth0 avec ifconfig en permanence pour limiter consommation

En principe tu devrais pouvoir configurer tout ça par NetworkManager... Je n'utilise pas ce genre de chose.

auto eth1
iface eth1 inet dhcp


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

Haut de page ↑