Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#26 Le 02/04/2013, à 11:59

xabilon

Re : Mise à jour de la distribution impossible

À mon avis tu es à cheval entre 2 versions. Essaye :

sudo apt-get dist-upgrade
sudo dpkg --configure -a

et pourquoi te logues-tu en root ? tu ne peux pas te loguer en tant qu'utilisateur ? Tu as activé le compte root ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#27 Le 02/04/2013, à 12:09

Siapran

Re : Mise à jour de la distribution impossible

je n'arrivais pas à ouvrir une interface graphique en tant qu'utilisateur donc j'ai essayé en tant que root.
plus précisément j'arrive à me loguer en utilisateur sur la console au démarrage mais je ne peux pas aller plus loin.

voici le retour des commandes:

root@siapran-laptop:~# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  linux-headers-3.0.0-32 linux-headers-3.0.0-32-generic
  linux-image-3.0.0-32-generic linux-libc-dev
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
19 not fully installed or removed.
Need to get 49,9 MB of archives.
After this operation, 2 109 kB disk space will be freed.
Do you want to continue [Y/n]? y
Get:1 http://fr.archive.ubuntu.com/ubuntu/ oneiric-updates/main linux-image-3.0.0-32-generic i386 3.0.0-32.51 [36,8 MB]
Get:2 http://fr.archive.ubuntu.com/ubuntu/ oneiric-updates/main linux-headers-3.0.0-32 all 3.0.0-32.51 [11,4 MB]
Get:3 http://fr.archive.ubuntu.com/ubuntu/ oneiric-updates/main linux-headers-3.0.0-32-generic i386 3.0.0-32.51 [872 kB]
Get:4 http://fr.archive.ubuntu.com/ubuntu/ oneiric-updates/main linux-libc-dev i386 3.0.0-32.51 [847 kB]
Fetched 49,9 MB in 42s (1 169 kB/s)                                            
(Reading database ... 288682 files and directories currently installed.)
Preparing to replace linux-image-3.0.0-32-generic 3.0.0-32.50 (using .../linux-image-3.0.0-32-generic_3.0.0-32.51_i386.deb) ...
Done.
Unpacking replacement linux-image-3.0.0-32-generic ...
dpkg: error processing /var/cache/apt/archives/linux-image-3.0.0-32-generic_3.0.0-32.51_i386.deb (--unpack):
 failed in write on buffer copy for backend dpkg-deb during `./boot/abi-3.0.0-32-generic': No space left on device
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.0.0-32-generic /boot/vmlinuz-3.0.0-32-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.0.0-32-generic /boot/vmlinuz-3.0.0-32-generic
Preparing to replace linux-headers-3.0.0-32 3.0.0-32.50 (using .../linux-headers-3.0.0-32_3.0.0-32.51_all.deb) ...
Unpacking replacement linux-headers-3.0.0-32 ...
Preparing to replace linux-headers-3.0.0-32-generic 3.0.0-32.50 (using .../linux-headers-3.0.0-32-generic_3.0.0-32.51_i386.deb) ...
Unpacking replacement linux-headers-3.0.0-32-generic ...
Preparing to replace linux-libc-dev 3.0.0-32.50 (using .../linux-libc-dev_3.0.0-32.51_i386.deb) ...
Unpacking replacement linux-libc-dev ...
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.0.0-32-generic_3.0.0-32.51_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@siapran-laptop:~# sudo dpkg --configure -a
Setting up initramfs-tools (0.99ubuntu8) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-libc-dev (3.0.0-32.51) ...
Setting up unattended-upgrades (0.73ubuntu1) ...
update-rc.d: warning: unattended-upgrades start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (none)
update-rc.d: warning: unattended-upgrades stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 6)
Checking for running unattended-upgrades: 
Traceback (most recent call last):
  File "/usr/share/unattended-upgrades/unattended-upgrade-shutdown", line 27, in <module>
    import apt_pkg
ImportError: No module named apt_pkg
invoke-rc.d: initscript unattended-upgrades, action "start" failed.
dpkg: error processing unattended-upgrades (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up linux-headers-3.0.0-32 (3.0.0-32.51) ...
Setting up mysql-server-5.1 (5.1.67-0ubuntu0.11.10.1) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.1; however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-software-properties:
 python-software-properties depends on unattended-upgrades; however:
  Package unattended-upgrades is not configured yet.
dpkg: error processing python-software-properties (--configure):
 dependency problems - leaving unconfigured
Setting up linux-headers-3.0.0-32-generic (3.0.0-32.51) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.0.0-32-generic /boot/vmlinuz-3.0.0-32-generic
dpkg: dependency problems prevent configuration of software-properties-gtk:
 software-properties-gtk depends on python-software-properties; however:
  Package python-software-properties is not configured yet.
dpkg: error processing software-properties-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-aptdaemon:
 python-aptdaemon depends on python-software-properties; however:
  Package python-software-properties is not configured yet.
dpkg: error processing python-aptdaemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apturl:
 apturl depends on software-properties-gtk; however:
  Package software-properties-gtk is not configured yet.
dpkg: error processing apturl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of software-center:
 software-center depends on python-aptdaemon (>= 0.40); however:
  Package python-aptdaemon is not configured yet.
dpkg: error processing software-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-aptdaemon.gtk3widgets:
 python-aptdaemon.gtk3widgets depends on python-aptdaemon (= 0.43+bzr697-0ubuntu1.3); however:
  Package python-aptdaemon is not configured yet.
dpkg: error processing python-aptdaemon.gtk3widgets (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xubuntu-desktop:
 xubuntu-desktop depends on software-center; however:
  Package software-center is not configured yet.
 xubuntu-desktop depends on software-properties-gtk; however:
  Package software-properties-gtk is not configured yet.
dpkg: error processing xubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-aptdaemon.gtkwidgets:
 python-aptdaemon.gtkwidgets depends on python-aptdaemon (= 0.43+bzr697-0ubuntu1.3); however:
  Package python-aptdaemon is not configured yet.
dpkg: error processing python-aptdaemon.gtkwidgets (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aptdaemon:
 aptdaemon depends on python-aptdaemon (= 0.43+bzr697-0ubuntu1.3); however:
  Package python-aptdaemon is not configured yet.
dpkg: error processing aptdaemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-aptdaemon-gtk:
 python-aptdaemon-gtk depends on python-aptdaemon.gtkwidgets (= 0.43+bzr697-0ubuntu1.3); however:
  Package python-aptdaemon.gtkwidgets is not configured yet.
 python-aptdaemon-gtk depends on python-aptdaemon.gtk3widgets (= 0.43+bzr697-0ubuntu1.3); however:
  Package python-aptdaemon.gtk3widgets is not configured yet.
dpkg: error processing python-aptdaemon-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xul-ext-ubufox:
 xul-ext-ubufox depends on apturl (>= 0.1.2ubuntu1) | apturl-kde; however:
  Package apturl is not configured yet.
  Package apturl-kde is not installed.
dpkg: error processing xul-ext-ubufox (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubufox:
 ubufox depends on xul-ext-ubufox; however:
  Package xul-ext-ubufox is not configured yet.
dpkg: error processing ubufox (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of language-selector-gnome:
 language-selector-gnome depends on aptdaemon (>= 0.40+bzr527); however:
  Package aptdaemon is not configured yet.
 language-selector-gnome depends on python-aptdaemon.gtk3widgets; however:
  Package python-aptdaemon.gtk3widgets is not configured yet.
dpkg: error processing language-selector-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sessioninstaller:
 sessioninstaller depends on aptdaemon (>= 0.30); however:
  Package aptdaemon is not configured yet.
 sessioninstaller depends on python-aptdaemon-gtk (>= 0.30); however:
  Package python-aptdaemon-gtk is not configured yet.
dpkg: error processing sessioninstaller (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of language-selector:
 language-selector depends on language-selector-gnome; however:
  Package language-selector-gnome is not configured yet.
dpkg: error processing language-selector (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-32-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.0.0-32-generic with 1.
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 unattended-upgrades
 mysql-server-5.1
 mysql-server
 python-software-properties
 software-properties-gtk
 python-aptdaemon
 apturl
 software-center
 python-aptdaemon.gtk3widgets
 xubuntu-desktop
 python-aptdaemon.gtkwidgets
 aptdaemon
 python-aptdaemon-gtk
 xul-ext-ubufox
 ubufox
 language-selector-gnome
 sessioninstaller
 language-selector
 initramfs-tools

Hors ligne

#28 Le 02/04/2013, à 12:19

xabilon

Re : Mise à jour de la distribution impossible

Comment as-tu fait de la place pour faire la mise à jour ? As-tu nettoyé avec sudo apt-get clean ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#29 Le 02/04/2013, à 12:27

Siapran

Re : Mise à jour de la distribution impossible

j'avais viré des jeux et des logiciels tiers qui ne me servaient plus (j'avais déjà fait un apt-get clean)

Hors ligne

#30 Le 02/04/2013, à 12:31

xabilon

Re : Mise à jour de la distribution impossible

Je dis ça pour cette erreur :

dpkg: error processing /var/cache/apt/archives/linux-image-3.0.0-32-generic_3.0.0-32.51_i386.deb (--unpack):
 failed in write on buffer copy for backend dpkg-deb during `./boot/abi-3.0.0-32-generic': No space left on device

mais là ça doit être la partition /boot qui est pleine... tu peux peut-être désinstaller de vieux noyaux plus utilisés ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#31 Le 02/04/2013, à 12:45

Siapran

Re : Mise à jour de la distribution impossible

houlà alors quand je lance synaptic il me sort ces erreurs et ferme:

E: Write error - write (28: No space left on device)
E: Can't mmap an empty file
E: Failed to truncate file - ftruncate (9: Bad file descriptor)
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

pour ce qui est du contenu de /boot

root@siapran-laptop:/boot# ls
abi-2.6.38-15-generic         memtest86+.bin
abi-2.6.38-16-generic         memtest86+_multiboot.bin
abi-3.0.0-32-generic          System.map-2.6.38-15-generic
config-2.6.38-15-generic      System.map-2.6.38-16-generic
config-2.6.38-16-generic      System.map-3.0.0-32-generic
config-3.0.0-32-generic       vmcoreinfo-2.6.38-15-generic
grub                          vmcoreinfo-2.6.38-16-generic
initrd.img-2.6.38-15-generic  vmcoreinfo-3.0.0-32-generic
initrd.img-2.6.38-16-generic  vmlinuz-2.6.38-15-generic
initrd.img-3.0.0-32-generic   vmlinuz-2.6.38-16-generic
lost+found                    vmlinuz-3.0.0-32-generic

Dernière modification par Siapran (Le 02/04/2013, à 12:48)

Hors ligne

#32 Le 02/04/2013, à 13:43

xabilon

Re : Mise à jour de la distribution impossible

Le 2.6.38-15 peut être désinstallé. Et la taille de ta partition /boot est un peu trop petite pour avoir plus de 2 noyaux installés.
Verifie la place disponible.

Après, je ne te cacherai pas que passer de la 10.04 à 11.10 puis à 12.04 dans ces conditions (paquet incohérent, place insuffisante...) c'est pas le top, et que tu devrais peut-être par ailleurs commencer à te pencher plus sérieusement sur ton problème de USB live (ou un CD live) pour réinstaller proprement, en agrandissant certaines partitions.

Dernière modification par xabilon (Le 02/04/2013, à 13:45)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#33 Le 04/04/2013, à 22:18

Siapran

Re : Mise à jour de la distribution impossible

Ma distribution avait complètement planté (Xorg ne voulait tout simplement plus se lancer) donc j'ai tout réinstallé avec l'excellent Cinnarch (Archlinux + Cinnamon)
Merci beaucoup tout de même d'avoir considéré mon problème =]

Hors ligne

Haut de page ↑