Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/11/2007, à 01:19

SaithamRent

kmail n'affiche pas bien les accents de certains mails

Salut a tous,

J'ai un probleme tres etrange.
Kmail n'affiche pas bien les accents de certains mails.  (c'est a dire que certains Emails ont les bons accents, d'autres des ? de partout)

J'ai teste les points suivants :

1) changer la langue du systeme - ca change que dalle

2) changer les options de visionnage sous Kmail (UTF -8 ou Iso 8859-1) sans resultats

3) j'ai verifie le header des emails en question, il y a bien 8859-1 de mentionne dedans.

Du coup je suis perdu !

Par ailleurs un locale renvoie

>locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"

ce qui ne sent pas bon

quelqu'un aurait une idee ?

Merci !!!

Edit : J'ai oublie de preciser le systeme : Kubuntu 7.10...

Dernière modification par SaithamRent (Le 11/11/2007, à 01:54)

Hors ligne

#2 Le 11/11/2007, à 11:28

bruno

Re : kmail n'affiche pas bien les accents de certains mails

A priori la langue du système ne joue pas sur l'affichage des courriers dans Kmail. Reprends quand me le point n°1 pour remettre ton système en fr_FR.

Si les en-têtes des messages précisent correctement l'encodage utilisé (par exemple : Content-Type: text/plain;
  charset="iso-8859-15" ), c'est sans doute un mauvais réglage de Kmail. Dans la configuration de Kmail > Apparence > onglet fenêtre des messages, j'ai :

encodage par défaut : iso8859-15
surcharger l'encodage : auto

Hors ligne

#3 Le 09/05/2009, à 17:13

lylian44

Re : kmail n'affiche pas bien les accents de certains mails

J'avais aussi ce problème.

Merci du tuyau, ça fonctionne bien chez moi !

Hors ligne

Haut de page ↑