Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/03/2013, à 04:21

echo-echo

[résolu] DD non reconnu a la cme mount

j'ai debranché le DD externe de mon ordi en cours d'utilisation.
Et depuis je ne peux pas l "ouvrir" via nautilus ou autre gestionnaire, c 'est a dire
qu'il n' apparaît pas lorsque je branche le DD

Et la commande mount affiche :

mount: ne peut repérer /sdb1 dans /etc/fstab ou /etc/mtab

Que passa ???

Dernière modification par echo-echo (Le 06/04/2013, à 23:48)

Hors ligne

#2 Le 28/03/2013, à 09:56

slasher-fun

Re : [résolu] DD non reconnu a la cme mount

Bonjour,

echo-echo a écrit :

Et la commande mount affiche :
mount: ne peut repérer /sdb1 dans /etc/fstab ou /etc/mtab

Quand tu dis "la commande mount", tu tapes juste "mount" ? Que renvoie "sudo fdisk -l" ?

Hors ligne

#3 Le 28/03/2013, à 12:21

echo-echo

Re : [résolu] DD non reconnu a la cme mount

j'ai essayé la commande  :mount /sdb1
et j' ai recu : mount: ne peut repérer /sdb1 dans /etc/fstab ou /etc/mtab


la commande mount m'indique ça :
~$ mount

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
nfsd on /proc/fs/nfsd type nfsd (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/etienne/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=etienne)
/dev/sdb1 on /media/C type vfat (rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush)


Et la cmde : sudo fdisk -l

Disque /dev/sda: 250.1 Go, 250059350016 octets
255 têtes, 63 secteurs/piste, 30401 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x0008ab88

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *           1       30141   242101248   83  Linux
/dev/sda2           30141       30402     2095105    5  Etendue
/dev/sda5           30141       30402     2095104   82  Linux swap / Solaris

Disque /dev/sdb: 4009 Mo, 4009754624 octets
23 têtes, 22 secteurs/piste, 15477 cylindres
Unités = cylindres de 506 * 512 = 259072 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1              17       15478     3911680    b  W95 FAT32


c'est bin le sdb1 qui pose pb ?

Hors ligne

#4 Le 28/03/2013, à 14:04

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

Ta partition ce n'est pas /sdb1, c'est /dev/sdb1...

Quel est le contenu du fichier /etc/fstab ?


PS : mets les contenus et les retours de commandes entre des balises "[ code ]", que tu obtiendras en cliquant sur l'icône "< >" au-dessus du champ où tu tapes tes réponses sur ce forum


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 28/03/2013, à 14:22

jamesbad000

Re : [résolu] DD non reconnu a la cme mount

Bonjour,
Dans le résultat de mount on voit ça :

/dev/sdb1 on /media/C type vfat 

Donc s'il s'agit bien du disque qui pose problème, qu'il n'apparait pas de média nommé C dans nautilus ou si tu ne peux l'ouvrir, c'est probablement parce qu'il n'a pas été ejecté proprement. Et il ne peut pas être remonté, puisqu'il est supposé déjà monté.

Donc après l'avoir déconnecté physiquement, commencer par essayer de le démonter :

sudo umount -fl /dev/sdb1

Dernière modification par jamesbad000 (Le 28/03/2013, à 14:24)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#6 Le 28/03/2013, à 14:24

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

Bien vu jamesbad000, je n'avais même pas regardé si c'était déjà monté smile

s'il s'agit bien du disque qui pose problème, qu'il n'apparait pas de média nommé C dans nautilus ou si tu ne peux l'ouvrir, c'est probablement parce qu'il n'a pas été ejecté proprement

J'ajoute juste ici que, si le disque est monté grâce à une ligne dans fstab, je ne suis pas sûr qu'il apparaîtra dans Nautilus d'une manière spéciale.

Dernière modification par tiramiseb (Le 28/03/2013, à 14:25)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 29/03/2013, à 00:50

jamesbad000

Re : [résolu] DD non reconnu a la cme mount

@tiramiseb : Moi c'est pareil, quand je regarde pas, je ne vois rien smile

Concernant le montage, je ne suis sur de rien nonplus, vu que je ne connais pas le mécanisme en jeu. Mais sur ma 10.04 j'ai un lecteur monté dans fstab, et il apparait bien (en double d'ailleurs...) dans nautilus.

Et sur 12.04, si je monte manuellement un système de fichier, sans nom de volume, dans un sous répertoire de /media. Un lecteur avec le nom du sous répertoire apparait dans la rubrique poste de travail de nautilus.
Il s'ajoute également dans périphérique avec la mention "système de fichier de x MB". Dont on ne peut rien faire !

Et rien ne se passe quand je le monte dans /mnt.

j'en déduis que nautilus est averti des montages dans media,..


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#8 Le 29/03/2013, à 01:53

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Salut,

J'ai essayé la cmde umount 

:~$ sudo umount -fl /dev/sdb1
umount: /dev/sdb1: n'est pas monté

Et donc j'ai essayé la cmde mount

:~$ sudo mount -fl /dev/sdb1
mount: ne peut repérer /dev/sdb1 dans /etc/fstab ou /etc/mtab

Me suis-je trompé quelque part ??.??
La réponse est forcément oui, mais la solution fera que non,
c'est la faute à Photon.
Vous savez, le Truk machin qui se la balade cool C = talali sur le Rzx,
et qui nous l'embrouille au binaire du dékonotron, toujours au delta Time
du pire moment .
Si je fais ce laius,, c'est de la faute de jamesbad, j'aime bien ton énergique citation.
En plus, en ce moment, je suis en pleine prise de tête sur le sujet, alors .....
c'est pas le moment de paumer des données mais c'est aussi le moment de les
sauvegarder. Donc ....
Albert Stp fait quelque chose pour moi ?

Hors ligne

#9 Le 29/03/2013, à 08:25

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

Me suis-je trompé quelque part ????

D'une part, il ne faut pas utiliser les arguments "f" et "l" avec "mount". La commande que t'a donnée jamesbad000 est spécifique à sa demande particulière, cela ne veut pas dire que tu vas devoir utiliser "-fl" à chaque utilisation de umount et de mount.

D'autre part, tu ne peux monter ce disque avec cette commande que s'il est présent dans le "fstab", ce qui n'est pas le cas. Le montage automatique lors du branchement d'un disque et la commande mount, ce sont deux choses totalement différentes, qui ne fonctionnent pas de la même manière et qui n'interagissent pas.

Si tu veux monter un disque "comme s'il était monté automatiquement lors de son branchement", tu dois installer et utiliser la commande pmount.

Je pense que tu te compliques la vie pour rien.
As-tu essayé simplement d'éteindre l'ordinateur, débrancher le disque, allumer l'ordinateur puis brancher le disque ?

Dernière modification par tiramiseb (Le 29/03/2013, à 08:26)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#10 Le 29/03/2013, à 14:06

echo-echo

Re : [résolu] DD non reconnu a la cme mount

yes , oeuf corse que j'ai branché et débranché et allumé et rebranché avec
tous les décalages spatio prise usb intégré aux mount et démontre que ...???

En fait j'ai un 2ème DD externe et le pb est le même.
Pa rcontre lorque je les utilises sur une autre bécane avec Ubuntu 12.10 là c'est ok.

Donc pour résumer :

~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
nfsd on /proc/fs/nfsd type nfsd (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/etienne/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=etienne)

Et là one ne trouve même plus la ligne /dev/sdb1 on /media/C type vfat
que l'on trouvait dans mon premiet mount.

Donc j'ai refais un mount qiu me donne ça :
etienne@detonotor:~$ mount /dev/sdb1
mount: ne peut repérer /dev/sdb1 dans /etc/fstab ou /etc/mtab

Est ce que j'ai bien posé la cmde ?
De plus j'ai essayé mount -f (forcé) mais y'a que la Root qu' est tout" droite.
Bon ? : Wanted DD à branchement ultra-luminique ?????

Hors ligne

#11 Le 29/03/2013, à 14:11

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

Est ce que j'ai bien posé la cmde ?

Non, car là tu as demandé de monter la partition /dev/sdb1 selon ce qu'il y a dans /etc/fstab, et tu n'as visiblement pas d'entrée pour /dev/sdb1 dans /etc/fstab.

Pour monter manuellement avec la commande "mount" et sans présence d'une ligne spécifique dans /etc/fstab, tu dois :

1/ créer le point de montage s'il n'existe pas déjà
2/ monter avec mount /dev/partition /point/de/montage


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#12 Le 29/03/2013, à 15:04

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Alors là, j'voudrais bien essayer mais .... on atteint mes limites opérationnelles.
Créer le point de montage ??? faut voir.... mais j'ai besoin pour ça d'Albert au clavier.
Cela dit le point de montage , il n'est pas établi une fois pour toute quelque part, normalement ?
Ma question en fait est a quoi sert exactement /etc/fstab . Est ce que c'est lui qui définit le point de montage ?  Je suis allé voir et j'ai bien trouvé le  sda1 ( si il est là, c'est que ça doit être sa place en principe . Ouf ! Ô- , mon ordi-tourne ! )
En aparté, vivement l'install party Ubuntu, parce que la liste de mes pb s'allllllllllonge .
J'ai pas trouvé la date sur le forum (mis a part le 1er samedi de chaque mois).

A part ça ?????,
Donc à Présent, je cherche toujours un DD montable au ... DétricoRotatif . .
(c'est p'tête le R qui fout le bingntz ?)

Hors ligne

#13 Le 29/03/2013, à 15:17

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

Créer le point de montage ??? faut voir.... mais j'ai besoin pour ça d'Albert au clavier.

Le point de montage c'est le répertoire dans lequel tu vas monter le disque.

le point de montage , il n'est pas établi une fois pour toute quelque part, normalement ?

Il est établi une fois pour toutes pour les disques fixes.
Pour les périphériques amovibles, il est normalement créé dynamiquement par Ubuntu lorsque tu en branches.
Peut-être as-tu trifouillé quelque chose qu'il ne fallait pas et as-tu désactivé cette fonctionnalité.

a quoi sert exactement /etc/fstab

À définir les options et points de montage de tous les disques connus (donc, dans l'écrasante majorité des cas, du ou des disque(s) interne(s)).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#14 Le 29/03/2013, à 20:09

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Donc il faudrait essayer les opérations que tu me conseillais :

1/ créer le point de montage s'il n'existe pas déjà
2/ monter avec mount /dev/partition /point/de/montage

mais comment dois-je m'y prendre ?

Hors ligne

#15 Le 29/03/2013, à 20:12

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

sudo mkdir /tmp/mon_petit_test
sudo mount /dev/sdb1 /tmp/mon_petit_test
ls /tmp/mon_petit_test
sudo umount /tmp/mon_petit_test
sudo rmdir /tmp/mon_petit_test

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#16 Le 30/03/2013, à 20:41

echo-echo

Re : [résolu] DD non reconnu a la cme mount

excuse moi je ne suis pas assez versé dans les manips

qu'entends tu par mon    _petit_test.
Dois-je créer un fichier avec un nom x ? Et si c'est le cas comment
est ce "d'abitude'.

Hors ligne

#17 Le 30/03/2013, à 20:48

jamesbad000

Re : [résolu] DD non reconnu a la cme mount

Tu tape les Commandes indiquées texto. Mieux tu fais un copier/collé...

après les 2 première commande (Si ca fonctionne ) tu trouvera le contenu de ta partition dans /tmp/mon_petit_test
Ce qui sera confirmé par la 3 ème commande.

La suite c'est pour éventuellement démonter. Mais de toute façon au prochain reboot le montage sera à refaire...


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#18 Le 03/04/2013, à 00:56

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Salut,

j'ai fait une première fois la manip, mais bon .... y'a un hic.

Voici maintenant le résultat des 3 premières commandes :

etienne@detonotor:~$ sudo mkdir /tmp/mon_petit_test
[sudo] password for etienne:
etienne@detonotor:~$ sudo mount /dev/sdb1 /tmp/mon_petit_test
mount: périphérique spécial /dev/sdb1 n'existe pas
etienne@detonotor:~$ ls /tmp/mon_petit_test
etienne@detonotor:~$

Je précise /tmp/mon_petit_test a bien été crée.

L'affaire se corse ... ?
Ou est-ce moi qui me complique the life, à tous les coups !!!???

Je crois que la 2ème option est la bonne car, prise .....de tête,
tu ne me croiras pas, mais cet aprèm' je suis aller fourrer mon nez dans la Relativité. Albert a écrit
un petit ouvrage dans lequel il explique très bien les principes avec un minimum de formules.
Donc en principe c'est approchable.... je dis, en principe, car je crois qu'il y a une coquille d'impression
dans un des graphes .. .  Je rigole car, va déjà capter  directement un e=mc2 ??? et si en plus y'a une
coquille d'imprimeur ou un x remplace un y !!??  ...va voir l'erreur l'effronté ???
Vas t'en savoir, que je suis vraiment naze !!!!!!!???? simplement d'ozer penser cela ????
Donc demain à l'aube, je suis en route pour un contrôle auprès de la première librairie open. 
Cela dit si on fait une translation de masse M = Lenovo Pc et C=Photonique applicative .... alors
....j 'habite sur quelle planète ????

Hors ligne

#19 Le 03/04/2013, à 08:37

tiramiseb

Re : [résolu] DD non reconnu a la cme mount

L'affaire se corse ... ?

Non, ton disque dur s'est peut-être "déplacé" sur /dev/sdc...
Les /dev/sdXY ça peut varier.

C'est pour ça qu'il existe les /dev/disk/by-uuid (par exemple) mais c'est vachement plus compliqué à taper : chez moi par exemple on y retrouve /dev/disk/by-uuid/11c11f71-d23a-4805-94ed-0045b9759c5a, qui est plus difficile à taper que /dev/sdb1. C'est pour ça qu'on continue à utiliser les /dev/sdXY, qui sont le système historique.

Pour retrouver ton disque, tu peux faire :

sudo fdisk -l

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#20 Le 05/04/2013, à 23:36

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Salut,
la cmde :  sudo fdisk -l

égale ça : bon ?!

Disque /dev/sda: 250.1 Go, 250059350016 octets
255 têtes, 63 secteurs/piste, 30401 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x0008ab88

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *           1       30141   242101248   83  Linux
/dev/sda2           30141       30402     2095105    5  Etendue
/dev/sda5           30141       30402     2095104   82  Linux swap / Solaris
etienne@detonotor:~$

Je suis largué............

Hors ligne

#21 Le 06/04/2013, à 00:31

jamesbad000

Re : [résolu] DD non reconnu a la cme mount

Là il n'y a que ton disque interne qui apparait.

Donc si vraiment ton disque externe était branché, il faudrait vérifier qu'il fonctionne sur un autre PC. Et d'en l'affirmative, vérifier que ton pc reconnais un autre dispositif disque usb (ou une clé)...

Mais vu comment on tourne en rond, ça commence à devenir assez probable que quelque chose est en panne.

Ou alors ton disque n'existe pas parce que tu ne le regarde pas wink


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#22 Le 06/04/2013, à 23:44

echo-echo

Re : [résolu] DD non reconnu a la cme mount

Trouvé ... le pb ....c'était tout bête as usual...

Et tu avais raison, c'est bien parce que je ne regardais pas le DD que ça ne tournais pas rond.

En fait le DD externe était branché via un hub usb, qui faisait correctement son boulot
pour d'autres types da matos genre clef usb et mon DD jusqu'à un certain moment.

Or le hub usb n'est pas toujours l'idéal (pour preuve) pour brancher les DD, because of
la question d' alimentation éléctrique  amenée soit via la prise usb, soit pas un transfo intégré
au hub.
Dans mon cas, effectivement le hub n'était pas relié au secteur et refusait de monter le DD
à cause de ces questions de gestion de jus.

Cela dit le mystère est quand même à moitié résolu, parce que, à un moment, au moins 1 fois,
ou 2 ou 3, le DD à été reconnu bien que le hub ne soit pas sur le secteur.
Pourquoi donc a t-il changé d'avis. ??? Bof .... l'informatique c'est comme la politique ?
Non ? Ah bon. 

Merci bien de ton aide

Hors ligne

#23 Le 07/04/2013, à 00:23

jamesbad000

Re : [résolu] DD non reconnu a la cme mount

La c'est pas l'informatique qui est en cause, mais l'électronique.
Ton montage dois se trouver un peu en dehors des limites de fonctionnement normal.
En électronique tout serait bien plus simple si les caractéristiques réelles des composants correspondaient exactement à leurs valeur nominales, et ne variaient pas en fonction des conditions de l'environnement...

Dernière modification par jamesbad000 (Le 07/04/2013, à 00:26)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

Haut de page ↑