Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#51 Le 10/03/2013, à 23:29

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

J'aurais du plutôt dire "gestionnaire de fichier... Il suffit de cliquer sur les lecteurs de disque qui apparaissent dans le panneau des racourci.
Bon si tu n'y arrive pas ce n'est pas grave on les montera à la main.

Mais  j'avais oublié que tu as un partitionnement gpt. du coup fdisk est muet. A la place il me faut le retour de :

sudo parted -l 

L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#52 Le 11/03/2013, à 21:16

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Salut jamesbad000,
Oui je vois bien 4 lecteurs en bas dans le panneau de gauche. Quand je clique sur le lecteur data je rentre dedans pour l'explorer.
Sinon voici le résultat de la commande

hatem@hatem-ubuntu:~$ sudo parted -l 
Modèle: ATA Hitachi HTS54505 (scsi)
Disque /dev/sda : 500GB
Taille des secteurs (logiques/physiques): 512B/4096B
Table de partitions : gpt

Numéro  Début   Fin     Taille  Système de fichiers  Nom                           Fanions
 1      1049kB  316MB   315MB   fat32                EFI system partition          démarrage
 2      316MB   1259MB  944MB   ntfs                 Basic data partition          caché, diag
 3      1259MB  1394MB  134MB                        Microsoft reserved partition  msftres
 4      1394MB  201GB   200GB   ntfs                 Basic data partition
 5      201GB   447GB   246GB   ntfs                 Basic data partition
 7      447GB   474GB   26,5GB  ext4
 8      474GB   478GB   4700MB  linux-swap(v1)
 6      479GB   500GB   21,5GB  ntfs                 Basic data partition          caché, diag

Hors ligne

#53 Le 11/03/2013, à 21:48

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Salut,

Bon je vois qu'il n'y a pas de place libre entre les partitions évidemment. Sinon ce serait trop simple :-)
Donc tu montes tes partition, comme si tu voulais aller regarder dedans, et après tu refais la commande df

sudo df

Ce qui va permettre de voir la place disponible dans les partitions.


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#54 Le 11/03/2013, à 22:50

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Bon j'ai monté graphiquement les partitions associées à :
-Restore
-DATA
-Recovery

Mais pour OS (/dev/sda4) j'obtiens un message d'erreur (Operation not permitted).

Hors ligne

#55 Le 11/03/2013, à 22:52

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Et voici le résultat de la commande :

hatem@hatem-ubuntu:~$ sudo df
Sys. fich.     1K-blocks    Util. Disponible Uti% Monté sur
/dev/sda7       25472100  3568876   20609300  15% /
udev             1957204        4    1957200   1% /dev
tmpfs             786560      876     785684   1% /run
none                5120        0       5120   0% /run/lock
none             1966396      160    1966236   1% /run/shm
none              102400       44     102356   1% /run/user
/dev/sda1         303104   303068         36 100% /boot/efi
/dev/sda5      239969276  5918188  234051088   3% /media/hatem/DATA
/dev/sr0         3592938  3592938          0 100% /media/hatem/Disc
/dev/sda6       20981756 11002648    9979108  53% /media/hatem/Restore
/dev/sda2         921596   328376     593220  36% /media/hatem/Recovery
hatem@hatem-ubuntu:~$ 

Hors ligne

#56 Le 11/03/2013, à 22:54

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

jamesbad000 a écrit :

Bon je vois qu'il n'y a pas de place libre entre les partitions évidemment. Sinon ce serait trop simple :-)

Simple... Fallait pas s'y attendre vu les galères avec cet ordi lol

Hors ligne

#57 Le 11/03/2013, à 23:15

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Ok il y a assez d'info...
La partition recovery qui suit la partition EFI à bien assez de place dispo pour qu'on puisse lui piquer 50 Mo...

Il faudrait que tu installes gparted, qui est l'outil de partitionnement graphique

sudo apt-get install gparted

Ensuite tu le lances. Après pour redimensionner un partition, il faut la sélectionner.
Avec un clic droit tu as les options disponibles
- il faudra d'abord choisir démonter, car on ne peut modifier un partition montée
- Puis prendre l'option redimensionner sur la partition recovery. Indiquer 50 dans "espace libre précédent" et 0 dans espace libre suivant.
- Puis sur la partition EFI indiquer 0 à espace suivant et précédent.
Vérifier les les actions en attente en bas. Si ok valider. ca va mouliner un bon moment....

Dernière modification par jamesbad000 (Le 11/03/2013, à 23:16)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#58 Le 12/03/2013, à 00:32

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

bon c'est installé et a priori partitionné.
Je l'ai lancé et l'opération s'est déroulé normalement avec succès. Pour le détails j'ai :
- Déplacer /dev/sda2 vers la droite et la réduire de 900.00 Mio à 850.00
- Agrandir /dev/sda1 de 300.00 Mio à 349.00 Mio
Donc je crois que c'est ok.

Hors ligne

#59 Le 12/03/2013, à 00:35

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

hatem@hatem-ubuntu:~$ sudo df
Sys. fich.     1K-blocks    Util. Disponible Uti% Monté sur
/dev/sda7       25472100  3597400   20580776  15% /
udev             1957204       12    1957192   1% /dev
tmpfs             786560      880     785680   1% /run
none                5120        0       5120   0% /run/lock
none             1966396      160    1966236   1% /run/shm
none              102400       36     102364   1% /run/user
/dev/sda5      239969276  5918208  234051068   3% /media/hatem/DATA
/dev/sr0         3592938  3592938          0 100% /media/hatem/Disc
/dev/sda6       20981756 11002648    9979108  53% /media/hatem/Restore
/dev/sda2         870392   328372     542020  38% /media/hatem/Recovery

Hors ligne

#60 Le 12/03/2013, à 00:54

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Bon la partition sda1 (efi) ne devait pas être remonté, car il n'apparait pas dans le df.
Mais je te fais confiance :-) je crois que tu commence à comprendre comment ça marche. Et de toute façon on va vite voir si on a gagné de la place.

Pour remonter la partition efi

sudo mount /dev/sda1 /boot/efi 

et après il suffit de reprendre là ou on s'était arrêté, c'est à dire la copie du 3ème fichier au post #40...

Dernière modification par jamesbad000 (Le 12/03/2013, à 00:57)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#61 Le 12/03/2013, à 01:09

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

je commence un peu à prendre la main. Mais bon c'est que le début.
Je reprend les manip demain. La je sens que je vais faire une erreur si je me lance... Trop fatigué.
Merci et je te tiens au courant.

Hors ligne

#62 Le 12/03/2013, à 01:14

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Ok, après reboot ta partition efi sera remontée toute seule (point de montage indiqué dans /etc/fstab. si tu veux comprendre il suffit d'ouvrir le fichier)
A+


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#63 Le 13/03/2013, à 00:28

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Salut,
Bon j'ai repris la suite des commandes. Je crois qu'il ne me restait qu'un seul mv à exécuter avant l'update. Voici exactement ce que j'ai lancé :

hatem@hatem-ubuntu:~$ sudo mv /home/bkpbootmgfw.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
hatem@hatem-ubuntu:~$ sudo update-grub
Création de grub.cfg…
Image Linux trouvée : /boot/vmlinuz-3.5.0-17-generic
Image mémoire initiale trouvée : /boot/initrd.img-3.5.0-17-generic
Windows Recovery Environment (loader) trouvé sur /dev/sda2
Windows 8 (loader) trouvé sur /dev/sda4
Adding boot menu entry for EFI firmware configuration
fait
hatem@hatem-ubuntu:~$ 

Ca a l'air de s'etre bien déroulé. Je reboot pour voir. Suspense...

Hors ligne

#64 Le 13/03/2013, à 00:45

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Bon toujours pas de Win8...
Voici le menu grub que j'ai :
Ubuntu
Options avancées pour Ubuntu
Windows UEFI bkpbootmgfw.efi
Windows Boot UEFI loader
Windows recovery Environment (loader) (sur /dev/sda2)
Windows 8 (loader) (sur /dev/sda4)
System setup


Si je sélectionne "Windows UEFI bkpbootmgfw.efi" j'obtiens :
erreur : fichier " /EFI/Microsoft/Boot/bkpbootmgfw.efi " non disponible.

Si je sélectionne "Windows Boot UEFI loader"  j'obtiens :
erreur : fichier " /EFI//Boot/bkpbootx64.efi " non disponible

Si je sélectionne "Windows 8 (loader) (sur /dev/sda4)"  j'obtiens :
erreur : impossible de trouver la commande " drivemap ".
erreur : invalid EFI file path.

Hors ligne

#65 Le 13/03/2013, à 01:02

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Bon. Je dois dire que le contraire m'aurait étonné...

Je ne sais pas pourquoi les options construites automatiquement par grub ne fonctionnent pas. Mais on va pouvoir corriger celles générées par boot repair...

Pour ça il faut éditer le fichier d'options personnalisées :

gksudo gedit /etc/grub.d/25_custom

tu modifie les 2 lignes

chainloader (${root})/EFI/Microsoft/Boot/bkpbootmgfw.efi
chainloader (${root})/EFI/Boot/bkpbootx64.efi

en retirant bkp aux 2 noms de fichier (pour correspondre aux noms de fichiers dans la partition EFI)
si tu veux sur la ligne "menuentry" tu peux adapter les titres entre guillemets. (c'est ce qui va apparaitre dans le menu

et ensuite à nouveau

sudo update-grub

les 2 autres options invalides vont rester. (on pourrait désactiver la détection automatique, mais il vaut mieux éviter. Car si tu décidait d'installer une autre version d'ubuntu, il va la détecter automatiquement (et il y a des chances que ça fonctionne mieux qu'avec windows)

Si vraiment tu veux les faire disparaitre, il suffit d'enlever le flag exec du fichier /etc/grub.d/30_os-prober

sudo chmod a-x /etc/grub.d/30_os-prober

si ultérieurement tu veux le remettre (garde ça dans un coin)

sudo chmod a+x /etc/grub.d/30_os-prober

puis toujours

sudo update-grub

pour reconstruire le menu

Dernière modification par jamesbad000 (Le 13/03/2013, à 01:04)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#66 Le 14/03/2013, à 00:10

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Salut,

Bon j'ai modifié le fichier et j'ai fait l'update :

hatem@hatem-ubuntu:~$ gksudo gedit /etc/grub.d/25_custom
hatem@hatem-ubuntu:~$ sudo update-grub
Création de grub.cfg…
Image Linux trouvée : /boot/vmlinuz-3.5.0-17-generic
Image mémoire initiale trouvée : /boot/initrd.img-3.5.0-17-generic
Windows Recovery Environment (loader) trouvé sur /dev/sda2
Windows 8 (loader) trouvé sur /dev/sda4
Adding boot menu entry for EFI firmware configuration
fait
hatem@hatem-ubuntu:~$ 

Je redémarre pour tester...

Hors ligne

#67 Le 14/03/2013, à 00:32

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Bon ca fonctionne :-) Trop fort !!!! Je te remercie vraiment beaucoup.

Donc au niveau du menu j'ai :
Ubuntu
Options avancées pour Ubuntu
Windows UEFI bootmgfw.efi
Windows Boot UEFI loader
Windows Recovery Environment (loader) (sur /dev/sda2)
Windows 8 (loader) (sur /dev/sda4)
System setup.

J'avais testé une première fois "Windows UEFI bootmgfw.efi" mais il a démarré sur le menu bleu de windows qui demande si on veut faire un diagnostique ou démarrer sur une clé ou continuer sur windows 8 . Ensuite j'ai re tester 2 à 3 fois et ca fonctionnait.

L'entrée Windows Boot UEFI loader a fonctionné dès le début et continue de fonctionner après deux tests.

L'entrée Windows 8 (loader) (sur /dev/sda4) ne fonctionne pas.

J'ai pas testé Windows Recovery Environment (loader) (sur /dev/sda2) ni l'entrée Options avancées pour Ubuntu (d'ailleurs à quoi elle sert?).

Et sinon pour le paramétrage du bios, je continue à garder les options suivantes ?
Fast Boot = Disabled
Launch CSM = Disabled
Secure Boot Control = Disabled

Hors ligne

#68 Le 14/03/2013, à 00:46

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Options avancées pour ubuntu donne accès au démarrage en mode "récupération" qui permet d'accéder directement à un terminal de commande en cas de problème avec le mode graphique... et aux anciennes versions de noyau ce qui peut s'avérer utile si suite à une mise à jour du noyau ton système de démarre plus.

Pour le paramétrage du bios, mieux vaut laisser tel quel.

Bon je crois que tu va pouvoir t'amuser avec ton PC:)

Et n'oublie pas de passer ton sujet en [résolu]
@+

Dernière modification par jamesbad000 (Le 14/03/2013, à 00:47)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#69 Le 14/03/2013, à 10:38

malbo

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

kais1978 a écrit :

L'entrée Windows 8 (loader) (sur /dev/sda4) ne fonctionne pas.

J'ai pas testé Windows Recovery Environment (loader) (sur /dev/sda2)

Ces deux entrées sont non-fonctionnelles et elles sont dues au Bug #1024383, un dysfonctionnement de Grub. je suggère de laisser ces entrées tranquille et de seulement les ignorer.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#70 Le 16/03/2013, à 19:56

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

Merci encore pour ton aide jamesbad big_smile

Hors ligne

#71 Le 16/03/2013, à 19:58

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

malbo a écrit :
kais1978 a écrit :

L'entrée Windows 8 (loader) (sur /dev/sda4) ne fonctionne pas.

J'ai pas testé Windows Recovery Environment (loader) (sur /dev/sda2)

Ces deux entrées sont non-fonctionnelles et elles sont dues au Bug #1024383, un dysfonctionnement de Grub. je suggère de laisser ces entrées tranquille et de seulement les ignorer.

Ok merci pour l'info

Hors ligne

#72 Le 17/03/2013, à 06:49

malbo

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

kais1978,
Pourrais-tu modifier le paramètre Fast Boot = Enabled (au lieu de Disabled) dans le "Bios", puis vérifier l'impact sur le démarrage ? D'après ce que j'ai lu, il est possible de réactiver Fast Boot après installation de Ubuntu. Si le dual-boot continue de fonctionner correctement, je te prie de confirmer que la fonctionnalité Fast Boot est effectivement réactivée (est-ce que Windows démarre plus vite ou c'est quasiment pareil ?).

Dernière modification par malbo (Le 17/03/2013, à 06:50)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#73 Le 17/03/2013, à 15:57

jamesbad000

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

@kais1978, Personnellement j'ai supposé que le "fast boot" se rapportait aux auto-test de mise sous tension (test mémoire et autre matériels) et non à windows lui même. Quoiqu'il en soit, la proposition de malbo me semble de bon aloi


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#74 Le 07/04/2013, à 21:03

kais1978

Re : [résolu] Asus R500A-SX061H Plus de boot (EFI) après usage boot repair

malbo a écrit :

kais1978,
Pourrais-tu modifier le paramètre Fast Boot = Enabled (au lieu de Disabled) dans le "Bios", puis vérifier l'impact sur le démarrage ? D'après ce que j'ai lu, il est possible de réactiver Fast Boot après installation de Ubuntu. Si le dual-boot continue de fonctionner correctement, je te prie de confirmer que la fonctionnalité Fast Boot est effectivement réactivée (est-ce que Windows démarre plus vite ou c'est quasiment pareil ?).

Bonsoir messieurs,

Je viens de récupérer l'ordi en question. Le fast boot est enabled. Le dual boot fonctionne par contre l'activation n'a rien changé au niveau de la vitesse de chargement. Ce n'est pas plus rapide. Mais au moins ca n'a aucun impact sur le boot des deux OS.

Hors ligne

Haut de page ↑