Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/11/2010, à 12:41

jojo_monk

[résolu] plus de son après mise en veille

Bonjour à tous,

Je suis sous ubuntu 10.10, j'ai une carte son m-audio audiophile 2496.
Tout fonctionne parfaitement bien, sauf quand le pc se met en veille (mise en veille sur RAM, je crois), au retour de la veille, je n'ai plus de son, pour tant aucune piste n'est muté, et le vu-mètre du digital mixer bouge normalement...

J'ai essayé ces commandes :

sudo alsa force-reload
pulseaudio --start

j'ai aussi testé cette manip' pour pouvoir redémarrer pulseaudio :
http://forum.ubuntu-fr.org/viewtopic.php?pid=2675978


mais ça ne fonctionne pas... 

La seule manière que j'ai trouvé, c'est de redémarrer l'ordi, pas très pratique. sad
Il doit bien y avoir une solution, non ?

Merci

Dernière modification par jojo_monk (Le 11/04/2013, à 20:33)

Hors ligne

#2 Le 11/11/2010, à 17:14

jojo_monk

Re : [résolu] plus de son après mise en veille

bon, ya pas de soluces, alors??

Hors ligne

#3 Le 12/11/2010, à 11:30

jojo_monk

Re : [résolu] plus de son après mise en veille

ça y est j'ai trouvé la solution ici : https://bugs.launchpad.net/ubuntu/+sour … +bug/93273

il faut utiliser ces commandes pour retrouver le son :

fuser -k /dev/snd/*
sudo rmmod snd-ice1712
sudo modprobe snd-ice1712

bon, maintenant si quelqu'un sait comment faire un script pour rendre cette manip' automatique après chaque mise en veille ou hibernation, ça serait le paradis big_smile

Hors ligne

#4 Le 03/10/2011, à 22:59

mitrendir63

Re : [résolu] plus de son après mise en veille

Hello,

Perso, j'ai résolu mon pb avec ce petit script:

#!/bin/bash
# by mitrendir63
# Logged as root, copy this to the file /etc/pm/sleep.d/88-unload2496
# chmod +x the file
case $1 in
    hibernate|suspend)
    echo "Remove pulseaudio and module snd_ice1712 for suspend to disk!"
    killall pulseaudio
    fuser -k /dev/snd/*
    rmmod -f snd_ice1712
        ;;
    thaw|resume)
        echo "Resume from disk...restart maudio module"
    killall pulseaudio
    modprobe snd_ice1712
        ;;
    *)  echo "somebody is calling me totally wrong."
        ;;
esac

Dernière modification par mitrendir63 (Le 03/10/2011, à 23:01)

Hors ligne

#5 Le 11/04/2013, à 20:29

jojo_monk

Re : [résolu] plus de son après mise en veille

J'avais pas vu ce post, depuis j'avais abandonné l'affaire...

Je viens de tester et ça marche, excellent!

Merci

big_smile

Hors ligne

Haut de page ↑