Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 10/04/2013, à 19:05

zezay

[Résolu] Problème d'affichage sur double écran

Bonjour,
Je viens d'installer Ubuntu (12.10) et c'est ma première expérience sous Linux tongue
L'installation c'est bien passée, mais je n'ai qu'un seul écran détecté dans les paramètres d'affichage.
J'ai 2 cartes graphique :
  - Une intégré a la carte mère (Nvidia Gforce 9200), mon écran branché ici en VGA fonctionne correctement.
  - Une Nvidia Gforce G100, mon écran branché en DVI n'est pas détecté.
La commande lspci | grep "VGA" me renvoie :

02:00.0 VGA compatible controller: NVIDIA Corporation C77 [GeForce 8200] (rev a2) 
03:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce G 100] (rev a1) 

Ma version des Drivers NVIDIA (Dans NVIDIA X Server) : 304.88

A priori, toutes les mises à jours sont installées.
Je dois faire un croix sur mon affichage double écran ou il y a une solution ?
Merci d'avances pour vos réponses.

Dernière modification par zezay (Le 14/04/2013, à 11:26)

Hors ligne

#2 Le 11/04/2013, à 14:59

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Salut,

Quand tu dis « pas détecté », c’est qu’il ne s’affiche ni dans le gestionnaire d’écrans d’Ubuntu, ni dans le gestionnaire Nvidia, ou simplement qu’il n’est pas activé par défaut ? Essaie d’aller dans les préférences système, section écran (ou affichage, je ne sais plus), et de voir si ton second écran n’apparaît pas, avec une case à cocher pour l’activer.

Tu utilises bien Unity, l’interface par défaut ?


No future? Future is now!

Hors ligne

#3 Le 11/04/2013, à 18:55

zezay

Re : [Résolu] Problème d'affichage sur double écran

Salut et merci de ta réponse,

Je n'ai qu'un écran d'affiché dans Paramètres système > Affichage
Paramètres système
J'ai regardé dans les settings de NVIDIA X server, j'ai ca :
Pour ma Gforce 9200 (fonctionne)
Gforce 9200
Pour ma gforce G100 (ne fonctionen pas)
Gforce G100

Il doit me manquer un truc au niveau de la config de mes drivers NVIDIA...

Hors ligne

#4 Le 11/04/2013, à 19:09

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Sur le premier utilitaire, ça ne change rien si tu cliques sur « Détecter les écrans » ?
À voir le gestionnaire Nvidia, on dirait bien que les cartes sont bien configurées, ce sont les écrans qui posent problème. Tu es allé te promener dans l’onglet « X Server Display Configuration », et cliqué sur « Detect Displays » ?


No future? Future is now!

Hors ligne

#5 Le 11/04/2013, à 20:43

zezay

Re : [Résolu] Problème d'affichage sur double écran

Bon j'ai bidouillé, dans X Server Display Configuration.
J'ai enregistré la configuration et rebooté, maintenant j'ai un écran blanc sur mon écran qui ne s’affichait pas...
Si me déplace ma souris dessus elle reste bloquée sur l'écran blanc... Une idée ?

Hors ligne

#6 Le 13/04/2013, à 10:57

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Cela me semble bien étrange comme problème maintenant. Je n’ai pas d’idée qui vienne comme ça, mais peut-être peux-tu me poster une capture d’écran de la section X Server Display Configuration telle qu’elle est maintenant, peut-être nous livrera-t-elle des informations intéressantes.


No future? Future is now!

Hors ligne

#7 Le 13/04/2013, à 11:55

zezay

Re : [Résolu] Problème d'affichage sur double écran

Hop, Voila les screens :
Pour GPU 0 (l'écran qui fonctionne)
GPU0
Pour GPU1 (l'écran blanc)
GPU1

C'est étrange car quand je reboot ou que j’éteins mon PC je vois le fond d'écran d'Ubuntu, il s'affiche 2 secondes, puis l'écran blanc apparaît...

Hors ligne

#8 Le 13/04/2013, à 13:45

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

D’accord, je vois le problème. Il faut que tu changes le champ « Configuration » (qui est actuellement « Separate X screen »), et que tu mettes « TwinView ». Normalement, ça devrait marcher après ça. wink

Dernière modification par ArzhurB (Le 13/04/2013, à 13:45)


No future? Future is now!

Hors ligne

#9 Le 13/04/2013, à 18:09

zezay

Re : [Résolu] Problème d'affichage sur double écran

J'ai bien un champ "Twinview" mais il est inactif, je ne peux pas le sélectionner.

Hors ligne

#10 Le 13/04/2013, à 19:41

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Tiens, c’est bizarre ! Bon, tout n’est pas perdu, il me semble que cocher la case « Enable Xinerama » résoudra le problème, mais je ne te l’avais pas conseillé car ce n’est pas la méthode que j’utilise.


No future? Future is now!

Hors ligne

#11 Le 13/04/2013, à 20:27

zezay

Re : [Résolu] Problème d'affichage sur double écran

Bon, on y est presque tongue
Maintenant, j'ai mes 2 écran mais je n'ai plus de "barre d'application" (a gauche avec la corbeille...)
De temps en temps j'ai une erreur qui me dis que compiz a arrêter de fonctionner...

Hors ligne

#12 Le 13/04/2013, à 21:19

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Bon, c’est une bonne nouvelle !

Voyons voyons, je n’utilise pas Unity moi-même, alors ça m’embête un peu que le problème le concerne directement. Enfin, on va essayer !

En allant faire un tours sur la documentation (dont je te conseille d’ailleurs vivement la lecture : [doc]multi-écran[/doc]), je me suis souvenu de quelque chose que je voulais te suggérer de faire au début : utiliser Arandr, une interface de XRandR, pour configurer tes écrans. En effet, il est spécifié dans la documentation qu’il gère tout seul XineRama.

Du coup, tu peux essayer ça : installer le paquet « arandr », puis utiliser l’application du même nom. L’interface est assez intuitive, mais si tu as un souci, n’hésite pas à me demander !


No future? Future is now!

Hors ligne

#13 Le 14/04/2013, à 11:25

zezay

Re : [Résolu] Problème d'affichage sur double écran

Merci ArzhurB pour ton aide !
J'ai réglé le problème en installant l'interface Gnome (qui m'a l'air fort jolie smile )
J'ai mes 2 écrans, tout fonctionne correctement !
Arandr m'affiche un message d'erreur quand je le lance "L'application ARandr a quitté de façon inattendue", lorsque je le lance depuis le terminal, j'ai une erreur Python...

Xlib:  extension "RANDR" missing on display ":0".
Traceback (most recent call last):
  File "/usr/bin/arandr", line 42, in <module>
    main()
  File "/usr/lib/python2.7/dist-packages/screenlayout/gui.py", line 318, in main
    force_version=options.force_version
  File "/usr/lib/python2.7/dist-packages/screenlayout/gui.py", line 157, in __init__
    self.widget = widget.ARandRWidget(display=randr_display, force_version=force_version)
  File "/usr/lib/python2.7/dist-packages/screenlayout/widget.py", line 48, in __init__
    self._xrandr = XRandR(display=display, force_version=force_version)
  File "/usr/lib/python2.7/dist-packages/screenlayout/xrandr.py", line 40, in __init__
    version_output = self._output("--version")
  File "/usr/lib/python2.7/dist-packages/screenlayout/xrandr.py", line 56, in _output
    raise Exception("XRandR returned error code %d: %s"%(status,err))
Exception: XRandR returned error code 1: RandR extension missing

Etrange... Mais pour moi le plus important c'est que tout fonctionne... Je vais rester dans cette configuration pour le moment.
Je vais retenir quelques leçons de cette expérience, tout d'abord il faut être patient, ensuite il faut toujours sauvegarder la configuration Xorg.conf tongue
Encore merci pour ton aide !

Hors ligne

#14 Le 14/04/2013, à 12:59

ArzhurB

Re : [Résolu] Problème d'affichage sur double écran

Parfait, je suis content que tout fonctionne ainsi ! smile

Concernant cette affaire d’ARandr, j’ai trouvé, pour info, un sujet sur le forum Ubuntu anglophone qui, quoi qu’assez ancien, semble donner la solution. Mais si ça fonctionne pour toi avec GRandr, aucune raison d’essayer coûte que coûte de faire fonctionner ARandr. wink

Je vois que tu as déjà mis le fameux [Résolu] ; tu m’enlèves les mots du clavier ! N’hésite pas si tu as d’autres problèmes, et bonne « première expérience » sous GNU/Linux !


No future? Future is now!

Hors ligne

Haut de page ↑