Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 20/04/2013, à 14:49

robin_moussu

pb ajout ppa - python-software-properties [presque résolu]

Titre original :
impossible dajouter un ppa - python-software-properties déjà installé
Voir dernier post pour l’état de résolution si vous avez eu le même problème que moi et voir si la solution vous convient.

Bonjour,
Lorsque j’essaye d’ajouter un ppa, j’obtiens l’erreur suivante :

sudo: add-apt-repository: command not found

J’ai essayé avec plusieurs ppa, notamment :

sudo add-apt-repository ppa:hannes-janetzek/enlightenment-svn

J’ai vérifié, j’ai bien python-software-properties qui est déjà installé

sudo apt-get install python-software-properties
[sudo] password for robin:
 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
python-software-properties est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 167 non mis à jour.

Les infos sur mon ordi :
ubuntu gnome remix 13.04 (depuis la béta)

 uname -a
Linux nuage 3.8.0-11-generic #20-Ubuntu SMP Tue Mar 5 20:32:48 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Mon système est évidemment à jour.
Je ne comprends pas pourquoi je ne peux pas ajouter de ppa.
Merci d’avance pour votre aide.

Dernière modification par robin_moussu (Le 22/04/2013, à 00:03)

Hors ligne

#2 Le 20/04/2013, à 19:44

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Bonjour robin_moussu,

robin_moussu a écrit :

Mon système est évidemment à jour.

Je ne crois pas :

0 mis à jour, 0 nouvellement installés, 0 à enlever et 167 non mis à jour

Pour faire tes mis à jour, tapes

sudo apt-get update
sudo apt-get dist-upgrade

De manière générale, lorsque tu veux ajouter un PPA, il faut :

1) ajouter l'adresse du dépôt PPA

sudo add-apt-repository ppa:hannes-janetzek/enlightenment-svn

2) réactualiser la liste des dépôts

sudo apt-get update

3) ajouter le logiciel désiré

sudo apt-get install e17

ou bien faire une mise à jour qui contient les logiciels plus récents à partir du PPA

sudo apt-get dist-upgrade

Dernière modification par f.x0 (Le 20/04/2013, à 19:45)


SOPI

Hors ligne

#3 Le 20/04/2013, à 20:41

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

Bonjour f.x0
Effectivement, je n’utilisais pas dist-upgrade mais seulement upgrade.

Maintenant tout mes paquets sauf un (je ne sais pas pourquoi) sont à jour :

robin@nuage:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libxkbcommon0
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Mais mon problème est toujours présent (toujours quelque-soit le ppa):

robin@nuage:~$ sudo add-apt-repository ppa:gnome3-team/gnome3
sudo: add-apt-repository: command not found

Hors ligne

#4 Le 20/04/2013, à 21:26

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Tu peux essayer de supprimer puis réinstaller python-software-properties

sudo apt-get purge python-software-properties
sudo apt-get install python-software-properties

puis réssaies

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get upgrade

SOPI

Hors ligne

#5 Le 20/04/2013, à 21:35

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

J’avais déjà testé sans succès avec

apt-get autoremove python-software-properties 

J’ai quand même essayé ce que tu m’a dis :

sudo apt-get purge python-software-properties
sudo apt-get install python-software-properties
sudo apt-get update

et hélas j’ai toujours la même erreur :

robin@nuage:~$ sudo add-apt-repository ppa:gnome3-team/gnome3
sudo: add-apt-repository: command not found

Hors ligne

#6 Le 20/04/2013, à 23:53

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Ben je vois pas comment régler ton problème,
mais si tu veux ajouter le dépôt PPA gnome3-team/gnome3
tu peux le faire :

- en ligne de commande comme ceci

echo "deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/gnome3.list
echo "deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/gnome3.list


- ou avec gedit

gksudo gedit

puis tu ajoutes ces 2 lignes

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu raring main
deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu raring main

et tu enregistres sous /etc/apt/sources.list.d/gnome3.list


Quelque soit ton choix, il faudra faire ensuite

sudo apt-get update
sudo apt-get dist-upgrade

SOPI

Hors ligne

#7 Le 21/04/2013, à 04:43

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

Merci f.x0 ta solution m’a permis d’ajouter le ppa de gnome.
En revanche je n’ai pas réussis à faire de même pour le ppa de e17. J’ai rentré les commandes suivantes :

echo "deb http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn raring main" | sudo tee -a /etc/apt/sources.list.d/e17.list
echo "deb-src http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn raring main" | sudo tee -a /etc/apt/sources.list.d/e17.list

mais maintenant je ne peux plus mettre à jour mes dépôts :

sudo apt-get update

bloque quand il essaye de se connecter sur le ppa de enlightenment :

97% [Connexion à ppa] [Connexion à ppa.hannes-janetzek]

reste affiché et plus rien ne se passe
Quelle est mon erreur dans l’ajout du ppa d’enlightenment ?

Hors ligne

#8 Le 21/04/2013, à 13:34

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Je crois avoir cerné ton erreur. (tu as oublié d'écrire ubuntu)


tout d'abord supprimes ton fichier /etc/apt/sources.list.d/e17.list :

sudo rm /etc/apt/sources.list.d/e17.list
sudo rm /etc/apt/sources.list.d/e17.list.save

puis tapes ceci :

echo "deb http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/e17.list
echo "deb-src http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/e17.list

Puis mettre à jour la liste des dépôts :

sudo apt-get update

installer E17:

sudo apt-get install e17

Dernière modification par f.x0 (Le 21/04/2013, à 13:35)


SOPI

Hors ligne

#9 Le 21/04/2013, à 13:59

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

Apparemment le ppa s’est ajouté correctement, merci de ton aide.
En revanche lorsque j’ai essayé d’installer e17, une erreur est survenue, et depuis impossible d’installer où de désinstaller quoi que ce soit.

robin@nuage:~$ sudo apt-get install e17 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
e17 est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 e17 : Dépend: libefl (>= 201304161338) mais ne sera pas installé
       Dépend: libefl-bin (>= 201200000000) mais ne sera pas installé
 evas-loaders : Dépend: libefl (>= 201303142155) mais ne sera pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
robin@nuage:~$ sudo apt-get install e17 -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
e17 est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 e17 : Dépend: libefl (>= 201304161338) mais ne sera pas installé
       Dépend: libefl-bin (>= 201200000000) mais ne sera pas installé
 evas-loaders : Dépend: libefl (>= 201303142155) mais ne sera pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
robin@nuage:~$ sudo apt-get autoremove e17 -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 evas-loaders : Dépend: libefl (>= 201303142155) mais ne sera pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
robin@nuage:~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  account-plugin-icons account-plugin-identica account-plugin-twitter friends friends-dispatcher friends-facebook friends-identica friends-twitter
  gir1.2-accounts-1.0 gir1.2-ebook-1.2 gir1.2-edataserver-1.2 gir1.2-messagingmenu-1.0 gir1.2-signon-1.0 gwibber-service gwibber-service-facebook
  gwibber-service-identica gwibber-service-twitter libaccounts-qt5-1 libc-ares2 libcogl9 libdee-qt5-3 libdevhelp-3-1 libecore-con1 libecore-evas1
  libecore-fb1 libecore-file1 libecore-imf1 libecore-input1 libecore-ipc1 libecore-x1 libecore1 libedje-bin libedje1 libeet1 libefreet1 libeina1
  libembryo-bin libembryo1 libevas1 libevas1-engines-core libevas1-engines-x libfriends0 libgexiv2-1 libgnome-keyring0:i386 libgoffice-0.8-8
  libgoffice-0.8-8-common libgtkspell-3-0 libgwibber-gtk3 libgwibber3 libllvm3.1 libllvm3.1:i386 libmjpegtools-1.9 libmozjs188-1.0 libqpdf8
  libqt5graphicaleffects5 libquicktime2 libreoffice-emailmerge librhythmbox-core6 libsignon-qt5-1 libtracker-extract-0.14-0 libtracker-miner-0.14-0
  libtracker-sparql-0.14-0 libudev0:i386 libwebp2:i386 python-oauth python3-crypto python3-oauthlib qtdeclarative5-accounts-plugin
  qtdeclarative5-friends-plugin qtdeclarative5-qtquick2-plugin qtdeclarative5-ubuntu-ui-toolkit-plugin ubuntu-ui-toolkit-theme unity-lens-friends
  unity-lens-gwibber
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libefl libefl-bin
Les NOUVEAUX paquets suivants seront installés :
  libefl libefl-bin
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
5 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 437 ko dans les archives.
Après cette opération, 6 878 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 349581 fichiers et répertoires déjà installés.)
Dépaquetage de libefl (à partir de .../libefl_201304161338-21778~raring1_amd64.deb) ...
Remplacement de fichiers dans l'ancien paquet libefreet1 ...
Remplacement de fichiers dans l'ancien paquet libevas1 ...
Remplacement de fichiers dans l'ancien paquet libeet1 ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/libembryo.so.1 », qui appartient aussi au paquet libembryo1 1.2.0-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Dépaquetage de libefl-bin (à partir de .../libefl-bin_201304161338-21778~raring1_amd64.deb) ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/embryo/include/default.inc », qui appartient aussi au paquet libembryo-bin 1.2.0-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb
 /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
robin@nuage:~$ sudo apt-get autoremove -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
  libefl libefl-bin
Les paquets suivants seront ENLEVÉS :
  account-plugin-icons account-plugin-identica account-plugin-twitter friends friends-dispatcher friends-facebook friends-identica friends-twitter
  gir1.2-accounts-1.0 gir1.2-ebook-1.2 gir1.2-edataserver-1.2 gir1.2-messagingmenu-1.0 gir1.2-signon-1.0 gwibber-service gwibber-service-facebook
  gwibber-service-identica gwibber-service-twitter libaccounts-qt5-1 libc-ares2 libcogl9 libdee-qt5-3 libdevhelp-3-1 libecore-con1 libecore-evas1
  libecore-fb1 libecore-file1 libecore-imf1 libecore-input1 libecore-ipc1 libecore-x1 libecore1 libedje-bin libedje1 libeet1 libefreet1 libeina1
  libembryo-bin libembryo1 libevas1 libevas1-engines-core libevas1-engines-x libfriends0 libgexiv2-1 libgnome-keyring0:i386 libgoffice-0.8-8
  libgoffice-0.8-8-common libgtkspell-3-0 libgwibber-gtk3 libgwibber3 libllvm3.1 libllvm3.1:i386 libmjpegtools-1.9 libmozjs188-1.0 libqpdf8
  libqt5graphicaleffects5 libquicktime2 libreoffice-emailmerge librhythmbox-core6 libsignon-qt5-1 libtracker-extract-0.14-0 libtracker-miner-0.14-0
  libtracker-sparql-0.14-0 libudev0:i386 libwebp2:i386 python-oauth python3-crypto python3-oauthlib qtdeclarative5-accounts-plugin
  qtdeclarative5-friends-plugin qtdeclarative5-qtquick2-plugin qtdeclarative5-ubuntu-ui-toolkit-plugin ubuntu-ui-toolkit-theme unity-lens-friends
  unity-lens-gwibber
Les NOUVEAUX paquets suivants seront installés :
  libefl libefl-bin
0 mis à jour, 2 nouvellement installés, 74 à enlever et 0 non mis à jour.
5 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 437 ko dans les archives.
Après cette opération, 67,1 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 349581 fichiers et répertoires déjà installés.)
Dépaquetage de libefl (à partir de .../libefl_201304161338-21778~raring1_amd64.deb) ...
Remplacement de fichiers dans l'ancien paquet libefreet1 ...
Remplacement de fichiers dans l'ancien paquet libevas1 ...
Remplacement de fichiers dans l'ancien paquet libeet1 ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/libembryo.so.1 », qui appartient aussi au paquet libembryo1 1.2.0-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Dépaquetage de libefl-bin (à partir de .../libefl-bin_201304161338-21778~raring1_amd64.deb) ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/embryo/include/default.inc », qui appartient aussi au paquet libembryo-bin 1.2.0-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb
 /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#10 Le 21/04/2013, à 17:47

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Commence par faire un peu de ménage

sudo apt-get clean
sudo apt-get purge e17
sudo apt-get autoremove --purge

puis essaies de réinstaller E17

sudo apt-get update
sudo apt-get install -f e17

postes le retour de la dernière commande


SOPI

Hors ligne

#11 Le 21/04/2013, à 23:02

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

Aucune des commande de apt-get ne marche :

robin@nuage:~$ sudo apt-get clean

(aucun retour)

robin@nuage:~$ sudo apt-get purge e17
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 evas-loaders : Dépend: libefl (>= 201303142155) mais ne sera pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
robin@nuage:~$ sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 e17 : Dépend: libefl (>= 201304161338) mais il n'est pas installé
       Dépend: libefl-bin (>= 201200000000) mais il n'est pas installé
 evas-loaders : Dépend: libefl (>= 201303142155) mais il n'est pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
robin@nuage:~$ sudo apt-get autoremove --purge -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
  libefl libefl-bin
Les paquets suivants seront ENLEVÉS :
  account-plugin-icons* account-plugin-identica* account-plugin-twitter*
  friends* friends-dispatcher* friends-facebook* friends-identica*
  friends-twitter* gir1.2-accounts-1.0* gir1.2-ebook-1.2*
  gir1.2-edataserver-1.2* gir1.2-messagingmenu-1.0* gir1.2-signon-1.0*
  gwibber-service* gwibber-service-facebook* gwibber-service-identica*
  gwibber-service-twitter* libaccounts-qt5-1* libc-ares2* libcogl9*
  libdee-qt5-3* libdevhelp-3-1* libecore-con1* libecore-evas1* libecore-fb1*
  libecore-file1* libecore-imf1* libecore-input1* libecore-ipc1* libecore-x1*
  libecore1* libedje-bin* libedje1* libeet1* libefreet1* libeina1*
  libembryo-bin* libembryo1* libevas1* libevas1-engines-core*
  libevas1-engines-x* libfriends0* libgexiv2-1* libgnome-keyring0:i386*
  libgoffice-0.8-8* libgoffice-0.8-8-common* libgtkspell-3-0* libgwibber-gtk3*
  libgwibber3* libllvm3.1* libllvm3.1:i386* libmjpegtools-1.9*
  libmozjs188-1.0* libqpdf8* libqt5graphicaleffects5* libquicktime2*
  libreoffice-emailmerge* librhythmbox-core6* libsignon-qt5-1*
  libtracker-extract-0.14-0* libtracker-miner-0.14-0*
  libtracker-sparql-0.14-0* libudev0:i386* libwebp2:i386* python-oauth*
  python3-crypto* python3-oauthlib* qtdeclarative5-accounts-plugin*
  qtdeclarative5-friends-plugin* qtdeclarative5-qtquick2-plugin*
  qtdeclarative5-ubuntu-ui-toolkit-plugin* ubuntu-ui-toolkit-theme*
  unity-lens-friends* unity-lens-gwibber*
Les NOUVEAUX paquets suivants seront installés :
  libefl libefl-bin
0 mis à jour, 2 nouvellement installés, 74 à enlever et 0 non mis à jour.
5 partiellement installés ou enlevés.
Il est nécessaire de prendre 2 437 ko dans les archives.
Après cette opération, 67,1 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn/ubuntu/ raring/main libefl amd64 201304161338-21778~raring1 [2 118 kB]
Réception de : 2 http://ppa.launchpad.net/hannes-janetzek/enlightenment-svn/ubuntu/ raring/main libefl-bin amd64 201304161338-21778~raring1 [319 kB]
2 437 ko réceptionnés en 5s (445 ko/s)
(Lecture de la base de données... 349581 fichiers et répertoires déjà installés.)
Dépaquetage de libefl (à partir de .../libefl_201304161338-21778~raring1_amd64.deb) ...
Remplacement de fichiers dans l'ancien paquet libefreet1 ...
Remplacement de fichiers dans l'ancien paquet libevas1 ...
Remplacement de fichiers dans l'ancien paquet libeet1 ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/libembryo.so.1 », qui appartient aussi au paquet libembryo1 1.2.0-1
Dépaquetage de libefl-bin (à partir de .../libefl-bin_201304161338-21778~raring1_amd64.deb) ...
dpkg: erreur de traitement de /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/embryo/include/default.inc », qui appartient aussi au paquet libembryo-bin 1.2.0-1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libefl_201304161338-21778~raring1_amd64.deb
 /var/cache/apt/archives/libefl-bin_201304161338-21778~raring1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
robin@nuage:~$ sudo apt-get check
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 e17 : Dépend: libefl (>= 201304161338) mais il n'est pas installé
       Dépend: libefl-bin (>= 201200000000) mais il n'est pas installé
 evas-loaders : Dépend: libefl (>= 201303142155) mais il n'est pas installé
 libedbus1 : Dépend: libefl (>= 201303142155) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
robin@nuage:~$ sudo apt-get check -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait

(mais n’a aucun effet réel, si je refais les commandes précédente j’ai toujours le même problème.
Je continue à chercher…

Hors ligne

#12 Le 21/04/2013, à 23:34

f.x0

Re : pb ajout ppa - python-software-properties [presque résolu]

Il n'y a pas de retour pour clean → c'est normal

Refais

sudo apt-get clean
sudo apt-get purge -f e17
sudo apt-get autoremove purge -f
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install -f e17

SOPI

Hors ligne

#13 Le 21/04/2013, à 23:41

robin_moussu

Re : pb ajout ppa - python-software-properties [presque résolu]

En continuant à tester des apt-get *** j’ai finis par identifier le paquet qui ne marchais pas :

robin@nuage:~$ sudo apt-get purge evas-loaders

Je passe le sujet en partiellement résolu, dans l’état actuel ça me suffit.

Résumé :
- Je ne peux toujours pas ajouter de ppa avec

sudo add-apt-repository nom_du_ppa

- Je sais ajouter un ppa à la main avec

echo "deb http://ppa.launchpad.net/nom_du_ppa/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/nom_perso_du_ppa.list
echo "deb-src http://ppa.launchpad.net/nom_du_ppa/ubuntu raring main" | sudo tee -a /etc/apt/sources.list.d/nom_perso_du_ppa.list

- Je peux à nouveau faire des mises à jour et mon système l’est.
- Je peux installer les logiciels provenant des ppa ajouté à la main.

Merci f.x0

Dernière modification par robin_moussu (Le 22/04/2013, à 00:03)

Hors ligne

Haut de page ↑