Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 22/04/2013, à 09:49

Merle

Problème pour paramétrer seafile

Bonjour à vous,

J'ai quelques problèmes à configurer seafile que je suis en train d'installer sur mon serveur apache et je trouve pas bien d'où vient le problème (j'ai suivi parfaitement le wiki d'installation mais je débute et je peux faire une erreur) :

voici mon vhost :

<VirtualHost *:80>
  ServerName domaine.fr
  DocumentRoot /var/www
  Alias /media    /home/julien/haiwen/installed/seafile-server-1.6.0/seahub/media      
  RewriteEngine On
  RewriteRule ^/(media.*)$ /$1 [QSA,L,PT]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule ^(.*)$ /seahub.fcgi$1 [QSA,L,E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
</virtualhost>

j'ai aussi entré l'alias dans la config d'apache de même que :

 FastCGIExternalServer /var/www/seahub.fcgi -host 127.0.0.1:8000

le domaine est bien paramétré dans la config de seafile et pourtant quand je le tappe dans mon navigateur je tombe sur la page "it works !", mais pas de problème en localhost.

Merci à ceux d'entre vous qui pourront m'aider.

Dernière modification par Merle (Le 22/04/2013, à 17:16)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#2 Le 22/04/2013, à 09:55

tiramiseb

Re : Problème pour paramétrer seafile

pas de problème en localhost.

1/
Pas de problème, ça veut dire quoi ?
Quand tu vas sur "http://localhost" tu obtiens l'interface de Seafile ? Autre chose ?

2/
Peux-tu confirmer que tu n'as rien de spécial dans les fichiers de log d'Apache (access.log et error.log) ?

3/
Que donne la commande suivante ?

ls /etc/apache2/mods-enabled/

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 22/04/2013, à 10:14

Merle

Re : Problème pour paramétrer seafile

Pas de problème, ça veut dire quoi ?
Quand tu vas sur "http://localhost" tu obtiens l'interface de Seafile ?

Quand je vais sur localhost:8000 je tombe bien sur l'interface de seafile.

Autre chose ?

Oui j'avais pas remarqué tout de suite mais apache est paramétré en ssl et mon domaine seafile est redirigé en https peut-être que le problème vient de là (mais je n'ai pas encore creusé).

Peux-tu confirmer que tu n'as rien de spécial dans les fichiers de log d'Apache (access.log et error.log) ?

Non rien pas de problème à ce niveau la.

Que donne la commande suivante ?

root@julien-Inspiron-530s:~# ls /etc/apache2/mods-enabled/
alias.conf            cgi.load      mime.load         reqtimeout.conf
alias.load            deflate.conf  mod-evasive.conf  reqtimeout.load
auth_basic.load       deflate.load  mod-evasive.load  rewrite.load
authn_file.load       dir.conf      negotiation.conf  setenvif.conf
authz_default.load    dir.load      negotiation.load  setenvif.load
authz_groupfile.load  env.load      php5.conf         ssl.conf
authz_host.load       fastcgi.conf  php5.load         ssl.load
authz_user.load       fastcgi.load  proxy.conf        status.conf
autoindex.conf        headers.load  proxy_http.load   status.load
autoindex.load        mime.conf     proxy.load        unique_id.load

Logithéque d'applications web très complète : Waah.info

Hors ligne

#4 Le 22/04/2013, à 10:21

tiramiseb

Re : Problème pour paramétrer seafile

Merle a écrit :

Pas de problème, ça veut dire quoi ?
Quand tu vas sur "http://localhost" tu obtiens l'interface de Seafile ?

Quand je vais sur localhost:8000 je tombe bien sur l'interface de seafile.

... quand tu vas directement sur l'interface de Seafile sans utiliser Apache.
Donc en effet Seafile marche bien a priori smile

j'avais pas remarqué tout de suite mais apache est paramétré en ssl et mon domaine seafile est redirigé en https

Comment ça "redirigé en https" ?

Le VirtualHost que tu nous montres est en HTTP sur le port 80, il n'a pas de redirection vers du HTTPS...

Dernière modification par tiramiseb (Le 22/04/2013, à 10:23)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 22/04/2013, à 10:33

Merle

Re : Problème pour paramétrer seafile

Le VirtualHost que tu nous montres est en HTTP sur le port 80, il n'a pas de redirection vers du HTTPS...

Tu as raison j'avais désactivé le vhost default pour faire une manip et je ne l'avais pas réactivé seul default-ssl était prit en compte ... donc ça c'est réglé, par contre sur mes autres domaines j'étais obligé d'ajouter un vhost pour la redirection no-ip et là pas besoin la redirection se fait toute seule.
Mais bon problème tjs présent.

Dernière modification par Merle (Le 22/04/2013, à 10:48)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#6 Le 22/04/2013, à 10:51

Merle

Re : Problème pour paramétrer seafile

Voici ma config seafile qui se trouve dans le ccnet.conf, ça pourra peut-être aider :

[General]
USER_NAME = my-seafile
ID = 7a89803b47e1d7fd95be53d8b4deb477fca82496
NAME = my-seafile
SERVICE_URL = http://mondomaine.fr

[Network]
PORT = 10001

[Client]
PORT = 13419

Dernière modification par Merle (Le 22/04/2013, à 17:16)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#7 Le 22/04/2013, à 11:03

tiramiseb

Re : Problème pour paramétrer seafile

Peux-tu préciser un peu plus cette histoire de redirection https ?

Le VirtualHost que tu as présenté ne parle pas du port 443 ni de HTTPS : il dessert normalement Seafile par le port 80 en HTTP.

Quand tu vas sur "http://seafile.mondomaine.fr", ça se connecte où et ça donne quoi ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#8 Le 22/04/2013, à 11:28

Merle

Re : Problème pour paramétrer seafile

Quand tu vas sur "http://seafile.mondomaine.fr", ça se connecte où et ça donne quoi ?

Ca se connecte sur apache avec le "it works !".

Petite question sur le wiki de seafile il y a un vhost pour le non root domain avec proxy (ici), je ne suis pas spécialiste mais est-ce que ce ne serait pas celui-là qu'il faudrait choisir ?

Dernière modification par Merle (Le 22/04/2013, à 11:28)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#9 Le 22/04/2013, à 11:47

tiramiseb

Re : Problème pour paramétrer seafile

Ca se connecte sur apache avec le "it works !".

En HTTP ou en HTTPS ?

Es-tu sûr que ton vhost est bien activé ?

Petite question sur le wiki de seafile il y a un vhost pour le non root domain avec proxy (ici), je ne suis pas spécialiste mais est-ce que ce ne serait pas celui-là qu'il faudrait choisir ?

Ah ben c'est toi qui dis si tu veux avoir Seafile à la racine ou si tu veux que Seafile soit un sous-répertoire...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#10 Le 22/04/2013, à 12:10

Merle

Re : Problème pour paramétrer seafile

En HTTP ou en HTTPS ?

En http.

Es-tu sûr que ton vhost est bien activé ?

Oui il est bien dans sites-enabled.

Ah ben c'est toi qui dis si tu veux avoir Seafile à la racine ou si tu veux que Seafile soit un sous-répertoire...

A la racine avec mon domaine.

Ben je comprends pas ça devrait marcher ....


Logithéque d'applications web très complète : Waah.info

Hors ligne

#11 Le 22/04/2013, à 12:13

tiramiseb

Re : Problème pour paramétrer seafile

Alors là je ne sais pas trop, sans avoir la main sur le serveur en question je ne saurais pas trop dans quel sens te guider, désolé...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#12 Le 22/04/2013, à 12:22

Merle

Re : Problème pour paramétrer seafile

Petite question quand même sur le wiki il est indiqué que :

FastCGIExternalServer /var/www/seahub.fcgi -host 127.0.0.1:8000

doit se trouver dans httpd.conf, donc c'est bien dans apache2.conf ?

Pour les alias c'est bien aussi dans apache2.conf ?

Dernière modification par Merle (Le 22/04/2013, à 12:23)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#13 Le 22/04/2013, à 12:34

tiramiseb

Re : Problème pour paramétrer seafile

Cette ligne doit se trouver en dehors du VirtualHost, mais tu le mets dans le fichier que tu veux, ça ne change rien... Apache "réunit" de toute manière tous les fichiers dans un seul gros "amas" avant de s'exécuter...

Moi je l'ai mis dans le même fichier que le VirtualHost, à la ligne juste au-dessus...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#14 Le 22/04/2013, à 12:59

Merle

Re : Problème pour paramétrer seafile

Ok merci pour ton aide, je vais attendre voir je referai une install propre en dernier ressort.


Logithéque d'applications web très complète : Waah.info

Hors ligne

#15 Le 22/04/2013, à 13:35

Merle

Re : Problème pour paramétrer seafile

Petite question tu connais la commande pour désinstaller seafile, supprimer le dossier d'install tout simplement ?

Dernière modification par Merle (Le 22/04/2013, à 13:37)


Logithéque d'applications web très complète : Waah.info

Hors ligne

#16 Le 22/04/2013, à 13:37

tiramiseb

Re : Problème pour paramétrer seafile

Comme l'explique le site de seafile, tu n'as pas *installé* le serveur au sein de ton système, tu l'as juste décompressé. Et pour le "désinstaller" il suffit de le supprimer...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#17 Le 22/04/2013, à 13:38

Merle

Re : Problème pour paramétrer seafile

Très bien merci.


Logithéque d'applications web très complète : Waah.info

Hors ligne

Haut de page ↑