Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 24/04/2013, à 16:50

Orion-Jones

[Résolu]Problème PHP 5 compatibility mode

Bonjour à tous,

Je vous expose mon problème. Je suis en train d'installer et configurer un serveur web "maison" sous ubuntu-server 12.04( serveur de récup ). Et j'ai un souci du mode de compatibilité avec PHP5 ( erreur PHP 5 compatibility mode ) avec l'installation du cms btitracker. Après avoir chercher 2 jours je sèche là.
Si quelqu'un peut me dépanner se serai super.

Merci

Dernière modification par Orion-Jones (Le 25/04/2013, à 08:56)

Hors ligne

#2 Le 24/04/2013, à 17:10

Kooothor

Re : [Résolu]Problème PHP 5 compatibility mode

Donne plus de détails.


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 24/04/2013, à 18:32

Orion-Jones

Re : [Résolu]Problème PHP 5 compatibility mode

Voici les différentes confirmations qui apparaissent lors de l'installation du CMS :

PHP version >= 4.1.2: ok
PHP 5 compatibility mode: ne marche pas
PHP session support - Check 1 (recommended):ok
PHP session support - Check 2 (recommended): ok
MySQL support exists - Check 1: ok
MySQL support exists - Check 2: ok
GD2 support exists: ok
/include/config.php/ is writable: ok
/torrents/ is writable: ok
chat.php/ is writable: ok
addons/guest.dat is writable: ok
badwords.txt is writable: ok

Mon config ; apache2, ubuntu-server 12.04.
J'ai utilisé les commandes :

apt-get install apache2 php5 mysql-server libapache2-mod-php5 php5-mysql; 
apt-get install phpmyadmin; 

pour tout installer

Ce qui me donne comme erreur lorsque je lance l'exportation de la base de données sous mysql :

Processing file: ../sql/database.sql
Starting at the line: 1
Error at the line 28: ) TYPE=MyISAM;
Query: -- -- -- -- -- CREATE TABLE `bannedip` ( `id` int(10) unsigned NOT NULL auto_increment, `added` int(11) NOT NULL default '0', `addedby` int(10) unsigned NOT NULL default '0', `comment` varchar(255) NOT NULL default '', `first` bigint(11) unsigned default NULL, `last` bigint(11) unsigned default NULL, PRIMARY KEY (`id`), KEY `first_last` (`first`,`last`) ) TYPE=MyISAM;
MySQL: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 15
Stopped on error

Je pense que cela vient d'un problème avec PHP5, mais celui-ci est pourtant bien installer vu que j'arrive à écrire et exécuter des fonctions PHP.

Dernière modification par Orion-Jones (Le 24/04/2013, à 18:36)

Hors ligne

#4 Le 24/04/2013, à 18:47

Kooothor

Re : [Résolu]Problème PHP 5 compatibility mode

D'après ce que j'ai pu glaner sur le web, il n'y a pas de mode de compatibilité php5, car un script php4 bien écrit fonctionne parfaitement avec php5. Donc le coup du PHP 5 compatibility mode: ne marche pas, on sait pas bien d'où ça sort. D'ailleurs ça serait intéressant de voir ce que teste cette ligne.

Ensuite, «You have an error in your SQL syntax».
Ça semble venir de la ligne TYPE=MyISAM.
Quelle est la version sql recommandée par le script ? (regarde l'entête du fichier sql et tu verras avec quelle version il a été exporté) EDIT: SQL 5.0.27 avec un php 5.2.0
Si t'enlèves TYPE=MyISAM, il se passe quoi ?

@+
~ktr

Dernière modification par Kooothor (Le 24/04/2013, à 18:51)


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#5 Le 24/04/2013, à 18:50

Kooothor

Re : [Résolu]Problème PHP 5 compatibility mode

Kooothor a écrit :

D'ailleurs ça serait intéressant de voir ce que teste cette ligne.

Bon j'ai DL le code source, et ça regarde http://www.php.net/manual/en/ini.core.p … ility-mode
Sauf que ça a été retiré avec php 5.3.0... Donc oublie cette ligne ! smile


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#6 Le 25/04/2013, à 08:54

Orion-Jones

Re : [Résolu]Problème PHP 5 compatibility mode

Merci beaucoup Koothor,
en enlevant "TYPE=MyISAM" et en supprimant les requêtes des tables créés juste avant ça marche nickel. Car si les tables existent déjà ça ne marche pas, c'est dommage qu'il n'y ai pas de fonctions qui vérifient la présence des tables.
Je vais modifier le database.sql pour le proposer comme màj.

Hors ligne

#7 Le 25/04/2013, à 09:18

Kooothor

Re : [Résolu]Problème PHP 5 compatibility mode

Orion-Jones a écrit :

Je vais modifier le database.sql pour le proposer comme màj.

Bonne attitude wink


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

Haut de page ↑