Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 04/05/2013, à 10:11

hcl_280

Débit réseau Samba bien plus faible qu'en FTP

Bonjour,

Je viens d'installer un serveur de fichier sous  Ubuntu serveur 13.04, j'ai un raid 5 logiciels fait avec 3*1 To WD Black, un CPU Intel E8400@3Ghz et 4 Go de RAM.

Le transfert entre le serveur et mon PC ne dépasse pas 60 Mo/s au maxi, aussi bien en lecture quand écriture, cela sous Samba, j'ai fait plusieurs tests en FTP et la je suis entre 100 et 120 Mo/s.

Pourquoi il y a t'il u,e si grosse différence de performances entre Samba et FTP, comment faire pour augmenter les performances sous smb.

Merci
@+

Hors ligne

#2 Le 07/05/2013, à 16:55

Kooothor

Re : Débit réseau Samba bien plus faible qu'en FTP

Salut,

Samba est bien plus complexe au niveau du protocole et nécessite plus de CPU.
Aussi Smb a besoin de config pour le gigabit : augmente la taille du buffer TCP.

@+
~ktr


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 08/05/2013, à 15:45

guyom.be

Re : Débit réseau Samba bien plus faible qu'en FTP

voir améliorations que tu peux ajouter dans le "smb.conf"

J'avais des lenteurs dans mon entreprise à la mise en place d'un file server (Suse) sous samba.

Tu as pas mal de topics sur le net qui traitent des soucis de lenteurs avec améliorations.

Moi j'ai basculer le MTU de ma NIC à 9000 (super rapide après), ajouter dans le smb.conf :

max protocol = NT1
socket options = TCP_NODELAY
read raw = yes                             
write raw = yes
max xmit = 65535                                                     
getwd cache = yes
lpq cache = 30
kernel oplocks= no
oplocks = yes

puis il reste :

SO_RCVBUF = 8192 SO_SNDBUF = 8192 IPTOS_LOWDELAY

que certains ajoutent pour rendre plus rapide (moi ca n'arrangeais rien)

Le MTU à tout fait pour moi, mais mes switchs sont config en 9000  mtu

Hors ligne

Haut de page ↑