Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 05/05/2013, à 09:14

thinkman

Problème d'accès web après activation d'un virtualhost

Bonjour à tous, voila je viens vers vous car je rencontre des problèmes
J'essaye d'installer un serveur sous ubuntu server 12.04 LTS avec ONLINE

Serveur qui servira pour plusieurs sites (je le précise)

Petite question concernant le compte administrateur :
Avec les anciennes versions, il été demandé un identifiant et mot de passe administrateur en plus d'un mot de passe utilisateur à l'installation
Maintenant il n'y a qu'un identifiant et mot de passe utilisateur
Pour me connecter en root, je ne peux plus me connecter avec su, en cherchant sur internet j'ai trouvé sudo -s avec le même mot de passe que l'utilisateur
Pouvez-vous me confirmer que c'est bien comme ça maintenant ?

J'ai installé LAMP (APACHE + PHP + MYSQL + PROFTPD + PHPMYADMIN + WEBMIN)
J'ai modifié cd /var/www/index.html en cd /var/www/index.php et y insérer <?php echo phpinfo(); ?>
J'ai transféré par ftp sur le serveur dans le dossier monsite, un fichier index.html test

Quand je tape l'url de mon serveur (ex :88.100.52.100), j'accède à la page du tableau avec toutes les informations PHP (phpinfo)
Quand je tape l'url/phpmyadmin (ex :88.100.52.100/phpmyadmin), j'accède bien à phpmyadmin

Mon problème vient quand je créée mon premier virtualhot "monsite.fr" et que je l'active
je n'ai plus accès à l'url de mon serveur mais à la page index.html test que j'ai transféré par ftp
Je n'ai plus accès aussi à phpmyadmin, j'ai Not Found The requested URL /phpmyadmin/index.php was not found on this server.

Ci dessous, exemple de ma configuration :
sous /etc/apache2/sites-available/monsite.fr

<VirtualHost 88.100.52.100:80>
        ServerAdmin webmaster@monsite.fr
        ServerName www.monsite.fr
        ServerAlias monsite.fr
        DocumentRoot /home/monsite/www
                <Directory />
                        Options FollowSymLinks
                        AllowOverride All
                </Directory>

                <Directory /home/monsite/www/>
                        Options -Indexes
                        Options FollowSymLinks MultiViews
                        AllowOverride All
                        Order allow,deny
                        Allow from all
                </Directory>
        ErrorLog /home/monsite/logs/www-monsite-error.log
        LogLevel warn
        CustomLog /home/monsite/logs/www-monsite-access.log combined
</VirtualHost>

a2ensite monsite.fr
/etc/init.d/apache2 reload (ok)

J'ai bien ajouté un utilisateur monsite avec dossier www avec les droits dessus

chown -R monsite www
chgrp -R monsite www

Petite précision : quand je fais a2dissite monsite.fr, j'ai de nouveau accès à ma page de configuration php et phpmyadmin

J'ai modifié le fichier /etc/apache2/mods-available/userdir.conf

<IfModule mod_userdir.c>
        UserDir www
        UserDir disabled root

        <Directory /home/*/www>
                AllowOverride FileInfo AuthConfig Limit Indexes
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
                <Limit GET POST OPTIONS>
                        Order allow,deny
                        Allow from all
                </Limit>
                <LimitExcept GET POST OPTIONS>
                        Order deny,allow
                        Deny from all
                </LimitExcept>
        </Directory>
</IfModule>

a2enmod userdir
/etc/init.d/apache2 reload

Merci d'avance pour votre aide, je suis perdu

Hors ligne

#2 Le 05/05/2013, à 12:14

tiramiseb

Re : Problème d'accès web après activation d'un virtualhost

Salut,

Quels sont les virtualhosts activés ?

ls /etc/apache2/sites-enabled
cat /etc/apache2/sites-enabled/*

Suppositions :

Pour PHPMyAdmin, tu dois réitérer l'alias qui va bien dans ton virtualhost, je pense...
Par ailleurs, lorsqu'il n'y a pas de virtualhost particulier demandé (donc en passant par l'adresse IP), Apache te renvoie vers le premier virtualhost défini (par ordre alphabétique).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 05/05/2013, à 18:42

thinkman

Re : Problème d'accès web après activation d'un virtualhost

Bonsoir,

Quand j'ai posté ce message sur le forum, je n'avais qu'un site actif, là j'en ai fait 2 :

voici ce que j'ai après avoir lancer :
/etc/apache2/sites-enabled# /etc/init.d/apache2 reload

 * Reloading web server config apache2  
[Sun May 05 18:40:16 2013] [warn] VirtualHost 88.100.52.100:80 overlaps with VirtualHost 88.100.52.100:80, the first has precedence, perhaps you need a NameVirtualHost directive
                                                                                                     [ OK ]

Maintenant quand je saisis l'url dans le navigateur, j'ai

Page Web inaccessible
Il se peut que la page Web à l'adresse http://88.100.52.100/ soit temporairement inaccessible ou qu'elle ait été déplacée de façon permanente à une autre adresse Web.
Erreur 103 (net::ERR_CONNECTION_ABORTED) : Erreur inconnue

Je suis un peu perdu

Help !

Hors ligne

#4 Le 05/05/2013, à 21:02

tiramiseb

Re : Problème d'accès web après activation d'un virtualhost

Comme le dit l'erreur, tu as besoin d'une directive NameVirtualHost.
Celles-ci sont généralement placées dans /etc/apache2/ports.conf ou dans /etc/apache2/apache2.conf :

NameVirtualHost 88.100.52.100:80

Mais as-tu vraiment besoin de préciser « 88.100.52.100:80 » ?
« *:80 » ne te convient pas ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 05/05/2013, à 22:25

thinkman

Re : Problème d'accès web après activation d'un virtualhost

Merci

Mais ça n'a pas fonctionné, en revanche j'ai mis un # devant NameVirtual host *:80 dans "ports.conf" et là tout fonctionne

Merci encore

Dernière modification par thinkman (Le 05/05/2013, à 22:25)

Hors ligne

#6 Le 09/05/2013, à 14:01

Titouan

Re : Problème d'accès web après activation d'un virtualhost

overlaps ...

cas type avec phpmyadmin, où tu as un conflit avec un lien symbolique et  un include en /etc/apache2/conf.d/phpmyadmin...
Tu liras la doc apache2.conf
Tente de créer 2 instances et finalement fait planter...

bref, il faut choisir entre la méthode du lien symbolique, l'alias de directory version /usr/share/phpmyadmin, l'alias de directory version décompression archive phpmyadmin.tar*, et celle par défaut ( include /etc/apache2.conf/conf.d/... ) qui est appelé pour le vhost par défaut ( sudo apache2ctl -S | grep default )

Hors ligne

Haut de page ↑