Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/05/2013, à 09:57

lip2502

Jeux ne se lancent plus sous la 12.04

Bonjour à tous les ubuntistes,

J'aimerais vous soumettre un problème auquel je suis confronté depuis peu. Je n'arrive plus à lancer aucun jeu sur mon système (alors que j'y arrivais avant). Le seul rescapé c'est minecraft, mais les autres ne fonctionnent plus. Lorsque je lance, rien ne se passe ou alors le plein écran quitte très rapidement sans message d'erreur.

J'ai essayé de les lancer via le terminal sans succés voilà ce que j'obtiens :

lip@lip:~$ apt-cache search wizorb
wizorb - Retro brick breaking adventure game.
lip@lip:~$ wizorb
wizorb: command not found
lip@lip:~$ apt-cache search dynamitejack
dynamitejack - Push button. Receive detonation.
dynamitejack-bin - Push button. Receive detonation.
lip@lip:~$ dynamitejack
dynamitejack: command not found

La désintallation /. réinstallation n'y change rien.

Auriez-vous une idée pour corriger ça ?


Merci d'avance.

Hors ligne

#2 Le 08/05/2013, à 10:04

abelthorne

Re : Jeux ne se lancent plus sous la 12.04

Ils sont installés où tes jeux ? Tu les installes manuellement ou via la Logithèque ?

Tu as ce problème aussi pour d'autres commandes ?

Donne voir le résultat de la commande echo $PATH

En ligne

#3 Le 08/05/2013, à 10:12

lip2502

Re : Jeux ne se lancent plus sous la 12.04

Salut merci pour ta réponse.

J'ai fait de plus ample recherches. Les jeux sont installés dans le répertoire /opt/. Je crois que j'ai installé dynamite jack via la logithèque et wizorb séparément depuis le lien .deb de la page Humble Bundle.

De plus j'ai essayé d'installer d'autres jeux (Super hexagone) ça fonctionne c'est spécifique à ceux là on dirait.

Le problème pour wizorb semble être une dépendance :

lip@lip:/opt$ cd /opt/wizorb
lip@lip:/opt/wizorb$ mono Wizorb.exe
Missing method .ctor in assembly /opt/wizorb/MonoGame.Framework.Linux.dll, type System.Runtime.CompilerServices.ExtensionAttribute
Can't find custom attr constructor image: /opt/wizorb/MonoGame.Framework.Linux.dll mtoken: 0x0a0003a9

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.
File name: 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
  at Paris.Paris..ctor () [0x00000] in <filename unknown>:0 
  at Paris.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.
File name: 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
  at Paris.Paris..ctor () [0x00000] in <filename unknown>:0 
  at Paris.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 

Pour dynamite jack je cherche.

Hors ligne

#4 Le 08/05/2013, à 10:29

abelthorne

Re : Jeux ne se lancent plus sous la 12.04

Tu n'as pas des lanceurs créés en installant les jeux ? S'ils n'apparaissent pas dans le menu Applications, il faudrait aller voir dans /usr/share/applications.

En tout cas, le problème dans ton premier message est à priori normal : les jeux de la Logithèque sont effectivement installés dans /opt (qui n'est pas dans le PATH) et je ne crois pas qu'ils installent un raccourci dans un dossier qui permettrait de les lancer en tapant simplement leur nom dans le terminal.

Il faudrait voir 1) s'ils se lancent ou non en utilisant leur lanceur et 2) voir ce que fait chaque lanceur.

À tout hasard, si tu possèdes les jeux sur la Logithèque suite à un achat dans un HIB, essaie d'installer le paquet DEB disponible sur le site du bundle (s'il existe) plutôt que la version de la Logithèque. Voire une version non-DEB du site du bundle (mais là, va falloir plutôt l'installer manuellement dans ton dossier perso). En effet, les paquets DEB des HIB ne sont pas toujours très à jour et la version de la Logithèque encore moins.

En ligne

#5 Le 08/05/2013, à 10:32

lip2502

Re : Jeux ne se lancent plus sous la 12.04

Oui. Bizarrement je viens de régler le problème pour wizorb en effectuant un :

sudo apt-get purge wizorb

Puis en réinstallant depuis la logithèque. Je pense que le paquet de HIB n'a pas satisfait toutes les dépendances lors de l'installation via dpkg. Je tente la même chose pour dynamtique Jack et je te tiens au courant.

Hors ligne

#6 Le 08/05/2013, à 10:51

lip2502

Re : Jeux ne se lancent plus sous la 12.04

Malheureusement toujours pas moyen de lancer dynamite jack.

Pour j'ai déjà joué à ce jeux sur ce même ordinateur. Bizarre voici le rapport d'erreur généré par le terminal.

lip@lip:/opt/dynamitejack$ ./run_me 
Game::init ...
SDL Runtime Version: 1.2.14
SDL Compile Version: 1.2.14
SDL_BYTEORDER == SDL_LIL_ENDIAN
== joystick init.............
irrKlang sound library version 1.4.0
Loaded plugin: ikpMP3.so
Loaded plugin: ikpFlac.so
Using ALSA driver
udid:001f3c8ef530-1363381507, name:Anonymous, uid:a:001f3c8ef530-1363381507 token:e2e09cae8e3406283d70481f34dae5d3
init_video: 1280 800 640 480 320 320 1
_try_init_video(1280,800,1)
VideoInfo->vfmt->BitsPerPixel:32
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  130 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0xa7
  Serial number of failed request:  151
  Current serial number in output stream:  153

Hors ligne

#7 Le 08/05/2013, à 11:15

abelthorne

Re : Jeux ne se lancent plus sous la 12.04

Là c'est un problème d'affichage : il ne peut pas lancer le jeu dans la résolution demandée.

Tu utilisais le même PC mais pas avec le même OS. Et donc pas le même pilote. Qu'est-ce que tu as comme puce graphique sur ton PC et quel pilote utilises-tu ?

En ligne

#8 Le 08/05/2013, à 13:45

lip2502

Re : Jeux ne se lancent plus sous la 12.04

Si si le même OS :s

Voici le résultat de lspci pour la carte graphique :

lip@lip:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series]

Et voici la version du driver que j'utilise :

1368017132-screen.png

Pour info j'ai une résolution 1280 x 800.

Dernière modification par lip2502 (Le 08/05/2013, à 13:48)

Hors ligne

#9 Le 09/05/2013, à 09:00

roden

Re : Jeux ne se lancent plus sous la 12.04

J'ai mis à jour ubuntu 12-10 et j'utilise ubuntu 13-04.Impossible d'installer Google Chrome, il ne  veut pas aller dans le  lanceur. De même, je me demande où sont passés les jeux. Dans les versions précédentes il était possible de les retirer du lanceur et de les envoyer sur le bureau où ils pouvaient être regroup&s dans un dossier.

Hors ligne

#10 Le 09/05/2013, à 09:35

abelthorne

Re : Jeux ne se lancent plus sous la 12.04

roden : ouvre un nouveau sujet dédié à ton problème, qui n'a rien à voir avec celui de lip2502.

En ligne

Haut de page ↑