Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#51 Le 12/10/2005, à 17:22

leloxias

Re : [Howto] Installation et configuration de e17 CVS

Pour ne plus avoir de soucis de dépendance pendant la compilation de e17 cvs, voici la liste des paquets a installer :

sudo apt-get install libtag1c2 libtagc0 libtagc0-dev libxml2-dev libxml2 cvs autoconf automake1.7 gettext libtool libfreetype6-dev libjpeg62-dev libpng3-dev libtiff4-dev
sudo apt-get install libungif4-dev libbz2-dev libltdl3-dev pkg-config libxine-dev build-essential flex bison sqlite3 libgtk2.0-dev libsqlite3-dev libXxf86vm-dev

Si il y a des soucis je ferais un update smile


MERCI à rezzakilla pour sa remarque très utile wink

Dernière modification par leloxias (Le 13/10/2005, à 04:13)


"C'est le devoir de chaque homme de rendre au monde au moins autant qu'il en a reçu." - Albert Einstein

Hors ligne

#52 Le 12/10/2005, à 22:59

rezzakilla

Re : [Howto] Installation et configuration de e17 CVS

leloxias a écrit :

Pour ne plus avoir de soucis de dépendance pendant la compilation de e17 cvs, voici la liste des paquets a installer :

sudo apt-get libtag1c2 libtagc0 libtagc0-dev libxml2-dev libxml2 cvs autoconf automake1.7 gettext libtool libfreetype6-dev libjpeg62-dev libpng3-dev libtiff4-dev libungif4-dev libbz2-dev libltdl3-dev pkg-config libxine-dev build-essential flex bison sqlite3 libgtk2.0-dev libsqlite3-dev libXxf86vm-dev imlib1-dev build-essentials

Si il y a des soucis je ferais un update smile

il manque "install" aprés apt-get tongue

Hors ligne

#53 Le 25/11/2005, à 14:03

fredebec

Re : [Howto] Installation et configuration de e17 CVS

vigilian3 a écrit :

et maintenant autre petit problème! youpiiiiiiiiiieeeeeeeeeee
+ Checking for required programs.
+ Done.
 
+ Building and installing libraries.
   .debs for edb already built.
   .debs for eet already built.
   .debs for imlib2 already built.
   .debs for imlib2_loaders already built.
   .debs for evas already built.
   .debs for ecore already built.
   .debs for epeg already built.
   Building .deb of epsilon

** Unable to build a debian package of epsilon.
** Check /home/charles/e17install/compile_logs/epsilon.log for details.
** An error occured. Exiting...


cvs pas conforme?

Bonjour.

J'ai le même probleme.

J'ai installé tous les paquets et dépendances que j'ai pu trouver dans le topic, mais rien a faire il bloque toujours sur la création du .deb d'epsilon.

Si quelqu'un a une idée, ça me retirerait une fiere chandelle du pied:)


To boldly go, where no Tux has gone before...

Hors ligne

#54 Le 27/11/2005, à 15:56

Golgoth

Re : [Howto] Installation et configuration de e17 CVS

fredebec a écrit :
vigilian3 a écrit :

et maintenant autre petit problème! youpiiiiiiiiiieeeeeeeeeee
+ Checking for required programs.
+ Done.
 
+ Building and installing libraries.
   .debs for edb already built.
   .debs for eet already built.
   .debs for imlib2 already built.
   .debs for imlib2_loaders already built.
   .debs for evas already built.
   .debs for ecore already built.
   .debs for epeg already built.
   Building .deb of epsilon

** Unable to build a debian package of epsilon.
** Check /home/charles/e17install/compile_logs/epsilon.log for details.
** An error occured. Exiting...


cvs pas conforme?

Bonjour.

J'ai le même probleme.

J'ai installé tous les paquets et dépendances que j'ai pu trouver dans le topic, mais rien a faire il bloque toujours sur la création du .deb d'epsilon.

Si quelqu'un a une idée, ça me retirerait une fiere chandelle du pied:)

+1

qd je vais voir le log:

/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_style_get'
/usr/lib/libedje.so: undefined reference to `evas_smart_below_get_set'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_add'
/usr/lib/libedje.so: undefined reference to `evas_textblock2_style_set'
/usr/lib/libedje.so: undefined reference to `evas_smart_above_get_set'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_style_set'
/usr/lib/libedje.so: undefined reference to `evas_textblock2_style_free'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_text_markup_set'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_style_insets_get'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_text_markup_get'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_size_native_get'
/usr/lib/libedje.so: undefined reference to `evas_textblock2_style_new'
/usr/lib/libedje.so: undefined reference to `evas_object_textblock2_size_formatted_get'

Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#55 Le 28/11/2005, à 13:11

obs-n

Re : [Howto] Installation et configuration de e17 CVS

le script sh n'est plus dispo sur le lien en première page!:o

Hors ligne

#56 Le 03/12/2005, à 20:29

fraide

Re : [Howto] Installation et configuration de e17 CVS

et si... big_smile

Hors ligne

#57 Le 04/12/2005, à 14:29

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Bonjour,
J'essaye d'installer E17 depuis hier soir lol
C'est fait, enfin, mais voilà, je ne peux pas le lancer.
Quand je le sélectionne dans gdm, j'ai un bel écran tout noir, puis il devient tout blanc et se gèle !
Quand je repasse en terminal pour voir les erreurs :

DYNAMIC DETERMINED PREFIX: /usr
WARNING: Prefix guess was wrong. Guessed:
         /usr
         Tried to find file:
         /usr/share/enlightenment/data/themes/default.edj
WARNING: Enlightenment could not determine its installed prefix
         and is falling back on the compiled in default:
         /usr
setlocale() :: No such file or directory
An error occured when trying to use the locale: fr_FR:fr:en_GB:en
Details:
E17 INIT: XINERAMA CHOSEN: [0], 1280x800+0+0
sh: /usr/share/enlightenment/data/other/applications.tar.gz: No such file or directory
**** SEGMENTATION FAULT ****

Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#58 Le 10/12/2005, à 21:32

SheepiZ

Re : [Howto] Installation et configuration de e17 CVS

Link a écrit :
eks a écrit :

Suite à d'autres problème avec le script et les dépot shadoi, j'ai finalement suivi l'installation manuelle décrite sur la page https://vogelweith.homeftp.net/Linux/e17.php

moi aussi j'ai suivi le meme install mais j'ai un petit probleme, le voici:


Making all in bin
make[3]: entrant dans le répertoire « /home/****/cvs/e17/libs/edje/src/bin »
/bin/sh ../../libtool --mode=link gcc  -g -O2   -o edje  edje_main.o ../../src/lib/libedje.la
gcc -g -O2 -o .libs/edje edje_main.o  ../../src/lib/.libs/libedje.so
../../src/lib/.libs/libedje.so: undefined reference to `evas_smart_below_get_set'
../../src/lib/.libs/libedje.so: undefined reference to `evas_smart_above_get_set'
../../src/lib/.libs/libedje.so: undefined reference to `evas_object_textblock2_style_insets_get'
../../src/lib/.libs/libedje.so: undefined reference to `evas_object_textblock2_size_native_get'
../../src/lib/.libs/libedje.so: undefined reference to `evas_object_textblock2_size_formatted_get'
collect2: ld returned 1 exit status
make[3]: *** [edje] Erreur 1
make[3]: quittant le répertoire « /home/****/cvs/e17/libs/edje/src/bin »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /home/****/cvs/e17/libs/edje/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/****/cvs/e17/libs/edje »
make: *** [all] Erreur 2



je ne peux pas terminer l'installation a cause de ca, est-ce que quelqu'un pourrais m'aider s.v.p.

J'ai exactement la même erreur que toi  ! Apres une courte recherche sur google je n'es rien trouvé .. Si tu trouve une solution previens moi.
(Et toute une installation ratée pour une seul librairie hmm )

#59 Le 10/12/2005, à 21:38

fraide

Re : [Howto] Installation et configuration de e17 CVS

https://vogelweith.homeftp.net/Linux/e17.php#x1-70002
C'est la seule solution trouvée pour que ça fonctionne comme une montre sur breezy...
Tout faire comme indiqué, après avoir désinstallé tout ce qui touche e17... par synaptic éventuellement. C'est un peu long à mettre en place, mais c'est le bonheur quand c'est fait. Je viens d'y passer l'aprem, et c'est beau, nondidzou ! big_smile

Hors ligne

#60 Le 10/12/2005, à 23:12

trasmontano

Re : [Howto] Installation et configuration de e17 CVS

TiteFleur a écrit :

Bonjour,
J'essaye d'installer E17 depuis hier soir lol
C'est fait, enfin, mais voilà, je ne peux pas le lancer.
Quand je le sélectionne dans gdm, j'ai un bel écran tout noir, puis il devient tout blanc et se gèle !
Quand je repasse en terminal pour voir les erreurs :

DYNAMIC DETERMINED PREFIX: /usr
WARNING: Prefix guess was wrong. Guessed:
         /usr
         Tried to find file:
         /usr/share/enlightenment/data/themes/default.edj
WARNING: Enlightenment could not determine its installed prefix
         and is falling back on the compiled in default:
         /usr
setlocale() :: No such file or directory
An error occured when trying to use the locale: fr_FR:fr:en_GB:en
Details:
E17 INIT: XINERAMA CHOSEN: [0], 1280x800+0+0
sh: /usr/share/enlightenment/data/other/applications.tar.gz: No such file or directory
**** SEGMENTATION FAULT ****

Enlève les paquets libeet0 et libeet0-dev

#apt-get remove libeet0 libeet0-dev
et tu relances ta compile

Hors ligne

#61 Le 13/12/2005, à 13:06

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Si je veux virer ces paquets, il veut tout me virer aussi ...

Les paquets suivants seront ENLEVÉS :
  eclair ecore0-bin edje0-bin elicit emodules engage enlightenment entice
  entrance epsilon0-bin esmart0-bin eutils evas0-bin examine imlib2-loaders
  libe libe-dev libecore0 libecore0-dev libedje0 libedje0-dev libeet0
  libeet0-dev libemotion0 libengrave0 libengrave0-dev libepsilon0
  libepsilon0-dev libesmart0 libesmart0-dev libevas0 libevas0-dev libewl0

??


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#62 Le 13/12/2005, à 15:01

fraide

Re : [Howto] Installation et configuration de e17 CVS

Ben et mon post alors ? ça sert à rien ? pas sympa... big_smile

Hors ligne

#63 Le 13/12/2005, à 20:42

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Oh pardon je ne pensais pas que ça m'était adressé !!
Je vais essayer ça dans la soirée, merci smile
Je tiens au courant.


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#64 Le 13/12/2005, à 21:48

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Bon ben en fait ça va pas très loin... Après avoir viré tout ce qui se reportait à Enlightenment, je lance & j'ai des erreurs tt de suite rien que pour récup les sources sad

marion@etout:~/cvs$ cvs -d:pserver:anonymous:@cvs.sourceforge.net:/cvsroot/enlightenment login
Logging in to :pserver:anonymous@cvs.sourceforge.net:2401/cvsroot/enlightenment
marion@etout:~/cvs$ cvs -z3 -d:pserver:anonymous:@cvs.sourceforge.net:/cvsroot/enlightenment co e17 misc
cvs [checkout aborted]: end of file from server (consult above messages if any)

Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#65 Le 13/12/2005, à 21:49

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Ah bah on dirait que j'ai parlé trop vite smile
J'ai insisté 5-6 fois et il est parti à récupérer des choses on dirait.


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#66 Le 13/12/2005, à 22:26

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Autre problème (ben voui hein), je n'ai pas "/etc/ld.so.conf".

?


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#67 Le 13/12/2005, à 22:48

fraide

Re : [Howto] Installation et configuration de e17 CVS

tu le crées...

Hors ligne

#68 Le 14/12/2005, à 17:55

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Ah ça y est !!
Tout s'est bien passé à part la compilation de emotion qui n'a pas voulu se faire mais comme le reste a suivi j'imagine que ce n'est pas très indispensable... Me voilà donc sous E17, depuis le temps que j'en rêvais. A première vue, j'aime bcp. Maintenant j'ai de belles heures devant moi à apprendre à maîtriser la bête big_smile
Merci bcp fraide pour ton aide.


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#69 Le 14/12/2005, à 18:03

yassine

Re : [Howto] Installation et configuration de e17 CVS

escusais mon ignorance, mais a quoi sert e17?
et qu'est ce que e17 svp?

Hors ligne

#70 Le 14/12/2005, à 18:24

Golgoth

Re : [Howto] Installation et configuration de e17 CVS

e17 est un environnement comme gnome, KDE, XFCE, ...


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#71 Le 14/12/2005, à 21:01

fraide

Re : [Howto] Installation et configuration de e17 CVS

TiteFleur a écrit :

A première vue, j'aime bcp. Maintenant j'ai de belles heures devant moi à apprendre à maîtriser la bête big_smile
Merci bcp fraide pour ton aide.

Si tu as besoin, TiteFleur, n'hésite pas... Suis abonné à ce post, et je ne me sers que de e17, qui est à mon sens [très gros double troll poilu] le seul environnement graphique qui peut rivaliser avec osX (je parle pas de Windows, c'est moche...) [/très gros double troll poilu]
Tu as une très bonne adresse aussi :
http://get-e.org/E17_User_Guide/French/
Amuses toi bien !
au cas où... fraide@jabber.org
wink

Hors ligne

#72 Le 14/12/2005, à 21:08

yassine

Re : [Howto] Installation et configuration de e17 CVS

merci golgoth pur la précision, et est ce qu'il existe en live ce e17, pour le tester?
car les screenshhoot sont super , vraiment, aprés pour l'installation c'est trops merdique!
trops compliqué pour monpetit cerveau, et donc, vais attendre,
"e17ubuntu"

Hors ligne

#73 Le 14/12/2005, à 21:22

Noé

Re : [Howto] Installation et configuration de e17 CVS

aaah.
Manque un /usr/lib/libXcursor.la
J'ai fait un symlink de libXcursor.la vers libXcursor.a a tout hasard et ca veut pas. préfère pas faire un lien en dur... Que faire ? j'ai libXcursor et libXcursor-dev installés sad
http://perso.wanadoo.fr/kritik-net/Epascompile.png

Dernière modification par Noé (Le 14/12/2005, à 21:26)


dotdotno ou Phlogistique sur IRC
Jabber : noe.rubinstein CHEZ fritalk.com

Hors ligne

#74 Le 14/12/2005, à 22:14

fraide

Re : [Howto] Installation et configuration de e17 CVS

Normal... J'ai eu le smêmes erreurs, à l'install des paquets sur ce site... Tu devrais utiliser la première adresse que j'ai donnée, et installer les cvs une par une... Je jure que ça marche et que je suis sous e17 et content depuis mon install. C'est magique, écran animé, ombres sous les fenêtres makgré mon ati de crotte...
Enfin bon... big_smile

Hors ligne

#75 Le 14/12/2005, à 22:26

TiteFleur

Re : [Howto] Installation et configuration de e17 CVS

Voui moi aussi, j'ai passé un certain temps à tout compiler à la main, mais tu fais autre chose en mm temps pis ça finit par passer wink Et même avec mon ATI de crotte aussi, j'ai tous les beaux effets. Maintenant faut que j'apprenne la bête mais je regrette pas, je compte bien chercher un peu partout car Gnome me convenait pas, j'aimais bien fvwm mais un peu trop la flemme j'avoue de m'y mettre... E17 je le regardais depuis bien longtemps et j'y suis enfin, donc maintenant, je le lâche plus avant de voir tout ce qu'il a dans le ventre lol

fraide, as-tu de bons liens de themes pour E17 ?
Je vais m'abonner au sujet aussi tiens wink

PS : j'adore changer de bureau par la molette ou en poussant sur le côté ça m'éclate big_smile

PPS pour fraide (ou autre) : mon firefox est tout pas beau par contre, les menus, enfin la police, elle est grosse pas belle... normal ?


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

Haut de page ↑