Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/05/2013, à 11:05

Valeryan_24

Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Bonjour,

J'ai profité de l'actualité calme sur Ubuntu 13.10 (déjà installé sur mon PC perso) en attendant l'UDS de mai, pour tester le nouveau Debian qui vient de sortir en stable (j'avais déjà vu le 6.0.7).

J'ai donc téléchargé sur le tracker BT officiel le debian-live-7.0.0-amd64-gnome-desktop.iso et booté sur le DVD.

Au début pas de souci, jusqu'à l'arrivée sur le bureau, en gros j'ai un écran stroboscopique avec des lignes de partout, parfois en entier, parfois scindé en deux avec les côtés inversés et impossible d'aller à gauche, jugez plutôt :

http://i.imgur.com/CKWOkXl.png

Avec un petit message d'erreur tout de même juste avant :

Debian 7 Bug HD 5770

Il semble que le problème vienne du modèle de ma carte graphique, une ATI RAdeon HD 5770 : lors du boot, j'ai le message d'erreur suivant

Radeon kernel modesetting for R600 or later requires firmware-linux-nonfree

http://i.imgur.com/M7FhK8l.png

D'après ce que je comprends, il manque le firmware proprio pour que l'affichage soit correct, mais la philosophie de Debian est justement de n'inclure que des composants strictement libres dans sa distro.

Sur Ubuntu, je crois savoir qu'il y a des blobs propriétaires inclus justement pour ce genre de cas, effectivement en LiveCD tout fonctionne out of the box nickel, et sur l'utilisation je tourne avec le pilote libre de toute façon. Sur le LiveCD Debian 6.0.7 je n'ai pas non plus ce problème, ça marche parfaitement. Je n'ai pas tenté non plus d'install' en dur de Debian 7.

D'où ma question préalable ici, avant éventuellement d'aller sur le forum / bugtracker dédié de Debian - car autant je connais bien ceux de Ubuntu et la manière de reporter un problème, autant ce n'est pas le cas avec Debian et je ne veux pas commettre d'impair.

Déjà, d'après vous s'agit-il réellement d'un bug - en gros même sans firmware non-free, ma CG devrait-elle être reconnue et fonctionner sur le LiveCD de Debian 7 ?

Si oui, où et comment le signaler de manière utile (ou vérifier que ce n'est pas connu) ? J'ai également pris des captures du Hardware Detection Tool intégré. Merci smile

Dernière modification par Valeryan_24 (Le 16/05/2013, à 00:06)

Hors ligne

#2 Le 12/05/2013, à 14:09

carld2010

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Bonjour, un apt-get upgrade en live cd te permettrais de voir si le pilote libre Xorg est offert en mise à jour, sinon tu peut essayer de l'installer manuellement:

su
apt-get install xserver-xorg-video-radeon xserver-xorg-video-radeonhd xserver-xorg-video-ati

Cependant, je ne suis pas certain que c'est possible d'installer un pilote graphique en live cd.

Le pilote libre Xorg supporte la série radeon hd 5000 sur squeeze mais j'ignore si elle le supporte sur la très très jeune wheezy; si elle ne l'ait pas, c'est probablement une question de temps. 

Donc, d'après moi, ce n'est pas un bug...

Dernière modification par carld2010 (Le 12/05/2013, à 15:29)

Hors ligne

#3 Le 12/05/2013, à 15:35

Valeryan_24

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

OK, je testerai, merci.

Je vais peut-être dire une bêtise - je ne suis pas familier avec cette distrib' - mais Debian n'est-elle pas justement axée sur la fiabilité et la stabilité ? Là où une Ubuntu sort tous les 6 mois, avec au début de chaque nouvelle version son lot de bugs non résolus, Debian prend son temps, je crois qu'il y a eu au moins deux ans depuis la dernière version dite "stable", en théorie ce statut n'est attribué que si aucun problème critique ne subsiste.

Or une incompatibilité avec une carte graphique relativement standard et ancienne (ce n'est pas un nouveau modèle d'une gamme différente sorti très récemment) n'en est-t-il pas un ?

Hors ligne

#4 Le 12/05/2013, à 16:54

carld2010

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Oui debian est + stable, mais les bugs son pas impossible. Je connait bien squeeze mais peu wheezy, à bien y repenser c'est vrai que c'est étrange que le pilote libre ne fonctionne pas en live cd pour ta carte.

Si mes conseil ne fonctionne pas, je suis vraiment désolé mais sa dépasse mes compétences. hmm
Certe c'est contre les valeurs Debian d'utiliser un pilote propriétaire, mais il est toujours disponible si tu en à besoin.
Bonne chance wink

Hors ligne

#5 Le 12/05/2013, à 17:27

Valeryan_24

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Je testerai ta solution déjà en LiveCD.

Je ne compte pas installer Debian en dur, je reste sur Ubuntu, mais si je peux aider en reportant un bug, je le ferai.

Hors ligne

#6 Le 12/05/2013, à 17:33

xavier4811

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Bonjour,

et en bootant avec l'option nomodeset ?

Hors ligne

#7 Le 12/05/2013, à 18:30

inkey

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Valeryan_24 a écrit :

Déjà, d'après vous s'agit-il réellement d'un bug - en gros même sans firmware non-free, ma CG devrait-elle être reconnue et fonctionner sur le LiveCD de Debian 7 ?

Je n'en suis pas certain malheureusement. Un firmware c'est vraiment bas niveau, le code dans firmware non free est nécessaire pour faire tourner le driver libre radeon correctement. D'après ce que je comprend ça peut marcher sans mais tu dois être franchement limité, genre l'accélération graphique n'est pas fonctionnelle, ça saccade beaucoup,etc…
Bref je crois pas que sans le firmware on peut considérer que la CG peut fonctionner normalement.

J'aurais tendance à dire s'il s'agit bien de gnome-shell (sur la capture d'écran) que le driver fonctionne et arrive même sans microcode à quelques capacité d'accélération 3D, de fait gnome-shell se lance (au lieu de fallback) et plante car le microcode étant manquant ça ne peut fonctionner correctement.

Mais c'est juste une supposition.
En fait ce que tu devrais tester pour «savoir», c'est un liveCD avec un environnement ou l'accélération 3D est pas nécessaire (genre xfce) , et si tu peux tester le même livecd avec firmware-nonfree d'inclus, comme ça tu sera fixé.

Hors ligne

#8 Le 12/05/2013, à 19:02

src

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

carld2010 a écrit :

Bonjour, un apt-get upgrade en live cd te permettrais de voir si le pilote libre Xorg est offert en mise à jour, sinon tu peut essayer de l'installer manuellement:

su
apt-get install xserver-xorg-video-radeon xserver-xorg-video-radeonhd xserver-xorg-video-ati

Cependant, je ne suis pas certain que c'est possible d'installer un pilote graphique en live cd.

Le pilote libre Xorg supporte la série radeon hd 5000 sur squeeze mais j'ignore si elle le supporte sur la très très jeune wheezy; si elle ne l'ait pas, c'est probablement une question de temps. 

Donc, d'après moi, ce n'est pas un bug...

Il faut surtout installer firmware-linux-nonfree comme indiqué dans le message...


Actuellement sur Manjaro Xfce (amd64)
Serveur sur Debian Wheezy + LXC + YunoHost.
http://maniatux.fr

Hors ligne

#9 Le 12/05/2013, à 19:21

Yanzo

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Il existe PLUSIEURS Debian 7 live avec les drivers nonfree:
http://live.debian.net/cdimage/release/ … so-hybrid/

Ceci étant cela fait plusieurs semaines que je tourne en Debian 7 stable sans problèmes.
J'ai aussi une Debian SID.

Hors ligne

#10 Le 12/05/2013, à 20:20

Valeryan_24

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

OK, merci pour vos messages, j'ai donc pris le mauvais Iso (ou il faut que j'installe les binaires non-free) donc tout est normal ; le contraire m'aurait certes étonné, mais je préférais demander. Je re-testerai avec la version adéquate mais je passe le post en "Résolu". Ça m'aura évité de passer pour un "noob" sur le forum Debian !

Ubuntu nous habitue à la simplicité et au "tout en un", si on revient à la base, il faut savoir s'adapter smile

Hors ligne

#11 Le 16/05/2013, à 00:21

Valeryan_24

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Re-bonjour,

Yanzo a écrit :

Il existe PLUSIEURS Debian 7 live avec les drivers nonfree:
http://live.debian.net/cdimage/release/ … so-hybrid/

Bon alors en fait, mon problème n'est pas résolu, impossible d'avoir Debian 7 en LiveCD (pas en dur) qui fonctionne avec ma carte graphique ATI HD 5770 !

Je suis bien allé télécharger debian-live-7.0.0-amd64-gnome-desktop+nonfree.iso

Sur la capture ci-dessous, on voit qu'il a exactement à l'octet près la même taille que la version Gnome par défaut debian-live-7.0.0-amd64-gnome-desktop.iso, mais les MD5 sont différentes et correspondent bien à celles indiquées sur le site de Debian. Si on parcourt le CD, on ne voit pas de paquet firmware-linux-nonfree

http://i.imgur.com/iO6xcoY.png

Quand je boote sur le LiveCD, j'obtiens le même message d'erreur "Radeon kernel modesetting for R600 or later requires firmware-linux-nonfree" et j'arrive sur un bureau scindé en deux avec toujours l'écran stroboscopique.

Dans Synaptic, xserver-xorg-video-radeon xserver-xorg-video-radeonhd sont bien installés, par contre pas de paquet firmware-linux-nonfree apparent, seul le firmware-linux-free est installé, l'autre même pas listé.

Autre conseil qu'on m'a donné sur LinuxFr : désactiver le modesetting dans la ligne de démarrage GRUB, soit dans /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.nomodeset"
ou nomodeset tout court, ou d'autres variantes comme radeon.modeset=0

Mais j'imagine que ce n'est pas possible en Live, uniquement avec une installation sur le disque ?

Là je sèche : y a-t-il une erreur sur le LiveCD non-free, est-ce que je loupe une manip' ou bien n'est-il pas possible d'avoir cette version en live avec ma config' ?

Edit : en machine virtuelle avec KVM et Virt-Manager, j'arrive à lancer le LiveCD de base (Debian 7 Gnome firmware-free uniquement) en session graphique sans aucun bug d'affichage, mais en essayant de l'installer en "dur" sur le disque virtuel, j'ai là aussi une erreur, cela s'arrête à l'étape "Installation du système". Décidément...

Dernière modification par Valeryan_24 (Le 16/05/2013, à 01:15)

Hors ligne

#12 Le 16/05/2013, à 02:11

xavier4811

Re : Debian 7 LiveCD inutilisable avec ATI Radeon HD 5770 : bug ?

Valeryan_24 a écrit :

Autre conseil qu'on m'a donné sur LinuxFr : désactiver le modesetting dans la ligne de démarrage GRUB, soit dans /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.nomodeset"
ou nomodeset tout court, ou d'autres variantes comme radeon.modeset=0

Mais j'imagine que ce n'est pas possible en Live, uniquement avec une installation sur le disque ?

Rien d'impossible, touche tab a l'écran de sélection des modes de démarrage et tu peux rajouter une option a la fin de la ligne.
Clavier qwerty donc "no,odeset"

Sinon une bidouille que j'ai déja faite pour une carte réseau sur un portable (firm Tigon/tg3 Broadcom pour ceux que ça intéresse):
Récupère le paquet firmware-linux-nonfree, décompresse le et colle les 3 fichiers sur une clé usb ;
R600_me.bin
R600_pfp.bin
R600_rlc.bin

Boote sur le live, Ctrl+Alt+F2 branche la clé usb et monte la dans un dossier temporaire, copie les 3 fichier dans /lib/firmware/radeon/ et relance l'env. graphique
(comment je sais pas, Ctrl+Alt+BackSpace? modprobe?)

sinon un autre dépot pour les live + nonfree : cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/

Dernière modification par xavier4811 (Le 16/05/2013, à 02:23)

Hors ligne

Haut de page ↑