Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 24/11/2005, à 22:29

manatlan

tuto : grab xmltv, applet ontv = marche plus

à ceux qui ont suivi cet excellent tuto/wiki :
http://debuntu.free.fr/index.php?2005/11/22/488-qu-est-ce-qu-il-y-a-la-tele
http://wiki.ubuntu-fr.org//applications/ontv

Sachez qu'actuellement ça ne marche plus ...
un tv_grab_fr renvoi un :

Can't call method "as_text" on an undefined value at /usr/bin/tv_grab_fr line 527.

J'ai un peu regardé, et il semblerait qu'il y ai une date extraite du "guidetele" qui soit nulle, et donc provoque cette erreur ...

Donc n'updater pas, au risque de casser votre XML ... (moi je l'ai déjà cassé ;-( )

Dernière modification par manatlan (Le 24/11/2005, à 22:31)


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#2 Le 24/11/2005, à 22:51

mariop31

Re : tuto : grab xmltv, applet ontv = marche plus

Bonsoir.

Effectivement j'ai le même message que toi.
Je ne comprends pas quand tu dis ne pas updater au risque de casser notre xml????


L’éducation c’est ce qui reste lorsqu’une personne a oublié tout ce qu’elle a appris à l’école... [Albert EINSTEIN]

Hors ligne

#3 Le 24/11/2005, à 23:21

manatlan

Re : tuto : grab xmltv, applet ontv = marche plus

mariop31 a écrit :

Je ne comprends pas quand tu dis ne pas updater au risque de casser notre xml????

oui, c juste pour les gens qui ont automatisé cette tache en regenerant l'xml en lieu et place du précédent, en fait


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#4 Le 28/11/2005, à 16:08

toomanymessi

Re : tuto : grab xmltv, applet ontv = marche plus

Hello,

Mais est-qu'il y a une altérnative ? ou truc à faire pour corriger le problème ? ( part debugger lecode)

J'ai essayé de poster un support request sur Sourceforge...mais pas de nouvelle.

Une idée ?

Hors ligne

#5 Le 28/11/2005, à 16:11

Golgoth

Re : tuto : grab xmltv, applet ontv = marche plus

juste attendre...


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#6 Le 28/11/2005, à 16:13

toomanymessi

Re : tuto : grab xmltv, applet ontv = marche plus

Golgoth a écrit :

juste attendre...

ok, snif....:rolleyes:

Hors ligne

#7 Le 28/11/2005, à 17:01

PYDou

Re : tuto : grab xmltv, applet ontv = marche plus

En fait, à la l igne 527, il cherche les mots clef  "td" "width" "50" dans le flux http ... et il ne les trouve pas. Cela veut dire que télépoche a changé le format de ses pages, et qu'il faudrait changer le script aussi ...

En regardant vite fait, j'ai vu un td width=2 qui aurait pu remplacer le td witdh=50, mais çà na marche pas non plus, il plante ailleurs, un peu plus loin dans la démarche, et je n'ai pas eu le temps de fouiller plus loin dans le script.

Il ne faut pas oublier que télépoche n'a rien à gagner avec l'accès par des automates qui ne lisent pas sa pub, et donc, les utilisateurs de xmltv ne peuvent rien d'autre que pleurer et attendre le bon vouloir des uns (telepoche) et des autres (programmeurs de scripts).

Pour certaines chaines de la TNT, on peut récupérer l'EPG au travers du broadcast du canal lui même, mais tous les canaux ne sont pas opérationnels

Si quelqu'un a une solution, je suis preneur.

Hors ligne

#8 Le 28/11/2005, à 22:11

jmsizun

Re : tuto : grab xmltv, applet ontv = marche plus

il semble que la ou on attendait une date dans la page telepoche, et bien, y'en a plus.

hack rapide et surement foireux: dans le script tv_grab_fr, remplacer les lignes autour de line=527:

    my ($day, $month) = split (/\//,$dateTree->as_text);
        $date = ParseDate("$month/$day/".UnixDate(DateCalc("today","+$nbloop days"),"%Y"));
        $dateindex = UnixDate($date, "%Y%m%d");

par

    $dateindex = UnixDate(DateCalc("today","+$nbloop days"),"%Y%m%d");

ca a l'air de tourner a partir de la.
Cependant, je pense que autour de minuit, ca doit pas marcher.

A+
Jimmy

Hors ligne

#9 Le 28/11/2005, à 23:42

Jeece

Re : tuto : grab xmltv, applet ontv = marche plus

Bonsoir,

Une méthode peut-être plus propre est encore de récupérer la dernière version du script tv_ grab_fr sur le CVS de XMLTV.

tv_grab_fr révision 1.23

Enregistrez le lien ci-dessus dans votre dossier personnel.

Sauvegarde de la version actuelle (Enfin ça c'est si vous le voulez bien au cas où ce serait pire avec le nouveau script. tongue )

sudo cp /usr/bin/tv_grab_fr /usr/bin/tv_grab_fr_1.20

On ecrase l'ancienne version par la nouvelle.

sudo cp ~/tv_grab_fr /usr/bin/tv_grab_fr

Bon ben là c'est en cours de mise à jour.  Ah ben non c'est fini !

Et ça fonctionne !!

Pour info biboobox le site de biboobox qui maintient le script fr de XMLTV.
Merci pour ta réactivité. cool

Dernière modification par Jeece (Le 28/11/2005, à 23:44)


Content que ça vous plaise !

Hors ligne

#10 Le 29/11/2005, à 00:10

jmsizun

Re : tuto : grab xmltv, applet ontv = marche plus

ben, il vaut mieux ca, vu que le hack, ben de toute facon il se gourrait totalement sur les dates.
Voila ce que c'est de plonger dans du Perl alors qu'on en a jamais fait. :-)
je l'ai corrigé apres coup (c'est marrant, a peu pres comme sur le CVS), mais bon, j'attendrais le package sarge (desole!).
Bye

Hors ligne

#11 Le 29/11/2005, à 00:20

manatlan

Re : tuto : grab xmltv, applet ontv = marche plus

Jeece a écrit :

Bonsoir,

tv_grab_fr révision 1.23

Et ça fonctionne !!

je confirme, ça fonctionne ! excellent !
merci !


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#12 Le 29/11/2005, à 00:33

Golgoth

Re : tuto : grab xmltv, applet ontv = marche plus

on va modifier le billet sur debuntu et sur le wiki!

merci Jeece! big_smile


Dell Dimension 9200: E6420 + 8600GTS + 2Go RAM

Hors ligne

#13 Le 29/11/2005, à 21:26

manatlan

Re : tuto : grab xmltv, applet ontv = marche plus

sinon, existe t il d'autre programmes pour exploiter un peu mieux les données XMLTV (par exemple, voir ce qu'il y a le lendemain ...etc ?)


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#14 Le 30/11/2005, à 00:45

Jeece

Re : tuto : grab xmltv, applet ontv = marche plus

Golgoth a écrit :

on va modifier le billet sur debuntu et sur le wiki!

merci Jeece! big_smile

De rien smile
J'étais tellement frustré de ne pas pouvoir testé cet applet.
Ben oui quoi ! Avoir le programme des 6 chaines hertziennes françaises, que je reçois mal en plus, en direct sur mon bureau... Vraiment j'en avait trop besoin. lol
N'empèche que ce soir il y avait Philadelphia. Sans OnTV je l'aurais manqué.

Manatlan va voir sur le site du projet XMLTV. Y'a une liste de projets utilisant le format XMLTV.

Dernière modification par Jeece (Le 30/11/2005, à 00:53)


Content que ça vous plaise !

Hors ligne

#15 Le 30/11/2005, à 08:50

toomanymessi

Re : tuto : grab xmltv, applet ontv = marche plus

Sinon vue sur Biboobox ( http://www.lahiette.com/biboobox/)

Dernières MAJ : 28/11/2005 :

    * Le grabbeur XMLTV a été mis à jour, suite à une modif du site telepoche le 25/11/2005. Le script est dispo sous le CVS de xmltv, et dans les "nightly" packages :
          o pour Unix : http://snapshot.xmltv.org/
          o Pour Windows : http://alpha-exe.xmltv.org/

Et ça marche aussi smile

Hors ligne

#16 Le 19/12/2005, à 22:05

Professeur Tibo

Re : tuto : grab xmltv, applet ontv = marche plus

Moi je viens de suivre vos conseil et j'ai ça :

root@professeur-tibo:~#  tv_grab_fr --days 7 --output /home/tibo/TV.xml
In normal, fast grabbing mode all days are fetched at once, so the
--days option does nothing.  The option is useful only for reducing
the extra downloads caused by --slow mode.

using config filename /home/tibo/.xmltv/tv_grab_fr.conf
getting listings
Can't download http://telepoche.guidetele.com/gtv/semaine?openagent&d=0&c=131&h=4 !!! Check you internet connection. at /usr/bin/tv_grab_fr line 249.

Est-ce que qq'un peu m'aider ?

Professeur Tibo

Dernière modification par Professeur Tibo (Le 19/12/2005, à 22:06)


Professeur Tibo

Hors ligne

#17 Le 20/12/2005, à 19:37

J_F

Re : tuto : grab xmltv, applet ontv = marche plus

ah !! enfin ça marche!! lol Un grand merci à Jeece pour sa méthode! Purée, ça faisait deux jours que je cherchais à le faire fonctionner.

Hors ligne

#18 Le 21/12/2005, à 10:20

Professeur Tibo

Re : tuto : grab xmltv, applet ontv = marche plus

Bonjour,

est-ce que quelqu'un pourrait faire un tuto avec les bonnes infos (vu qu'elles viennent de changer) ?
Je suis débutant et je n'arrive pas a installer correctement le prog.

Merci


Professeur Tibo

Hors ligne

#19 Le 02/02/2006, à 21:36

Soulfly_tribe90

Re : tuto : grab xmltv, applet ontv = marche plus

J'ai bo faire ce que je veux il me fait toujours un fichier de conf vide donc kan je fais un ptit /.xmltv/run-tv-grab ben j'obtiens ca :
config file /home/nicolas/.xmltv/tv_grab_fr.conf is empty, please delete and run me with --configure
-:
no element found at line 1, column 0, byte 0 at /usr/lib/perl5/XML/Parser.pm line 187

Personne n'a un fichier de config a me montrer que je le fasse a ma sauce big_smile sans passer par le script ou tu repond par oui ou non parce que apparement il se fout des reponses que je lui donne lol

Hors ligne

#20 Le 03/02/2006, à 21:47

skelettor

Re : tuto : grab xmltv, applet ontv = marche plus

Soulfly_tribe90 a écrit :

J'ai bo faire ce que je veux il me fait toujours un fichier de conf vide donc kan je fais un ptit /.xmltv/run-tv-grab ben j'obtiens ca :
config file /home/nicolas/.xmltv/tv_grab_fr.conf is empty, please delete and run me with --configure
-:
no element found at line 1, column 0, byte 0 at /usr/lib/perl5/XML/Parser.pm line 187

Personne n'a un fichier de config a me montrer que je le fasse a ma sauce big_smile sans passer par le script ou tu repond par oui ou non parce que apparement il se fout des reponses que je lui donne lol

Meme problème que toi sad

@+

Hors ligne

#21 Le 03/02/2006, à 23:58

david2b

Re : tuto : grab xmltv, applet ontv = marche plus

J'ai l'impression que le problème est revenu... Faut-il une nouvelle version de tv-grab ?


Ubuntu Karmic Koala - Shuttle SK83G + Acer Aspire One A110 (Netbook remix)
Plus touché windows depuis 2002....
Je tape sur un clavier fr-dvorak-bépo : http://www.clavier-dvorak.org/
Registered Linux User #45312.

Hors ligne

#22 Le 05/02/2006, à 14:16

geantick

Re : tuto : grab xmltv, applet ontv = marche plus

bonjour, probleme aussi avec les configurations belge et française. au moment de la configuration de xmltv-druid la console se ferme des mon premier choix d'option, et mon fichier de configuration n'est pas valable, ob tv le refuse. :'(


finallement apres une bonne lutte et le lien donné par toomanymessi un peu plus haut tout est ok smile

Dernière modification par geantick (Le 05/02/2006, à 15:35)


soit A=B , si l'on ajoute A de chaque cotés => 2A=B+A , on soustrait 2B de chaque coté => 2A-2B=A-B  <=> 2(A-B)=1(A-B)
en simplifiant 2=1 ! et voilà. Mais 0/0 çà fait combien?

Hors ligne

#23 Le 08/02/2006, à 23:01

Aresthya

Re : tuto : grab xmltv, applet ontv = marche plus

Même problème hmm


"La théorie, c'est quand on sait tout et que rien ne fonctionne. La pratique, c'est quand tout fonctionne et que personne ne sait pourquoi. Ici, nous avons réuni théorie et pratique : Rien ne fonctionne... et personne ne sait pourquoi !" -Albert Einstein

Hors ligne

#24 Le 08/02/2006, à 23:18

manatlan

Re : tuto : grab xmltv, applet ontv = marche plus

moi mon tv_grab_fr "fonctionne"
j'ai pas de message d'erreur, mais il me retrieve le xml en 15sec
mais y a rien dedans, aucun "programmes", il y a juste les chaines
et ce depuis hier ou avant hier


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#25 Le 14/02/2006, à 17:10

parpayou

Re : tuto : grab xmltv, applet ontv = marche plus

manatlan a écrit :

moi mon tv_grab_fr "fonctionne"
j'ai pas de message d'erreur, mais il me retrieve le xml en 15sec
mais y a rien dedans, aucun "programmes", il y a juste les chaines
et ce depuis hier ou avant hier

Pareil pour moi, marche plus depuis 2 semaine . Qu'est ce qui se passe ?

Hors ligne

Haut de page ↑